lang/ghc fixups

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

lang/ghc fixups

Greg Steuck
Hi Matthias,

I made a couple of simplifications that pass lang/ghc build and the
resulting ghc package works for building a subset of Haskell packages (e.g.
xmonad, xmobar). I only tested on amd64.

* Remove unneeded patch-libffi_ghc_mk
* Use ghc 8.6 for bootstrap, cut gcc dependency

Thanks
Greg
--
nest.cx is Gmail hosted, use PGP:
https://pgp.key-server.io/0x0B1542BD8DF5A1B0
Fingerprint: 5E2B 2D0E 1E03 2046 BEC3  4D50 0B15 42BD 8DF5 A1B0

0001-Remove-unneeded-patch-libffi_ghc_mk.patch (2K) Download Attachment
0002-Use-ghc-8.6-for-bootstrap-cut-gcc-dependency.patch (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: lang/ghc fixups

Matthias Kilian
Hi Greg,

On Sun, Mar 08, 2020 at 10:25:15PM -0700, Greg Steuck wrote:
> I made a couple of simplifications that pass lang/ghc build and the
> resulting ghc package works for building a subset of Haskell packages (e.g.
> xmonad, xmobar). I only tested on amd64.
>
> * Remove unneeded patch-libffi_ghc_mk
> * Use ghc 8.6 for bootstrap, cut gcc dependency

Really cool, thanks!

I'll check this against all hs-ports on amd64 and a build of ghc and
some hs-ports on i386 before committing this. (May take a day or
two, because I'm still waiting for my poppler test builds).

Ciao,
        Kili