kernel crash on 3.9

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

kernel crash on 3.9

Matt Rowley
Hi,
We've had one of our firewalls crash.  I've included ps and trace output
below, along with the dmesg.  Thanks!  --Matt


kernel: page fault trap, code=0
Stopped at       ip_output+0x7e0:         testb    $0x5,0x34(%eax)

ddb> ps
   PID   PPID    PGRP     UID  S       FLAGS  WAIT        COMMAND
  3612  24433   11482       0  2      0x4004              perl
  5019  11482   11482       0  3      0x4084  piperd      mail
  6835  11482   11482       0  3      0x4084  piperd      tee
 24433  11482   11482       0  3      0x4084  pause       sh
 11482   9074   11482       0  3      0x4084  pause       sh
  9074   4906   11482       0  3        0x84  piperd      cron
  5139      1    5139       0  3      0x4086  ttyin       getty
 25257      1   25257       0  3     0x40184  select      sendmail
 28426      1   28426       0  3      0x4086  ttyin       getty
 10636      1   10636       0  3      0x4086  ttyin       getty
 19975      1   19975       0  3      0x4086  ttyin       getty
 22453      1   22453       0  3      0x4086  ttyin       getty
  4906      1    4906       0  3        0x84  select      cron
 14416      1   14416       0  3        0x84  select      sshd
  3601      1    3601       0  3       0x184  select      inetd
  2715  13271   13271      74  3       0x184  bpf         pflogd
 13271      1   13271       0  3        0x84  netio       pflogd
 28383   2219    2219      73  3       0x184  poll        syslogd
  2219      1    2219       0  3        0x84  netio       syslogd
    17      0       0       0  3    0x100204  crypto_wa   crypto
    16      0       0       0  3    0x100204  aiodoned    aiodoned
    15      0       0       0  3    0x100204  syncer      update
    14      0       0       0  3    0x100204  cleaner     cleaner
    13      0       0       0  3    0x100204  reaper      reaper
    12      0       0       0  3    0x100204  pgdaemon    pagedaemon
    11      0       0       0  3    0x100204  pftm        pfpurge
    10      0       0       0  3    0x100204  timeout     sensors
     9      0       0       0  3    0x100204  usbevt      usb4
     8      0       0       0  3    0x100204  usbevt      usb3
     7      0       0       0  3    0x100204  usbevt      usb2
     6      0       0       0  3    0x100204  usbevt      usb1
     5      0       0       0  3    0x100204  usbtsk      usbtask
     4      0       0       0  3    0x100204  usbevt      usb0
     3      0       0       0  3    0x100204  apmev       apm0
     2      0       0       0  2    0x100204              kmthread
     1      0       1       0  3      0x4084  wait        init
     0     -1       0       0  3     0x80204  scheduler   swapper
ddb> trace
ip_output(e849cd00,0,0,2,d05dc4a8,0,d070bb94,d01e5e39) at ip_output+0x7e0
pfsync_sendout_mbuf(d05dc2e0,e849cd00,ffffffff,3500,0) at
pfsync_sendout_mbuf+0x106
pfsync_sendout(d05dc2e0,0,d64a45fc,e896939c,e84195e8) at pfsync_sendout+0x57
pfsync_pack_state(1,e84195e8,1,d689fa00) at pfsync_pack_state+0x95
pf_insert_state(d0faba00,e84195e8,2,d070bcfc) at pf_insert_state+0x14b
pf_test_udp(d070bd0c,d070bd04,1,d0faba00,d640e300) at pf_test_udp+0x597
pf_test(1,d103d400,d070be2c,0) at pf_test+0xc27
ipv4_input(d640e300,d028bca9,50,296) at ipv4_input+0x121
ipintr(58,60010,380010,d0700010,d070a000) at ipintr+0x67
Bad frame pointer: 0xd070be44


Here's the dmesg:

OpenBSD 3.9 (GENERIC) #617: Thu Mar  2 02:26:48 MST 2006
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Pentium(R) 4 CPU 2.80GHz ("GenuineIntel" 686-class) 2.80 GHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,CNXT-ID
real mem  = 536387584 (523816K)
avail mem = 482426880 (471120K)
using 4278 buffers containing 26923008 bytes (26292K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(66) BIOS, date 04/13/04, BIOS32 rev. 0 @ 0xfb7f0
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
apm0: flags 70102 dobusy 1 doidle 1
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xdf64
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfde90/208 (11 entries)
pcibios0: PCI Exclusive IRQs: 3 5 9 10 11
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82371SB ISA" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x1800 0xca000/0x1800
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82875P Host" rev 0x02
uhci0 at pci0 dev 29 function 0 "Intel 82801EB/ER USB" rev 0x02: irq 9
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 29 function 1 "Intel 82801EB/ER USB" rev 0x02: irq 11
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2 at pci0 dev 29 function 2 "Intel 82801EB/ER USB" rev 0x02: irq 11
usb2 at uhci2: USB revision 1.0
uhub2 at usb2
uhub2: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3 at pci0 dev 29 function 3 "Intel 82801EB/ER USB" rev 0x02: irq 9
usb3 at uhci3: USB revision 1.0
uhub3 at usb3
uhub3: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 29 function 7 "Intel 82801EB/ER USB2" rev 0x02: irq 10
usb4 at ehci0: USB revision 2.0
uhub4 at usb4
uhub4: Intel EHCI root hub, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
ppb0 at pci0 dev 30 function 0 "Intel 82801BA AGP" rev 0xc2
pci1 at ppb0 bus 1
fxp0 at pci1 dev 3 function 0 "Intel 8255x" rev 0x0c, i82550: irq 3, address
00:02:b3:ea:fc:5c
inphy0 at fxp0 phy 1: i82555 10/100 PHY, rev. 4
vga1 at pci1 dev 9 function 0 "ATI Rage XL" rev 0x27
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
em0 at pci1 dev 10 function 0 "Intel PRO/1000MT (82541EI)" rev 0x00: irq 5,
address 00:30:48:72:47:de
em1 at pci1 dev 11 function 0 "Intel PRO/1000MT (82541EI)" rev 0x00: irq 10,
address 00:30:48:72:47:df
ichpcib0 at pci0 dev 31 function 0 "Intel 82801EB/ER LPC" rev 0x02
"Intel 82801EB SATA" rev 0x02 at pci0 dev 31 function 2 not configured
ichiic0 at pci0 dev 31 function 3 "Intel 82801EB/ER SMBus" rev 0x02: irq 3
iic0 at ichiic0
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
wdc0 at isa0 port 0x1f0/8 irq 14
wd0 at wdc0 channel 0 drive 0: <ST380013AS>
wd0: 16-sector PIO, LBA48, 76319MB, 156301488 sectors
wd0(wdc0:0:0): using BIOS timings
wdc1 at isa0 port 0x170/8 irq 15
atapiscsi0 at wdc1 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <QSI, CD-ROM SCR-242, CXAC> SCSI0 5/cdrom
removable
cd0(wdc1:0:0): using BIOS timings
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
lm0 at isa0 port 0x290/8: W83627HF
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask ef4d netmask ef6d ttymask ffef
pctr: user-level cycle counter enabled
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302