kernel/5128: panic on current when removing pcmcia card - lenovo thinkpad X60s

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

kernel/5128: panic on current when removing pcmcia card - lenovo thinkpad X60s

didier-3
>Number:         5128
>Category:       kernel
>Synopsis:       when removing the pcmcia card I get a panic (on laptop lenovo thinkpad X60s)
>Confidential:   yes
>Severity:       critical
>Priority:       low
>Responsible:    bugs
>State:          open
>Quarter:        
>Keywords:      
>Date-Required:
>Class:          support
>Submitter-Id:   net
>Arrival-Date:   Mon May 22 14:40:01 GMT 2006
>Closed-Date:
>Last-Modified:
>Originator:     Didier Wiroth
>Release:        current (sources from 22.05.2006)
>Organization:
net
>Environment:
       
        System      : OpenBSD 3.9
        Architecture: OpenBSD.i386
        Machine     : i386
>Description:

I tried my umts card today on the lenovo thinkpad X60s.
I get a panic on current, while I eject my pcmcia vodafone
mobile connect card.
(The vodafone card is a: option wireless technology qualcomm
3g cdma card)

PHase 1: I insert the card into the pcmcia slot:
The console screen output is:
ohci0 at cardbus0 dev 0 function 0: irq 11, version 0.0
ohci0: unsupported OHCI revision
ohci0: init failed, error=4

Phase 2: I eject the card by pressing the pcmcia eject button, and
the panic happens:

$ panic: hook_disestablish: hook not established
Stopped at      Debugger+0x4:   leave
RUN AT LEAST 'trace' AND 'ps' AND INCLUDE OUTPUT WHEN REPORTING THIS PANIC!
DO NOT EVEN BOTHER REPORTING THIS WITHOUT INCLUDING THAT INFORMATION!
ddb>

ddb> trace
Debugger(0,0,0,d06bf3e0,d2ba2900) at Debugger+0x4
panic(d062f200,0,0,eb885e8c,d06bf408) at panic+0x63
hook_disestablish(d06bf3e0,0,0,0,0) at hook_disestablish+0x61
ohci_detach(d2bba000,0,202,d2ba2900) at ohci_detach+0x33
ohci_cardbus_detach(d2bba000,0,10,2ec29,d06fae80) at ohci_cardbus_detach+0x1a
config_detach(d2bba000,0,0,d2af1b80) at config_detach+0x218
cardbus_detach_card(d2af1b00,7f,0,eb884000,da575b40) at cardbus_detach_card+0x2
d
cardslot_event_throw(d2af1b80) at cardslot_event_throw+0x12c
Bad frame pointer: 0xd082ae78

ddb> ps
   PID   PPID   PGRP    UID  S       FLAGS  WAIT       COMMAND
 26866      1  26866   1000  3      0x4086  ttyin      ksh
 32720      1  32720      0  3      0x4086  ttyin      getty
 17381      1  17381      0  3      0x4086  ttyin      getty
 22406      1  22406      0  3      0x4086  ttyin      getty
 20618      1  20618      0  3      0x4086  ttyin      getty
 20911      1  20911      0  3      0x4086  ttyin      getty
 29943      1  29943      0  3        0x84  poll       wsmoused
 18109      1  18109      0  3        0x84  select     cron
  2771      1   2771      0  3     0x40184  select     sendmail
 18642      1  18642      0  3        0x84  select     sshd
 10246      1  10246      0  3       0x184  select     inetd
  3210  20798  20798     73  3       0x184  poll       syslogd
 20798      1  20798      0  3        0x84  netio      syslogd
 29574      1  29574     77  3       0x184  poll       dhclient
 12519      1  12890      0  3        0x86  poll       dhclient
    16      0      0      0  3    0x100204  crypto_wa  crypto
    15      0      0      0  3    0x100204  aiodoned   aiodoned
    14      0      0      0  3    0x100204  syncer     update
    13      0      0      0  3    0x100204  cleaner    cleaner
    12      0      0      0  3    0x100204  reaper     reaper
    11      0      0      0  3    0x100204  pgdaemon   pagedaemon
    10      0      0      0  3    0x100204  pftm       pfpurge
*    9      0      0      0  7    0x100204             cardslot0
     8      0      0      0  3    0x100204  usbevt     usb4
     7      0      0      0  3    0x100204  usbevt     usb3
     6      0      0      0  3    0x100204  usbevt     usb2
     5      0      0      0  3    0x100204  usbevt     usb1
     4      0      0      0  3    0x100204  usbtsk     usbtask
     3      0      0      0  3    0x100204  usbevt     usb0
     2      0      0      0  3    0x100204  kmalloc    kmthread
     1      0      1      0  3      0x4084  wait       init
     0     -1      0      0  3     0x80204  scheduler  swapper


Here dmesg of a docked Lenovo thinkpad X60s:

OpenBSD 3.9-current (GENERIC) #5: Mon May 22 13:20:45 CEST 2006
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Genuine Intel(R) CPU L2400 @ 1.66GHz ("GenuineIntel" 686-class) 1.67 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CFLUSH,D
S,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,VMX,EST,TM2
cpu0: unknown Enhanced SpeedStep CPU, msr 0x06130a2206000a22
real mem  = 2137419776 (2087324K)
avail mem = 1942081536 (1896564K)
using 4256 buffers containing 106975232 bytes (104468K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(98) BIOS, date 03/13/06, BIOS32 rev. 0 @ 0xfd690, SMB
IOS rev. 2.4 @ 0xe0010 (67 entries)
bios0: LENOVO 17025PG
pcibios0 at bios0: rev 2.1 @ 0xfd620/0x9e0
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdea0/272 (15 entries)
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82371FB ISA" rev 0x00)
pcibios0: PCI bus #6 is the last bus
bios0: ROM list: 0xc0000/0xe400! 0xce800/0x1000 0xcf800/0x1000 0xdc000/0x4000! 0
xe0000/0x10000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82945GM MCH" rev 0x03
vga1 at pci0 dev 2 function 0 "Intel 82945GM Video" rev 0x03: aperture at 0xee10
0000, size 0x10000000
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"Intel 82945GM Video" rev 0x03 at pci0 dev 2 function 1 not configured
"Intel 82801GB HD Audio" rev 0x02 at pci0 dev 27 function 0 not configured
ppb0 at pci0 dev 28 function 0 "Intel 82801GB PCIE" rev 0x02
pci1 at ppb0 bus 1
em0 at pci1 dev 0 function 0 "Intel PRO/1000MT (82573L)" rev 0x00: irq 11, addre
ss 00:16:d3:21:4b:b6
ppb1 at pci0 dev 28 function 1 "Intel 82801GB PCIE" rev 0x02
pci2 at ppb1 bus 2
wpi0 at pci2 dev 0 function 0 "Intel PRO/Wireless 3945ABG" rev 0x02: irq 11chann
el 1 pwr1 0x0079 pwr2 0x007a
channel 2 pwr1 0x007b pwr2 0x0078
channel 3 pwr1 0x0069 pwr2 0x006a
channel 4 pwr1 0x006c pwr2 0x0069
channel 5 pwr1 0x0000 pwr2 0x0000
channel 6 pwr1 0x007d pwr2 0x007d
channel 7 pwr1 0x007c pwr2 0x007d
channel 8 pwr1 0x0080 pwr2 0x007f
channel 9 pwr1 0x007f pwr2 0x0080
channel 10 pwr1 0x0000 pwr2 0x0000
channel 11 pwr1 0xfffe pwr2 0xfffe
channel 12 pwr1 0xffff pwr2 0xffff
channel 13 pwr1 0xfffe pwr2 0xfffe
channel 14 pwr1 0xffff pwr2 0xffff
, address 00:13:02:16:27:0f
ppb2 at pci0 dev 28 function 2 "Intel 82801GB PCIE" rev 0x02
pci3 at ppb2 bus 3
ppb3 at pci0 dev 28 function 3 "Intel 82801GB PCIE" rev 0x02
pci4 at ppb3 bus 4
uhci0 at pci0 dev 29 function 0 "Intel 82801GB USB" rev 0x02: irq 11
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 29 function 1 "Intel 82801GB USB" rev 0x02: irq 11
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2 at pci0 dev 29 function 2 "Intel 82801GB USB" rev 0x02: irq 11
usb2 at uhci2: USB revision 1.0
uhub2 at usb2
uhub2: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3 at pci0 dev 29 function 3 "Intel 82801GB USB" rev 0x02: irq 11
usb3 at uhci3: USB revision 1.0
uhub3 at usb3
uhub3: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 29 function 7 "Intel 82801GB USB" rev 0x02: irq 11
usb4 at ehci0: USB revision 2.0
uhub4 at usb4
uhub4: Intel EHCI root hub, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
ppb4 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xe2
pci5 at ppb4 bus 5
cbb0 at pci5 dev 0 function 0 "Ricoh 5C476 CardBus" rev 0xb4: irq 11
"Ricoh 5C552 Firewire" rev 0x09 at pci5 dev 0 function 1 not configured
"Ricoh 5C822 SD/MMC" rev 0x18 at pci5 dev 0 function 2 not configured
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 6 device 0 cacheline 0x0, lattimer 0xb0
pcmcia0 at cardslot0
ichpcib0 at pci0 dev 31 function 0 "Intel 82801GBM LPC" rev 0x02: PM disabled
pciide0 at pci0 dev 31 function 1 "Intel 82801GB IDE" rev 0x02: DMA, channel 0 c
onfigured to compatibility, channel 1 configured to compatibility
atapiscsi0 at pciide0 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MATSHITA, DVD-RAM UJ-842, RB01> SCSI0 5/cdrom rem
ovable
cd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
pciide0: channel 1 ignored (disabled)
pciide1 at pci0 dev 31 function 2 "Intel 82801GBM AHCI SATA" rev 0x02: DMA, chan
nel 0 wired to native-PCI, channel 1 wired to native-PCI
pciide1: using irq 11 for native-PCI interrupt
wd0 at pciide1 channel 0 drive 0: <HTS541010G9SA00>
wd0: 16-sector PIO, LBA48, 95396MB, 195371568 sectors
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5
ichiic0 at pci0 dev 31 function 3 "Intel 82801GB SMBus" rev 0x02: irq 11
iic0 at ichiic0
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt2 at isa0 port 0x3bc/4: polled
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
biomask efed netmask efed ttymask ffef
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
uhub5 at uhub4 port 6
uhub5: vendor 0x17ef product 0x1000, rev 2.00/0.01, addr 2
uhub5: 4 ports with 4 removable, self powered, multiple transaction translators
uhidev0 at uhub5 port 2 configuration 1 interface 0
uhidev0: vendor 0x062a product 0x0000, rev 1.10/0.00, addr 3, iclass 3/1
ums0 at uhidev0: 3 buttons and Z dir.
wsmouse1 at ums0 mux 0
ugen0 at uhub3 port 1
ugen0: Broadcom Corp BCM2045B, rev 2.00/1.00, addr 2
ugen1 at uhub3 port 2
ugen1: STMicroelectronics Biometric Coprocessor, rev 1.00/0.01, addr 3
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302

>How-To-Repeat:
Due to panic, I reboot.
Insert card and remove it, results in a new panic.
>Fix:


>Release-Note:
>Audit-Trail:
>Unformatted:

Reply | Threaded
Open this post in threaded view
|

Re: kernel/5128: panic on current when removing pcmcia card - lenovo thinkpad X60s

Didier Wiroth
Hello,
As requested:

I tested the card on a hp/compaq nc6000 laptop. The nc6000 has an older current snapshot.
The card is recognized and works on this system.

The card was inserted and removed, see bottom of dmesg.

I also made a connection with it:
May 23 20:08:19 nc6000 pppd[2345]: pppd 2.3.5 started by dda, uid 0
May 23 20:08:22 nc6000 pppd[2345]: Serial connection established.
May 23 20:08:23 nc6000 pppd[2345]: Using interface ppp0
May 23 20:08:23 nc6000 pppd[2345]: Connect: ppp0 <--> /dev/ttyU0
May 23 20:09:02 nc6000 pppd[2345]: local  IP address 213.135.252.251
May 23 20:09:02 nc6000 pppd[2345]: remote IP address 213.135.252.1
May 23 20:12:03 nc6000 pppd[2345]: Connection terminated.

If you require more info or testing, let me know ...

thanks a lot for helping!!!
regards
didier

OpenBSD 3.9-current (GENERIC) #732: Wed May 10 18:48:35 MDT 2006
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Pentium(R) M processor 1600MHz ("GenuineIntel" 686-class) 599 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,TM,SBF,EST,TM2
cpu0: Enhanced SpeedStep 600 MHz (956 mV): speeds: 1600, 1400, 1200, 1000, 800, 600 MHz
real mem  = 1073115136 (1047964K)
avail mem = 971415552 (948648K)
using 4256 buffers containing 53760000 bytes (52500K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(c3) BIOS, date 06/23/05, BIOS32 rev. 0 @ 0xf0000, SMBIOS rev. 2.3 @ 0xfa1ee (31 entries)
bios0: Hewlett-Packard HP Compaq nc6000 (DJ299A#ABB)  
apm0 at bios0: Power Management spec V1.2 (BIOS managing devices)
apm0: AC off, battery charge unknown
apm0: flags 130102 dobusy 0 doidle 1
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x2000
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xf0840/160 (8 entries)
pcibios0: bad IRQ table checksum
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xf6360/160 (8 entries)
pcibios0: PCI Exclusive IRQs: 5 10 11
pcibios0: no compatible PCI ICU found: ICU vendor 0x8086 product 0x24cc
pcibios0: PCI bus #5 is the last bus
bios0: ROM list: 0xc0000/0x10000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82855PE Hub" rev 0x03
ppb0 at pci0 dev 1 function 0 "Intel 82855PE AGP" rev 0x03
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "ATI Radeon Mobility M10 NP" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
uhci0 at pci0 dev 29 function 0 "Intel 82801DB USB" rev 0x03: irq 10
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 29 function 1 "Intel 82801DB USB" rev 0x03: irq 10
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2 at pci0 dev 29 function 2 "Intel 82801DB USB" rev 0x03: irq 10
usb2 at uhci2: USB revision 1.0
uhub2 at usb2
uhub2: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 29 function 7 "Intel 82801DB USB" rev 0x03: irq 10
usb3 at ehci0: USB revision 2.0
uhub3 at usb3
uhub3: Intel EHCI root hub, rev 2.00/1.00, addr 1
uhub3: 6 ports with 6 removable, self powered
ppb1 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0x83
pci2 at ppb1 bus 2
ath0 at pci2 dev 4 function 0 "Atheros AR5212" rev 0x01: irq 11
ath0: AR5213 5.6 phy 4.1 rf5111 1.7 rf2111 2.3, WOR0W, address 00:0f:20:94:99:e5
cbb0 at pci2 dev 6 function 0 "O2 Micro OZ711E0 CardBus" rev 0x00: irq 10
cbb1 at pci2 dev 6 function 1 "O2 Micro OZ711E0 CardBus" rev 0x00: irq 10
"O2 Micro OZ711Mx CardBus" rev 0x00 at pci2 dev 6 function 2 not configured
cbb2 at pci2 dev 6 function 3 "O2 Micro OZ711E0 CardBus" rev 0x00: irq 10
bge0 at pci2 dev 14 function 0 "Broadcom BCM5705M_ALT" rev 0x03, BCM5705 A3 (0x3003): irq 11, address 00:0d:9d:8c:12:85
brgphy0 at bge0 phy 1: BCM5705 10/100/1000baseT PHY, rev. 2
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 3 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 4 device 0 cacheline 0x0, lattimer 0x20
pcmcia1 at cardslot1
cardslot2 at cbb2 slot 2 flags 0
cardbus2 at cardslot2: bus 5 device 0 cacheline 0x0, lattimer 0x20
pcmcia2 at cardslot2
ichpcib0 at pci0 dev 31 function 0 "Intel 82801DBM LPC" rev 0x03
pciide0 at pci0 dev 31 function 1 "Intel 82801DBM IDE" rev 0x03: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <HITACHI_DK23FB-60>
wd0: 16-sector PIO, LBA, 57231MB, 117210240 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <TEAC, DW-224E-A, A.2F> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
auich0 at pci0 dev 31 function 5 "Intel 82801DB AC97" rev 0x03: irq 11, ICH4 AC97
ac97: codec id 0x41445374 (Analog Devices AD1981B)
ac97: codec features headphone, 20 bit DAC, No 3D Stereo
audio0 at auich0
"Intel 82801DB Modem" rev 0x03 at pci0 dev 31 function 6 not configured
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom2 at isa0 port 0x3e8/8 irq 5: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
biomask e74d netmask ef4d ttymask ffcf
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
ugen0 at uhub2 port 1
ugen0: ACTIONTEC Bluetooth by hp, rev 1.10/8.02, addr 2
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
ohci0 at cardbus1 dev 0 function 0: irq 10, version 1.0, legacy support
usb4 at ohci0: USB revision 1.0
uhub4 at usb4
uhub4: Opti OHCI root hub, rev 1.00/1.00, addr 1
uhub4: 2 ports with 2 removable, self powered
ubsa0 at uhub4 port 1
ubsa0: Vodafone Vodafone Mobile Connect Card - 3G, rev 2.00/0.01, addr 2
ucom0 at ubsa0
uhub4: at usb4 (addr 1) disconnected
ubsa0: at uhub4 port 1 (addr 2) disconnected
ucom0 detached
ubsa0 detached
uhub4 detached
usb4 detached
ohci0 detached