kernel/5114: panic in bge_intr on IBM e326m

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

kernel/5114: panic in bge_intr on IBM e326m

Srebrenko Sehic-2
>Number:         5114
>Category:       kernel
>Synopsis:       panic in bge_intr on IBM e326m
>Confidential:   yes
>Severity:       serious
>Priority:       medium
>Responsible:    bugs
>State:          open
>Quarter:        
>Keywords:      
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu May 11 08:40:01 GMT 2006
>Closed-Date:
>Last-Modified:
>Originator:     Srebrenko Sehic
>Release:        3.9-CURRENT
>Organization:
net
>Environment:
        System      : OpenBSD 3.9
        Architecture: OpenBSD.i386
        Machine     : i386

>Description:

Booting an i386 kernel (or bsd.rd) on IBM e326m panics somewhere in bge_intr.
Details below. However, the problem does not exist on amd64. This has something
to do with the fact that interrupts are disabled on amd64 on boot.

boot> boot
booting hd0a:/bsd: 5002792+868392 [52+257888+239276]=0x612e04
entry point at 0x200120m
[ using 497588 bytes of bsd ELF symbol table ]
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2006 OpenBSD. All rights reserved.  http://www.OpenBSD.org

OpenBSD 3.9-current (GENERIC) #717: Wed Apr 26 11:46:02 MDT 2006
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Dual Core AMD Opteron(tm) Processor 275 ("AuthenticAMD"
686-class, 1024KB L2 cache) 2.20 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3
real mem  = 2146377728 (2096072K)
avail mem = 1950351360 (1904640K)
using 4256 buffers containing 107421696 bytes (104904K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(6d) BIOS, date 12/16/05, BIOS32 rev. 0 @ 0xfd6d1
pcibios0 at bios0: rev 2.1 @ 0xfd650/0x9b0
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfde50/400 (23 entries)
pcibios0: no compatible PCI ICU found: ICU vendor 0xffff product 0xffff
pcibios0: Warning, unable to fix up PCI interrupt routing
pcibios0: PCI bus #8 is the last bus
bios0: ROM list: 0xc0000/0x9000 0xc9000/0x1600 0xca800/0x1600 0xcc000/0x4000
ipmi0 at mainbus0: version 1.5 interface KCS iobase 0xca2/2 spacing 1
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
ppb0 at pci0 dev 1 function 0 "ServerWorks HT-1000 PCI" rev 0x00
pci1 at ppb0 bus 1
ppb1 at pci1 dev 13 function 0 "ServerWorks HT-1000 PCIX" rev 0xb2
pci2 at ppb1 bus 2
mpt0 at pci2 dev 3 function 0 "Symbios Logic 53c1030" rev 0x08: irq 11
scsibus0 at mpt0: 16 targets
sd0 at scsibus0 targ 0 lun 0: <IBM-ESXS, MAX3036NC FN, CA06> SCSI4
0/direct fixed
sd0: 34715MB, 49158 cyl, 2 head, 723 sec, 512 bytes/sec, 71096640 sec total
mpt0: target 0 Synchronous at 160MHz width 16bit offset 127 QAS 0 DT 1 IU 1
pchb0 at pci0 dev 2 function 0 "ServerWorks HT-1000" rev 0x00
pciide0 at pci0 dev 2 function 1 "ServerWorks HT-1000 IDE" rev 0x00: DMA
atapiscsi0 at pciide0 channel 0 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <HL-DT-ST, CD-ROM GCR-8240N, 1.06> SCSI0
5/cdrom removable
cd0(pciide0:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 0
pcib0 at pci0 dev 2 function 2 "ServerWorks HT-1000 LPC" rev 0x00
ohci0 at pci0 dev 3 function 0 "ServerWorks HT-1000 USB" rev 0x01: irq
10, version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: ServerWorks OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
ohci1 at pci0 dev 3 function 1 "ServerWorks HT-1000 USB" rev 0x01: irq
10, version 1.0, legacy support
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: ServerWorks OHCI root hub, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 3 function 2 "ServerWorks HT-1000 USB" rev 0x01: irq 10
usb2 at ehci0: USB revision 2.0
uhub2 at usb2
uhub2: ServerWorks EHCI root hub, rev 2.00/1.00, addr 1
uhub2: 4 ports with 4 removable, self powered
vga1 at pci0 dev 4 function 0 "ATI ES1000" rev 0x01
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
ppb2 at pci0 dev 6 function 0 "ServerWorks HT-2000 PCIX" rev 0xa3
pci3 at ppb2 bus 3
ppb3 at pci0 dev 7 function 0 "ServerWorks HT-2000 PCIX" rev 0xa3
pci4 at ppb3 bus 4
bge0 at pci4 dev 4 function 0 "Broadcom BCM5780" rev 0x03,

uvm_fault(0xd06ea940, 0x10000, 0, 1) -> e
kernel: page fault trap, code=0
Stopped at      bge_intr+0x12:  testb   $0x1,0x10000(%eax)
ddb> ps
   PID   PPID   PGRP    UID  S       FLAGS  WAIT       COMMAND
*    0     -1      0      0  7     0x80204             swapper
ddb> trace
bge_intr(d2b50000) at bge_intr+0x12
Xrecurse_legacy7() at Xrecurse_legacy7+0xb2
--- interrupt ---
Xspllower(d06af524,d06e2400,d0818b48,d0327229,d0818c20) at Xspllower+0xe
printf(d068ec0d,80042000,68,d2aa94c0,d06eb180) at printf+0x57
bge_attach(d2b3f600,d2b50000,d0818c20,0,80042000) at bge_attach+0x18f
config_attach(d2b3f600,d06a8c78,d0818c20,d0471ae8) at config_attach+0xef
pci_probe_device(d2b3f600,80042000,0,0,15) at pci_probe_device+0x135
pci_enumerate_bus(d2b3f600,0,0,0,d06af524) at pci_enumerate_bus+0xef
config_attach(d2aa9500,d06a7e68,d0818d00,d04b4850,d0676022) at config_attach+0x
ef
ppbattach(d2aaa680,d2aa9500,d0818da0,0,80003800) at ppbattach+0x9c
config_attach(d2aaa680,d06a8498,d0818da0,d0471ae8) at config_attach+0xef
pci_probe_device(d2aaa680,80003800,0,0,15) at pci_probe_device+0x135
pci_enumerate_bus(d2aaa680,0,0,0,26) at pci_enumerate_bus+0xef
config_attach(d2aa9fc0,d06a7e68,d0818ea0,d0471878) at config_attach+0xef
mainbus_attach(0,d2aa9fc0,0,0,d0818f10) at mainbus_attach+0x1ce
config_attach(0,d06a7e44,0,0,d06eaa20) at config_attach+0xef
config_rootfound(d064043c,0,d0818f58,d04440bd) at config_rootfound+0x27
cpu_configure(0,1,3,0,0) at cpu_configure+0x24
main(0,0,0,0,0) at main+0x352
ddb>

>How-To-Repeat:

Boot 3.9/i386 on IBM e326m.

>Fix:

Unknown.


>Release-Note:
>Audit-Trail:
>Unformatted:

Reply | Threaded
Open this post in threaded view
|

Re: kernel/5114: panic in bge_intr on IBM e326m

Srebrenko Sehic-2
This can be closed now. I've tested the same box with a recent
-current and it works fine.

OpenBSD 3.9-current (RAMDISK_CD) #1160: Mon Jun  5 00:49:42 MDT 2006
   [hidden email]:/usr/src/sys/arch/i386/compile/RAMDISK_CD
cpu0: Dual Core AMD Opteron(tm) Processor 275 ("AuthenticAMD"
686-class, 1024KB L2 cache) 2.20 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3
real mem  = 2146377728 (2096072K)
avail mem = 1951416320 (1905680K)
using 4256 buffers containing 107421696 bytes (104904K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(5f) BIOS, date 12/16/05, BIOS32 rev. 0 @
0xfd6d1, SMBIOS rev. 2.34 @ 0x7ff7c000 (46 entries)
bios0: IBM IBM eServer 326m -[796965Y]-
pcibios0 at bios0: rev 2.1 @ 0xfd650/0x9b0
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfde50/400 (23 entries)
pcibios0: no compatible PCI ICU found: ICU vendor 0xffff product 0xffff
pcibios0: Warning, unable to fix up PCI interrupt routing
pcibios0: PCI bus #8 is the last bus
bios0: ROM list: 0xc0000/0x9000 0xc9000/0x1600 0xca800/0x1600 0xcc000/0x4000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
ppb0 at pci0 dev 1 function 0 "ServerWorks HT-1000 PCI" rev 0x00
pci1 at ppb0 bus 1
ppb1 at pci1 dev 13 function 0 "ServerWorks HT-1000 PCIX" rev 0xb2
pci2 at ppb1 bus 2
mpt0 at pci2 dev 3 function 0 "Symbios Logic 53c1030" rev 0x08: irq 11
scsibus0 at mpt0: 16 targets
sd0 at scsibus0 targ 0 lun 0: <IBM-ESXS, MAX3036NC FN, CA06> SCSI4
0/direct fixed
sd0: 34715MB, 49158 cyl, 2 head, 723 sec, 512 bytes/sec, 71096640 sec total
mpt0: target 0 Synchronous at 160MHz width 16bit offset 127 QAS 0 DT 1 IU 1
pchb0 at pci0 dev 2 function 0 "ServerWorks HT-1000" rev 0x00
pciide0 at pci0 dev 2 function 1 "ServerWorks HT-1000 IDE" rev 0x00: DMA
atapiscsi0 at pciide0 channel 0 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <HL-DT-ST, CD-ROM GCR-8240N, 1.06> SCSI0
5/cdrom removable
cd0(pciide0:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 0
pcib0 at pci0 dev 2 function 2 "ServerWorks HT-1000 LPC" rev 0x00
ohci0 at pci0 dev 3 function 0 "ServerWorks HT-1000 USB" rev 0x01: irq
10, version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: ServerWorks OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
ohci1 at pci0 dev 3 function 1 "ServerWorks HT-1000 USB" rev 0x01: irq
10, version 1.0, legacy support
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: ServerWorks OHCI root hub, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
ehci0 at pci0 dev 3 function 2 "ServerWorks HT-1000 USB" rev 0x01: irq 10
usb2 at ehci0: USB revision 2.0
uhub2 at usb2
uhub2: ServerWorks EHCI root hub, rev 2.00/1.00, addr 1
uhub2: 4 ports with 4 removable, self powered
vga1 at pci0 dev 4 function 0 "ATI ES1000" rev 0x01
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
ppb2 at pci0 dev 6 function 0 "ServerWorks HT-2000 PCIX" rev 0xa3
pci3 at ppb2 bus 3
ppb3 at pci0 dev 7 function 0 "ServerWorks HT-2000 PCIX" rev 0xa3
pci4 at ppb3 bus 4
bge0 at pci4 dev 4 function 0 "Broadcom BCM5780" rev 0x03, BCM5714 B3
(0x8003): irq 7, address 00:11:25:c4:48:a6
brgphy0 at bge0 phy 1: BCM5780 10/100/1000baseT PHY, rev. 0
bge1 at pci4 dev 4 function 1 "Broadcom BCM5780" rev 0x03, BCM5714 B3
(0x8003): irq 12, address 00:11:25:c4:48:a7
brgphy1 at bge1 phy 1: BCM5780 10/100/1000baseT PHY, rev. 0
ppb4 at pci0 dev 8 function 0 "ServerWorks HT-2000 PCIE" rev 0xa3
pci5 at ppb4 bus 5
ppb5 at pci0 dev 9 function 0 "ServerWorks HT-2000 PCIE" rev 0xa3
pci6 at ppb5 bus 6
ppb6 at pci0 dev 10 function 0 "ServerWorks HT-2000 PCIE" rev 0xa3
pci7 at ppb6 bus 7
ppb7 at pci0 dev 11 function 0 "ServerWorks HT-2000 PCIE" rev 0xa3
pci8 at ppb7 bus 8
pchb1 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
pchb2 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
pchb3 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
pchb4 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
biomask ef6d netmask ffed ttymask ffef
rd0: fixed, 3800 blocks
uhidev0 at uhub1 port 2 configuration 1 interface 0
uhidev0: LITE-ON Technology USB NetVista Full Width Keyboard., rev
1.10/1.00, addr 2, iclass 3/1
ukbd0 at uhidev0
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
dkcsum: sd0 matches BIOS drive 0x80
root on rd0a
rootdev=0x1100 rrootdev=0x2f00 rawdev=0x2f02
umass0 at uhub2 port 3 configuration 1 interface 0
umass0: vendor 0x0d7d USB DISK Pro, rev 2.00/1.00, addr 2
umass0: using SCSI over Bulk-Only
scsibus2 at umass0: 2 targets
sd1 at scsibus2 targ 1 lun 0: <, USB DISK Pro, PMAP> SCSI0 0/direct removable
sd1: 121MB, 121 cyl, 64 head, 32 sec, 512 bytes/sec, 248832 sec total
sd2 at scsibus2 targ 1 lun 1: <, USB DISK Pro, PMAP> SCSI0 0/direct removable
sd2: 1MB, 1 cyl, 64 head, 32 sec, 512 bytes/sec, 2880 sec total

Reply | Threaded
Open this post in threaded view
|

Re: kernel/5114: panic in bge_intr on IBM e326m

Srebrenko Sehic-2
In reply to this post by Srebrenko Sehic-2
The following reply was made to PR kernel/5114; it has been noted by GNATS.

From: "Srebrenko Sehic" <[hidden email]>
To: [hidden email], [hidden email]
Cc:  
Subject: Re: kernel/5114: panic in bge_intr on IBM e326m
Date: Tue, 20 Jun 2006 16:01:19 +0200

 This can be closed now. I've tested the same box with a recent
 -current and it works fine.
 
 OpenBSD 3.9-current (RAMDISK_CD) #1160: Mon Jun  5 00:49:42 MDT 2006
    [hidden email]:/usr/src/sys/arch/i386/compile/RAMDISK_CD
 cpu0: Dual Core AMD Opteron(tm) Processor 275 ("AuthenticAMD"
 686-class, 1024KB L2 cache) 2.20 GHz
 cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3
 real mem  = 2146377728 (2096072K)
 avail mem = 1951416320 (1905680K)
 using 4256 buffers containing 107421696 bytes (104904K) of memory
 mainbus0 (root)
 bios0 at mainbus0: AT/286+(5f) BIOS, date 12/16/05, BIOS32 rev. 0 @
 0xfd6d1, SMBIOS rev. 2.34 @ 0x7ff7c000 (46 entries)
 bios0: IBM IBM eServer 326m -[796965Y]-
 pcibios0 at bios0: rev 2.1 @ 0xfd650/0x9b0
 pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfde50/400 (23 entries)
 pcibios0: no compatible PCI ICU found: ICU vendor 0xffff product 0xffff
 pcibios0: Warning, unable to fix up PCI interrupt routing
 pcibios0: PCI bus #8 is the last bus
 bios0: ROM list: 0xc0000/0x9000 0xc9000/0x1600 0xca800/0x1600 0xcc000/0x4000
 cpu0 at mainbus0
 pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
 ppb0 at pci0 dev 1 function 0 "ServerWorks HT-1000 PCI" rev 0x00
 pci1 at ppb0 bus 1
 ppb1 at pci1 dev 13 function 0 "ServerWorks HT-1000 PCIX" rev 0xb2
 pci2 at ppb1 bus 2
 mpt0 at pci2 dev 3 function 0 "Symbios Logic 53c1030" rev 0x08: irq 11
 scsibus0 at mpt0: 16 targets
 sd0 at scsibus0 targ 0 lun 0: <IBM-ESXS, MAX3036NC FN, CA06> SCSI4
 0/direct fixed
 sd0: 34715MB, 49158 cyl, 2 head, 723 sec, 512 bytes/sec, 71096640 sec total
 mpt0: target 0 Synchronous at 160MHz width 16bit offset 127 QAS 0 DT 1 IU 1
 pchb0 at pci0 dev 2 function 0 "ServerWorks HT-1000" rev 0x00
 pciide0 at pci0 dev 2 function 1 "ServerWorks HT-1000 IDE" rev 0x00: DMA
 atapiscsi0 at pciide0 channel 0 drive 0
 scsibus1 at atapiscsi0: 2 targets
 cd0 at scsibus1 targ 0 lun 0: <HL-DT-ST, CD-ROM GCR-8240N, 1.06> SCSI0
 5/cdrom removable
 cd0(pciide0:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 0
 pcib0 at pci0 dev 2 function 2 "ServerWorks HT-1000 LPC" rev 0x00
 ohci0 at pci0 dev 3 function 0 "ServerWorks HT-1000 USB" rev 0x01: irq
 10, version 1.0, legacy support
 usb0 at ohci0: USB revision 1.0
 uhub0 at usb0
 uhub0: ServerWorks OHCI root hub, rev 1.00/1.00, addr 1
 uhub0: 2 ports with 2 removable, self powered
 ohci1 at pci0 dev 3 function 1 "ServerWorks HT-1000 USB" rev 0x01: irq
 10, version 1.0, legacy support
 usb1 at ohci1: USB revision 1.0
 uhub1 at usb1
 uhub1: ServerWorks OHCI root hub, rev 1.00/1.00, addr 1
 uhub1: 2 ports with 2 removable, self powered
 ehci0 at pci0 dev 3 function 2 "ServerWorks HT-1000 USB" rev 0x01: irq 10
 usb2 at ehci0: USB revision 2.0
 uhub2 at usb2
 uhub2: ServerWorks EHCI root hub, rev 2.00/1.00, addr 1
 uhub2: 4 ports with 4 removable, self powered
 vga1 at pci0 dev 4 function 0 "ATI ES1000" rev 0x01
 wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
 ppb2 at pci0 dev 6 function 0 "ServerWorks HT-2000 PCIX" rev 0xa3
 pci3 at ppb2 bus 3
 ppb3 at pci0 dev 7 function 0 "ServerWorks HT-2000 PCIX" rev 0xa3
 pci4 at ppb3 bus 4
 bge0 at pci4 dev 4 function 0 "Broadcom BCM5780" rev 0x03, BCM5714 B3
 (0x8003): irq 7, address 00:11:25:c4:48:a6
 brgphy0 at bge0 phy 1: BCM5780 10/100/1000baseT PHY, rev. 0
 bge1 at pci4 dev 4 function 1 "Broadcom BCM5780" rev 0x03, BCM5714 B3
 (0x8003): irq 12, address 00:11:25:c4:48:a7
 brgphy1 at bge1 phy 1: BCM5780 10/100/1000baseT PHY, rev. 0
 ppb4 at pci0 dev 8 function 0 "ServerWorks HT-2000 PCIE" rev 0xa3
 pci5 at ppb4 bus 5
 ppb5 at pci0 dev 9 function 0 "ServerWorks HT-2000 PCIE" rev 0xa3
 pci6 at ppb5 bus 6
 ppb6 at pci0 dev 10 function 0 "ServerWorks HT-2000 PCIE" rev 0xa3
 pci7 at ppb6 bus 7
 ppb7 at pci0 dev 11 function 0 "ServerWorks HT-2000 PCIE" rev 0xa3
 pci8 at ppb7 bus 8
 pchb1 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
 pchb2 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
 pchb3 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
 pchb4 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
 isa0 at pcib0
 isadma0 at isa0
 pckbc0 at isa0 port 0x60/5
 pckbd0 at pckbc0 (kbd slot)
 pckbc0: using irq 1 for kbd slot
 wskbd0 at pckbd0: console keyboard, using wsdisplay0
 npx0 at isa0 port 0xf0/16: using exception 16
 pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
 biomask ef6d netmask ffed ttymask ffef
 rd0: fixed, 3800 blocks
 uhidev0 at uhub1 port 2 configuration 1 interface 0
 uhidev0: LITE-ON Technology USB NetVista Full Width Keyboard., rev
 1.10/1.00, addr 2, iclass 3/1
 ukbd0 at uhidev0
 wskbd1 at ukbd0 mux 1
 wskbd1: connecting to wsdisplay0
 dkcsum: sd0 matches BIOS drive 0x80
 root on rd0a
 rootdev=0x1100 rrootdev=0x2f00 rawdev=0x2f02
 umass0 at uhub2 port 3 configuration 1 interface 0
 umass0: vendor 0x0d7d USB DISK Pro, rev 2.00/1.00, addr 2
 umass0: using SCSI over Bulk-Only
 scsibus2 at umass0: 2 targets
 sd1 at scsibus2 targ 1 lun 0: <, USB DISK Pro, PMAP> SCSI0 0/direct removable
 sd1: 121MB, 121 cyl, 64 head, 32 sec, 512 bytes/sec, 248832 sec total
 sd2 at scsibus2 targ 1 lun 1: <, USB DISK Pro, PMAP> SCSI0 0/direct removable
 sd2: 1MB, 1 cyl, 64 head, 32 sec, 512 bytes/sec, 2880 sec total