kernel/4613: Slow SATA performance with nForce4 on amd64

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

kernel/4613: Slow SATA performance with nForce4 on amd64

Srebrenko Sehic-2
>Number:         4613
>Category:       kernel
>Synopsis:       Slow SATA performance with nForce4 on amd64
>Confidential:   yes
>Severity:       serious
>Priority:       medium
>Responsible:    bugs
>State:          open
>Quarter:        
>Keywords:      
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Nov 11 21:10:01 GMT 2005
>Closed-Date:
>Last-Modified:
>Originator:     Srebrenko Sehic
>Release:        OpenBSD 3.8-amd64
>Organization:
Armorlogic
>Environment:
   System      : OpenBSD 3.8
   Architecture: OpenBSD.amd64
   Machine     : amd64
>Description:
After installaing OpenBSD 3.8-amd64 on HT DL145 G2 server with SATA
driver, I noticed rather poor disk performance. AFAIK, the problem is
due to nForce4 disk controller which is not that well supported or is
somehow different for this HP box. A previous HP DL145 G1 which had
the AMD 8111 (I think) works like a charm.

Here is some disk performance data:

# dd if=/dev/zero of=dump count=1000000
1000000+0 records in
1000000+0 records out
512000000 bytes transferred in 67.214 secs (7617393 bytes/sec)

Dmesg follows:

OpenBSD 3.8 (GENERIC) #247: Sat Sep 10 15:53:26 MDT 2005
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC
real mem = 1072398336 (1047264K)
avail mem = 908378112 (887088K)
using 22937 buffers containing 107446272 bytes (104928K) of memory
mainbus0 (root)
cpu0 at mainbus0: (uniprocessor)
cpu0: AMD Opteron(tm) Processor 246, 2009.53 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,SSE3,NXE,MMXX,FFXSR,LO
NG,3DNOW2,3DNOW
cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 1MB
64b/line 16-way L2 cache
cpu0: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu0: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
pci0 at mainbus0 bus 0: configuration mode 1
"Nvidia nForce4 DDR" rev 0xa3 at pci0 dev 0 function 0 not configured
"Nvidia nForce4 ISA" rev 0xa3 at pci0 dev 1 function 0 not configured
"Nvidia nForce4 SMBus" rev 0xa2 at pci0 dev 1 function 1 not configured
ohci0 at pci0 dev 2 function 0 "Nvidia nForce4 USB" rev 0xa2: irq 10,
version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: Nvidia OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
ehci0 at pci0 dev 2 function 1 "Nvidia nForce4 USB" rev 0xa3: irq 11
ehci0: timed out waiting for BIOS
usb1 at ehci0: USB revision 2.0
uhub1 at usb1
uhub1: Nvidia EHCI root hub, rev 2.00/1.00, addr 1
uhub1: 4 ports with 4 removable, self powered
pciide0 at pci0 dev 6 function 0 "Nvidia nForce4 IDE" rev 0xa2: DMA,
channel 0 configured to compatibility, channel 1 configu
red to compatibility
pciide0: channel 0 disabled (no drives)
pciide0: channel 1 disabled (no drives)
pciide1 at pci0 dev 8 function 0 "Nvidia nForce4 SATA 2" rev 0xa3: DMA
pciide1: using irq 10 for native-PCI interrupt
wd0 at pciide1 channel 0 drive 0: <Maxtor 6L080M0>
wd0: 16-sector PIO, LBA48, 76319MB, 156301488 sectors
wd0(pciide1:0:0): using PIO mode 4, Ultra-DMA mode 5
ppb0 at pci0 dev 9 function 0 "Nvidia nForce4 PCI-PCI" rev 0xa2
pci1 at ppb0 bus 1
vga1 at pci1 dev 5 function 0 "Nvidia GeForce2 MX" rev 0xb2
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
ppb1 at pci0 dev 12 function 0 "Nvidia nForce4 PCIE" rev 0xa3
pci2 at ppb1 bus 2
bge0 at pci2 dev 0 function 0 "Broadcom BCM5721" rev 0x11, BCM5750 B1
(0x4101): irq 11 address 00:14:38:a7:35:b6
brgphy0 at bge0 phy 1: BCM5750 10/100/1000baseT PHY, rev. 0
ppb2 at pci0 dev 13 function 0 "Nvidia nForce4 PCIE" rev 0xa3
pci3 at ppb2 bus 3
bge1 at pci3 dev 0 function 0 "Broadcom BCM5721" rev 0x11, BCM5750 B1
(0x4101): irq 10 address 00:14:38:a7:35:b7
brgphy1 at bge1 phy 1: BCM5750 10/100/1000baseT PHY, rev. 0
ppb3 at pci0 dev 14 function 0 "Nvidia nForce4 PCIE" rev 0xa3
pci4 at ppb3 bus 4
pchb0 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
pchb1 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
pchb2 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
pchb3 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
isa0 at mainbus0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
sysbeep0 at pcppi0
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302

>How-To-Repeat:

Install OpenBSD 3.8 on a HP DL145 G2 (with SATA drives), boot and do
some disk benchmarks.

>Fix:
Unavailable.


>Release-Note:
>Audit-Trail:
>Unformatted:
 To: [hidden email]
 Subject:
 From: Srebrenko Sehic
 Cc:
 Reply-To: [hidden email]
 X-sendbug-version: 3.97