installing clamav package fails on current

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

installing clamav package fails on current

Didier Wiroth
Hello,

I'm trying to install clamav on current (which is a custom build from yesterday) but it fails.
I did not install X11!

When I try to install clamav it fails at some point complaining about a missing library "expat.8.0"?!
$ sudo pkg_add clamav
Can't install gettext-0.14.6p0: lib not found expat.8.0
Dependencies for gettext-0.14.6p0 resolve to: libiconv-1.9.2p3
Full dependency tree is libiconv-1.9.2p3
Can't install libidn-0.6.1: can't resolve gettext-0.14.6p0
Can't install curl-7.16.2: can't resolve libidn-0.6.1
Can't install clamav-0.90.3: can't resolve curl-7.16.2

I'm using the latest available packages:
$ echo $PKG_PATH
ftp://ftp.belnet.be/packages/openbsd/snapshots/packages/i386
The packages are from the 10 june

Am I doing something wrong?

Other packages installed well, here are the currently installed packages:
$ pkg_info
arc-5.21op0         create & extract files from DOS .ARC files
bzip2-1.0.4         block-sorting file compressor, unencumbered
gmp-4.2.1           library for arbitrary precision arithmetic
lha-1.14i.ac20050924.1 archive files using LZW compression (.lzh files)
libiconv-1.9.2p3    character set conversion library
no-ip-2.1.3         No-IP.com Dynamic DNS client
pdnsd-1.2.5         threaded DNS daemon, optimized for caching
smtp-vilter-1.3.6p0 sendmail milter to scan messages for viruses and spam
unzip-5.52          extract, list & test files in a ZIP archive
zoo-2.10.1p1        handle the old .ZOO archive format

Thank you very much for your help!

Didier

Reply | Threaded
Open this post in threaded view
|

Re: installing clamav package fails on current

Antoine Jacoutot
On Wednesday 13 June 2007 17:34:23 Didier Wiroth wrote:
> Hello,
>
> I'm trying to install clamav on current (which is a custom build from
> yesterday) but it fails. I did not install X11!

That is the reason.
$ locate libexpat.so
/usr/X11R6/lib/libexpat.so.8.0

The expat port has been removed and you need the xbase set if you want
libexpat.

--
Antoine

Reply | Threaded
Open this post in threaded view
|

Re: installing clamav package fails on current

Will Maier
In reply to this post by Didier Wiroth
On Wed, Jun 13, 2007 at 05:34:23PM +0200, Didier Wiroth wrote:
> I'm trying to install clamav on current (which is a custom build
> from yesterday) but it fails.  I did not install X11!

Read the archives[0]. Read the FAQ[1]. Install X11. This has come up a
couple times...

[0] http://marc.info/?l=openbsd-misc&w=2&r=1&s=expat&q=b
[1] http://www.openbsd.org/faq/faq15.html#PkgInstall

--

o--------------------------{ Will Maier }--------------------------o
| web:.......http://www.lfod.us/ | [hidden email] |
*------------------[ BSD Unix: Live Free or Die ]------------------*

Reply | Threaded
Open this post in threaded view
|

Re: installing clamav package fails on current

Markus Lude-3
In reply to this post by Didier Wiroth
On Wed, Jun 13, 2007 at 05:34:23PM +0200, Didier Wiroth wrote:
> Hello,
>
> I'm trying to install clamav on current (which is a custom build from yesterday) but it fails.
> I did not install X11!
>
> When I try to install clamav it fails at some point complaining about a missing library "expat.8.0"?!
> $ sudo pkg_add clamav
> Can't install gettext-0.14.6p0: lib not found expat.8.0

expat.8.0 is from the xbase set. You need to install the xbase set.

> Dependencies for gettext-0.14.6p0 resolve to: libiconv-1.9.2p3
> Full dependency tree is libiconv-1.9.2p3
> Can't install libidn-0.6.1: can't resolve gettext-0.14.6p0
> Can't install curl-7.16.2: can't resolve libidn-0.6.1
> Can't install clamav-0.90.3: can't resolve curl-7.16.2
>
> I'm using the latest available packages:
> $ echo $PKG_PATH
> ftp://ftp.belnet.be/packages/openbsd/snapshots/packages/i386

AFAIK there should be a slash at the end.

> The packages are from the 10 june
>
> Am I doing something wrong?
>
> Other packages installed well, here are the currently installed packages:
> $ pkg_info
> arc-5.21op0         create & extract files from DOS .ARC files
> bzip2-1.0.4         block-sorting file compressor, unencumbered
> gmp-4.2.1           library for arbitrary precision arithmetic
> lha-1.14i.ac20050924.1 archive files using LZW compression (.lzh files)
> libiconv-1.9.2p3    character set conversion library
> no-ip-2.1.3         No-IP.com Dynamic DNS client
> pdnsd-1.2.5         threaded DNS daemon, optimized for caching
> smtp-vilter-1.3.6p0 sendmail milter to scan messages for viruses and spam
> unzip-5.52          extract, list & test files in a ZIP archive
> zoo-2.10.1p1        handle the old .ZOO archive format
>
> Thank you very much for your help!

Regards,
Markus