i810 story

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

i810 story

Markus Schatzl-2
Hi,

I got a Thinkpad X40 with an additional display. Somewhere
around end of March and beginning of April I switched to
xenocara to be able to use the 19" thing in portrait mode.
Though the xenocara-version I built myself at this time did not
work for me, the snapshots from xenocara.org ran without problems.
Screen rotation was then doable via the xrandr extension.

As I followed misc@, there have been some problems with the i810
driver recently. I never saw them with the version I ran. I gather
that the "old" version (from March/April, which ran well on my machine)
was reverted. When installing the current X-snapshots from 04/20/07,
I recognized thats some things like the said rotation do not work
anymore:

# xrandr
 SZ:    Pixels          Physical       Refresh
 *0   1280 x 1024   ( 382mm x 302mm )  *75  
  1   1024 x 768    ( 382mm x 302mm )   75  
  2    800 x 600    ( 382mm x 302mm )   75  
  3    640 x 480    ( 382mm x 302mm )   75  
  Current rotation - normal
  Current reflection - none
  Rotations possible - normal
  Reflections possible - none

Rotation to the left is not possible anymore since the card has
no clue that it is capable of doing this:

# xrandr -o left
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  156 (RANDR)
  Minor opcode of failed request:  2 (RRSetScreenConfig)
  Serial number of failed request:  12
  Current serial number in output stream:  12

My xorg.conf has not been changed within the last month. It
worked very well until installing those recent snapshots. As I
auto-generated it when switching to xenocara and adapated it to
my needs afterwards, I think config issues can be entirely
excluded.

Frankly, I lost the overview in xenocara - at least for whats
inside in which version and of what reason. I'd therefore be
happy if anybody could tell me if the absence of the rotation
functionality is a temporary issue or if this is kicked out forever.

Please let me know for in case you need additional information.

Thanks in advance,
/Markus