Quantcast

i386: gcc: error: -msave-args makes no sense in the 32-bit mode

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

i386: gcc: error: -msave-args makes no sense in the 32-bit mode

Sebastien Marie-4
Hi,

I am trying to build -current kernel on i386 (current running code is
from Sun May  7 07:09:01 CEST 2017 - full dmesg below).


As mentioned in /faq/current.html, I first rebuild and install cc (and
do a make clean for kernel) before trying to build a new kernel.


semarie@bert:/usr/src/sys/arch/amd64/compile/GENERIC.MP$ doas make
cat /usr/src/sys/arch/amd64/amd64/genassym.cf
/usr/src/sys/arch/amd64/amd64/genassym.cf |  sh
/usr/src/sys/kern/genassym.sh cc -g -Werror -Wall
-Wimplicit-function-declaration  -Wno-uninitialized -Wno-pointer-sign  
-Wframe-larger-than=2047 -mcmodel=kernel -mno-red-zone -mno-sse2
-mno-sse -mno-3dnow  -mno-mmx -msoft-float -fno-omit-frame-pointer
-ffreestanding -fno-pie -msave-args -O2 -pipe -nostdinc -I/usr/src/sys
-I/home/openbsd/src/sys/arch/amd64/compile/GENERIC.MP/obj
-I/usr/src/sys/arch -DDDB -DDIAGNOSTIC -DKTRACE -DACCOUNTING -DKMEMSTATS
-DPTRACE -DPOOL_DEBUG -DCRYPTO -DSYSVMSG -DSYSVSEM -DSYSVSHM
-DUVM_SWAP_ENCRYPT -DFFS -DFFS2 -DFFS_SOFTUPDATES -DUFS_DIRHASH -DQUOTA
-DEXT2FS -DMFS -DNFSCLIENT -DNFSSERVER -DCD9660 -DUDF -DMSDOSFS -DFIFO
-DFUSE -DSOCKET_SPLICE -DTCP_SACK -DTCP_ECN -DTCP_SIGNATURE -DART
-DINET6 -DIPSEC -DPPP_BSDCOMP -DPPP_DEFLATE -DPIPEX -DMROUTING -DMPLS
-DBOOT_CONFIG -DUSER_PCICONF -DAPERTURE -DMTRR -DNTFS -DHIBERNATE
-DPCIVERBOSE -DUSBVERBOSE -DWSDISPLAY_COMPAT_USL
-DWSDISPLAY_COMPAT_RAWKBD -DWSDISPLAY_DEFAULTSCREENS="6" -DX86EMU
-DONEWIREVERBOSE -DMULTIPROCESSOR -DMAXUSERS=80 -D_KERNEL -MD -MP -MF
assym.P > assym.h.tmp
/tmp/genassym_c.A2WiqRuwqq:1: error: code model 'kernel' not supported
in the 32 bit mode
/tmp/genassym_c.A2WiqRuwqq:1: error: -msave-args makes no sense in the
32-bit mode
*** Error 1 in /home/openbsd/src/sys/arch/amd64/compile/GENERIC.MP
(Makefile:884 'assym.h')


Looking at gcc code source, it seems `-msave-args' is unsupported under
i386:

/usr/src/gnu/gcc/gcc/config/i386/i386.c

   1891    if (TARGET_64BIT)
   1892      {
                [...]
   1904       }
   1905    else
   1906      {
   1907        if (TARGET_SAVE_ARGS)
   1908          error ("-msave-args makes no sense in the 32-bit mode");
   1909        /* i386 ABI does not specify red zone.  It still makes
sense to use it
   1910           when programmer takes care to stack from being
destroyed.  */
   1911        if (!(target_flags_explicit & MASK_NO_RED_ZONE))
   1912          target_flags |= MASK_NO_RED_ZONE;
   1913      }


Does I miss something ?

Thanks.
--
Sebastien Marie



OpenBSD 6.1-current (GENERIC.MP) #46: Sun May  7 07:09:01 CEST 2017
     
[hidden email]:/home/openbsd/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Genuine Intel(R) CPU T2400 @ 1.83GHz ("GenuineIntel" 686-class)
1.83 GHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,SSE3,MWAIT,VMX,EST,TM2,xTPR,PDCM,PERF,SENSOR
real mem  = 2137354240 (2038MB)
avail mem = 2083622912 (1987MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: date 06/13/07, BIOS32 rev. 0 @ 0xffa10, SMBIOS rev.
2.4 @ 0xf7980 (44 entries)
bios0: vendor Dell Inc. version "A17" date 06/13/2007
bios0: Dell Inc. MM061
acpi0 at bios0: rev 0
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP HPET APIC MCFG SLIC BOOT SSDT
acpi0: wakeup devices LID_(S3) PBTN(S4) MBTN(S5) PCI0(S3) USB0(S0)
USB1(S0) USB2(S0) USB3(S0) EHCI(S0) AZAL(S3) PCIE(S4) RP01(S4) RP02(S3)
RP03(S3) RP04(S3) RP05(S3) [...]
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
cpu0: apic clock running at 166MHz
cpu0: mwait min=64, max=64, C-substates=0.2.2.2.2, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Genuine Intel(R) CPU T2400 @ 1.83GHz ("GenuineIntel" 686-class)
1.83 GHz
cpu1:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,SSE3,MWAIT,VMX,EST,TM2,xTPR,PDCM,PERF,SENSOR
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
acpimcfg0 at acpi0 addr 0xf0000000, bus 0-63
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (AGP_)
acpiprt2 at acpi0: bus 3 (PCIE)
acpiprt3 at acpi0: bus 11 (RP01)
acpiprt4 at acpi0: bus -1 (RP02)
acpiprt5 at acpi0: bus -1 (RP03)
acpiprt6 at acpi0: bus 12 (RP04)
acpiprt7 at acpi0: bus -1 (RP05)
acpiprt8 at acpi0: bus -1 (RP06)
acpicpu0 at acpi0: !C3(250@85 io@0x1015), !C2(500@1 io@0x1014),
C1(1000@1 halt), PSS
acpicpu1 at acpi0: !C3(250@85 io@0x1015), !C2(500@1 io@0x1014),
C1(1000@1 halt), PSS
acpitz0 at acpi0: critical temperature is 126 degC
"*pnp0c14" at acpi0 not configured
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT0 model " DELLUD2649" serial 878 type LION oem
"Sanyo"
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: PBTN
acpibtn2 at acpi0: SBTN
"PNP0C32" at acpi0 not configured
"PNP0F13" at acpi0 not configured
"PNP0303" at acpi0 not configured
acpivideo0 at acpi0: VID_
acpivideo1 at acpi0: VID_
acpivout0 at acpivideo1: LCD_
acpivideo2 at acpi0: VID2
bios0: ROM list: 0xc0000/0xe800! 0xce800/0x1800
cpu0: Enhanced SpeedStep 1829 MHz: speeds: 1833, 1333, 1000 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82945GM Host" rev 0x03
inteldrm0 at pci0 dev 2 function 0 "Intel 82945GM Video" rev 0x03
drm0 at inteldrm0
intagp0 at inteldrm0
agp0 at intagp0: aperture at 0xd0000000, size 0x10000000
inteldrm0: apic 2 int 16
inteldrm0: 1280x800, 32bpp
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
"Intel 82945GM Video" rev 0x03 at pci0 dev 2 function 1 not configured
azalia0 at pci0 dev 27 function 0 "Intel 82801GB HD Audio" rev 0x01: msi
azalia0: codecs: Sigmatel STAC9200, Conexant/0x2bfa, using Sigmatel
STAC9200
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 82801GB PCIE" rev 0x01: apic 2 int
16
pci1 at ppb0 bus 11
wpi0 at pci1 dev 0 function 0 "Intel PRO/Wireless 3945ABG" rev 0x02:
msi, MoW2, address 00:13:02:2e:8b:46
ppb1 at pci0 dev 28 function 3 "Intel 82801GB PCIE" rev 0x01: apic 2 int
19
pci2 at ppb1 bus 12
uhci0 at pci0 dev 29 function 0 "Intel 82801GB USB" rev 0x01: apic 2 int
20
uhci1 at pci0 dev 29 function 1 "Intel 82801GB USB" rev 0x01: apic 2 int
21
uhci2 at pci0 dev 29 function 2 "Intel 82801GB USB" rev 0x01: apic 2 int
22
uhci3 at pci0 dev 29 function 3 "Intel 82801GB USB" rev 0x01: apic 2 int
23
ehci0 at pci0 dev 29 function 7 "Intel 82801GB USB" rev 0x01: apic 2 int
20
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "Intel EHCI root hub" rev
2.00/1.00 addr 1
ppb2 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xe1
pci3 at ppb2 bus 3
bce0 at pci3 dev 0 function 0 "Broadcom BCM4401B1" rev 0x02: apic 2 int
17, address 00:15:c5:0b:8b:7a
bmtphy0 at bce0 phy 1: BCM4401 10/100baseTX PHY, rev. 0
"Ricoh 5C832 Firewire" rev 0x00 at pci3 dev 1 function 0 not configured
sdhc0 at pci3 dev 1 function 1 "Ricoh 5C822 SD/MMC" rev 0x19: apic 2 int
18
sdhc0: SDHC 1.0, 33 MHz base clock
sdmmc0 at sdhc0: 4-bit, sd high-speed, mmc high-speed
"Ricoh 5C843 MMC" rev 0x01 at pci3 dev 1 function 2 not configured
"Ricoh 5C592 Memory Stick" rev 0x0a at pci3 dev 1 function 3 not
configured
"Ricoh 5C852 xD" rev 0x05 at pci3 dev 1 function 4 not configured
ichpcib0 at pci0 dev 31 function 0 "Intel 82801GBM LPC" rev 0x01: PM
disabled
pciide0 at pci0 dev 31 function 2 "Intel 82801GBM SATA" rev 0x01: DMA,
channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <ST96812AS>
wd0: 16-sector PIO, LBA48, 57241MB, 117231408 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <_NEC, DVD+-RW ND-6650A, 102C> ATAPI
5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
ichiic0 at pci0 dev 31 function 3 "Intel 82801GB SMBus" rev 0x01: apic 2
int 17
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 1GB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
spdmem1 at iic0 addr 0x52: 1GB DDR2 SDRAM non-parity PC2-5300CL5 SO-DIMM
usb1 at uhci0: USB revision 1.0
uhub1 at usb1 configuration 1 interface 0 "Intel UHCI root hub" rev
1.00/1.00 addr 1
usb2 at uhci1: USB revision 1.0
uhub2 at usb2 configuration 1 interface 0 "Intel UHCI root hub" rev
1.00/1.00 addr 1
usb3 at uhci2: USB revision 1.0
uhub3 at usb3 configuration 1 interface 0 "Intel UHCI root hub" rev
1.00/1.00 addr 1
usb4 at uhci3: USB revision 1.0
uhub4 at usb4 configuration 1 interface 0 "Intel UHCI root hub" rev
1.00/1.00 addr 1
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pms0: Synaptics touchpad, firmware 6.2
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
vmm0 at mainbus0: VMX
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on wd0a (055d82c92ce5e61f.a) swap on wd0b dump on wd0b

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: i386: gcc: error: -msave-args makes no sense in the 32-bit mode

Mark Kettenis
> Date: Wed, 10 May 2017 09:06:24 +0200
> From: Sebastien Marie <[hidden email]>
>
> Hi,
>
> I am trying to build -current kernel on i386 (current running code is
> from Sun May  7 07:09:01 CEST 2017 - full dmesg below).
>
>
> As mentioned in /faq/current.html, I first rebuild and install cc (and
> do a make clean for kernel) before trying to build a new kernel.
>
>
> semarie@bert:/usr/src/sys/arch/amd64/compile/GENERIC.MP$ doas make

Building an amd64 kernel on i386 never worked.

Time for coffee? ;)

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: i386: gcc: error: -msave-args makes no sense in the 32-bit mode

Theo Buehler
In reply to this post by Sebastien Marie-4
On Wed, May 10, 2017 at 09:06:24AM +0200, Sebastien Marie wrote:

> Hi,
>
> I am trying to build -current kernel on i386 (current running code is
> from Sun May  7 07:09:01 CEST 2017 - full dmesg below).
>
>
> As mentioned in /faq/current.html, I first rebuild and install cc (and
> do a make clean for kernel) before trying to build a new kernel.
>
>
> semarie@bert:/usr/src/sys/arch/amd64/compile/GENERIC.MP$ doas make

You're trying to build an amd64 kernel on i386, I don't think this
works, independently of -msave-args.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: i386: gcc: error: -msave-args makes no sense in the 32-bit mode

Sebastien Marie-3
In reply to this post by Mark Kettenis
On Wed, May 10, 2017 at 09:46:55AM +0200, Mark Kettenis wrote:

> > Date: Wed, 10 May 2017 09:06:24 +0200
> > From: Sebastien Marie <[hidden email]>
> >
> > Hi,
> >
> > I am trying to build -current kernel on i386 (current running code is
> > from Sun May  7 07:09:01 CEST 2017 - full dmesg below).
> >
> >
> > As mentioned in /faq/current.html, I first rebuild and install cc (and
> > do a make clean for kernel) before trying to build a new kernel.
> >
> >
> > semarie@bert:/usr/src/sys/arch/amd64/compile/GENERIC.MP$ doas make
>
> Building an amd64 kernel on i386 never worked.
>
> Time for coffee? ;)

arg my bad. yes, something like coffee... lot of coffee.

thanks for your reply, and sorry for the noise.
--
Sebastien Marie

Loading...