i386 bsd.rd panic

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

i386 bsd.rd panic

Eivind Eide
I've been trying to update this -current machine with the bsd.rd from
the last 4 snapshots,
the last being from "Sun Apr 26 02:22:08 MDT 2015".
However this kernel immediately after reporting how much ram I have
panics with this message:

fatal protection fault (4) in supervisor mode
trap type 4 code 0 eip d020204e cs 8 eflags 10006 cr2 0 cpl 0
panic: trap type 4, code=0, pc=d020204e

Any ideas?

dmesg from still installed system:

OpenBSD 5.7-current (GENERIC) #760: Thu Apr  2 11:18:47 MDT 2015
     [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Pentium(R) 4 Mobile CPU 1.80GHz ("GenuineIntel"
686-class) 1.80 GHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PERF
real mem  = 2146852864 (2047MB)
avail mem = 2099503104 (2002MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: date 05/15/03, BIOS32 rev. 0 @ 0xffe90, SMBIOS rev.
2.3 @ 0xf7690 (61 entries)
bios0: vendor Dell Computer Corporation version "A09" date 05/15/2003
bios0: Dell Computer Corporation Latitude C640
acpi0 at bios0: rev 0
acpi0: sleep states S0 S1 S3 S4 S5
acpi0: tables DSDT FACP
acpi0: wakeup devices LID_(S3) PBTN(S4) PCI0(S3) UAR1(S3) USB0(S1)
USB1(S1) USB2(S1) MODM(S3) PCIE(S3) MPCI(S3)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (AGP_)
acpiprt2 at acpi0: bus 2 (PCIE)
acpiprt3 at acpi0: bus -1 (MPCI)
acpicpu0 at acpi0acpicpu0: struck PSS entry, core frequency equals  last
acpicpu0: struck PSS entry, core frequency equals  last
acpicpu0: invalid _PSS length
: C2
acpipwrres0 at acpi0: PADA, resource for ADPT
acpitz0 at acpi0: critical temperature is 99 degC
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT0 model "LIP8120DLP" serial 5184 type LION oem
"Sony Corp."
acpibat1 at acpi0: BAT1 not present
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: PBTN
acpibtn2 at acpi0: SBTN
acpidock0 at acpi0: GDCK not docked (0)
acpivideo0 at acpi0: VID_
bios0: ROM list: 0xc0000/0xf000 0xcf000/0x800! 0xcf800/0x800!
cpu0 at mainbus0: (uniprocessor)
mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82845 Host" rev 0x04
intelagp0 at pchb0
agp0 at intelagp0: aperture at 0xe8000000, size 0x4000000
ppb0 at pci0 dev 1 function 0 "Intel 82845 AGP" rev 0x04
pci1 at ppb0 bus 1
radeondrm0 at pci1 dev 0 function 0 "ATI Radeon Mobility M7" rev 0x00
drm0 at radeondrm0
radeondrm0: irq 11
uhci0 at pci0 dev 29 function 0 "Intel 82801CA/CAM USB" rev 0x02: irq 11
ppb1 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0x42
pci2 at ppb1 bus 2
xl0 at pci2 dev 0 function 0 "3Com 3c905C 100Base-TX" rev 0x78: irq 11,
address 00:08:74:48:40:d6
exphy0 at xl0 phy 24: 3Com internal media interface
cbb0 at pci2 dev 1 function 0 "TI PCI1420 CardBus" rev 0x00: irq 11
cbb1 at pci2 dev 1 function 1 "TI PCI1420 CardBus" rev 0x00: irq 11
ath0 at pci2 dev 3 function 0 "Atheros AR2413" rev 0x01: irq 11
ath0: AR2413 7.8 phy 4.5 rf 5.6 eeprom 5.2, WOR3W, address 00:16:cf:53:07:71
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 4 device 0 cacheline 0x8, lattimer 0x20
pcmcia0 at cardslot0
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 5 device 0 cacheline 0x8, lattimer 0x20
pcmcia1 at cardslot1
ichpcib0 at pci0 dev 31 function 0 "Intel 82801CAM LPC" rev 0x02
pciide0 at pci0 dev 31 function 1 "Intel 82801CAM IDE" rev 0x02: DMA,
channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <Hitachi HTS541080G9AT00>
wd0: 16-sector PIO, LBA, 76319MB, 156301488 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
atapiscsi0 at pciide0 channel 1 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <TOSHIBA, DVD-ROM SD-C2612, 1D21> ATAPI
5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
auich0 at pci0 dev 31 function 5 "Intel 82801CA/CAM AC97" rev 0x02: irq
11, ICH3 AC97
ac97: codec id 0x4352595b (Cirrus Logic CS4205 rev 3)
ac97: codec features mic channel, tone, simulated stereo, bass boost, 20
bit DAC, 18 bit ADC, SRS 3D
audio0 at auich0
"Intel 82801CA/CAM Modem" rev 0x02 at pci0 dev 31 function 6 not configured
usb0 at uhci0: USB revision 1.0
uhub0 at usb0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at ichpcib0
isadma0 at isa0
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
wsmouse1 at pms0 mux 0
pms0: Synaptics touchpad, firmware 5.9
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
sd0 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 005> SCSI2 0/direct fixed
sd0: 73241MB, 512 bytes/sector, 149998377 sectors
root on sd0a (b7aac228eb17d109.a) swap on sd0b dump on sd0b
radeondrm0: 1400x1050
wsdisplay0 at radeondrm0 mux 1: console (std, vt100 emulation), using wskbd0
wsdisplay0: screen 1-5 added (std, vt100 emulation)


--


Eivind Eide

"ONLY THOSE WHO ATTEMPT THE IMPOSSIBLE WILL ACHIEVE THE ABSURD"
- Oceania Association of Autonomous Astronauts

Reply | Threaded
Open this post in threaded view
|

Re: i386 bsd.rd panic

Tim van der Molen-3
Eivind Eide (2015-04-26 13:02 +0200):
> I've been trying to update this -current machine with the bsd.rd from the
> last 4 snapshots,
> the last being from "Sun Apr 26 02:22:08 MDT 2015".
> However this kernel immediately after reporting how much ram I have panics
> with this message:
>
> fatal protection fault (4) in supervisor mode
> trap type 4 code 0 eip d020204e cs 8 eflags 10006 cr2 0 cpl 0
> panic: trap type 4, code=0, pc=d020204e

I see the same when booting bsd.rd (#788, 24 April) on a medieval
laptop. Below a dmesg from the currently installed snapshot.

OpenBSD 5.7-beta (GENERIC) #729: Tue Mar  3 17:40:43 MST 2015
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Pentium(R) III Mobile CPU 933MHz ("GenuineIntel" 686-class) 931 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PSE36,MMX,FXSR,SSE,PERF
real mem  = 266747904 (254MB)
avail mem = 250011648 (238MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: date 07/30/01, BIOS32 rev. 0 @ 0xfd860, SMBIOS rev. 2.3 @ 0xfef0000 (53 entries)
bios0: vendor Phoenix/FUJITSU version "Version  1.06" date 07/30/2001
bios0: FUJITSU SIEMENS LIFEBOOK E Series
acpi0 at bios0: rev 0
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP
acpi0: wakeup devices UAR1(S3) HUB_(S4) DCS1(S4) A97M(S3) LID_(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (AGP_)
acpiprt2 at acpi0: bus 2 (HUB_)
acpiec0 at acpi0
acpicpu0 at acpi0: C3, C2, FVS, 933, 733 MHz
acpibtn0 at acpi0: PWRB
acpibtn1 at acpi0: LID_
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: CMB1 model "CP021007-XX" serial 1 type LION oem "Fujitsu"
acpibat1 at acpi0: CMB2 not present
acpidock0 at acpi0: DCS3 not docked (0)
acpidock1 at acpi0: DCS1 not docked (0)
acpivideo0 at acpi0: VGA_
bios0: ROM list: 0xc0000/0xe000
cpu0 at mainbus0: (uniprocessor)
mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82830M Host" rev 0x02
intelagp0 at pchb0
agp0 at intelagp0: aperture at 0xe0000000, size 0xe400000
ppb0 at pci0 dev 1 function 0 "Intel 82830M AGP" rev 0x02
pci1 at ppb0 bus 1
radeondrm0 at pci1 dev 0 function 0 "ATI Radeon Mobility M6" rev 0x00
drm0 at radeondrm0
radeondrm0: irq 11
uhci0 at pci0 dev 29 function 0 "Intel 82801CA/CAM USB" rev 0x01: irq 11
uhci1 at pci0 dev 29 function 2 "Intel 82801CA/CAM USB" rev 0x01: irq 11
ppb1 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0x41
pci2 at ppb1 bus 2
cbb0 at pci2 dev 10 function 0 "O2 Micro OZ6933 CardBus" rev 0x02: irq 11
cbb1 at pci2 dev 10 function 1 "O2 Micro OZ6933 CardBus" rev 0x02: irq 11
rl0 at pci2 dev 13 function 0 "Realtek 8139" rev 0x10: irq 11, address 00:e0:00:58:97:2d
rlphy0 at rl0 phy 0: RTL internal PHY
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 3 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
cardslot1 at cbb1 slot 1 flags 0
cardbus1 at cardslot1: bus 4 device 0 cacheline 0x0, lattimer 0x20
pcmcia1 at cardslot1
ichpcib0 at pci0 dev 31 function 0 "Intel 82801CAM LPC" rev 0x01
pciide0 at pci0 dev 31 function 1 "Intel 82801CAM IDE" rev 0x01: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <HITACHI_DK239A-65>
wd0: 16-sector PIO, LBA, 6194MB, 12685680 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <MATSHITA, UJDA310, 1.38> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 0, DMA mode 1
ichiic0 at pci0 dev 31 function 3 "Intel 82801CA/CAM SMBus" rev 0x01: SMI
iic0 at ichiic0
iic0: addr 0x19 00=00 01=00 02=00 03=00 04=00 05=00 06=00 07=00 08=00 09=00 0a=00 0b=00 0c=00 0d=00 0e=00 0f=00 10=00 11=20 24=00 b9=00 ba=00 words 00=0000 01=0000 02=0000 03=0000 04=0000 05=0000 06=0000 07=0000
auich0 at pci0 dev 31 function 5 "Intel 82801CA/CAM AC97" rev 0x01: irq 11, ICH3 AC97
ac97: codec id 0x83847609 (SigmaTel STAC9721/23)
ac97: codec features 18 bit DAC, 18 bit ADC, SigmaTel 3D
audio0 at auich0
usb0 at uhci0: USB revision 1.0
uhub0 at usb0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb1 at uhci1: USB revision 1.0
uhub1 at usb1 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at ichpcib0
isadma0 at isa0
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pms0: ALPS Glidepoint, version 0x7321
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
sd0 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 005> SCSI2 0/direct fixed
sd0: 6193MB, 512 bytes/sector, 12685088 sectors
root on sd0a (449bf7c9b38d71e5.a) swap on sd0b dump on sd0b
radeondrm0: 1024x768
wsdisplay0 at radeondrm0 mux 1: console (std, vt100 emulation), using wskbd0
wsdisplay0: screen 1-5 added (std, vt100 emulation)

Reply | Threaded
Open this post in threaded view
|

Re: i386 bsd.rd panic

Theo de Raadt
In reply to this post by Eivind Eide
> Eivind Eide (2015-04-26 13:02 +0200):
> > I've been trying to update this -current machine with the bsd.rd from the
> > last 4 snapshots,
> > the last being from "Sun Apr 26 02:22:08 MDT 2015".
> > However this kernel immediately after reporting how much ram I have panics
> > with this message:
> >
> > fatal protection fault (4) in supervisor mode
> > trap type 4 code 0 eip d020204e cs 8 eflags 10006 cr2 0 cpl 0
> > panic: trap type 4, code=0, pc=d020204e
>
> I see the same when booting bsd.rd (#788, 24 April) on a medieval
> laptop. Below a dmesg from the currently installed snapshot.

You don't have a NX bit.  Please try a new snapshot in a few hours.

Reply | Threaded
Open this post in threaded view
|

Re: i386 bsd.rd panic

Mike Larkin
In reply to this post by Eivind Eide
On Sun, Apr 26, 2015 at 01:02:49PM +0200, Eivind Eide wrote:

> I've been trying to update this -current machine with the bsd.rd
> from the last 4 snapshots,
> the last being from "Sun Apr 26 02:22:08 MDT 2015".
> However this kernel immediately after reporting how much ram I have
> panics with this message:
>
> fatal protection fault (4) in supervisor mode
> trap type 4 code 0 eip d020204e cs 8 eflags 10006 cr2 0 cpl 0
> panic: trap type 4, code=0, pc=d020204e
>
> Any ideas?
>
> dmesg from still installed system:
>
> OpenBSD 5.7-current (GENERIC) #760: Thu Apr  2 11:18:47 MDT 2015
>     [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
> cpu0: Intel(R) Pentium(R) 4 Mobile CPU 1.80GHz ("GenuineIntel"
> 686-class) 1.80 GHz
> cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PERF

Turn on NX (Execute Disable) support in your BIOS or wait for the next
snapshot.

-ml

> real mem  = 2146852864 (2047MB)
> avail mem = 2099503104 (2002MB)
> mpath0 at root
> scsibus0 at mpath0: 256 targets
> mainbus0 at root
> bios0 at mainbus0: date 05/15/03, BIOS32 rev. 0 @ 0xffe90, SMBIOS
> rev. 2.3 @ 0xf7690 (61 entries)
> bios0: vendor Dell Computer Corporation version "A09" date 05/15/2003
> bios0: Dell Computer Corporation Latitude C640
> acpi0 at bios0: rev 0
> acpi0: sleep states S0 S1 S3 S4 S5
> acpi0: tables DSDT FACP
> acpi0: wakeup devices LID_(S3) PBTN(S4) PCI0(S3) UAR1(S3) USB0(S1)
> USB1(S1) USB2(S1) MODM(S3) PCIE(S3) MPCI(S3)
> acpitimer0 at acpi0: 3579545 Hz, 24 bits
> acpiprt0 at acpi0: bus 0 (PCI0)
> acpiprt1 at acpi0: bus 1 (AGP_)
> acpiprt2 at acpi0: bus 2 (PCIE)
> acpiprt3 at acpi0: bus -1 (MPCI)
> acpicpu0 at acpi0acpicpu0: struck PSS entry, core frequency equals  last
> acpicpu0: struck PSS entry, core frequency equals  last
> acpicpu0: invalid _PSS length
> : C2
> acpipwrres0 at acpi0: PADA, resource for ADPT
> acpitz0 at acpi0: critical temperature is 99 degC
> acpiac0 at acpi0: AC unit online
> acpibat0 at acpi0: BAT0 model "LIP8120DLP" serial 5184 type LION oem
> "Sony Corp."
> acpibat1 at acpi0: BAT1 not present
> acpibtn0 at acpi0: LID_
> acpibtn1 at acpi0: PBTN
> acpibtn2 at acpi0: SBTN
> acpidock0 at acpi0: GDCK not docked (0)
> acpivideo0 at acpi0: VID_
> bios0: ROM list: 0xc0000/0xf000 0xcf000/0x800! 0xcf800/0x800!
> cpu0 at mainbus0: (uniprocessor)
> mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
> pci0 at mainbus0 bus 0: configuration mode 1 (bios)
> pchb0 at pci0 dev 0 function 0 "Intel 82845 Host" rev 0x04
> intelagp0 at pchb0
> agp0 at intelagp0: aperture at 0xe8000000, size 0x4000000
> ppb0 at pci0 dev 1 function 0 "Intel 82845 AGP" rev 0x04
> pci1 at ppb0 bus 1
> radeondrm0 at pci1 dev 0 function 0 "ATI Radeon Mobility M7" rev 0x00
> drm0 at radeondrm0
> radeondrm0: irq 11
> uhci0 at pci0 dev 29 function 0 "Intel 82801CA/CAM USB" rev 0x02: irq 11
> ppb1 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0x42
> pci2 at ppb1 bus 2
> xl0 at pci2 dev 0 function 0 "3Com 3c905C 100Base-TX" rev 0x78: irq
> 11, address 00:08:74:48:40:d6
> exphy0 at xl0 phy 24: 3Com internal media interface
> cbb0 at pci2 dev 1 function 0 "TI PCI1420 CardBus" rev 0x00: irq 11
> cbb1 at pci2 dev 1 function 1 "TI PCI1420 CardBus" rev 0x00: irq 11
> ath0 at pci2 dev 3 function 0 "Atheros AR2413" rev 0x01: irq 11
> ath0: AR2413 7.8 phy 4.5 rf 5.6 eeprom 5.2, WOR3W, address 00:16:cf:53:07:71
> cardslot0 at cbb0 slot 0 flags 0
> cardbus0 at cardslot0: bus 4 device 0 cacheline 0x8, lattimer 0x20
> pcmcia0 at cardslot0
> cardslot1 at cbb1 slot 1 flags 0
> cardbus1 at cardslot1: bus 5 device 0 cacheline 0x8, lattimer 0x20
> pcmcia1 at cardslot1
> ichpcib0 at pci0 dev 31 function 0 "Intel 82801CAM LPC" rev 0x02
> pciide0 at pci0 dev 31 function 1 "Intel 82801CAM IDE" rev 0x02:
> DMA, channel 0 configured to compatibility, channel 1 configured to
> compatibility
> wd0 at pciide0 channel 0 drive 0: <Hitachi HTS541080G9AT00>
> wd0: 16-sector PIO, LBA, 76319MB, 156301488 sectors
> wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 5
> atapiscsi0 at pciide0 channel 1 drive 0
> scsibus1 at atapiscsi0: 2 targets
> cd0 at scsibus1 targ 0 lun 0: <TOSHIBA, DVD-ROM SD-C2612, 1D21>
> ATAPI 5/cdrom removable
> cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
> auich0 at pci0 dev 31 function 5 "Intel 82801CA/CAM AC97" rev 0x02:
> irq 11, ICH3 AC97
> ac97: codec id 0x4352595b (Cirrus Logic CS4205 rev 3)
> ac97: codec features mic channel, tone, simulated stereo, bass
> boost, 20 bit DAC, 18 bit ADC, SRS 3D
> audio0 at auich0
> "Intel 82801CA/CAM Modem" rev 0x02 at pci0 dev 31 function 6 not configured
> usb0 at uhci0: USB revision 1.0
> uhub0 at usb0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> isa0 at ichpcib0
> isadma0 at isa0
> fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
> com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
> pckbc0 at isa0 port 0x60/5
> pckbd0 at pckbc0 (kbd slot)
> pckbc0: using irq 1 for kbd slot
> wskbd0 at pckbd0: console keyboard
> pms0 at pckbc0 (aux slot)
> pckbc0: using irq 12 for aux slot
> wsmouse0 at pms0 mux 0
> wsmouse1 at pms0 mux 0
> pms0: Synaptics touchpad, firmware 5.9
> pcppi0 at isa0 port 0x61
> spkr0 at pcppi0
> lpt0 at isa0 port 0x378/4 irq 7
> npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
> vscsi0 at root
> scsibus2 at vscsi0: 256 targets
> softraid0 at root
> scsibus3 at softraid0: 256 targets
> sd0 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 005> SCSI2 0/direct fixed
> sd0: 73241MB, 512 bytes/sector, 149998377 sectors
> root on sd0a (b7aac228eb17d109.a) swap on sd0b dump on sd0b
> radeondrm0: 1400x1050
> wsdisplay0 at radeondrm0 mux 1: console (std, vt100 emulation), using wskbd0
> wsdisplay0: screen 1-5 added (std, vt100 emulation)
>
>
> --
>
>
> Eivind Eide
>
> "ONLY THOSE WHO ATTEMPT THE IMPOSSIBLE WILL ACHIEVE THE ABSURD"
> - Oceania Association of Autonomous Astronauts

Reply | Threaded
Open this post in threaded view
|

Re: i386 bsd.rd panic

Tim van der Molen-3
In reply to this post by Eivind Eide
Theo de Raadt (2015-04-26 16:53 +0200):

> > Eivind Eide (2015-04-26 13:02 +0200):
> > > I've been trying to update this -current machine with the bsd.rd from the
> > > last 4 snapshots,
> > > the last being from "Sun Apr 26 02:22:08 MDT 2015".
> > > However this kernel immediately after reporting how much ram I have panics
> > > with this message:
> > >
> > > fatal protection fault (4) in supervisor mode
> > > trap type 4 code 0 eip d020204e cs 8 eflags 10006 cr2 0 cpl 0
> > > panic: trap type 4, code=0, pc=d020204e
> >
> > I see the same when booting bsd.rd (#788, 24 April) on a medieval
> > laptop. Below a dmesg from the currently installed snapshot.
>
> You don't have a NX bit.  Please try a new snapshot in a few hours.

Problem solved; thanks.

Reply | Threaded
Open this post in threaded view
|

interesting package isue....cant find with a browser.

Ton Muller-2
Ok.
perhaps a bit cryptic.
but this is the situation, the package portal is huge, ok, no problem
with it.
but finding a sertain package is a pain.
i can recall from the time i was running 4.6, i when to below link
http://www.openbsd.org/4.6_packages/i386.html

a nice web portal opened with a discription what each package is.
but for later versions it was removed.
perhaps it is hidden, but i cant find it, i am not in for downloading
26gb on packages, is there a faster way to see what package who is ?

Tony.

sam
Reply | Threaded
Open this post in threaded view
|

Re: interesting package isue....cant find with a browser.

sam
On Mon, 27 Apr 2015 20:56:00 +0200
Ton Muller <[hidden email]> wrote:

> Ok.
> perhaps a bit cryptic.
> but this is the situation, the package portal is huge, ok, no problem
> with it.
> but finding a sertain package is a pain.
> i can recall from the time i was running 4.6, i when to below link
> http://www.openbsd.org/4.6_packages/i386.html
>
> a nice web portal opened with a discription what each package is.
> but for later versions it was removed.
> perhaps it is hidden, but i cant find it, i am not in for downloading
> 26gb on packages, is there a faster way to see what package who is ?
>
> Tony.
>

It'd be nice if OpenBSD still had those VERSION_packages pages. In any
case, http://openports.se/ or http://ports.su/ may prove helpful.

Reply | Threaded
Open this post in threaded view
|

Re: interesting package isue....cant find with a browser.

Ville Valkonen
In reply to this post by Ton Muller-2
Hi,

On Apr 27, 2015 9:56 PM, "Ton Muller" <[hidden email]> wrote:

>
> Ok.
> perhaps a bit cryptic.
> but this is the situation, the package portal is huge, ok, no problem
> with it.
> but finding a sertain package is a pain.
> i can recall from the time i was running 4.6, i when to below link
> http://www.openbsd.org/4.6_packages/i386.html
>
> a nice web portal opened with a discription what each package is.
> but for later versions it was removed.
> perhaps it is hidden, but i cant find it, i am not in for downloading
> 26gb on packages, is there a faster way to see what package who is ?
>
> Tony.

install pkgmgr.

--
Regards,
Ville

Reply | Threaded
Open this post in threaded view
|

Re: interesting package isue....cant find with a browser.

Ton Muller-2
On 27-4-2015 21:46, Ville Valkonen wrote:

> Hi,
>
> On Apr 27, 2015 9:56 PM, "Ton Muller" <[hidden email]> wrote:
>>
>> Ok.
>> perhaps a bit cryptic.
>> but this is the situation, the package portal is huge, ok, no problem
>> with it.
>> but finding a sertain package is a pain.
>> i can recall from the time i was running 4.6, i when to below link
>> http://www.openbsd.org/4.6_packages/i386.html
>>
>> a nice web portal opened with a discription what each package is.
>> but for later versions it was removed.
>> perhaps it is hidden, but i cant find it, i am not in for downloading
>> 26gb on packages, is there a faster way to see what package who is ?
>>
>> Tony.
>
> install pkgmgr.
>
> --
> Regards,
> Ville
>
wow, that looks nice!

Thankxs !
Tony.