i386 GENERIC.MP kernel panics booting on Sun x4100

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

i386 GENERIC.MP kernel panics booting on Sun x4100

Russell McGregor
i386 GENERIC.MP kernel panics booting on Sun x4100

System has 2x dual core Opteron CPUs, 16GB RAM &
4 x 73GB SAS disks (First 2 in RAID-1 volume)

Boots uniproc GENERIC kernel OK. Tested with snapshot from around
20060803, and -current checkout on Aug 9.

I haven't tested with amd64

[ using 527744 bytes of bsd ELF symbol table ]
Copyright (c) 1982, 1986, 1989, 1991, 1993
       The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2006 OpenBSD. All rights reserved.  http://www.OpenBSD.org

OpenBSD 4.0-beta (GENERIC.MP) #0: Wed Aug  9 09:17:22 EST 2006
   [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Dual Core AMD Opteron(tm) Processor 280 ("AuthenticAMD"
686-class, 1024KB L2 cache) 2.40 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3
real mem  = 4160249856 (4062744K)
avail mem = 3818115072 (3728628K)
using 4256 buffers containing 208113664 bytes (203236K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 08/10/05, SMBIOS rev. 2.3 @
0xf8fb0 (65 entries)
bios0: Sun Microsystems Sun Fire X4100 Server
pcibios at bios0 function 0x1a not configured
bios0: ROM list: 0xc0000/0xa000 0xca000/0x1000 0xcb000/0x1000
0xcc000/0x1000 0xcd000/0x1000 0xce000/0x4800 0xd2800/0x1000
ipmi0 at mainbus0: version 2.0 interface KCS iobase 0xca2/2 spacing 1
mainbus0: Intel MP Specification (Version 1.4) (SUN      X4200       )
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 199 MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Dual Core AMD Opteron(tm) Processor 280 ("AuthenticAMD"
686-class, 1024KB L2 cache) 2.40 GHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3
cpu2 at mainbus0: apid 2 (application processor)
cpu2: Dual Core AMD Opteron(tm) Processor 280 ("AuthenticAMD"
686-class, 1024KB L2 cache) 2.40 GHz
cpu2: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3
cpu3 at mainbus0: apid 3 (application processor)
cpu3: Dual Core AMD Opteron(tm) Processor 280 ("AuthenticAMD"
686-class, 1024KB L2 cache) 2.40 GHz
cpu3: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3
mainbus0: bus 0 is type PCI
mainbus0: bus 1 is type PCI
mainbus0: bus 2 is type PCI
mainbus0: bus 3 is type PCI
mainbus0: bus 4 is type PCI
mainbus0: bus 5 is type PCI
mainbus0: bus 6 is type PCI
mainbus0: bus 7 is type ISA
ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 11, 24 pins
ioapic1 at mainbus0: apid 5 pa 0xfe6ff000, version 11, 4 pins
ioapic2 at mainbus0: apid 6 pa 0xfe6fe000, version 11, 4 pins
ioapic3 at mainbus0: apid 7 pa 0xfeaff000, version 11, 4 pins
ioapic4 at mainbus0: apid 8 pa 0xfeafe000, version 11, 4 pins
panic: pci_make_tag: mode not configured
Stopped at      Debugger+0x4:   leave
RUN AT LEAST 'trace' AND 'ps' AND INCLUDE OUTPUT WHEN REPORTING THIS PANIC!
DO NOT EVEN BOTHER REPORTING THIS WITHOUT INCLUDING THAT INFORMATION!
ddb{0}> trace
Debugger(d072a000,d072a0a4,d087fdb8,0,ffffffff) at Debugger+0x4
panic(d06d31c0,d072a004,d073f258,4,4) at panic+0x63
pci_make_tag(0,0,0) at pci_make_tag+0x38
mpbios_intr_fixup(ee1d71f0,19c,19c,4,5) at mpbios_intr_fixup+0x42
mpbios_scan(d4bf8fc0,d07081d4,d087fe80,d0481d2c,d07493c0) at mpbios_scan+0x27e
mainbus_attach(0,d4bf8fc0,0,0,c) at mainbus_attach+0x8e
config_attach(0,d0705468,0,0,d0748c60) at config_attach+0xef
config_rootfound(d06735c4,0,d087ff38,d0452942) at config_rootfound+0x27
cpu_configure(0,1,3,0,0) at cpu_configure+0x29
main(0,0,0,0,0) at main+0x372
ddb{0}> ps
  PID   PPID   PGRP    UID  S       FLAGS  WAIT       COMMAND
*    0     -1      0      0  7     0x80204             swapper
ddb{0}>