i386/5057: IIC at ALIPM Problem ThinkPadR30

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

i386/5057: IIC at ALIPM Problem ThinkPadR30

jtwebb
>Number:         5057
>Category:       i386
>Synopsis:       IIC0 driver causes poweroff condition on ThinkPadR30
>Confidential:   yes
>Severity:       non-critical
>Priority:       low
>Responsible:    bugs
>State:          open
>Quarter:        
>Keywords:      
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Mar 19 02:40:02 GMT 2006
>Closed-Date:
>Last-Modified:
>Originator:     jtwebb
>Release:        current
>Organization:
net
>Environment:
i386
       
        System      : OpenBSD 3.9
        Architecture: OpenBSD.i386
        Machine     : i386
>Description:
-
        Loading OpenBSD 3.9-current (GENERIC), synched/built Sat Mar 18 18:55:19 EST 2006,
        on ThinkPadR30 laptop results in the system powering-off.
       
        When the system powers-off on boot the last line that appears seems to
        be iic0 at alipm0 (no serial port on this laptop).
         
        Disabling iic or alipm from UKC allows the system to boot without poweroff.
         
        I've tried passing flags to IIC via UKC (1-20) with no change in behavior.  
        I've also altered all available Bios PM settings with no change in behavior.
        I don't have access to another ThinkPadR30 to test for any singular hardware issues, but
        I did test loaded other OS's onto this laptop without encountering any problems.

       Here's the system message buffer after disabling iic:
       
OpenBSD 3.9-current (GENERIC) #1: Sat Mar 18 18:55:19 EST 2006
[hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium III ("GenuineIntel" 686-class) 1 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 393715712 (384488K)
avail mem = 351883264 (343636K)
using 4278 buffers containing 19787776 bytes (19324K) of memory
User Kernel Config
UKC> de\^H \^Hisable 328
328 iic* disabled
UKC> quit
Continuing...
mainbus0 (root)
bios0 at mainbus0: AT/286+(ff) BIOS, date 03/12/02, BIOS32 rev. 0 @ 0xf0210
apm0 at bios0: Power Management spec V1.2 (BIOS mgmt disabled)
apm0: APM power management enable: unrecognized device ID (9)
apm0: APM engage (device 1): power management disabled (1)
apm0: battery life expectancy 100%
apm0: AC on, battery charge high
apm0: flags f0102 dobusy 1 doidle 1
pcibios0 at bios0: rev 2.1 @ 0xf0200/0xb00
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfb9d0/192 (10 entries)
pcibios0: PCI Interrupt Router at 000:07:0 ("Acer Labs M1533 ISA" rev 0x00)
pcibios0: PCI bus #2 is the last bus
bios0: ROM list: 0xc0000/0xc000
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Acer Labs M1621 PCI" rev 0x01
ppb0 at pci0 dev 1 function 0 "Acer Labs M5247 AGP/PCI-PC" rev 0x01
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "Trident CyberBlade Ai1 AGP" rev 0x5d
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
autri0 at pci0 dev 6 function 0 "Acer Labs M5451 Audio" rev 0x01: irq 11
ac97: codec id 0x414c4710 (Avance Logic ALC200)
ac97: codec features headphone, 18 bit DAC, 18 bit ADC, Realtek 3D
audio0 at autri0
midi0 at autri0: <4DWAVE MIDI UART>
pcib0 at pci0 dev 7 function 0 "Acer Labs M1533 ISA" rev 0x00
fxp0 at pci0 dev 10 function 0 "Intel 8255x" rev 0x0d, i82550: irq 11, address 00:00:e2:59:56:fa
inphy0 at fxp0 phy 1: i82555 10/100 PHY, rev. 4
pciide0 at pci0 dev 16 function 0 "Acer Labs M5229 UDMA IDE" rev 0xc3: DMA, channel 0 configured to compatibility, channel 1 configured to compa
tibility
wd0 at pciide0 channel 0 drive 0: <FUJITSU MHT2040AH>
wd0: 16-sector PIO, LBA, 38154MB, 78140160 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 4
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <TEAC, CD-224E, 2.7B> SCSI0 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
alipm0 at pci0 dev 17 function 0 "Acer Labs M7101 Power" rev 0x00: 74KHz clock
iic at alipm0 not configured
cbb0 at pci0 dev 19 function 0 "O2 Micro OZ69[17]2 CardBus" rev 0x00: irq 11
ohci0 at pci0 dev 20 function 0 "Acer Labs M5237 USB" rev 0x03: irq 10, version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: Acer Labs OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi1 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt2 at isa0 port 0x3bc/4: polled
npx0 at isa0 port 0xf0/16: using exception 16
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 2 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
biomask effd netmask effd ttymask ffff
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
wi0 at pcmcia0 function 0 "Cabletron, RoamAbout 802.11 DS, Version 01.01" port 0xa000/64
wi0: Firmware 6.04 variant 1, address 00:01:f4:ec:9b:9c
dkcsum: wd0 matches BIOS drive 0x80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302

 
>How-To-Repeat:
        Load i386 GENERIC from current onto ThinkPadR30 or perhaps ThinkPad with similar I2C slaves.
>Fix:
         Disable IIC and compile new kernel with driver disabled.


>Release-Note:
>Audit-Trail:
>Unformatted: