gobject-introspection: can't resolve dependencies

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

gobject-introspection: can't resolve dependencies

deserter666
This happened out of blue, don't know how deal with this.
This is repeatable, everytime. I came across it while
installing ImageMagick.

===> gobject-introspection-1.64.1 depends on: py3-mako-* - not found
===>  Verifying install for py3-mako-* in www/py-mako
`/usr/portsdir/bulk/amd64/py3-mako-1.1.1' is up to date.
===>  Installing py3-mako-1.1.1 from /usr/portsdir/packages/amd64/all/
Can't find gmp-6.2.0
Can't install py3-cryptodome-3.9.7: can't resolve gmp-6.2.0
Can't install py3-beaker-1.10.0p0: can't resolve py3-cryptodome-3.9.7
Can't install py3-mako-1.1.1: can't resolve py3-beaker-1.10.0p0
Couldn't install gmp-6.2.0 py3-beaker-1.10.0p0 py3-cryptodome-3.9.7
py3-mako-1.1.1
*** Error 1 in /usr/ports/www/py-mako
(/usr/ports/infrastructure/mk/bsd.port.mk:2138
'/var/db/pkg/py3-mako-1.1.1/+CONTENTS': @/usr/bin/env -...)
*** Error 2 in /usr/ports/www/py-mako
(/usr/ports/infrastructure/mk/bsd.port.mk:2581 'install':
@lock=py3-mako-1.1.1;  export _LOCKS_HELD=" ...)
*** Error 1 in . (/usr/ports/infrastructure/mk/bsd.port.mk:2263
'/usr/portsdir/pobj/gobject-introspection-1.64.1/.dep-www-py-mako,python3')
*** Error 2 in /usr/ports/devel/gobject-introspection
(/usr/ports/infrastructure/mk/bsd.port.mk:2581 'prepare':
@lock=gobject-introspection-...)

This is my mk.conf, I don't know what more info I need to provide

SUDO=sudo
PORTS_PRIVSEP=Yes
DISTDIR=/usr/distfiles
BULK_COOKIES_DIR=/usr/portsdir/bulk/amd64
UPDATE_COOKIES_DIR=/usr/portsdir/update/amd64
WRKOBJDIR=/usr/portsdir/pobj
PACKAGE_REPOSITORY=/usr/portsdir/packages
PLIST_REPOSITORY=/usr/portsdir/plist


Reply | Threaded
Open this post in threaded view
|

Re: gobject-introspection: can't resolve dependencies

Stuart Henderson
On 2020/06/26 16:13, [hidden email] wrote:

> This happened out of blue, don't know how deal with this.
> This is repeatable, everytime. I came across it while
> installing ImageMagick.
>
> ===> gobject-introspection-1.64.1 depends on: py3-mako-* - not found
> ===>  Verifying install for py3-mako-* in www/py-mako
> `/usr/portsdir/bulk/amd64/py3-mako-1.1.1' is up to date.
> ===>  Installing py3-mako-1.1.1 from /usr/portsdir/packages/amd64/all/
> Can't find gmp-6.2.0
> Can't install py3-cryptodome-3.9.7: can't resolve gmp-6.2.0
> Can't install py3-beaker-1.10.0p0: can't resolve py3-cryptodome-3.9.7
> Can't install py3-mako-1.1.1: can't resolve py3-beaker-1.10.0p0
> Couldn't install gmp-6.2.0 py3-beaker-1.10.0p0 py3-cryptodome-3.9.7
> py3-mako-1.1.1
> *** Error 1 in /usr/ports/www/py-mako
> (/usr/ports/infrastructure/mk/bsd.port.mk:2138
> '/var/db/pkg/py3-mako-1.1.1/+CONTENTS': @/usr/bin/env -...)
> *** Error 2 in /usr/ports/www/py-mako
> (/usr/ports/infrastructure/mk/bsd.port.mk:2581 'install':
> @lock=py3-mako-1.1.1;  export _LOCKS_HELD=" ...)
> *** Error 1 in . (/usr/ports/infrastructure/mk/bsd.port.mk:2263
> '/usr/portsdir/pobj/gobject-introspection-1.64.1/.dep-www-py-mako,python3')
> *** Error 2 in /usr/ports/devel/gobject-introspection
> (/usr/ports/infrastructure/mk/bsd.port.mk:2581 'prepare':
> @lock=gobject-introspection-...)

You have some mixture of /usr/ports and /usr/portsdir which might be
confusing things. I sugggest just using /usr/ports (as a real directory
not a symlink).

> This is my mk.conf, I don't know what more info I need to provide
>
> SUDO=sudo

SUDO=sudo -E

and make sure the user has "setenv" permission in sudoers.

> PORTS_PRIVSEP=Yes
> DISTDIR=/usr/distfiles
> BULK_COOKIES_DIR=/usr/portsdir/bulk/amd64
> UPDATE_COOKIES_DIR=/usr/portsdir/update/amd64
> WRKOBJDIR=/usr/portsdir/pobj
> PACKAGE_REPOSITORY=/usr/portsdir/packages
> PLIST_REPOSITORY=/usr/portsdir/plist
>
>


Reply | Threaded
Open this post in threaded view
|

Re: gobject-introspection: can't resolve dependencies

deserter666
In reply to this post by deserter666
On Fri, June 26, 2020 4:29 pm, Stuart Henderson wrote:
>
> You have some mixture of /usr/ports and /usr/portsdir which might be
> confusing things. I sugggest just using /usr/ports (as a real directory not
> a symlink).
>
The error lies with this, the fact is I have different partitions for
repo and the actual work directory, so I don't mess up the repo and since
the functionality for personalised dirs was present. I'll move in all dirs
back to their default paths now.
>
> SUDO=sudo -E
>
>
> and make sure the user has "setenv" permission in sudoers.
This didn't really help the situation on its own, but I appended it anyway.


Reply | Threaded
Open this post in threaded view
|

Re: gobject-introspection: can't resolve dependencies

deserter666
In reply to this post by deserter666
Now it's a different error

/bin/sh cannot fork - try again

===> ImageMagick-6.9.10.86p0 depends on: ghostscript-* - not found
===>  Verifying install for ghostscript-* in print/ghostscript/gnu
===>  Checking files for ghostscript-9.07p7
`/usr/ports/distfiles/ghostscript-9.07.tar.gz' is up to date.
>> (SHA256) ghostscript-9.07.tar.gz: OK
===> ghostscript-9.07p7 depends on: cups-libs-* - not found
===>  Verifying install for cups-libs-* in print/cups
===>  Checking files for cups-2.3.3
`/usr/ports/distfiles/cups-2.3.3.tar.gz' is up to date.
>> (SHA256) cups-2.3.3.tar.gz: OK
===> cups-libs-2.3.3 depends on: gnutls-* - not found
===>  Verifying install for gnutls-* in security/gnutls
===>  Checking files for gnutls-3.6.14
`/usr/ports/distfiles/gnutls-3.6.14.tar.xz' is up to date.
>> (SHA256) gnutls-3.6.14.tar.xz: OK
===> gnutls-3.6.14 depends on: cmocka-* - not found
===>  Verifying install for cmocka-* in devel/cmocka
===>  Checking files for cmocka-1.1.3
`/usr/ports/distfiles/cmocka-1.1.3.tar.xz' is up to date.
>> (SHA256) cmocka-1.1.3.tar.xz: OK
===> cmocka-1.1.3 depends on: cmake-* - not found
===>  Verifying install for cmake-* in devel/cmake
===>  Checking files for cmake-3.17.2p0v0
`/usr/ports/distfiles/cmake-3.17.2.tar.gz' is up to date.
>> (SHA256) cmake-3.17.2.tar.gz: OK
===> cmake-3.17.2p0v0 depends on: libuv-* - not found
===>  Verifying install for libuv-* in devel/libuv
===>  Checking files for libuv-1.30.1
`/usr/ports/distfiles/libuv-v1.30.1.tar.gz' is up to date.
>> (SHA256) libuv-v1.30.1.tar.gz: OK
===> libuv-1.30.1 depends on: py-sphinx-* - not found
===>  Verifying install for py-sphinx-* in textproc/py-sphinx
===>  Checking files for py-sphinx-1.4.8p2
`/usr/ports/distfiles/Sphinx-1.4.8.tar.gz' is up to date.
>> (SHA256) Sphinx-1.4.8.tar.gz: OK
===> py-sphinx-1.4.8p2 depends on: py-snowballstemmer-* - not found
===>  Verifying install for py-snowballstemmer-* in
textproc/py-snowballstemmer
`/usr/ports/bulk/amd64/py-snowballstemmer-1.2.1p2' is up to date.
===> py-snowballstemmer-1.2.1p2 depends on: py-stemmer-* - not found
===>  Verifying install for py-stemmer-* in textproc/py-stemmer
===>  Checking files for py-stemmer-1.3.0p4
`/usr/ports/distfiles/PyStemmer-1.3.0.tar.gz' is up to date.
>> (SHA256) PyStemmer-1.3.0.tar.gz: OK
===> py-stemmer-1.3.0p4 depends on: py-cython-* - not found
===>  Verifying install for py-cython-* in lang/cython
===>  Faking installation for py-cython-0.29.19
/bin/sh: cannot fork - try again
*** Error 1 in /usr/ports/lang/cython
(/usr/ports/infrastructure/mk/bsd.port.mk:2992
'/usr/ports/pobj/py-cython-0.29.19/fake-amd64/.fake_done')
*** Error 2 in /usr/ports/lang/cython
(/usr/ports/infrastructure/mk/bsd.port.mk:2116
'/usr/ports/packages/amd64/all/py-cython-0.29.19.tgz')
*** Error 2 in /usr/ports/lang/cython
(/usr/ports/infrastructure/mk/bsd.port.mk:2605 '_internal-package': @case
X${_DEPENDS_CACHE} in  X) _D...)
*** Error 2 in /usr/ports/lang/cython
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'package': @:; cd
/usr/ports/lang/cython && PKGPATH=lan...)
*** Error 2 in /usr/ports/lang/cython
(/usr/ports/infrastructure/mk/bsd.port.mk:2137
'/var/db/pkg/py-cython-0.29.19/+CONTENTS': @cd /usr/por...)
*** Error 2 in /usr/ports/lang/cython
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'install':
@lock=py-cython-0.29.19;  export _LOCKS_HELD...)
*** Error 1 in /usr/ports/textproc/py-stemmer
(/usr/ports/infrastructure/mk/bsd.port.mk:2266
'/usr/ports/pobj/py-stemmer-1.3.0/.dep-lang-cython')
*** Error 2 in /usr/ports/textproc/py-stemmer
(/usr/ports/infrastructure/mk/bsd.port.mk:2663
'/usr/ports/pobj/py-stemmer-1.3.0/.extract_done')
*** Error 2 in /usr/ports/textproc/py-stemmer
(/usr/ports/infrastructure/mk/bsd.port.mk:2116
'/usr/ports/packages/amd64/all/py-stemmer-1.3.0p4.tgz')
*** Error 2 in /usr/ports/textproc/py-stemmer
(/usr/ports/infrastructure/mk/bsd.port.mk:2605 '_internal-package': @case
X${_DEPENDS_CACHE} i...)
*** Error 2 in /usr/ports/textproc/py-stemmer
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'package': @:; cd
/usr/ports/textproc/py-stemme...)
*** Error 2 in /usr/ports/textproc/py-stemmer
(/usr/ports/infrastructure/mk/bsd.port.mk:2137
'/var/db/pkg/py-stemmer-1.3.0p4/+CONTENTS': @cd...)
*** Error 2 in /usr/ports/textproc/py-stemmer
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'install':
@lock=py-stemmer-1.3.0p4;  export _L...)
*** Error 1 in /usr/ports/textproc/py-snowballstemmer
(/usr/ports/infrastructure/mk/bsd.port.mk:2266
'/usr/ports/pobj/py-snowballstemmer-1.2.1/.dep-textproc-py-stemmer')
*** Error 2 in /usr/ports/textproc/py-snowballstemmer
(/usr/ports/infrastructure/mk/bsd.port.mk:2139
'/var/db/pkg/py-snowballstemmer-1.2.1p2/+CONTENTS')
*** Error 2 in /usr/ports/textproc/py-snowballstemmer
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'install':
@lock=py-snowballstemmer-1.2...)
*** Error 1 in /usr/ports/textproc/py-sphinx
(/usr/ports/infrastructure/mk/bsd.port.mk:2266
'/usr/ports/pobj/py-sphinx-1.4.8/.dep-textproc-py-snowballstemmer')
*** Error 2 in /usr/ports/textproc/py-sphinx
(/usr/ports/infrastructure/mk/bsd.port.mk:2663
'/usr/ports/pobj/py-sphinx-1.4.8/.extract_done')
*** Error 2 in /usr/ports/textproc/py-sphinx
(/usr/ports/infrastructure/mk/bsd.port.mk:2116
'/usr/ports/packages/amd64/all/py-sphinx-1.4.8p2.tgz')
*** Error 2 in /usr/ports/textproc/py-sphinx
(/usr/ports/infrastructure/mk/bsd.port.mk:2605 '_internal-package': @case
X${_DEPENDS_CACHE} in...)
*** Error 2 in /usr/ports/textproc/py-sphinx
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'package': @:; cd
/usr/ports/textproc/py-sphinx ...)
*** Error 2 in /usr/ports/textproc/py-sphinx
(/usr/ports/infrastructure/mk/bsd.port.mk:2137
'/var/db/pkg/py-sphinx-1.4.8p2/+CONTENTS': @cd /...)
*** Error 2 in /usr/ports/textproc/py-sphinx
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'install':
@lock=py-sphinx-1.4.8p2;  export _LOC...)
*** Error 1 in /usr/ports/devel/libuv
(/usr/ports/infrastructure/mk/bsd.port.mk:2266
'/usr/ports/pobj/libuv-1.30.1/.dep-textproc-py-sphinx')
*** Error 2 in /usr/ports/devel/libuv
(/usr/ports/infrastructure/mk/bsd.port.mk:2663
'/usr/ports/pobj/libuv-1.30.1/.extract_done': @cd /usr/...)
*** Error 2 in /usr/ports/devel/libuv
(/usr/ports/infrastructure/mk/bsd.port.mk:2116
'/usr/ports/packages/amd64/all/libuv-1.30.1.tgz': @cd /...)
*** Error 2 in /usr/ports/devel/libuv
(/usr/ports/infrastructure/mk/bsd.port.mk:2605 '_internal-package': @case
X${_DEPENDS_CACHE} in  X) _D...)
*** Error 2 in /usr/ports/devel/libuv
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'package': @:; cd
/usr/ports/devel/libuv && PKGPATH=dev...)
*** Error 2 in /usr/ports/devel/libuv
(/usr/ports/infrastructure/mk/bsd.port.mk:2137
'/var/db/pkg/libuv-1.30.1/+CONTENTS': @cd /usr/ports/de...)
*** Error 2 in /usr/ports/devel/libuv
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'install':
@lock=libuv-1.30.1;  export _LOCKS_HELD=" Im...)
*** Error 1 in /usr/ports/devel/cmake
(/usr/ports/infrastructure/mk/bsd.port.mk:2266
'/usr/ports/pobj/cmake-3.17.2/.dep-devel-libuv': @unset...)
*** Error 2 in /usr/ports/devel/cmake
(/usr/ports/infrastructure/mk/bsd.port.mk:2663
'/usr/ports/pobj/cmake-3.17.2/.extract_done': @cd /usr/...)
*** Error 2 in /usr/ports/devel/cmake
(/usr/ports/infrastructure/mk/bsd.port.mk:2116
'/usr/ports/packages/amd64/all/cmake-3.17.2p0v0.tgz': @...)
*** Error 2 in /usr/ports/devel/cmake
(/usr/ports/infrastructure/mk/bsd.port.mk:2605 '_internal-package': @case
X${_DEPENDS_CACHE} in  X) _D...)
*** Error 2 in /usr/ports/devel/cmake
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'package': @:; cd
/usr/ports/devel/cmake && PKGPATH=dev...)
*** Error 2 in /usr/ports/devel/cmake
(/usr/ports/infrastructure/mk/bsd.port.mk:2137
'/var/db/pkg/cmake-3.17.2p0v0/+CONTENTS': @cd /usr/port...)
*** Error 2 in /usr/ports/devel/cmake
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'install':
@lock=cmake-3.17.2p0v0;  export _LOCKS_HELD=...)
*** Error 1 in /usr/ports/devel/cmocka
(/usr/ports/infrastructure/mk/bsd.port.mk:2266
'/usr/ports/pobj/cmocka-1.1.3/.dep-devel-cmake': @unse...)
*** Error 2 in /usr/ports/devel/cmocka
(/usr/ports/infrastructure/mk/bsd.port.mk:2663
'/usr/ports/pobj/cmocka-1.1.3/.extract_done': @cd /usr...)
*** Error 2 in /usr/ports/devel/cmocka
(/usr/ports/infrastructure/mk/bsd.port.mk:2116
'/usr/ports/packages/amd64/all/cmocka-1.1.3.tgz': @cd ...)
*** Error 2 in /usr/ports/devel/cmocka
(/usr/ports/infrastructure/mk/bsd.port.mk:2605 '_internal-package': @case
X${_DEPENDS_CACHE} in  X) _...)
*** Error 2 in /usr/ports/devel/cmocka
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'package': @:; cd
/usr/ports/devel/cmocka && PKGPATH=d...)
*** Error 2 in /usr/ports/devel/cmocka
(/usr/ports/infrastructure/mk/bsd.port.mk:2137
'/var/db/pkg/cmocka-1.1.3/+CONTENTS': @cd /usr/ports/d...)
*** Error 2 in /usr/ports/devel/cmocka
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'install':
@lock=cmocka-1.1.3;  export _LOCKS_HELD=" I...)
*** Error 1 in /usr/ports/security/gnutls
(/usr/ports/infrastructure/mk/bsd.port.mk:2266
'/usr/ports/pobj/gnutls-3.6.14/.dep-devel-cmocka')
*** Error 2 in /usr/ports/security/gnutls
(/usr/ports/infrastructure/mk/bsd.port.mk:2663
'/usr/ports/pobj/gnutls-3.6.14/.extract_done': @cd ...)
*** Error 2 in /usr/ports/security/gnutls
(/usr/ports/infrastructure/mk/bsd.port.mk:2116
'/usr/ports/packages/amd64/all/gnutls-3.6.14.tgz')
*** Error 2 in /usr/ports/security/gnutls
(/usr/ports/infrastructure/mk/bsd.port.mk:2605 '_internal-package': @case
X${_DEPENDS_CACHE} in  X...)
*** Error 2 in /usr/ports/security/gnutls
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'package': @:; cd
/usr/ports/security/gnutls && PKG...)
*** Error 2 in /usr/ports/security/gnutls
(/usr/ports/infrastructure/mk/bsd.port.mk:2137
'/var/db/pkg/gnutls-3.6.14/+CONTENTS': @cd /usr/por...)
*** Error 2 in /usr/ports/security/gnutls
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'install':
@lock=gnutls-3.6.14;  export _LOCKS_HELD...)
*** Error 1 in /usr/ports/print/cups
(/usr/ports/infrastructure/mk/bsd.port.mk:2266
'/usr/ports/pobj/cups-2.3.3/.dep-security-gnutls': @unse...)
*** Error 2 in /usr/ports/print/cups
(/usr/ports/infrastructure/mk/bsd.port.mk:2663
'/usr/ports/pobj/cups-2.3.3/.extract_done': @cd /usr/por...)
*** Error 2 in /usr/ports/print/cups
(/usr/ports/infrastructure/mk/bsd.port.mk:2116
'/usr/ports/packages/amd64/all/cups-2.3.3.tgz': @cd /usr...)
*** Error 2 in /usr/ports/print/cups
(/usr/ports/infrastructure/mk/bsd.port.mk:2605 '_internal-package': @case
X${_DEPENDS_CACHE} in  X) _DE...)
*** Error 2 in /usr/ports/print/cups
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'package': @:; cd
/usr/ports/print/cups && PKGPATH=print...)
*** Error 2 in /usr/ports/print/cups
(/usr/ports/infrastructure/mk/bsd.port.mk:2137
'/var/db/pkg/cups-libs-2.3.3/+CONTENTS': @cd /usr/ports/...)
*** Error 2 in /usr/ports/print/cups
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'install':
@lock=cups-2.3.3;  export _LOCKS_HELD=" Image...)
*** Error 1 in /usr/ports/print/ghostscript/gnu
(/usr/ports/infrastructure/mk/bsd.port.mk:2266
'/usr/ports/pobj/ghostscript-9.07/.dep-print-cups,-libs')
*** Error 2 in /usr/ports/print/ghostscript/gnu
(/usr/ports/infrastructure/mk/bsd.port.mk:2663
'/usr/ports/pobj/ghostscript-9.07/.extract_done')
*** Error 2 in /usr/ports/print/ghostscript/gnu
(/usr/ports/infrastructure/mk/bsd.port.mk:2116
'/usr/ports/packages/amd64/all/ghostscript-9.07p7.tgz')
*** Error 2 in /usr/ports/print/ghostscript/gnu
(/usr/ports/infrastructure/mk/bsd.port.mk:2605 '_internal-package': @case
X${_DEPENDS_CACHE}...)
*** Error 2 in /usr/ports/print/ghostscript/gnu
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'package': @:; cd
/usr/ports/print/ghostscrip...)
*** Error 2 in /usr/ports/print/ghostscript/gnu
(/usr/ports/infrastructure/mk/bsd.port.mk:2137
'/var/db/pkg/ghostscript-9.07p7/+CONTENTS': @...)
*** Error 2 in /usr/ports/print/ghostscript/gnu
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'install':
@lock=ghostscript-9.07p7;  export ...)
*** Error 1 in . (/usr/ports/infrastructure/mk/bsd.port.mk:2266
'/usr/ports/pobj/ImageMagick-6.9.10.86/.dep-print-ghostscript-gnu': @unset
_...)
*** Error 2 in /usr/ports/graphics/ImageMagick
(/usr/ports/infrastructure/mk/bsd.port.mk:2584 'prepare':
@lock=ImageMagick-6.9.10.86p0;  exp...)