gimp-2.6.6p0 install failed.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

gimp-2.6.6p0 install failed.

4625
1) It is not possible to detect that avahi is absent during configure?
2) Why he think that avahi is absent when:
 2a) $ pkg_info | grep -i avahi
avahi-0.6.25p5      framework for Multicast DNS Service Discovery
 2b) $ ldconfig -r | grep -i avahi
        382:-lavahi-client.0.0 => /usr/local/lib/libavahi-client.so.0.0
        383:-lavahi-common.0.0 => /usr/local/lib/libavahi-common.so.0.0
        385:-lavahi-core.0.0 => /usr/local/lib/libavahi-core.so.0.0
        386:-lavahi-glib.0.0 => /usr/local/lib/libavahi-glib.so.0.0
        390:-lavahi-gobject.0.0 =>
        /usr/local/lib/libavahi-gobject.so.0.0

===>  Installing gimp-2.6.6p0 from /usr/ports/packages/i386/all/
Can't install gimp-2.6.6p0: lib not found avahi-client.0.0
Can't install gimp-2.6.6p0: lib not found avahi-common.0.0
Can't install gimp-2.6.6p0: lib not found avahi-glib.0.0
Dependencies for gimp-2.6.6p0 resolve to: gegl-0.0.22,
desktop-file-utils-0.15, libwmf-0.2.8.3p4, ORBit2-2.14.16,
libmng-1.0.10, dbus-glib-0.80, gnome-vfs2-2.24.0p1, libiconv-1.13,
aalib-1.4p1, tiff-3.8.2p2, py-gtk2-2.12.1p2, poppler-0.10.0p0,
atk-1.24.0, gtk+2-2.14.7, libexif-0.6.16p0, gettext-0.17p0
Full dependency tree is
py-cairo-1.8.2,gnome-mime-data-2.18.0p2,py-Numeric-23.1p2,libwmf-0.2.8.3p4,pango-1.22.3,gconf2-2.24.0,libxml-2.6.32p2,libmng-1.0.10,bzip2-1.0.5,python-2.5.4p1,cdparanoia-3.a9.8p0,dbus-glib-0.80,jpeg-6bp3,aalib-1.4p1,sqlite3-3.6.10,libiconv-1.13,glib2-2.18.4p0,libIDL-0.8.12,babl-0.0.22,libglade2-2.6.2p2,gtk+2-2.14.7,gettext-0.17p0,libcroco-0.6.2,dbus-1.2.12p0,pcre-7.8,gegl-0.0.22,png-1.2.33,desktop-file-utils-0.15,lcms-1.17p0,cairo-1.8.6p1,jasper-1.900.1p0,ORBit2-2.14.16,.libs-libiconv-1.12,hicolor-icon-theme-0.10p4,gnome-vfs2-2.24.0p1,tiff-3.8.2p2,py-gtk2-2.12.1p2,atk-1.24.0,poppler-0.10.0p0,librsvg-2.22.3p1,fam-2.7.0p6,libexif-0.6.16p0,libgsf-1.14.11,glitz-0.5.6p1,py-gobject-2.16.0
*** Error code 1

Stop in /usr/ports/graphics/gimp/stable (line 1474 of
/usr/ports/infrastructure/mk/bsd.port.mk).
===> Exiting graphics/gimp/stable with an error
*** Error code 1

Stop in /usr/ports/graphics/gimp (line 129 of
/usr/ports/infrastructure/mk/bsd.port.subdir.mk).
--- Tue Oct 27 09:49:51 2009

--
/Buzzer () кампания ascii ribbon - против писем в html формате
                /\ www.asciiribbon.org   - против проприетарных вложений


Reply | Threaded
Open this post in threaded view
|

Re: gimp-2.6.6p0 install failed.

Giovanni Bechis-4
Buzzer wrote:
> 1) It is not possible to detect that avahi is absent during configure?
Avahi is needed by gnome-vfs2 which is needed by gimp-2.6.6p0
With gimp-2.6.7 (on -current) the dependency on gnome-vfs2 has been removed
> 2) Why he think that avahi is absent when:
>
Does it work if you use packages ?
  Cheers
   Giovanni