gdt and smp = bug

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

gdt and smp = bug

Yakshin Andrey
Hi.

 I have machine - on Intel 7500VW2 with 2 Xeon. And I have
Intel SRCZCR RAID controller there.
 So, with uniprocessor kernel it's recognized and work fine.

 With multiprocessor kernel (earlier, without changes) loading goes
until
pctr: user-level cycle counter enabled
sd0(gdt0:0:0): timed out
sd0(gdt0:0:0): timed out
sd0(gdt0:0:0): timed out
...
I'm a little despair... But here is dmesg from uniproc, maybe it helps
somewhat. And I will be glad if someone explain this...

OpenBSD 3.9 (GENERIC) #617: Thu Mar  2 02:26:48 MST 2006
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) XEON(TM) CPU 1.80GHz ("GenuineIntel" 686-class) 1.80 GHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM
real mem  = 2146983936 (2096664K)
avail mem = 1952976896 (1907204K)
using 4278 buffers containing 107450368 bytes (104932K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 09/13/02, BIOS32 rev. 0 @ 0xfdb64
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xf3070/336 (19 entries)
pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82801CA LPC" rev 0x00)
pcibios0: PCI bus #4 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x5200! 0xcd800/0x1000 0xce800/0x1800
0xd0000/0x1800 0xdd000/0x1000
ipmi0 at mainbus0: version 1.5 interface KCS iobase 0xca2/2 spacing 1 irq 0
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel E7500 MCH Host" rev 0x03
"Intel E7500 DRAM" rev 0x03 at pci0 dev 0 function 1 not configured
ppb0 at pci0 dev 3 function 0 "Intel E7500 MCH" rev 0x03
pci1 at ppb0 bus 1
"Intel 82870P2 IOxAPIC" rev 0x03 at pci1 dev 28 function 0 not configured
ppb1 at pci1 dev 29 function 0 "Intel 82870P2 PCI-PCI" rev 0x03
pci2 at ppb1 bus 2
gdt0 at pci2 dev 8 function 0 "Intel GDT RAID" rev 0x00: irq 9 dpmem fa000000
2-bus 1 cache device
gdt0: ver 222, cache on, strategy 2, writeback on, blksz 32
gdt0: raw feat 1 cache feat 101
scsibus0 at gdt0: 35 targets
sd0 at scsibus0 targ 0 lun 0: <ICP, Host drive #00, > SCSI2 0/direct fixed
sd0: 34961MB, 34961 cyl, 64 head, 32 sec, 512 bytes/sec, 71601705 sec total
scsibus1 at gdt0: 16 targets
scsibus2 at gdt0: 16 targets
"Intel 82870P2 IOxAPIC" rev 0x03 at pci1 dev 30 function 0 not configured
ppb2 at pci1 dev 31 function 0 "Intel 82870P2 PCI-PCI" rev 0x03
pci3 at ppb2 bus 3
em0 at pci3 dev 7 function 0 "Intel PRO/1000MT (82546EB)" rev 0x01: irq 9,
address 00:07:e9:05:75:ae
em1 at pci3 dev 7 function 1 "Intel PRO/1000MT (82546EB)" rev 0x01: irq 9,
address 00:07:e9:05:75:af
fxp0 at pci3 dev 8 function 0 "Intel 8255x" rev 0x08, i82559: irq 9, address
00:02:b3:3a:42:36
inphy0 at fxp0 phy 1: i82555 10/100 PHY, rev. 4
"Intel E7500 MCH" rev 0x03 at pci0 dev 3 function 1 not configured
uhci0 at pci0 dev 29 function 0 "Intel 82801CA/CAM USB" rev 0x02: irq 9
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 29 function 1 "Intel 82801CA/CAM USB" rev 0x02: irq 10
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: Intel UHCI root hub, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
ppb3 at pci0 dev 30 function 0 "Intel 82801BA AGP" rev 0x42
pci4 at ppb3 bus 4
vga1 at pci4 dev 12 function 0 "ATI Rage XL" rev 0x27
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
ichpcib0 at pci0 dev 31 function 0 "Intel 82801CA LPC" rev 0x02
pciide0 at pci0 dev 31 function 1 "Intel 82801CA IDE" rev 0x02: DMA, channel 0
configured to compatibility, channel 1 configured to compatibility
pciide0: channel 0 disabled (no drives)
atapiscsi0 at pciide0 channel 1 drive 0
scsibus3 at atapiscsi0: 2 targets
cd0 at scsibus3 targ 0 lun 0: <SAMSUNG, CD-ROM SN-124, N101> SCSI0 5/cdrom
removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
ichiic0 at pci0 dev 31 function 3 "Intel 82801CA/CAM SMBus" rev 0x02: irq 11
iic0 at ichiic0: disabled to avoid ipmi0 interactions
isa0 at ichpcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask ffe5 netmask ffe5 ttymask ffe7
pctr: user-level cycle counter enabled
dkcsum: sd0 matches BIOS drive 0x80
root on sd0a
rootdev=0x400 rrootdev=0xd00 rawdev=0xd02
WARNING: / was not properly unmounted




--
Yakshin Andrey
Spylog

Reply | Threaded
Open this post in threaded view
|

Re: gdt and smp = bug

Niklas Hallqvist
Sounds like MPBIOS could lie about the interrupt mapping (not unusual
these days, many (most?) OSes get their
mapping info from ACPI instead, and thus MPBIOS bugs may go unnoticed).  
Of course it could be a bug
of ours as well, but it's hard to tell. I see it hangs off a bridge,
which reminds me of so called interrupt
swizzling issues.  That could well be it.  I wonder if there's not a
diff floating around trying to fix a bug
in that area.  I'll hunt a bit. To come further, we'd like much more
debugging info.  For example turning on mp_verbose
(boot -d, in ddb do "write mp_verbose 1" and "c") and capture the output
e.g. via serial console.  If another OS
boots MultiCPU on this machine, the interrupt mapping info from that OS
would help too.

Niklas

Yakshin Andrey wrote:

> Hi.
>
>  I have machine - on Intel 7500VW2 with 2 Xeon. And I have
> Intel SRCZCR RAID controller there.
>  So, with uniprocessor kernel it's recognized and work fine.
>
>  With multiprocessor kernel (earlier, without changes) loading goes
> until
> pctr: user-level cycle counter enabled
> sd0(gdt0:0:0): timed out
> sd0(gdt0:0:0): timed out
> sd0(gdt0:0:0): timed out
> ...
> I'm a little despair... But here is dmesg from uniproc, maybe it helps
> somewhat. And I will be glad if someone explain this...
>
> OpenBSD 3.9 (GENERIC) #617: Thu Mar  2 02:26:48 MST 2006
>     [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
> cpu0: Intel(R) XEON(TM) CPU 1.80GHz ("GenuineIntel" 686-class) 1.80 GHz
> cpu0:
> FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM
> real mem  = 2146983936 (2096664K)
> avail mem = 1952976896 (1907204K)
> using 4278 buffers containing 107450368 bytes (104932K) of memory
> mainbus0 (root)
> bios0 at mainbus0: AT/286+(00) BIOS, date 09/13/02, BIOS32 rev. 0 @ 0xfdb64
> pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
> pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xf3070/336 (19 entries)
> pcibios0: PCI Interrupt Router at 000:31:0 ("Intel 82801CA LPC" rev 0x00)
> pcibios0: PCI bus #4 is the last bus
> bios0: ROM list: 0xc0000/0x8000 0xc8000/0x5200! 0xcd800/0x1000 0xce800/0x1800
> 0xd0000/0x1800 0xdd000/0x1000
> ipmi0 at mainbus0: version 1.5 interface KCS iobase 0xca2/2 spacing 1 irq 0
> cpu0 at mainbus0
> pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
> pchb0 at pci0 dev 0 function 0 "Intel E7500 MCH Host" rev 0x03
> "Intel E7500 DRAM" rev 0x03 at pci0 dev 0 function 1 not configured
> ppb0 at pci0 dev 3 function 0 "Intel E7500 MCH" rev 0x03
> pci1 at ppb0 bus 1
> "Intel 82870P2 IOxAPIC" rev 0x03 at pci1 dev 28 function 0 not configured
> ppb1 at pci1 dev 29 function 0 "Intel 82870P2 PCI-PCI" rev 0x03
> pci2 at ppb1 bus 2
> gdt0 at pci2 dev 8 function 0 "Intel GDT RAID" rev 0x00: irq 9 dpmem fa000000
> 2-bus 1 cache device
> gdt0: ver 222, cache on, strategy 2, writeback on, blksz 32
> gdt0: raw feat 1 cache feat 101
> scsibus0 at gdt0: 35 targets
> sd0 at scsibus0 targ 0 lun 0: <ICP, Host drive #00, > SCSI2 0/direct fixed
> sd0: 34961MB, 34961 cyl, 64 head, 32 sec, 512 bytes/sec, 71601705 sec total
> scsibus1 at gdt0: 16 targets
> scsibus2 at gdt0: 16 targets
> "Intel 82870P2 IOxAPIC" rev 0x03 at pci1 dev 30 function 0 not configured
> ppb2 at pci1 dev 31 function 0 "Intel 82870P2 PCI-PCI" rev 0x03
> pci3 at ppb2 bus 3
> em0 at pci3 dev 7 function 0 "Intel PRO/1000MT (82546EB)" rev 0x01: irq 9,
> address 00:07:e9:05:75:ae
> em1 at pci3 dev 7 function 1 "Intel PRO/1000MT (82546EB)" rev 0x01: irq 9,
> address 00:07:e9:05:75:af
> fxp0 at pci3 dev 8 function 0 "Intel 8255x" rev 0x08, i82559: irq 9, address
> 00:02:b3:3a:42:36
> inphy0 at fxp0 phy 1: i82555 10/100 PHY, rev. 4
> "Intel E7500 MCH" rev 0x03 at pci0 dev 3 function 1 not configured
> uhci0 at pci0 dev 29 function 0 "Intel 82801CA/CAM USB" rev 0x02: irq 9
> usb0 at uhci0: USB revision 1.0
> uhub0 at usb0
> uhub0: Intel UHCI root hub, rev 1.00/1.00, addr 1
> uhub0: 2 ports with 2 removable, self powered
> uhci1 at pci0 dev 29 function 1 "Intel 82801CA/CAM USB" rev 0x02: irq 10
> usb1 at uhci1: USB revision 1.0
> uhub1 at usb1
> uhub1: Intel UHCI root hub, rev 1.00/1.00, addr 1
> uhub1: 2 ports with 2 removable, self powered
> ppb3 at pci0 dev 30 function 0 "Intel 82801BA AGP" rev 0x42
> pci4 at ppb3 bus 4
> vga1 at pci4 dev 12 function 0 "ATI Rage XL" rev 0x27
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> ichpcib0 at pci0 dev 31 function 0 "Intel 82801CA LPC" rev 0x02
> pciide0 at pci0 dev 31 function 1 "Intel 82801CA IDE" rev 0x02: DMA, channel 0
> configured to compatibility, channel 1 configured to compatibility
> pciide0: channel 0 disabled (no drives)
> atapiscsi0 at pciide0 channel 1 drive 0
> scsibus3 at atapiscsi0: 2 targets
> cd0 at scsibus3 targ 0 lun 0: <SAMSUNG, CD-ROM SN-124, N101> SCSI0 5/cdrom
> removable
> cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
> ichiic0 at pci0 dev 31 function 3 "Intel 82801CA/CAM SMBus" rev 0x02: irq 11
> iic0 at ichiic0: disabled to avoid ipmi0 interactions
> isa0 at ichpcib0
> isadma0 at isa0
> pckbc0 at isa0 port 0x60/5
> pckbd0 at pckbc0 (kbd slot)
> pckbc0: using irq 1 for kbd slot
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pcppi0 at isa0 port 0x61
> midi0 at pcppi0: <PC speaker>
> spkr0 at pcppi0
> npx0 at isa0 port 0xf0/16: using exception 16
> pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
> pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
> fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
> fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
> biomask ffe5 netmask ffe5 ttymask ffe7
> pctr: user-level cycle counter enabled
> dkcsum: sd0 matches BIOS drive 0x80
> root on sd0a
> rootdev=0x400 rrootdev=0xd00 rawdev=0xd02
> WARNING: / was not properly unmounted