fw_update signify unsigned package on current and 6.2-stable

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

fw_update signify unsigned package on current and 6.2-stable

Theodore Wynnychenko-2
Hello:

A couple of month ago, I decided to take the plunge and setup an openbsd laptop.
I bought a relatively newer ThinkPad, and (a couple of months ago) set it up and
started playing with the desktop environment.

Well, life happened, and I put it aside for a while.  Yesterday, I decided to
look at it again, and decided I would just start over.

So, I downloaded the current install image, and installed it on the laptop.

This laptop has no wired Ethernet port, just wireless which requires the
iwm-firmware.

So, after installing -current and booting into the system, I plugged in a USB
drive with the "iwm-firmware-0.20170105.tgz" on it, and issued:
# fw_update -p /mnt iwm

This worked a couple of months ago, and the wireless came up.  Yesterday (and
today), I got/get:

file:/mnt/iwm-firmware-0.20170105.tgz: unsigned package (signify(1) doesn't see
old-style signatures)

I see that how signify works had recently changed, so, I reinstalled with the
6.2 stable image.
But, I get the same error.

I would rather not go all the way back to 6.1.
I can find no way in the man page to get fw_update to install without checking
signatures.  I did try using "pkg_add -D unsigned" as a guess (with little
hope), but that did not work either.

It seems that the firmware package ("20170105") is from the time before signify
changed, and has not been brought into sync with the new signify (that's just a
guess).

How do I install the iwm-firmware without a network connection on either
6.2-stable or -current?

Thanks
Ted



---
This email has been checked for viruses by AVG.
http://www.avg.com