fix apache-httpd-2.4.35 under openbsd

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

fix apache-httpd-2.4.35 under openbsd

avomoch
Hi all,April 8, 2019, the bug in apache-httpd for Linux and Unix systems was updated to a new version of Apache-httpd-2.4.39. However, I found only sources, not the entire upgrade package. If I enter pkgadd -u apache-httpd it will not allow me to update apache-httpd-2.4.35 to the new version 2.4.39. Can you please advise me?
 
Thank you for your answer.
 
Stevo
P.S.Author -  sthenRevision 1.90.2.2 <https://cvsweb.openbsd.org/ports/www/apache-httpd/Makefile?rev=1.90.2.2&content-type=text/x-cvsweb-markup> / (download <https://cvsweb.openbsd.org/cgi-bin/cvsweb/~checkout~/ports/www/apache-httpd/Makefile?rev=1.90.2.2&content-type=text/plain>) - annotate <https://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/www/apache-httpd/Makefile?annotate=1.90.2.2> - [select for diffs] <https://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/www/apache-httpd/Makefile?r1=1.90.2.2>, Mon Apr 8 23:26:39 2019 UTC (30 hours, 46 minutes ago) by sthen
Branch: OPENBSD_6_4 <https://cvsweb.openbsd.org/ports/www/apache-httpd/Makefile?only_with_tag=OPENBSD_6_4>  
Changes since 1.90.2.1: +2 -1 lines
Diff to previous 1.90.2.1 <https://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/www/apache-httpd/Makefile.diff?r1=1.90.2.1&r2=1.90.2.2> (colored <https://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/www/apache-httpd/Makefile.diff?r1=1.90.2.1&r2=1.90.2.2&f=h>) to branchpoint 1.90 <https://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/www/apache-httpd/Makefile.diff?r1=1.90&r2=1.90.2.2> (colored <https://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/www/apache-httpd/Makefile.diff?r1=1.90&r2=1.90.2.2&f=h>) next main 1.91 <https://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/www/apache-httpd/Makefile.diff?r1=1.91&r2=1.90.2.2> (colored <https://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/www/apache-httpd/Makefile.diff?r1=1.91&r2=1.90.2.2&f=h>)MFC: backport Apache httpd fix affecting file uploads, they were broken in 2.4.39unless the admin specifies an explicit RequestReadTimeout.https://bz.apache.org/bugzilla/show_bug.cgi?id=63325 <https://bz.apache.org/bugzilla/show_bug.cgi?id=63325>https://svn.apache.org/viewv
 c?view=r
 evision&revision=1857129 <https://svn.apache.org/viewvc?view=revision&revision=1857129



Reply | Threaded
Open this post in threaded view
|

Re: fix apache-httpd-2.4.35 under openbsd

Janne Johansson-3
Den ons 10 apr. 2019 kl 09:39 skrev <[hidden email]>:

> Hi all,April 8, 2019, the bug in apache-httpd for Linux and Unix systems
> was updated to a new version of Apache-httpd-2.4.39. However, I found only
> sources, not the entire upgrade package. If I enter pkgadd -u apache-httpd
> it will not allow me to update apache-httpd-2.4.35 to the new version
> 2.4.39. Can you please advise me?
>

https://www.openbsd.org/faq/faq10.html#Patches
first section of "For third party software installed via packages
<https://www.openbsd.org/faq/faq15.html>, there are two options:"


--
May the most significant bit of your life be positive.