firefox(-esr) libGL errors

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

firefox(-esr) libGL errors

Anirudh Oppiliappan
Hi,

firefox (80) and firefox-esr (78) both dump the below error, when
launched from the terminal. When the browser starts up, the tabs hang
for about 3-4 minutes before they can be used.

libGL error: MESA-LOADER: failed to open iris (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: iris
libGL error: MESA-LOADER: failed to open swrast (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: swrast
libGL error: MESA-LOADER: failed to open iris (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: iris
libGL error: MESA-LOADER: failed to open swrast (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: swrast
Crash Annotation GraphicsCriticalError: |[G0][GFX1-]: Failed GL context
creation for WebRender: 0x0 (t=0.97406) [GFX1-]: Failed GL context
creation for WebRender: 0x0 Crash Annotation GraphicsCriticalError:
|[0][GFX1-]: Failed to connect WebRenderBridgeChild. (t=2.31584)
[GFX1-]: Failed to connect WebRenderBridgeChild.  libGL error:
MESA-LOADER: failed to open iris (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: iris
libGL error: MESA-LOADER: failed to open swrast (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: swrast
Crash Annotation GraphicsCriticalError: |[G0][GFX1-]: Failed GL context
creation for WebRender: 0x0 (t=0.97406) |[G1][GFX1-]: [OPENGL] Failed to
init compositor with reason: FEATURE_FAILURE_OPENGL_CREATE_CONTEXT
(t=1.00251) [GFX1-]: [OPENGL] Failed to init compositor with reason:
FEATURE_FAILURE_OPENGL_CREATE_CONTEXT firefox-esr:
/etc/firefox-esr/pledge.main: disabled libGL error: MESA-LOADER: failed
to open iris (search paths /usr/X11R6/lib/modules/dri) libGL error:
failed to load driver: iris libGL error: MESA-LOADER: failed to open
swrast (search paths /usr/X11R6/lib/modules/dri) libGL error: failed to
load driver: swrast Crash Annotation GraphicsCriticalError:
|[G0][GFX1-]: Failed GL context creation for WebRender: 0x0 (t=0.97406)
|[G1][GFX1-]: [OPENGL] Failed to init compositor with reason:
FEATURE_FAILURE_OPENGL_CREATE_CONTEXT (t=1.00251) |[G2][GFX1-]: [OPENGL]
Failed to init compositor with reason:
FEATURE_FAILURE_OPENGL_CREATE_CONTEXT (t=2.16835) [GFX1-]: [OPENGL]
Failed to init compositor with reason:
FEATURE_FAILURE_OPENGL_CREATE_CONTEXT

I'm running Intel UHD 620 graphics. Moreover, the
/usr/X11R6/lib/modules/dri directory seems to exist, and so do the
apparently missing drivers -- iris and swarst. What could be the issue?
Are there any known solutions to this?
Date: Thu, 10 Sep 2020 22:48:43 +0530
From: Anirudh Oppiliappan <[hidden email]>
To: [hidden email]
Subject: firefox(-esr) libGL errors
Message-ID: <20200910171843.qSfMC%[hidden email]>
User-Agent: nail v14.9.19

Hi,

firefox (80) and firefox-esr (78) both dump the below error, when
launched from the terminal. When the browser starts up, the tabs hang
for about 3-4 minutes before they can be used.

libGL error: MESA-LOADER: failed to open iris (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: iris
libGL error: MESA-LOADER: failed to open swrast (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: swrast
libGL error: MESA-LOADER: failed to open iris (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: iris
libGL error: MESA-LOADER: failed to open swrast (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: swrast
Crash Annotation GraphicsCriticalError: |[G0][GFX1-]: Failed GL context
creation for WebRender: 0x0 (t=0.97406) [GFX1-]: Failed GL context
creation for WebRender: 0x0 Crash Annotation GraphicsCriticalError:
|[0][GFX1-]: Failed to connect WebRenderBridgeChild. (t=2.31584)
[GFX1-]: Failed to connect WebRenderBridgeChild.  libGL error:
MESA-LOADER: failed to open iris (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: iris
libGL error: MESA-LOADER: failed to open swrast (search paths
/usr/X11R6/lib/modules/dri) libGL error: failed to load driver: swrast
Crash Annotation GraphicsCriticalError: |[G0][GFX1-]: Failed GL context
creation for WebRender: 0x0 (t=0.97406) |[G1][GFX1-]: [OPENGL] Failed to
init compositor with reason: FEATURE_FAILURE_OPENGL_CREATE_CONTEXT
(t=1.00251) [GFX1-]: [OPENGL] Failed to init compositor with reason:
FEATURE_FAILURE_OPENGL_CREATE_CONTEXT firefox-esr:
/etc/firefox-esr/pledge.main: disabled libGL error: MESA-LOADER: failed
to open iris (search paths /usr/X11R6/lib/modules/dri) libGL error:
failed to load driver: iris libGL error: MESA-LOADER: failed to open
swrast (search paths /usr/X11R6/lib/modules/dri) libGL error: failed to
load driver: swrast Crash Annotation GraphicsCriticalError:
|[G0][GFX1-]: Failed GL context creation for WebRender: 0x0 (t=0.97406)
|[G1][GFX1-]: [OPENGL] Failed to init compositor with reason:
FEATURE_FAILURE_OPENGL_CREATE_CONTEXT (t=1.00251) |[G2][GFX1-]: [OPENGL]
Failed to init compositor with reason:
FEATURE_FAILURE_OPENGL_CREATE_CONTEXT (t=2.16835) [GFX1-]: [OPENGL]
Failed to init compositor with reason:
FEATURE_FAILURE_OPENGL_CREATE_CONTEXT

I'm running Intel UHD 620 graphics. Moreover, the
/usr/X11R6/lib/modules/dri directory seems to exist, and so do the
apparently missing drivers -- iris and swarst. What could be the issue?
Are there any known solutions to this?