failing to install RRDtool package and MRTGpackage on openBSD 3.9

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

failing to install RRDtool package and MRTGpackage on openBSD 3.9

Ton Muller-3
a good morning.

I am using openBSD 3.9 on several machines, i have a seperate machine
for testing purpose.
today i want to try to install the RRDtool and MRTGpackage from your site.

Package name mrtg-2.12.2p1.tgz and rrdtool-1.0.49p3.tgz

both packages gives below error messages.

Terminal type? [xterm]
D/3.9/packages/i386/rrdtool-1.0.49p3-tcl.tgz

<
Error from ftp://192.168.0.254/pub/OpenBSD/3.9/packages/i386/:
Unknown command.
Can't install gd-2.0.33p2: lib not found fontconfig.3.0
Even by looking in the dependency tree:
        jpeg-6bp3, png-1.2.8, libiconv-1.9.2p3
Maybe it's in a dependent package, but not tagged with @lib ?
(check with pkg_info -K -L)
If you are still running 3.6 packages, update them.
Can't install gd-2.0.33p2: lib not found freetype.13.1
rrdtool-1.0.49p3-tcl:tcl-8.4.7p1: complete
Can't install
ftp://192.168.0.254/pub/OpenBSD/3.9/packages/i386/rrdtool-1.0.49p3-tcl.tgz:
can't resolve gd-2.0.33p2
--- tcl-8.4.7p1 -------------------
You may wish to add /usr/local/lib/tcl8.4/man to /etc/man.conf
# pkg add
ftp://192.168.0.254/pub/OpenBSD/3.9/packages/i386/mrtg-2.12.2p1.tgz
Error from ftp://192.168.0.254/pub/OpenBSD/3.9/packages/i386/:
Unknown command.
Can't install gd-2.0.33p2: lib not found fontconfig.3.0
Even by looking in the dependency tree:
        jpeg-6bp3, png-1.2.8, libiconv-1.9.2p3
Maybe it's in a dependent package, but not tagged with @lib ?
(check with pkg_info -K -L)
If you are still running 3.6 packages, update them.
Can't install gd-2.0.33p2: lib not found freetype.13.1
mrtg-2.12.2p1:p5-SNMP_Session-1.07: complete
mrtg-2.12.2p1:p5-Pod-Escapes-1.04: complete
mrtg-2.12.2p1:p5-Pod-Simple-3.02: complete
Can't install
ftp://192.168.0.254/pub/OpenBSD/3.9/packages/i386/mrtg-2.12.2p1.tgz:
can't resolve gd-2.0.33p2
# pkg add ftp://192.168.0.254/pub/OpenBSD/3.9/packages/i386/gd-2.0.33p2.tgz
Can't install
ftp://192.168.0.254/pub/OpenBSD/3.9/packages/i386/gd-2.0.33p2.tgz: lib
not found fontconfig.3.0
Even by looking in the dependency tree:
        jpeg-6bp3, png-1.2.8, libiconv-1.9.2p3
Maybe it's in a dependent package, but not tagged with @lib ?
(check with pkg_info -K -L)
If you are still running 3.6 packages, update them.
Can't install
ftp://192.168.0.254/pub/OpenBSD/3.9/packages/i386/gd-2.0.33p2.tgz: lib
not found freetype.13.1
#

oh, i have completly downloaded the I386 packages to my lokal FTP for
speeding up bandwide and, save the badwide from openbsd.org :)

first i thought that the packages where corrupt on my FTP, but after
trying to download them from ftp.openbsd.org the same messages where
displayed.

My computer is a Compaq proline EN desktop with a 6.4GB maxtor HD ,a
667mhz P3 cpu ,with 512MB memory, running openBSD 3.9

most kindly
Ton muller ,aka spatieman..

Reply | Threaded
Open this post in threaded view
|

Re: failing to install RRDtool package and MRTGpackage on openBSD 3.9

Nikolay Sturm-3
* Ton [2006-06-16]:
> Can't install gd-2.0.33p2: lib not found fontconfig.3.0

You don't have xbase39.tgz installed.

Questions regarding ports and packages should be sent to ports@ instead.

Nikolay