expat package fails to install (conflict .libs-expat-1.95.6p1)

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

expat package fails to install (conflict .libs-expat-1.95.6p1)

Benjamin A. Collins
I recently upgraded to the latest snapshot and was in the process of
upgrading all the packages I had installed, and when I tried to install
packages that depend on expat, the install of expat failed with this:

Can't install expat-2.0.0 because of conflicts (.libs-expat-1.95.6p1)

I tried building from ports and got the same result.


Reply | Threaded
Open this post in threaded view
|

Re: expat package fails to install (conflict .libs-expat-1.95.6p1)

dorqus
Benjamin Collins wrote...
> I recently upgraded to the latest snapshot and was in the process of
> upgrading all the packages I had installed, and when I tried to install
> packages that depend on expat, the install of expat failed with this:
>
> Can't install expat-2.0.0 because of conflicts (.libs-expat-1.95.6p1)
>
> I tried building from ports and got the same result.

rm -r /var/db/pkg/.libs-expat-1.95.6p1

rebuild your new port.

--
josh
        There are 10 types of people.  Those that understand binary,
        and those that don't.

Reply | Threaded
Open this post in threaded view
|

Re: expat package fails to install (conflict .libs-expat-1.95.6p1)

Marc Espie-2
In reply to this post by Benjamin A. Collins
On Wed, Apr 26, 2006 at 05:12:22AM -0700, Benjamin Collins wrote:
> I recently upgraded to the latest snapshot and was in the process of
> upgrading all the packages I had installed, and when I tried to install
> packages that depend on expat, the install of expat failed with this:
>
> Can't install expat-2.0.0 because of conflicts (.libs-expat-1.95.6p1)

Remove the libs,

pkg_delete .libs-expat

Reply | Threaded
Open this post in threaded view
|

Re: expat package fails to install (conflict .libs-expat-1.95.6p1)

Alexander Belikov
In reply to this post by dorqus

d> Benjamin Collins wrote...
>> I recently upgraded to the latest snapshot and was in the process of
>> upgrading all the packages I had installed, and when I tried to install
>> packages that depend on expat, the install of expat failed with this:
>>
>> Can't install expat-2.0.0 because of conflicts (.libs-expat-1.95.6p1)
>>
>> I tried building from ports and got the same result.

d> rm -r /var/db/pkg/.libs-expat-1.95.6p1
or pkg_delete .libs-expat-1.95.6p1

d> rebuild your new port.

--
Best regards,
 Alexander                            mailto:[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: expat package fails to install (conflict .libs-expat-1.95.6p1)

Marc Espie-2
In reply to this post by dorqus
On Wed, Apr 26, 2006 at 09:15:24AM -0400, dorqus wrote:

> Benjamin Collins wrote...
> > I recently upgraded to the latest snapshot and was in the process of
> > upgrading all the packages I had installed, and when I tried to install
> > packages that depend on expat, the install of expat failed with this:
> >
> > Can't install expat-2.0.0 because of conflicts (.libs-expat-1.95.6p1)
> >
> > I tried building from ports and got the same result.
>
> rm -r /var/db/pkg/.libs-expat-1.95.6p1
>
> rebuild your new port.
>
Don't do that!!!!

Any package installed can be deleted...

if you have conflicts with .libs-expat, it means you already updated expat,
so you can usually just pkg_delete .libs-expat, as nothing will depend on
it any longer.

Reply | Threaded
Open this post in threaded view
|

Re: expat package fails to install (conflict .libs-expat-1.95.6p1)

dorqus
Marc-

Marc Espie wrote...
> Don't do that!!!!
>
> Any package installed can be deleted...
>
> if you have conflicts with .libs-expat, it means you already updated expat,
> so you can usually just pkg_delete .libs-expat, as nothing will depend on
> it any longer.

My apologies....I had this happen once before, I thought I just rm'ed
that directory, but in retrospect I did the pkg_delete .libs-expat
and all was well.

Too early in the AM for me :/
Josh

Reply | Threaded
Open this post in threaded view
|

Re: expat package fails to install (conflict .libs-expat-1.95.6p1)

Bernd Ahlers
In reply to this post by dorqus
dorqus [Wed, Apr 26, 2006 at 09:15:24AM -0400] wrote:

>Benjamin Collins wrote...
>> I recently upgraded to the latest snapshot and was in the process of
>> upgrading all the packages I had installed, and when I tried to install
>> packages that depend on expat, the install of expat failed with this:
>>
>> Can't install expat-2.0.0 because of conflicts (.libs-expat-1.95.6p1)
>>
>> I tried building from ports and got the same result.
>
>rm -r /var/db/pkg/.libs-expat-1.95.6p1
>
>rebuild your new port.
>
This is a _BAD_ advice!!! Don't do that.

"pkg_delete .libs-expat-1.95.6p1" is the way to go.

Bernd