error : pkg_add analog-6.0.tgz / webalizer-2.01.10p2.tgz

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

error : pkg_add analog-6.0.tgz / webalizer-2.01.10p2.tgz

MichaelBibby
hi all:
        I use OpenBSD 3.8 release,but download packages from "ftp://ftp.openbsd.org/pub/OpenBSD/snapshots/i386/".
        When i install analog-6.0.tgz and webalizer-2.01.10p2.tgz,i got the same error message.
i run "pkg_info -K -L PKGNAME" ,but not found lib "ttf.1.3".

Is there something wrong with my system?

# pkg_add analog-6.0.tgz
analog-6.0:libiconv-1.9.2p1: complete
analog-6.0:pcre-4.5p1: complete
analog-6.0:jpeg-6bp2: complete
analog-6.0:png-1.2.8: complete
analog-6.0:gd-2.0.33p2: complete
Can't install analog-6.0.tgz: lib not found ttf.1.3
Even by looking in the dependency tree:
        libiconv-1.9.2p1, jpeg-6bp2, png-1.2.8, gd-2.0.33p2, pcre-4.5p1
Maybe it's in a dependent package, but not tagged with @lib ?
(check with pkg_info -K -L)
If you are still running 3.6 packages, update them.
#

# pkg_add webalizer-2.01.10p2.tgz
Can't install webalizer-2.01.10p2.tgz: lib not found ttf.1.3
Even by looking in the dependency tree:
        jpeg-6bp2, libiconv-1.9.2p1, png-1.2.8, gd-2.0.33p2
Maybe it's in a dependent package, but not tagged with @lib ?
(check with pkg_info -K -L)
If you are still running 3.6 packages, update them.
#

Reply | Threaded
Open this post in threaded view
|

Re: error : pkg_add analog-6.0.tgz / webalizer-2.01.10p2.tgz

Josh Grosse
On Fri, Nov 04, 2005 at 09:22:41AM +0800, MichaelBibby wrote:
> hi all:
> I use OpenBSD 3.8 release,but download packages from "ftp://ftp.openbsd.org/pub/OpenBSD/snapshots/i386/".

You've missed FAQ 15.4.1:
---------------------------
15.4.1 - I'm getting all kinds of crazy errors. I just can't seem to get this
ports stuff working at all.

It is very likely that you are using a system and ports tree which are not in
sync.

Sorry?

...

* Do not check out a -current ports tree and expect it to work on a -release
or -stable system. This is one of the most common errors and you will irritate
people when you ask for help about why "nothing seems to work!"

* Because this is important to get right, we will rephrase it once more. If
your system is -release, use the -release version of the ports tree. If your
system is -stable, you need the -stable version of the ports tree. And finally,
if you follow -current, you need both a -current system and a -current ports
tree. If you use X11 as part of your system, it must also follow the
corresponding branch!

Yes, this really does mean a wonderful new port will typically not work on
your "older" system -- even if that system was -current just a few weeks ago.

Reply | Threaded
Open this post in threaded view
|

Re: error : pkg_add analog-6.0.tgz / webalizer-2.01.10p2.tgz

Steven Shockley
In reply to this post by MichaelBibby
MichaelBibby wrote:
> hi all:
> I use OpenBSD 3.8 release,but download packages from "ftp://ftp.openbsd.org/pub/OpenBSD/snapshots/i386/".
> When i install analog-6.0.tgz and webalizer-2.01.10p2.tgz,i got the same error message.
> i run "pkg_info -K -L PKGNAME" ,but not found lib "ttf.1.3".
>
> Is there something wrong with my system?

Yes.  You're using snapshot packages with 3.8 Release.  Remove all your
packages and reinstall from
ftp://ftp.openbsd.org/pub/OpenBSD/3.8/packages/i386/ or a closer mirror.

Reply | Threaded
Open this post in threaded view
|

Re: error : pkg_add analog-6.0.tgz / webalizer-2.01.10p2.tgz

MichaelBibby
In reply to this post by MichaelBibby
sorry ,what a stupid question :(

and thanks
Steve Shockley<[hidden email]>
Josh Grosse<[hidden email]>

^_^