em(4) diff for ICH9 IGP M needs testing.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

em(4) diff for ICH9 IGP M needs testing.

Brad Smith-14
If you have a system with the Intel ICH9 IGP M or ICH9 IGP M AMT chipset
please test the following diff. I'm especially interested in having this
tested with the ICH9 IGP M. Please provide me with a dmesg.


Index: if_em.c
===================================================================
RCS file: /cvs/src/sys/dev/pci/if_em.c,v
retrieving revision 1.198
diff -u -p -r1.198 if_em.c
--- if_em.c 28 Nov 2008 02:44:17 -0000 1.198
+++ if_em.c 28 Nov 2008 04:50:25 -0000
@@ -127,7 +127,9 @@ const struct pci_matchid em_devices[] =
  { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IFE_G },
  { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IFE_GT },
  { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IGP_AMT },
- { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IGP_C }
+ { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IGP_C },
+ { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IGP_M },
+ { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IGP_M_AMT }
 };
 
 /*********************************************************************
Index: if_em_hw.c
===================================================================
RCS file: /cvs/src/sys/dev/pci/if_em_hw.c,v
retrieving revision 1.30
diff -u -p -r1.30 if_em_hw.c
--- if_em_hw.c 24 Sep 2008 19:12:59 -0000 1.30
+++ if_em_hw.c 28 Nov 2008 05:10:34 -0000
@@ -460,6 +460,8 @@ em_set_mac_type(struct em_hw *hw)
     case E1000_DEV_ID_ICH9_IFE_GT:
     case E1000_DEV_ID_ICH9_IGP_AMT:
     case E1000_DEV_ID_ICH9_IGP_C:
+    case E1000_DEV_ID_ICH9_IGP_M:
+    case E1000_DEV_ID_ICH9_IGP_M_AMT:
         hw->mac_type = em_ich9lan;
         break;
     default:
@@ -4045,6 +4047,15 @@ em_detect_gig_phy(struct em_hw *hw)
         hw->mac_type == em_82572) {
         hw->phy_id = IGP01E1000_I_PHY_ID;
         hw->phy_type = em_phy_igp_2;
+        return E1000_SUCCESS;
+    }
+
+    /* until something better comes along... makes the Lenovo X200 work */
+    if (hw->mac_type == em_ich9lan &&
+        (hw->device_id == E1000_DEV_ID_ICH9_IGP_M ||
+         hw->device_id == E1000_DEV_ID_ICH9_IGP_M_AMT)) {
+        hw->phy_id = IGP03E1000_E_PHY_ID;
+        hw->phy_type = em_phy_igp_3;
         return E1000_SUCCESS;
     }
 

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

Reply | Threaded
Open this post in threaded view
|

Re: em(4) diff for ICH9 IGP M needs testing.

guilherme m. schroeder-2
Brad,

I have been using jcs@ hack for a while.
It's available here:

http://jcs.org/patches/openbsd-em_match_thinkpad_x200.diff

I noticed that is basically equal to this one you have sent to list, but it just have my card.
I didn't have any problem with it (low traffic, normal usage).

Here's my dmesg:

OpenBSD 4.4-current (GENERIC.MP) #2: Wed Nov 26 00:17:53 BRST 2008
    root@dub:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 3694911488 (3523MB)
avail mem = 3585921024 (3419MB)
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.4 @ 0xf6590 (57 entries)
bios0: vendor Dell Inc. version "A06" date 10/10/2008
bios0: Dell Inc. Latitude E6400
acpi0 at bios0: rev 2
acpi0: tables DSDT FACP HPET DMAR APIC ASF! MCFG SLIC TCPA SSDT
acpi0: wakeup devices PCI0(S4) PCIE(S4) USB1(S0) USB2(S0) USB3(S0) USB4(S0) USB5(S0) USB6(S0) EHC2(S0) EHCI(S0) AZAL(S3) RP01(S4) RP02(S4) RP03(S4) RP04(S3) RP05(S3) RP06(S5) LID_(S3) PBTN(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz, 2261.33 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,SMX,EST,TM2,CX16,xTPR,NXE,LONG
cpu0: 3MB 64b/line 8-way L2 cache
cpu0: apic clock running at 266MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz, 2261.00 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,SMX,EST,TM2,CX16,xTPR,NXE,LONG
cpu1: 3MB 64b/line 8-way L2 cache
ioapic0 at mainbus0 apid 2 pa 0xfec00000, version 20, 24 pins
ioapic0: misconfigured as apic 0, remapped to apid 2
acpiprt0 at acpi0: bus 3 (PCIE)
acpiprt1 at acpi0: bus -1 (AGP_)
acpiprt2 at acpi0: bus 11 (RP01)
acpiprt3 at acpi0: bus 12 (RP02)
acpiprt4 at acpi0: bus 13 (RP03)
acpiprt5 at acpi0: bus 14 (RP04)
acpiprt6 at acpi0: bus -1 (RP05)
acpiprt7 at acpi0: bus -1 (RP06)
acpiprt8 at acpi0: bus 0 (PCI0)
acpiec0 at acpi0
acpicpu0 at acpi0: C3, C2, C1, PSS
acpicpu1 at acpi0: C3, C2, C1, PSS
acpitz0 at acpi0: critical temperature 107 degC
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: PBTN
acpibtn2 at acpi0: SBTN
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT0 model "DELL FU27488" serial 30161 type LION oem "Sony"
acpibat1 at acpi0: BAT1 not present
acpivideo at acpi0 not configured
acpivideo at acpi0 not configured
acpivideo at acpi0 not configured
cpu0: Enhanced SpeedStep 2261 MHz: speeds: 2268, 2267, 1600, 800 MHz
pci0 at mainbus0 bus 0: configuration mode 1
pchb0 at pci0 dev 0 function 0 "Intel GM45 Host" rev 0x07
vga1 at pci0 dev 2 function 0 "Intel GM45 Video" rev 0x07
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
intagp at vga1 not configured
inteldrm0 at vga1
drm0 at inteldrm0: couldn't find agp
"Intel GM45 Video" rev 0x07 at pci0 dev 2 function 1 not configured
em0 at pci0 dev 25 function 0 "Intel ICH9 IGP M AMT" rev 0x03: apic 2 int 22 (irq 10), address 00:21:70:a5:77:b8
uhci0 at pci0 dev 26 function 0 "Intel 82801I USB" rev 0x03: apic 2 int 20 (irq 7)
uhci1 at pci0 dev 26 function 1 "Intel 82801I USB" rev 0x03: apic 2 int 21 (irq 4)
uhci2 at pci0 dev 26 function 2 "Intel 82801I USB" rev 0x03: apic 2 int 22 (irq 10)
ehci0 at pci0 dev 26 function 7 "Intel 82801I USB" rev 0x03: apic 2 int 22 (irq 10)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 82801I HD Audio" rev 0x03: apic 2 int 21 (irq 4)
azalia0: invalid ADC PCM format: 0x00000000
azalia0: codecs: IDT/0x76b2, Intel/0x2802, using IDT/0x76b2
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 82801I PCIE" rev 0x03: apic 2 int 16 (irq 0)
pci1 at ppb0 bus 11
ppb1 at pci0 dev 28 function 1 "Intel 82801I PCIE" rev 0x03: apic 2 int 17 (irq 0)
pci2 at ppb1 bus 12
iwn0 at pci2 dev 0 function 0 "Intel WiFi Link 5300AGN" rev 0x00: apic 2 int 17 (irq 3), MIMO 3T3R, MoW, address 00:16:ea:5e:dc:32
ppb2 at pci0 dev 28 function 2 "Intel 82801I PCIE" rev 0x03: apic 2 int 18 (irq 0)
pci3 at ppb2 bus 13
ppb3 at pci0 dev 28 function 3 "Intel 82801I PCIE" rev 0x03: apic 2 int 19 (irq 0)
pci4 at ppb3 bus 14
uhci3 at pci0 dev 29 function 0 "Intel 82801I USB" rev 0x03: apic 2 int 20 (irq 7)
uhci4 at pci0 dev 29 function 1 "Intel 82801I USB" rev 0x03: apic 2 int 21 (irq 4)
uhci5 at pci0 dev 29 function 2 "Intel 82801I USB" rev 0x03: apic 2 int 22 (irq 10)
ehci1 at pci0 dev 29 function 7 "Intel 82801I USB" rev 0x03: apic 2 int 20 (irq 7)
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb4 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0x93
pci5 at ppb4 bus 3
"Ricoh 5C832 Firewire" rev 0x04 at pci5 dev 1 function 0 not configured
sdhc0 at pci5 dev 1 function 1 "Ricoh 5C822 SD/MMC" rev 0x21: apic 2 int 18 (irq 11)
sdmmc0 at sdhc0
sdhc1 at pci5 dev 1 function 2 "Ricoh 5C843 MMC" rev 0x11: apic 2 int 18 (irq 11)
sdhc1: base clock frequency unknown
sdhc1 at 0x10: can't initialize host
pcib0 at pci0 dev 31 function 0 "Intel 82801IEM LPC" rev 0x03
ahci0 at pci0 dev 31 function 2 "Intel 82801I AHCI" rev 0x03: apic 2 int 19 (irq 10), AHCI 1.2
scsibus0 at ahci0: 32 targets, initiator 32
sd0 at scsibus0 targ 0 lun 0: <ATA, ST980813ASG, 3.AD> SCSI3 0/direct fixed
sd0: 76319MB, 512 bytes/sec, 156301488 sec total
cd0 at scsibus0 targ 1 lun 0: <PLDS, DVD+-RW DU-8A2S, 4D12> ATAPI 5/cdrom removable
ichiic0 at pci0 dev 31 function 3 "Intel 82801I SMBus" rev 0x03: apic 2 int 17 (irq 3)
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 2GB DDR2 SDRAM non-parity PC2-6400CL5 SO-DIMM
spdmem1 at iic0 addr 0x52: 2GB DDR2 SDRAM non-parity PC2-6400CL5 SO-DIMM
usb2 at uhci0: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci1: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci2: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb5 at uhci3: USB revision 1.0
uhub5 at usb5 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb6 at uhci4: USB revision 1.0
uhub6 at usb6 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb7 at uhci5: USB revision 1.0
uhub7 at usb7 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at pcib0
isadma0 at isa0
com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
mtrr: Pentium Pro MTRR support
umass0 at uhub1 port 3 configuration 1 interface 0 "Kingston DataTraveler 2.0" rev 2.00/1.00 addr 2
umass0: using SCSI over Bulk-Only
scsibus1 at umass0: 2 targets, initiator 0
sd1 at scsibus1 targ 1 lun 0: <Kingston, DataTraveler 2.0, PMAP> SCSI0 0/direct removable
sd1: 1968MB, 512 bytes/sec, 4030464 sec total
ugen0 at uhub4 port 1 "Broadcom Corp 5880" rev 1.10/1.01 addr 2
uhidev0 at uhub5 port 2 configuration 1 interface 0 "Microsoft Basic Optical Mouse" rev 1.10/0.00 addr 2
uhidev0: iclass 3/1
ums0 at uhidev0: 3 buttons, Z dir
wsmouse1 at ums0 mux 0
softraid0 at root
root on sd0a swap on sd0b dump on sd0b

Thanks.

On Wed, 3 Dec 2008 05:14:02 -0500
Brad <[hidden email]> wrote:

> If you have a system with the Intel ICH9 IGP M or ICH9 IGP M AMT chipset
> please test the following diff. I'm especially interested in having this
> tested with the ICH9 IGP M. Please provide me with a dmesg.
>
>
> Index: if_em.c
> ===================================================================
> RCS file: /cvs/src/sys/dev/pci/if_em.c,v
> retrieving revision 1.198
> diff -u -p -r1.198 if_em.c
> --- if_em.c 28 Nov 2008 02:44:17 -0000 1.198
> +++ if_em.c 28 Nov 2008 04:50:25 -0000
> @@ -127,7 +127,9 @@ const struct pci_matchid em_devices[] =
>   { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IFE_G },
>   { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IFE_GT },
>   { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IGP_AMT },
> - { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IGP_C }
> + { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IGP_C },
> + { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IGP_M },
> + { PCI_VENDOR_INTEL, PCI_PRODUCT_INTEL_ICH9_IGP_M_AMT }
>  };
>  
>  /*********************************************************************
> Index: if_em_hw.c
> ===================================================================
> RCS file: /cvs/src/sys/dev/pci/if_em_hw.c,v
> retrieving revision 1.30
> diff -u -p -r1.30 if_em_hw.c
> --- if_em_hw.c 24 Sep 2008 19:12:59 -0000 1.30
> +++ if_em_hw.c 28 Nov 2008 05:10:34 -0000
> @@ -460,6 +460,8 @@ em_set_mac_type(struct em_hw *hw)
>      case E1000_DEV_ID_ICH9_IFE_GT:
>      case E1000_DEV_ID_ICH9_IGP_AMT:
>      case E1000_DEV_ID_ICH9_IGP_C:
> +    case E1000_DEV_ID_ICH9_IGP_M:
> +    case E1000_DEV_ID_ICH9_IGP_M_AMT:
>          hw->mac_type = em_ich9lan;
>          break;
>      default:
> @@ -4045,6 +4047,15 @@ em_detect_gig_phy(struct em_hw *hw)
>          hw->mac_type == em_82572) {
>          hw->phy_id = IGP01E1000_I_PHY_ID;
>          hw->phy_type = em_phy_igp_2;
> +        return E1000_SUCCESS;
> +    }
> +
> +    /* until something better comes along... makes the Lenovo X200 work */
> +    if (hw->mac_type == em_ich9lan &&
> +        (hw->device_id == E1000_DEV_ID_ICH9_IGP_M ||
> +         hw->device_id == E1000_DEV_ID_ICH9_IGP_M_AMT)) {
> +        hw->phy_id = IGP03E1000_E_PHY_ID;
> +        hw->phy_type = em_phy_igp_3;
>          return E1000_SUCCESS;
>      }
>  
>
> --
> This message has been scanned for viruses and
> dangerous content by MailScanner, and is
> believed to be clean.

Reply | Threaded
Open this post in threaded view
|

Re: em(4) diff for ICH9 IGP M needs testing.

STeve Andre'
In reply to this post by Brad Smith-14
On Wednesday 03 December 2008 05:14:02 Brad wrote:
> If you have a system with the Intel ICH9 IGP M or ICH9 IGP M AMT chipset
> please test the following diff. I'm especially interested in having this
> tested with the ICH9 IGP M. Please provide me with a dmesg.

Hello Brad,

My brand new W500 Thinkpad now has em0, and I am using
it to send this email.  Thank you!

OpenBSD 4.4-current (GENERIC.MP) #3: Wed Dec  3 20:15:32 EST 2008
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Intel(R) Core(TM)2 Duo CPU T9600 @ 2.80GHz ("GenuineIntel" 686-class)
2.80 GHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,SMX,EST,TM2,CX16,xTPR
real mem  = 2123657216 (2025MB)
avail mem = 2045124608 (1950MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 09/24/08, BIOS32 rev. 0 @ 0xfdc80,
SMBIOS rev. 2.4 @ 0xe0010 (74 entries)
bios0: vendor LENOVO version "6FET46WW (1.16 )" date 09/24/2008
bios0: LENOVO 4061CTO
acpi0 at bios0: rev 2
acpi0: tables DSDT FACP SSDT ECDT APIC MCFG HPET SLIC BOOT ASF! SSDT TCPA SSDT
SSDT SSDT
acpi0: wakeup devices LID_(S3) SLPB(S3) UART(S3) IGBE(S4) EXP0(S4) EXP1(S4)
EXP2(S4) EXP3(S4) EXP4(S4) PCI1(S4) USB0(S3) USB1(S3) USB2(S3) USB3(S3) USB4
(S3) USB5(S3) EHC0(S3) EHC1(S3) HDEF(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: unknown i686 EBL_CR_POWERON value 3 (0x428c0800)
cpu0: apic clock running at 265MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM)2 Duo CPU T9600 @ 2.80GHz ("GenuineIntel" 686-class)
2.80 GHz
cpu1:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,SMX,EST,TM2,CX16,xTPR
ioapic0 at mainbus0: apid 1 pa 0xfec00000, version 20, 24 pins
ioapic0: misconfigured as apic 2, remapped to apid 1
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (AGP_)
acpiprt2 at acpi0: bus 2 (EXP0)
acpiprt3 at acpi0: bus 3 (EXP1)
acpiprt4 at acpi0: bus -1 (EXP2)
acpiprt5 at acpi0: bus 5 (EXP3)
acpiprt6 at acpi0: bus 13 (EXP4)
acpiprt7 at acpi0: bus 21 (PCI1)
acpiec0 at acpi0
acpicpu0 at acpi0: C3, C2
acpicpu1 at acpi0: C3, C2
acpitz0 at acpi0: critical temperature 127 degC
acpitz1 at acpi0: critical temperature 100 degC
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: SLPB
acpibat0 at acpi0: BAT0 model "42T4619" serial 30781 type LION oem "SANYO"
acpibat1 at acpi0: BAT1 not present
acpiac0 at acpi0: AC unit online
acpithinkpad0 at acpi0
acpidock at acpi0 not configured
acpivideo at acpi0 not configured
acpivideo at acpi0 not configured
bios0: ROM list: 0xc0000/0xfc00 0xd0000/0x1000 0xd1000/0x1000 0xd2000/0x1000
0xde000/0x1800! 0xe0000/0x10000
cpu0: EST: unknown system bus clock
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel GM45 Host" rev 0x07
ppb0 at pci0 dev 1 function 0 vendor "Intel", unknown product 0x2a41 rev 0x07:
apic 1 int 16 (irq 11)
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "ATI Mobility Radeon HD 3650" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"Intel GM45 HECI" rev 0x07 at pci0 dev 3 function 0 not configured
pciide0 at pci0 dev 3 function 2 vendor "Intel", unknown product 0x2a46 rev
0x07: DMA (unsupported), channel 0 wired to native-PCI, channel 1 wired to
native-PCI
pciide0: using apic 1 int 18 (irq 11) for native-PCI interrupt
pciide0: channel 0 ignored (not responding; disabled or no drives?)
pciide0: channel 1 ignored (not responding; disabled or no drives?)
vendor "Intel", unknown product 0x2a47 (class communications subclass serial,
rev 0x07) at pci0 dev 3 function 3 not configured
em0 at pci0 dev 25 function 0 "Intel ICH9 IGP M AMT" rev 0x03: apic 1 int 20
(irq 11), address 00:1c:25:99:d7:77
uhci0 at pci0 dev 26 function 0 "Intel 82801I USB" rev 0x03: apic 1 int 20
(irq 11)
uhci1 at pci0 dev 26 function 1 "Intel 82801I USB" rev 0x03: apic 1 int 21
(irq 11)
uhci2 at pci0 dev 26 function 2 "Intel 82801I USB" rev 0x03: apic 1 int 22
(irq 11)
ehci0 at pci0 dev 26 function 7 "Intel 82801I USB" rev 0x03: apic 1 int 23
(irq 11)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 82801I HD Audio" rev 0x03: apic 1 int
17 (irq 11)
azalia0: RIRB time out
azalia0: codecs: Conexant CX20561, Conexant/0x2c06, using Conexant CX20561
audio0 at azalia0
ppb1 at pci0 dev 28 function 0 "Intel 82801I PCIE" rev 0x03: apic 1 int 20
(irq 11)
pci2 at ppb1 bus 2
ppb2 at pci0 dev 28 function 1 "Intel 82801I PCIE" rev 0x03: apic 1 int 21
(irq 11)
pci3 at ppb2 bus 3
iwn0 at pci3 dev 0 function 0 "Intel WiFi Link 5300AGN" rev 0x00: apic 1 int
17 (irq 11), MIMO 3T3R, MoW, address 00:21:6a:01:d0:b6
ppb3 at pci0 dev 28 function 3 "Intel 82801I PCIE" rev 0x03: apic 1 int 23
(irq 11)
pci4 at ppb3 bus 5
ppb4 at pci0 dev 28 function 4 "Intel 82801I PCIE" rev 0x03: apic 1 int 20
(irq 11)
pci5 at ppb4 bus 13
uhci3 at pci0 dev 29 function 0 "Intel 82801I USB" rev 0x03: apic 1 int 16
(irq 11)
uhci4 at pci0 dev 29 function 1 "Intel 82801I USB" rev 0x03: apic 1 int 17
(irq 11)
uhci5 at pci0 dev 29 function 2 "Intel 82801I USB" rev 0x03: apic 1 int 18
(irq 11)
ehci1 at pci0 dev 29 function 7 "Intel 82801I USB" rev 0x03: apic 1 int 19
(irq 11)
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb5 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0x93
pci6 at ppb5 bus 21
cbb0 at pci6 dev 0 function 0 "Ricoh 5C476 CardBus" rev 0xba: apic 1 int 16
(irq 11)
"Ricoh 5C832 Firewire" rev 0x04 at pci6 dev 0 function 1 not configured
sdhc0 at pci6 dev 0 function 2 "Ricoh 5C822 SD/MMC" rev 0x21: apic 1 int 18
(irq 11)
sdmmc0 at sdhc0
"Ricoh 5C843 MMC" rev 0x11 at pci6 dev 0 function 3 not configured
"Ricoh 5C592 Memory Stick" rev 0x11 at pci6 dev 0 function 4 not configured
"Ricoh 5C852 xD" rev 0x11 at pci6 dev 0 function 5 not configured
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 22 device 0 cacheline 0x0, lattimer 0xb0
pcmcia0 at cardslot0
pcib0 at pci0 dev 31 function 0 "Intel 82801IEM LPC" rev 0x03
ahci0 at pci0 dev 31 function 2 "Intel 82801I AHCI" rev 0x03: apic 1 int 16
(irq 11), AHCI 1.2
scsibus0 at ahci0: 32 targets, initiator 32
sd0 at scsibus0 targ 0 lun 0: <ATA, WDC WD3200BEKT-2, 11.0> SCSI3 0/direct
fixed
sd0: 305245MB, 512 bytes/sec, 625142448 sec total
sd1 at scsibus0 targ 1 lun 0: <ATA, ST9500325AS, 0001> SCSI3 0/direct fixed
sd1: 476940MB, 512 bytes/sec, 976773168 sec total
ichiic0 at pci0 dev 31 function 3 "Intel 82801I SMBus" rev 0x03: apic 1 int 23
(irq 11)
iic0 at ichiic0
usb2 at uhci0: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci1: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci2: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb5 at uhci3: USB revision 1.0
uhub5 at usb5 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb6 at uhci4: USB revision 1.0
uhub6 at usb6 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb7 at uhci5: USB revision 1.0
uhub7 at usb7 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
aps0 at isa0 port 0x1600/31
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
mtrr: Pentium Pro MTRR support
dc0 at cardbus0 dev 0 function 0 "Xircom X3201-3 (21143)" rev 0x03: irq
268505099, address 00:10:a4:d0:cb:55
tqphy0 at dc0 phy 0: 78Q2120 10/100 PHY, rev. 10
com3 at cardbus0 dev 0 function 1 "Xircom 56k Modem" rev 0x03: irq 268505099:
ti16750, 64 byte fifo
com3: probed fifo depth: 0 bytes
ubt0 at uhub3 port 2 "Lenovo Computer Corp ThinkPad Bluetooth with Enhanced
Data Rate II" rev 2.00/3.52 addr 2
softraid0 at root
root on sd0a swap on sd0b dump on sd0b
cpu1: unknown i686 EBL_CR_POWERON value 3 (0x428c0800)