Quantcast

eclipse-sdk-3.2.2p16 memory configuration

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

eclipse-sdk-3.2.2p16 memory configuration

Justin Lindberg
Eclipse won't start in its present configuration on a recent amd64
snapshot. /usr/local/eclipse/eclipse.ini doesn't allow it enough
memory with -Xmx256m. This is too small, and if you raise it, then
you also have to raise ulimit -d in a shell.

I had success starting eclipse and building the HelloWorld
application with the following:

$ cat /usr/local/eclipse/eclipse.ini
-vmargs
-Xms40m
-Xmx384m
$ ulimit -d 1048576
$ eclipse &

By the way, this is the first time I've ever used eclipse, since
I've never had enough physical memory to run such a beast before.

Loading...