dump | restore crashed with OpenBSD amd64 6.5

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

dump | restore crashed with OpenBSD amd64 6.5

Federico Giannici
Since I upgraded to OpenBSD amd64 6.5 I wasn't able to do a disk
mirroring with a dump | restore without producing system panic like this:

https://www.neomedia.it/images/IMG_20190426_183116.jpg

I use the following script, executed after a boot in single user mode:

newfs -q /dev/rsd2a
if mount -o async /dev/sd2a /mirror; then
         cd /mirror
         dump 0f - / | restore rf -
        cd /
        # Make disk boottable...
        installboot -r /mirror sd2
         sleep 5
         umount /mirror
else
         echo ERROR: mount failed!
         exit;
fi

sd2a is a softraid in RAID1 with sd0 and sd1.

I always used scripts like this in a lot of servers with OpenBSD upto
6.3 without any problem (even with live systems).

Below is the dmesg.

Thanks



OpenBSD 6.5 (GENERIC.MP) #3: Sat Apr 13 14:48:43 MDT 2019
     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 12848857088 (12253MB)
avail mem = 12449824768 (11873MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.4 @ 0xf0100 (59 entries)
bios0: vendor Award Software International, Inc. version "F7" date
10/13/2011
bios0: Gigabyte Technology Co., Ltd. GA-970A-D3
acpi0 at bios0: rev 0
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP MSDM HPET MCFG MATS TAMG APIC MATS SSDT
acpi0: wakeup devices USB0(S3) USB1(S3) USB2(S3) USB3(S3) USB4(S3)
USB5(S3) USB6(S3) SBAZ(S4) PEX0(S5) PEX1(S5) PEX2(S5) PEX3(S5) P2P_(S5)
PCE2(S4) PCE3(S4) PCE4(S4) [...]
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpihpet0 at acpi0: 14318180 Hz
acpimcfg0 at acpi0
acpimcfg0: addr 0xe0000000, bus 0-255
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: AMD FX(tm)-4100 Quad-Core Processor, 3624.68 MHz, 15-01-02
cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,NODEID,TOPEXT,CPCTR,ITSC
cpu0: 64KB 64b/line 2-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
64b/line 16-way L2 cache, 8MB 64b/line 64-way L3 cache
cpu0: ITLB 48 4KB entries fully associative, 24 4MB entries fully
associative
cpu0: DTLB 32 4KB entries fully associative, 32 4MB entries fully
associative
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
cpu0: apic clock running at 201MHz
cpu0: mwait min=64, max=64, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: AMD FX(tm)-4100 Quad-Core Processor, 3624.19 MHz, 15-01-02
cpu1:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,NODEID,TOPEXT,CPCTR,ITSC
cpu1: 64KB 64b/line 2-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
64b/line 16-way L2 cache, 8MB 64b/line 64-way L3 cache
cpu1: ITLB 48 4KB entries fully associative, 24 4MB entries fully
associative
cpu1: DTLB 32 4KB entries fully associative, 32 4MB entries fully
associative
cpu1: smt 1, core 0, package 0
cpu2 at mainbus0: apid 2 (application processor)
cpu2: AMD FX(tm)-4100 Quad-Core Processor, 3624.20 MHz, 15-01-02
cpu2:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,NODEID,TOPEXT,CPCTR,ITSC
cpu2: 64KB 64b/line 2-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
64b/line 16-way L2 cache, 8MB 64b/line 64-way L3 cache
cpu2: ITLB 48 4KB entries fully associative, 24 4MB entries fully
associative
cpu2: DTLB 32 4KB entries fully associative, 32 4MB entries fully
associative
cpu2: smt 0, core 1, package 0
cpu3 at mainbus0: apid 3 (application processor)
cpu3: AMD FX(tm)-4100 Quad-Core Processor, 3624.20 MHz, 15-01-02
cpu3:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,NODEID,TOPEXT,CPCTR,ITSC
cpu3: 64KB 64b/line 2-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
64b/line 16-way L2 cache, 8MB 64b/line 64-way L3 cache
cpu3: ITLB 48 4KB entries fully associative, 24 4MB entries fully
associative
cpu3: DTLB 32 4KB entries fully associative, 32 4MB entries fully
associative
cpu3: smt 1, core 1, package 0
ioapic0 at mainbus0: apid 8 pa 0xfec00000, version 21, 24 pins, remapped
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 5 (PEX0)
acpiprt2 at acpi0: bus -1 (PEX1)
acpiprt3 at acpi0: bus -1 (PEX2)
acpiprt4 at acpi0: bus -1 (PEX3)
acpiprt5 at acpi0: bus 4 (P2P_)
acpiprt6 at acpi0: bus 1 (PCE2)
acpiprt7 at acpi0: bus -1 (PCE3)
acpiprt8 at acpi0: bus 2 (PCE4)
acpiprt9 at acpi0: bus -1 (PCE5)
acpiprt10 at acpi0: bus -1 (PCE6)
acpiprt11 at acpi0: bus -1 (PCE7)
acpiprt12 at acpi0: bus 3 (PCE9)
acpiprt13 at acpi0: bus -1 (PCEA)
acpiprt14 at acpi0: bus -1 (PCEB)
acpiprt15 at acpi0: bus -1 (PCEC)
acpiprt16 at acpi0: bus -1 (PCED)
acpicpu0 at acpi0: C2(0@100 io@0x841), C1(@1 halt!), PSS
acpicpu1 at acpi0: C2(0@100 io@0x841), C1(@1 halt!), PSS
acpicpu2 at acpi0: C2(0@100 io@0x841), C1(@1 halt!), PSS
acpicpu3 at acpi0: C2(0@100 io@0x841), C1(@1 halt!), PSS
acpibtn0 at acpi0: PWRB
acpipci0 at acpi0 PCI0: _OSC failed
acpicmos0 at acpi0
"PNP0C14" at acpi0 not configured
cpu0: 3624 MHz: speeds: 3600 3300 2500 1700 1400 MHz
pci0 at mainbus0 bus 0
0:0:0: mem address conflict 0xe0000000/0x20000000
pchb0 at pci0 dev 0 function 0 vendor "ATI", unknown product 0x5a14 rev 0x02
ppb0 at pci0 dev 2 function 0 "ATI SR5690 PCIE" rev 0x00: msi
pci1 at ppb0 bus 1
radeondrm0 at pci1 dev 0 function 0 "ATI Radeon HD 8500" rev 0x87
drm0 at radeondrm0
radeondrm0: msi
azalia0 at pci1 dev 0 function 1 "ATI Radeon HD 7700 Audio" rev 0x00: msi
azalia0: no supported codecs
ppb1 at pci0 dev 4 function 0 "ATI SR5690 PCIE" rev 0x00: msi
pci2 at ppb1 bus 2
xhci0 at pci2 dev 0 function 0 "Etron EJ168 xHCI" rev 0x01: msi, xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Etron xHCI root hub" rev
3.00/1.00 addr 1
ppb2 at pci0 dev 9 function 0 "ATI SR5690 PCIE" rev 0x00: msi
pci3 at ppb2 bus 3
re0 at pci3 dev 0 function 0 "Realtek 8168" rev 0x06: RTL8168E/8111E-VL
(0x2c80), msi, address 90:2b:34:14:b4:db
rgephy0 at re0 phy 7: RTL8169S/8110S/8211 PHY, rev. 5
ahci0 at pci0 dev 17 function 0 "ATI SBx00 SATA" rev 0x40: apic 8 int
19, AHCI 1.2
ahci0: port 0: 6.0Gb/s
ahci0: port 1: 6.0Gb/s
ahci0: port 2: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, Samsung SSD 850, EMT0> SCSI3
0/direct fixed naa.5002538da0264cef
sd0: 238475MB, 512 bytes/sector, 488397168 sectors, thin
sd1 at scsibus1 targ 1 lun 0: <ATA, Samsung SSD 850, EMT0> SCSI3
0/direct fixed naa.5002538da0264cee
sd1: 238475MB, 512 bytes/sector, 488397168 sectors, thin
sd2 at scsibus1 targ 2 lun 0: <ATA, Samsung SSD 860, RVT0> SCSI3
0/direct fixed naa.5002538e40c6edee
sd2: 476940MB, 512 bytes/sector, 976773168 sectors, thin
ohci0 at pci0 dev 18 function 0 "ATI SB700 USB" rev 0x00: apic 8 int 18,
version 1.0, legacy support
ehci0 at pci0 dev 18 function 2 "ATI SB700 USB2" rev 0x00: apic 8 int 17
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "ATI EHCI root hub" rev
2.00/1.00 addr 1
ohci1 at pci0 dev 19 function 0 "ATI SB700 USB" rev 0x00: apic 8 int 18,
version 1.0, legacy support
ehci1 at pci0 dev 19 function 2 "ATI SB700 USB2" rev 0x00: apic 8 int 17
usb2 at ehci1: USB revision 2.0
uhub2 at usb2 configuration 1 interface 0 "ATI EHCI root hub" rev
2.00/1.00 addr 1
piixpm0 at pci0 dev 20 function 0 "ATI SBx00 SMBus" rev 0x42: polling
iic0 at piixpm0
spdmem0 at iic0 addr 0x50: 4GB DDR3 SDRAM PC3-10600
spdmem1 at iic0 addr 0x51: 4GB DDR3 SDRAM PC3-10600
spdmem2 at iic0 addr 0x52: 2GB DDR3 SDRAM PC3-10600
spdmem3 at iic0 addr 0x53: 2GB DDR3 SDRAM PC3-10600
azalia1 at pci0 dev 20 function 2 "ATI SBx00 HD Audio" rev 0x40: apic 8
int 16
azalia1: codecs: Realtek/0x0889
audio0 at azalia1
pcib0 at pci0 dev 20 function 3 "ATI SB700 ISA" rev 0x40
ppb3 at pci0 dev 20 function 4 "ATI SB600 PCI" rev 0x40
pci4 at ppb3 bus 4
skc0 at pci4 dev 7 function 0 "D-Link DGE-530T B1" rev 0x11, Yukon Lite
(0x9): apic 8 int 21
sk0 at skc0 port A: address 00:1b:11:17:40:e6
eephy0 at sk0 phy 0: 88E1011 Gigabit PHY, rev. 5
ohci2 at pci0 dev 20 function 5 "ATI SB700 USB" rev 0x00: apic 8 int 18,
version 1.0, legacy support
ppb4 at pci0 dev 21 function 0 "ATI SB800 PCIE" rev 0x00: msi
pci5 at ppb4 bus 5
ohci3 at pci0 dev 22 function 0 "ATI SB700 USB" rev 0x00: apic 8 int 18,
version 1.0, legacy support
ehci2 at pci0 dev 22 function 2 "ATI SB700 USB2" rev 0x00: apic 8 int 17
usb3 at ehci2: USB revision 2.0
uhub3 at usb3 configuration 1 interface 0 "ATI EHCI root hub" rev
2.00/1.00 addr 1
pchb1 at pci0 dev 24 function 0 "AMD AMD64 15/0xh Link Cfg" rev 0x00
pchb2 at pci0 dev 24 function 1 "AMD AMD64 15/0xh Address Map" rev 0x00
pchb3 at pci0 dev 24 function 2 "AMD AMD64 15/0xh DRAM Cfg" rev 0x00
km0 at pci0 dev 24 function 3 "AMD AMD64 15/0xh Misc Cfg" rev 0x00
pchb4 at pci0 dev 24 function 4 "AMD AMD64 15/0xh CPU Power" rev 0x00
pchb5 at pci0 dev 24 function 5 "AMD AMD64 15/0xh Host" rev 0x00
usb4 at ohci0: USB revision 1.0
uhub4 at usb4 configuration 1 interface 0 "ATI OHCI root hub" rev
1.00/1.00 addr 1
usb5 at ohci1: USB revision 1.0
uhub5 at usb5 configuration 1 interface 0 "ATI OHCI root hub" rev
1.00/1.00 addr 1
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
it0 at isa0 port 0x2e/2: IT8720F rev 8, EC port 0x228
usb6 at ohci2: USB revision 1.0
uhub6 at usb6 configuration 1 interface 0 "ATI OHCI root hub" rev
1.00/1.00 addr 1
usb7 at ohci3: USB revision 1.0
uhub7 at usb7 configuration 1 interface 0 "ATI OHCI root hub" rev
1.00/1.00 addr 1
uhidev0 at uhub4 port 1 configuration 1 interface 0 "Cooler Master
Technology Inc. MASTERKEYS PRO L with intelligent RGB" rev 1.10/21.04 addr 2
uhidev0: iclass 3/1
ukbd0 at uhidev0: 8 variable keys, 6 key codes
wskbd0 at ukbd0: console keyboard
uhidev1 at uhub4 port 1 configuration 1 interface 1 "Cooler Master
Technology Inc. MASTERKEYS PRO L with intelligent RGB" rev 1.10/21.04 addr 2
uhidev1: iclass 3/0
uhid0 at uhidev1: input=64, output=64, feature=0
uhidev2 at uhub4 port 1 configuration 1 interface 2 "Cooler Master
Technology Inc. MASTERKEYS PRO L with intelligent RGB" rev 1.10/21.04 addr 2
uhidev2: iclass 3/0, 4 report ids
uhid1 at uhidev2 reportid 1: input=1, output=0, feature=0
uhid2 at uhidev2 reportid 2: input=4, output=0, feature=0
ukbd1 at uhidev2 reportid 4: no usable key codes array
uhidev3 at uhub4 port 2 configuration 1 interface 0 "Logitech USB
Optical Mouse" rev 2.00/72.00 addr 3
uhidev3: iclass 3/1
ums0 at uhidev3: 3 buttons, Z dir
wsmouse0 at ums0 mux 0
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
softraid0: trying to bring up sd3 degraded
softraid0: sd3 was not shutdown properly
sd3 at scsibus3 targ 1 lun 0: <OPENBSD, SR RAID 1, 006> SCSI2 0/direct fixed
sd3: 238472MB, 512 bytes/sector, 488391473 sectors
softraid0: roaming device  -> sd1a
root on sd3a (409ffd737f4265d7.a) swap on sd3b dump on sd3b
WARNING: / was not properly unmounted
initializing kernel modesetting (OLAND 0x1002:0x6613 0x1043:0x048B).
drm:pid0:si_startup *ERROR* VCE init error (-60).
radeondrm0: 1920x1080, 32bpp
wsdisplay0 at radeondrm0 mux 1: console (std, vt100 emulation), using wskbd0
wsdisplay0: screen 1-5 added (std, vt100 emulation)
wsmouse0 detached
ums0 detached
uhidev3 detached
uhidev3 at uhub4 port 2 configuration 1 interface 0 "Logitech USB
Optical Mouse" rev 2.00/72.00 addr 3
uhidev3: iclass 3/1
ums0 at uhidev3: 3 buttons, Z dir
wsmouse0 at ums0 mux 0
acpi0: PM1 stuck (en 0x121 st 0x1), clearing