dnscrypt_proxy fails to start (core dump) after upgrade to tonight snapshot

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

dnscrypt_proxy fails to start (core dump) after upgrade to tonight snapshot

Chris Jones
Synopsis: dnscrypt_proxy fails to start (core dump) after upgrade to tonight snapshot
Category: Ports package
Environment:

System : OpenBSD 6.9
Details : OpenBSD 6.9-beta (GENERIC.MP) #394: Wed Mar 10 19:59:10 MST 2021
[hidden email] <mailto:[hidden email]> :/usr/src/sys/arch/amd64/compile/GENERIC.MP


    Architecture: OpenBSD.amd64
    Machine     : amd64


Description:

After upgrading to the snapshot this evening, all daemons came backup as expected except one — dnscrypt_proxy. When I tried to manually start the dnscrypt_proxy service ('rcctl start dnscrypt_proxy') I could see the following message in /var/log/messages:

Mar 10 21:39:07 minto-fw01 /bsd: [dnscrypt-proxy]62869/394062 pc=46b946 inside 2318ff000-23190c000: bogus syscall

How-To-Repeat:

This will repeat evertime I try to start dnscrypt_proxy.

Fix:

No workaround at this point.

dmesg:
OpenBSD 6.9-beta (GENERIC.MP) #394: Wed Mar 10 19:59:10 MST 2021
[hidden email] <mailto:[hidden email]> :/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 8519643136 (8124MB)
avail mem = 8246059008 (7864MB)
random: good seed from bootblocks
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.8 @ 0x7cd0b020 (14 entries)
bios0: vendor coreboot version "v4.12.0.3" date 10/28/2020
bios0: Protectli FW4B
acpi0 at bios0: ACPI 6.0
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP SSDT MCFG APIC
acpi0: wakeup devices XHCI(S3)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimcfg0 at acpi0
acpimcfg0: addr 0xe0000000, bus 0-255
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2240.42 MHz, 06-4c-04
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
cpu0: 1MB 64b/line 16-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
cpu0: apic clock running at 79MHz
cpu0: mwait min=64, max=64, C-substates=0.2.0.0.0.0.3.3, IBE
cpu1 at mainbus0: apid 2 (application processor)
cpu1: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2239.94 MHz, 06-4c-04
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
cpu1: 1MB 64b/line 16-way L2 cache
cpu1: smt 0, core 1, package 0
cpu2 at mainbus0: apid 4 (application processor)
cpu2: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2239.95 MHz, 06-4c-04
cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
cpu2: 1MB 64b/line 16-way L2 cache
cpu2: smt 0, core 2, package 0
cpu3 at mainbus0: apid 6 (application processor)
cpu3: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2239.95 MHz, 06-4c-04
cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
cpu3: 1MB 64b/line 16-way L2 cache
cpu3: smt 0, core 3, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 115 pins, remapped
acpiprt0 at acpi0: bus 0 (PCI0)
acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
"INT33BD" at acpi0 not configured
acpicmos0 at acpi0
chvgpio0 at acpi0 GPSW uid 1 addr 0xfed80000/0x8000 irq 49, 56 pins
chvgpio1 at acpi0 GPNC uid 2 addr 0xfed88000/0x8000 irq 48, 59 pins
chvgpio2 at acpi0 GPEC uid 3 addr 0xfed90000/0x8000 irq 50, 24 pins
chvgpio3 at acpi0 GPSE uid 4 addr 0xfed98000/0x8000 irq 91, 55 pins
"BOOT0000" at acpi0 not configured
acpicpu0 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51), C1(1000@1 mwait.1), PSS
acpicpu1 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51), C1(1000@1 mwait.1), PSS
acpicpu2 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51), C1(1000@1 mwait.1), PSS
acpicpu3 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51), C1(1000@1 mwait.1), PSS
cpu0: using VERW MDS workaround
cpu0: Enhanced SpeedStep 2240 MHz: speeds: 1601, 1600, 1520, 1440, 1360, 1280, 1200, 1120, 1040, 960, 880, 800, 720, 640, 560, 480 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Braswell Host" rev 0x35
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics" rev 0x35
drm0 at inteldrm0
inteldrm0: msi, CHERRYVIEW, gen 8
ahci0 at pci0 dev 19 function 0 "Intel Braswell AHCI" rev 0x35: msi, AHCI 1.3.1
ahci0: port 0: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, KINGSTON SUV500M, 0030> naa.50026b77836de374
sd0: 228936MB, 512 bytes/sector, 468862128 sectors, thin
xhci0 at pci0 dev 20 function 0 "Intel Braswell xHCI" rev 0x35: msi, xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel Braswell HD Audio" rev 0x35: msi
azalia0: codecs: Realtek ALC662, Intel/0x2883, using Realtek ALC662
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel Braswell PCIE" rev 0x35: msi
pci1 at ppb0 bus 1
em0 at pci1 dev 0 function 0 "Intel I210" rev 0x03: msi, address 00:e0:67:22:36:a4
ppb1 at pci0 dev 28 function 1 "Intel Braswell PCIE" rev 0x35: msi
pci2 at ppb1 bus 2
em1 at pci2 dev 0 function 0 "Intel I210" rev 0x03: msi, address 00:e0:67:22:36:a5
ppb2 at pci0 dev 28 function 2 "Intel Braswell PCIE" rev 0x35: msi
pci3 at ppb2 bus 3
em2 at pci3 dev 0 function 0 "Intel I210" rev 0x03: msi, address 00:e0:67:22:36:a6
ppb3 at pci0 dev 28 function 3 "Intel Braswell PCIE" rev 0x35: msi
pci4 at ppb3 bus 4
em3 at pci4 dev 0 function 0 "Intel I210" rev 0x03: msi, address 00:e0:67:22:36:a7
pcib0 at pci0 dev 31 function 0 "Intel Braswell PCU LPC" rev 0x35
ichiic0 at pci0 dev 31 function 3 "Intel Braswell SMBus" rev 0x35: apic 2 int 18
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
com0: console
vga0 at isa0 port 0x3b0/48 iomem 0xa0000/131072
wsdisplay at vga0 not configured
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: VMX/EPT (using slow L1TF mitigation)
umass0 at uhub0 port 1 configuration 1 interface 0 "SanDisk Cruzer Fit" rev 2.00/1.27 addr 2
umass0: using SCSI over Bulk-Only
scsibus2 at umass0: 2 targets, initiator 0
sd1 at scsibus2 targ 1 lun 0: <SanDisk, Cruzer Fit, 1.27> removable serial.07815571870804115450
sd1: 7633MB, 512 bytes/sector, 15633408 sectors
vscsi0 at root
scsibus3 at vscsi0: 256 targets
softraid0 at root
scsibus4 at softraid0: 256 targets
root on sd0a (993900eb51631b95.a) swap on sd0b dump on sd0b
inteldrm0: 1024x768, 32bpp
wsdisplay0 at inteldrm0 mux 1
wsdisplay0: screen 0-5 added (std, vt100 emulation)

usbdevs:
Controller /dev/usb0:
addr 01: 8086:0000 Intel, xHCI root hub
super speed, self powered, config 1, rev 1.00
driver: uhub0
addr 02: 0781:5571 SanDisk, Cruzer Fit
high speed, power 200 mA, config 1, rev 1.27, iSerial 4C530102870804115450
driver: umass0

Reply | Threaded
Open this post in threaded view
|

Re: dnscrypt_proxy fails to start (core dump) after upgrade to tonight snapshot

Stuart Henderson
Reinstall the package (pkg_delete and pkg_add again).

Same applies for anyone else with problems for software written in go,
package revisions have now been bumped so after the next snapshot is
available pkg_add -u will pick it up, but reinstall will fix it now.


On 2021/03/11 15:17, Chris Jones wrote:

> Synopsis: dnscrypt_proxy fails to start (core dump) after upgrade to tonight snapshot
> Category: Ports package
> Environment:
>
> System : OpenBSD 6.9
> Details : OpenBSD 6.9-beta (GENERIC.MP) #394: Wed Mar 10 19:59:10 MST 2021
> [hidden email] <mailto:[hidden email]> :/usr/src/sys/arch/amd64/compile/GENERIC.MP
>
>
>     Architecture: OpenBSD.amd64
>     Machine     : amd64
>
>
> Description:
>
> After upgrading to the snapshot this evening, all daemons came backup as expected except one — dnscrypt_proxy. When I tried to manually start the dnscrypt_proxy service ('rcctl start dnscrypt_proxy') I could see the following message in /var/log/messages:
>
> Mar 10 21:39:07 minto-fw01 /bsd: [dnscrypt-proxy]62869/394062 pc=46b946 inside 2318ff000-23190c000: bogus syscall
>
> How-To-Repeat:
>
> This will repeat evertime I try to start dnscrypt_proxy.
>
> Fix:
>
> No workaround at this point.
>
> dmesg:
> OpenBSD 6.9-beta (GENERIC.MP) #394: Wed Mar 10 19:59:10 MST 2021
> [hidden email] <mailto:[hidden email]> :/usr/src/sys/arch/amd64/compile/GENERIC.MP
> real mem = 8519643136 (8124MB)
> avail mem = 8246059008 (7864MB)
> random: good seed from bootblocks
> mpath0 at root
> scsibus0 at mpath0: 256 targets
> mainbus0 at root
> bios0 at mainbus0: SMBIOS rev. 2.8 @ 0x7cd0b020 (14 entries)
> bios0: vendor coreboot version "v4.12.0.3" date 10/28/2020
> bios0: Protectli FW4B
> acpi0 at bios0: ACPI 6.0
> acpi0: sleep states S0 S3 S4 S5
> acpi0: tables DSDT FACP SSDT MCFG APIC
> acpi0: wakeup devices XHCI(S3)
> acpitimer0 at acpi0: 3579545 Hz, 24 bits
> acpimcfg0 at acpi0
> acpimcfg0: addr 0xe0000000, bus 0-255
> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
> cpu0 at mainbus0: apid 0 (boot processor)
> cpu0: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2240.42 MHz, 06-4c-04
> cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
> cpu0: 1MB 64b/line 16-way L2 cache
> cpu0: smt 0, core 0, package 0
> mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
> cpu0: apic clock running at 79MHz
> cpu0: mwait min=64, max=64, C-substates=0.2.0.0.0.0.3.3, IBE
> cpu1 at mainbus0: apid 2 (application processor)
> cpu1: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2239.94 MHz, 06-4c-04
> cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
> cpu1: 1MB 64b/line 16-way L2 cache
> cpu1: smt 0, core 1, package 0
> cpu2 at mainbus0: apid 4 (application processor)
> cpu2: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2239.95 MHz, 06-4c-04
> cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
> cpu2: 1MB 64b/line 16-way L2 cache
> cpu2: smt 0, core 2, package 0
> cpu3 at mainbus0: apid 6 (application processor)
> cpu3: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2239.95 MHz, 06-4c-04
> cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
> cpu3: 1MB 64b/line 16-way L2 cache
> cpu3: smt 0, core 3, package 0
> ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 115 pins, remapped
> acpiprt0 at acpi0: bus 0 (PCI0)
> acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
> "INT33BD" at acpi0 not configured
> acpicmos0 at acpi0
> chvgpio0 at acpi0 GPSW uid 1 addr 0xfed80000/0x8000 irq 49, 56 pins
> chvgpio1 at acpi0 GPNC uid 2 addr 0xfed88000/0x8000 irq 48, 59 pins
> chvgpio2 at acpi0 GPEC uid 3 addr 0xfed90000/0x8000 irq 50, 24 pins
> chvgpio3 at acpi0 GPSE uid 4 addr 0xfed98000/0x8000 irq 91, 55 pins
> "BOOT0000" at acpi0 not configured
> acpicpu0 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51), C1(1000@1 mwait.1), PSS
> acpicpu1 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51), C1(1000@1 mwait.1), PSS
> acpicpu2 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51), C1(1000@1 mwait.1), PSS
> acpicpu3 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51), C1(1000@1 mwait.1), PSS
> cpu0: using VERW MDS workaround
> cpu0: Enhanced SpeedStep 2240 MHz: speeds: 1601, 1600, 1520, 1440, 1360, 1280, 1200, 1120, 1040, 960, 880, 800, 720, 640, 560, 480 MHz
> pci0 at mainbus0 bus 0
> pchb0 at pci0 dev 0 function 0 "Intel Braswell Host" rev 0x35
> inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics" rev 0x35
> drm0 at inteldrm0
> inteldrm0: msi, CHERRYVIEW, gen 8
> ahci0 at pci0 dev 19 function 0 "Intel Braswell AHCI" rev 0x35: msi, AHCI 1.3.1
> ahci0: port 0: 6.0Gb/s
> scsibus1 at ahci0: 32 targets
> sd0 at scsibus1 targ 0 lun 0: <ATA, KINGSTON SUV500M, 0030> naa.50026b77836de374
> sd0: 228936MB, 512 bytes/sector, 468862128 sectors, thin
> xhci0 at pci0 dev 20 function 0 "Intel Braswell xHCI" rev 0x35: msi, xHCI 1.0
> usb0 at xhci0: USB revision 3.0
> uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
> azalia0 at pci0 dev 27 function 0 "Intel Braswell HD Audio" rev 0x35: msi
> azalia0: codecs: Realtek ALC662, Intel/0x2883, using Realtek ALC662
> audio0 at azalia0
> ppb0 at pci0 dev 28 function 0 "Intel Braswell PCIE" rev 0x35: msi
> pci1 at ppb0 bus 1
> em0 at pci1 dev 0 function 0 "Intel I210" rev 0x03: msi, address 00:e0:67:22:36:a4
> ppb1 at pci0 dev 28 function 1 "Intel Braswell PCIE" rev 0x35: msi
> pci2 at ppb1 bus 2
> em1 at pci2 dev 0 function 0 "Intel I210" rev 0x03: msi, address 00:e0:67:22:36:a5
> ppb2 at pci0 dev 28 function 2 "Intel Braswell PCIE" rev 0x35: msi
> pci3 at ppb2 bus 3
> em2 at pci3 dev 0 function 0 "Intel I210" rev 0x03: msi, address 00:e0:67:22:36:a6
> ppb3 at pci0 dev 28 function 3 "Intel Braswell PCIE" rev 0x35: msi
> pci4 at ppb3 bus 4
> em3 at pci4 dev 0 function 0 "Intel I210" rev 0x03: msi, address 00:e0:67:22:36:a7
> pcib0 at pci0 dev 31 function 0 "Intel Braswell PCU LPC" rev 0x35
> ichiic0 at pci0 dev 31 function 3 "Intel Braswell SMBus" rev 0x35: apic 2 int 18
> iic0 at ichiic0
> spdmem0 at iic0 addr 0x50: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
> isa0 at pcib0
> isadma0 at isa0
> com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
> com0: console
> vga0 at isa0 port 0x3b0/48 iomem 0xa0000/131072
> wsdisplay at vga0 not configured
> pcppi0 at isa0 port 0x61
> spkr0 at pcppi0
> vmm0 at mainbus0: VMX/EPT (using slow L1TF mitigation)
> umass0 at uhub0 port 1 configuration 1 interface 0 "SanDisk Cruzer Fit" rev 2.00/1.27 addr 2
> umass0: using SCSI over Bulk-Only
> scsibus2 at umass0: 2 targets, initiator 0
> sd1 at scsibus2 targ 1 lun 0: <SanDisk, Cruzer Fit, 1.27> removable serial.07815571870804115450
> sd1: 7633MB, 512 bytes/sector, 15633408 sectors
> vscsi0 at root
> scsibus3 at vscsi0: 256 targets
> softraid0 at root
> scsibus4 at softraid0: 256 targets
> root on sd0a (993900eb51631b95.a) swap on sd0b dump on sd0b
> inteldrm0: 1024x768, 32bpp
> wsdisplay0 at inteldrm0 mux 1
> wsdisplay0: screen 0-5 added (std, vt100 emulation)
>
> usbdevs:
> Controller /dev/usb0:
> addr 01: 8086:0000 Intel, xHCI root hub
> super speed, self powered, config 1, rev 1.00
> driver: uhub0
> addr 02: 0781:5571 SanDisk, Cruzer Fit
> high speed, power 200 mA, config 1, rev 1.27, iSerial 4C530102870804115450
> driver: umass0
>

Reply | Threaded
Open this post in threaded view
|

Re: dnscrypt_proxy fails to start (core dump) after upgrade to tonight snapshot

Chris Jones
Thanks Stuart,

That worked. I appreciate your help. Noted for next time.

Cheers,
-Chris

On 11 Mar 2021, at 7:55, Stuart Henderson wrote:

> Reinstall the package (pkg_delete and pkg_add again).
>
> Same applies for anyone else with problems for software written in go,
> package revisions have now been bumped so after the next snapshot is
> available pkg_add -u will pick it up, but reinstall will fix it now.
>
>
> On 2021/03/11 15:17, Chris Jones wrote:
>> Synopsis: dnscrypt_proxy fails to start (core dump) after upgrade to
>> tonight snapshot
>> Category: Ports package
>> Environment:
>>
>> System : OpenBSD 6.9
>> Details : OpenBSD 6.9-beta (GENERIC.MP) #394: Wed Mar 10 19:59:10 MST
>> 2021
>> [hidden email] <mailto:[hidden email]>
>> :/usr/src/sys/arch/amd64/compile/GENERIC.MP
>>
>>
>>     Architecture: OpenBSD.amd64
>>     Machine     : amd64
>>
>>
>> Description:
>>
>> After upgrading to the snapshot this evening, all daemons came backup
>> as expected except one — dnscrypt_proxy. When I tried to manually
>> start the dnscrypt_proxy service ('rcctl start dnscrypt_proxy') I
>> could see the following message in /var/log/messages:
>>
>> Mar 10 21:39:07 minto-fw01 /bsd: [dnscrypt-proxy]62869/394062
>> pc=46b946 inside 2318ff000-23190c000: bogus syscall
>>
>> How-To-Repeat:
>>
>> This will repeat evertime I try to start dnscrypt_proxy.
>>
>> Fix:
>>
>> No workaround at this point.
>>
>> dmesg:
>> OpenBSD 6.9-beta (GENERIC.MP) #394: Wed Mar 10 19:59:10 MST 2021
>> [hidden email] <mailto:[hidden email]>
>> :/usr/src/sys/arch/amd64/compile/GENERIC.MP
>> real mem = 8519643136 (8124MB)
>> avail mem = 8246059008 (7864MB)
>> random: good seed from bootblocks
>> mpath0 at root
>> scsibus0 at mpath0: 256 targets
>> mainbus0 at root
>> bios0 at mainbus0: SMBIOS rev. 2.8 @ 0x7cd0b020 (14 entries)
>> bios0: vendor coreboot version "v4.12.0.3" date 10/28/2020
>> bios0: Protectli FW4B
>> acpi0 at bios0: ACPI 6.0
>> acpi0: sleep states S0 S3 S4 S5
>> acpi0: tables DSDT FACP SSDT MCFG APIC
>> acpi0: wakeup devices XHCI(S3)
>> acpitimer0 at acpi0: 3579545 Hz, 24 bits
>> acpimcfg0 at acpi0
>> acpimcfg0: addr 0xe0000000, bus 0-255
>> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
>> cpu0 at mainbus0: apid 0 (boot processor)
>> cpu0: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2240.42 MHz, 06-4c-04
>> cpu0:
>> FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
>> cpu0: 1MB 64b/line 16-way L2 cache
>> cpu0: smt 0, core 0, package 0
>> mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
>> cpu0: apic clock running at 79MHz
>> cpu0: mwait min=64, max=64, C-substates=0.2.0.0.0.0.3.3, IBE
>> cpu1 at mainbus0: apid 2 (application processor)
>> cpu1: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2239.94 MHz, 06-4c-04
>> cpu1:
>> FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
>> cpu1: 1MB 64b/line 16-way L2 cache
>> cpu1: smt 0, core 1, package 0
>> cpu2 at mainbus0: apid 4 (application processor)
>> cpu2: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2239.95 MHz, 06-4c-04
>> cpu2:
>> FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
>> cpu2: 1MB 64b/line 16-way L2 cache
>> cpu2: smt 0, core 2, package 0
>> cpu3 at mainbus0: apid 6 (application processor)
>> cpu3: Intel(R) Celeron(R) CPU J3160 @ 1.60GHz, 2239.95 MHz, 06-4c-04
>> cpu3:
>> FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,DEADLINE,AES,RDRAND,NXE,RDTSCP,LONG,LAHF,3DNOWP,PERF,ITSC,TSC_ADJUST,SMEP,ERMS,MD_CLEAR,IBRS,IBPB,STIBP,SENSOR,ARAT,MELTDOWN
>> cpu3: 1MB 64b/line 16-way L2 cache
>> cpu3: smt 0, core 3, package 0
>> ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 115 pins,
>> remapped
>> acpiprt0 at acpi0: bus 0 (PCI0)
>> acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
>> "INT33BD" at acpi0 not configured
>> acpicmos0 at acpi0
>> chvgpio0 at acpi0 GPSW uid 1 addr 0xfed80000/0x8000 irq 49, 56 pins
>> chvgpio1 at acpi0 GPNC uid 2 addr 0xfed88000/0x8000 irq 48, 59 pins
>> chvgpio2 at acpi0 GPEC uid 3 addr 0xfed90000/0x8000 irq 50, 24 pins
>> chvgpio3 at acpi0 GPSE uid 4 addr 0xfed98000/0x8000 irq 91, 55 pins
>> "BOOT0000" at acpi0 not configured
>> acpicpu0 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51),
>> C1(1000@1 mwait.1), PSS
>> acpicpu1 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51),
>> C1(1000@1 mwait.1), PSS
>> acpicpu2 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51),
>> C1(1000@1 mwait.1), PSS
>> acpicpu3 at acpi0: C3(1@1500 mwait.1@0x52), C2(10@500 mwait.1@0x51),
>> C1(1000@1 mwait.1), PSS
>> cpu0: using VERW MDS workaround
>> cpu0: Enhanced SpeedStep 2240 MHz: speeds: 1601, 1600, 1520, 1440,
>> 1360, 1280, 1200, 1120, 1040, 960, 880, 800, 720, 640, 560, 480 MHz
>> pci0 at mainbus0 bus 0
>> pchb0 at pci0 dev 0 function 0 "Intel Braswell Host" rev 0x35
>> inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics" rev 0x35
>> drm0 at inteldrm0
>> inteldrm0: msi, CHERRYVIEW, gen 8
>> ahci0 at pci0 dev 19 function 0 "Intel Braswell AHCI" rev 0x35: msi,
>> AHCI 1.3.1
>> ahci0: port 0: 6.0Gb/s
>> scsibus1 at ahci0: 32 targets
>> sd0 at scsibus1 targ 0 lun 0: <ATA, KINGSTON SUV500M, 0030>
>> naa.50026b77836de374
>> sd0: 228936MB, 512 bytes/sector, 468862128 sectors, thin
>> xhci0 at pci0 dev 20 function 0 "Intel Braswell xHCI" rev 0x35: msi,
>> xHCI 1.0
>> usb0 at xhci0: USB revision 3.0
>> uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev
>> 3.00/1.00 addr 1
>> azalia0 at pci0 dev 27 function 0 "Intel Braswell HD Audio" rev 0x35:
>> msi
>> azalia0: codecs: Realtek ALC662, Intel/0x2883, using Realtek ALC662
>> audio0 at azalia0
>> ppb0 at pci0 dev 28 function 0 "Intel Braswell PCIE" rev 0x35: msi
>> pci1 at ppb0 bus 1
>> em0 at pci1 dev 0 function 0 "Intel I210" rev 0x03: msi, address
>> 00:e0:67:22:36:a4
>> ppb1 at pci0 dev 28 function 1 "Intel Braswell PCIE" rev 0x35: msi
>> pci2 at ppb1 bus 2
>> em1 at pci2 dev 0 function 0 "Intel I210" rev 0x03: msi, address
>> 00:e0:67:22:36:a5
>> ppb2 at pci0 dev 28 function 2 "Intel Braswell PCIE" rev 0x35: msi
>> pci3 at ppb2 bus 3
>> em2 at pci3 dev 0 function 0 "Intel I210" rev 0x03: msi, address
>> 00:e0:67:22:36:a6
>> ppb3 at pci0 dev 28 function 3 "Intel Braswell PCIE" rev 0x35: msi
>> pci4 at ppb3 bus 4
>> em3 at pci4 dev 0 function 0 "Intel I210" rev 0x03: msi, address
>> 00:e0:67:22:36:a7
>> pcib0 at pci0 dev 31 function 0 "Intel Braswell PCU LPC" rev 0x35
>> ichiic0 at pci0 dev 31 function 3 "Intel Braswell SMBus" rev 0x35:
>> apic 2 int 18
>> iic0 at ichiic0
>> spdmem0 at iic0 addr 0x50: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
>> isa0 at pcib0
>> isadma0 at isa0
>> com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
>> com0: console
>> vga0 at isa0 port 0x3b0/48 iomem 0xa0000/131072
>> wsdisplay at vga0 not configured
>> pcppi0 at isa0 port 0x61
>> spkr0 at pcppi0
>> vmm0 at mainbus0: VMX/EPT (using slow L1TF mitigation)
>> umass0 at uhub0 port 1 configuration 1 interface 0 "SanDisk Cruzer
>> Fit" rev 2.00/1.27 addr 2
>> umass0: using SCSI over Bulk-Only
>> scsibus2 at umass0: 2 targets, initiator 0
>> sd1 at scsibus2 targ 1 lun 0: <SanDisk, Cruzer Fit, 1.27> removable
>> serial.07815571870804115450
>> sd1: 7633MB, 512 bytes/sector, 15633408 sectors
>> vscsi0 at root
>> scsibus3 at vscsi0: 256 targets
>> softraid0 at root
>> scsibus4 at softraid0: 256 targets
>> root on sd0a (993900eb51631b95.a) swap on sd0b dump on sd0b
>> inteldrm0: 1024x768, 32bpp
>> wsdisplay0 at inteldrm0 mux 1
>> wsdisplay0: screen 0-5 added (std, vt100 emulation)
>>
>> usbdevs:
>> Controller /dev/usb0:
>> addr 01: 8086:0000 Intel, xHCI root hub
>> super speed, self powered, config 1, rev 1.00
>> driver: uhub0
>> addr 02: 0781:5571 SanDisk, Cruzer Fit
>> high speed, power 200 mA, config 1, rev 1.27, iSerial
>> 4C530102870804115450
>> driver: umass0
>>