devel/cargo: remove gcc4 requirement

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

devel/cargo: remove gcc4 requirement

Sebastien Marie-3
Hi,

Now that rustc is able to deal alone with libgcc.a, makes cargo to use
standard compiler as linker.

I didn't bump REVISION as there are no differences in package.

Thanks.
--
Sebastien Marie


Index: Makefile
===================================================================
RCS file: /cvs/ports/devel/cargo/Makefile,v
retrieving revision 1.12
diff -u -p -r1.12 Makefile
--- Makefile 5 May 2017 11:42:27 -0000 1.12
+++ Makefile 19 May 2017 08:10:52 -0000
@@ -142,9 +142,6 @@ SEPARATE_BUILD = Yes
 MODULES = devel/cargo \
  lang/python
 
-MODULES += gcc4
-MODGCC4_ARCHS = * # patches required in rustc for using base clang
-
 # only deal with MODCARGO_CRATES
 MODCARGO_BUILDDEP = No
 MODCARGO_BUILD = No