compaq array controller 4250ES on 3.9

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

compaq array controller 4250ES on 3.9

Czesław Liebert
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

my h/w is:
hp/comapq proliant 8000:
- - - 8x Xeon 550MHz
- - - 8GB ram
- - - compaq array controller 4250ES
- - - 1x intel 82558b lan
- - - 1x intel 82559 lan
- - - 8x 18GB scsi u160

according to harware support list for i386 found on BSD site, all of
that h/w is supported in version 3.9. it should, but it does not. i
tried 3.8, 3.9 and 4.0b - couldn't get it to run. i used boot floppy B -
according to the manual this one contains proper stuff.

at kernel start the hd0 device is shown properly, but afterwards kernel
does not see the 4250es array controller nor intel lan cards.

any ideas on how to run openBSD on this machine? i hope it can be done
somehow, as i really do not want to switch to another OS, been using
openBSD for years now...

i get the same result on every kernel i used:

OpenBSD 3.9 (RAMDISK_CD) #1025: Thu Mar  2 02:43:29 MST 2006
    [hidden email]:/usr/src/sys/arch/i386/compile/RAMDISK_CD
cpu0: Intel Pentium III Xeon ("GenuineIntel" 686-class, 2048KB L2 cache)
550 MHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 4026081280 (3931720K)
avail mem = 3669291008 (3583292K)
using 4278 buffers containing 201408512 bytes (196688K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 12/31/99, BIOS32 rev. 0 @ 0xf0000
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x2000
pcibios0: PCI BIOS has 14 Interrupt Routing table entries
pcibios0: PCI Interrupt Router at 000:15:0 ("ServerWorks OSB4" rev 0x00)
pcibios0: PCI bus #0 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x4000 0xcc000/0x800
0xe8000/0x6000! 0xee000/0x2000!
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
ahc0 at pci0 dev 4 function 0 "Adaptec AHA-2940U2 U2" rev 0x00: irq 5
scsibus0 at ahc0: 16 targets
ahc0: target 6 using 8bit transfers
ahc0: target 6 using asynchronous transfers
st0 at scsibus0 targ 6 lun 0: <QUANTUM, DLT7000, 2255> SCSI2
1/sequential removable
st0: drive empty or not ready
"Compaq PCI Hotplug" rev 0x11 at pci0 dev 11 function 0 not configured
"Compaq Netelligent ASMC" rev 0x00 at pci0 dev 12 function 0 not configured
vga1 at pci0 dev 13 function 0 "ATI Mach64 GV" rev 0x7a
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
pcib0 at pci0 dev 15 function 0 "ServerWorks OSB4" rev 0x4d
pciide0 at pci0 dev 15 function 1 vendor "ServerWorks", unknown product
0x0210 rev 0x4a: DMA (unsupported), channel 0 configured to
compatibility, channel 1 configured to compatibility
atapiscsi0 at pciide0 channel 0 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <COMPAQ, CD-224E, 9.0B> SCSI0 5/cdrom
removable
pciide0: channel 1 ignored (not responding; disabled or no drives?)
vendor "Corrollary", unknown product 0x1117 (class memory subclass RAM,
rev 0x05) at pci0 dev 20 function 0 not configured
vendor "Corrollary", unknown product 0x1117 (class memory subclass RAM,
rev 0x05) at pci0 dev 20 function 1 not configured
pchb0 at pci0 dev 25 function 0 vendor "Compaq", unknown product 0x6010
rev 0x01
pchb1 at pci0 dev 26 function 0 vendor "Compaq", unknown product 0x6010
rev 0x01
pchb2 at pci0 dev 27 function 0 vendor "Compaq", unknown product 0x6010
rev 0x01
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask ffe5 netmask ffe5 ttymask ffe7
rd0: fixed, 3800 blocks
root on rd0a
rootdev=0x1100 rrootdev=0x2f00 rawdev=0x2f02
fd0: timeout (st0 20<seek_cmplt> cyl 0)
fd0a: soft error reading fsbn 0

waping PCI slots didn't help (i have only one more
such slot, as the scsi controller uses the "pci 64bit scsi extended
slot" with only two possibilities)

I have also tried the cd boot - wasn't much of a help. The floppy is ok,
i needed to write dmesg to floppy and mounted the drive before inserting
a blank diskette. and yes, by saying 4.0b i really meant the lates
snapshot.

thanks in advance for help replies
iD8DBQFFBXZT3VOnD+tUq3sRAsn6AJwOI23Q+YQmk+E5425qkgb3N+h48QCfSWO4
VRWe2+DOxJsiMFrLJzRh2/E=
=2CIv
-----END PGP SIGNATURE-----

Reply | Threaded
Open this post in threaded view
|

Re: compaq array controller 4250ES on 3.9

Steven Shockley
Czes3aw Liebert wrote:

 > pchb0 at pci0 dev 25 function 0 vendor "Compaq", unknown product
 > 0x6010 rev 0x01
 > pchb1 at pci0 dev 26 function 0 vendor "Compaq", unknown product
 > 0x6010 rev 0x01
 > pchb2 at pci0 dev 27 function 0 vendor "Compaq", unknown product
 > 0x6010 rev 0x01

This should be your RAID controller.  I think the 4250ES is a cac
controller, you could try hacking pcidevs and cac_pci.c to add it and
see if it works.

Reply | Threaded
Open this post in threaded view
|

Re: compaq array controller 4250ES on 3.9

Steven Shockley
Steve Shockley wrote:
> This should be your RAID controller.

Ignore me, this is a PCI bridge.  Follow the better instructions on misc@.

Reply | Threaded
Open this post in threaded view
|

Re: compaq array controller 4250ES on 3.9

Brad Smith-14
In reply to this post by Steven Shockley
On Mon, Sep 11, 2006 at 12:20:04PM -0400, Steve Shockley wrote:

> Czes3aw Liebert wrote:
>
> > pchb0 at pci0 dev 25 function 0 vendor "Compaq", unknown product
> > 0x6010 rev 0x01
> > pchb1 at pci0 dev 26 function 0 vendor "Compaq", unknown product
> > 0x6010 rev 0x01
> > pchb2 at pci0 dev 27 function 0 vendor "Compaq", unknown product
> > 0x6010 rev 0x01
>
> This should be your RAID controller.  I think the 4250ES is a cac
> controller, you could try hacking pcidevs and cac_pci.c to add it and
> see if it works.

The devices listed are clearly attached as PCI host bridges and that is
what they should be. The real problem is that pchb is not attaching the
one or more PCI busses sitting behind these host bridges. Once the
appropriate PCI busses have been attached properly then the additional
devices in the system will show up. The Smart ARRAY controller mentioned
is already supported by the cac(4) driver, there is no need to add any
additional PCI ids.

Reply | Threaded
Open this post in threaded view
|

Re: compaq array controller 4250ES on 3.9

Czesław Liebert
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Brad napisaE(a):
> The devices listed are clearly attached as PCI host bridges and that is
> what they should be. The real problem is that pchb is not attaching the
> one or more PCI busses sitting behind these host bridges. Once the
> appropriate PCI busses have been attached properly then the additional
> devices in the system will show up. The Smart ARRAY controller mentioned
> is already supported by the cac(4) driver, there is no need to add any
> additional PCI ids.

After playing a while with swapping pci busses as for the intel lan
cards i finally came to a point where both those cards and the DEC are
recognized properly by kernel. now the dmesg have changed:

OpenBSD 3.9 (RAMDISK_CD) #1025: Thu Mar  2 02:43:29 MST 2006
    [hidden email]:/usr/src/sys/arch/i386/compile/RAMDISK_CD
cpu0: Intel Pentium III Xeon ("GenuineIntel" 686-class, 2048KB L2 cache)
550 MHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 4026081280 (3931720K)
avail mem = 3669291008 (3583292K)
using 4278 buffers containing 201408512 bytes (196688K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 12/31/99, BIOS32 rev. 0 @ 0xf0000
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x2000
pcibios0: PCI BIOS has 14 Interrupt Routing table entries
pcibios0: PCI Interrupt Router at 000:15:0 ("ServerWorks OSB4" rev 0x00)
pcibios0: PCI bus #2 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x4000 0xcc000/0x800
0xe8000/0x6000! 0xee000/0x2000!
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
ppb0 at pci0 dev 2 function 0 "DEC 21154 PCI-PCI" rev 0x02
pci1 at ppb0 bus 1
fxp0 at pci1 dev 4 function 0 "Intel 8255x" rev 0x05, i82558: irq 11,
address 00:50:8b:6f:c5:fe
inphy0 at fxp0 phy 1: i82555 10/100 PHY, rev. 0
fxp1 at pci1 dev 5 function 0 "Intel 8255x" rev 0x05, i82558: irq 11,
address 00:50:8b:6f:c5:ff
inphy1 at fxp1 phy 1: i82555 10/100 PHY, rev. 0
ppb1 at pci0 dev 3 function 0 "DEC 21154 PCI-PCI" rev 0x05
pci2 at ppb1 bus 2
fxp2 at pci2 dev 4 function 0 "Intel 8255x" rev 0x08, i82559: irq 15,
address 00:02:a5:ad:e6:48
inphy2 at fxp2 phy 1: i82555 10/100 PHY, rev. 4
fxp3 at pci2 dev 5 function 0 "Intel 8255x" rev 0x08, i82559: irq 15,
address 00:02:a5:ad:e6:49
inphy3 at fxp3 phy 1: i82555 10/100 PHY, rev. 4
ahc0 at pci0 dev 4 function 0 "Adaptec AHA-2940U2 U2" rev 0x00: irq 5
scsibus0 at ahc0: 16 targets
ahc0: target 6 using 8bit transfers
ahc0: target 6 using asynchronous transfers
st0 at scsibus0 targ 6 lun 0: <QUANTUM, DLT7000, 2255> SCSI2
1/sequential removable
st0: drive empty or not ready
"Compaq PCI Hotplug" rev 0x11 at pci0 dev 11 function 0 not configured
"Compaq Netelligent ASMC" rev 0x00 at pci0 dev 12 function 0 not configured
vga1 at pci0 dev 13 function 0 "ATI Mach64 GV" rev 0x7a
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
pcib0 at pci0 dev 15 function 0 "ServerWorks OSB4" rev 0x4d
pciide0 at pci0 dev 15 function 1 vendor "ServerWorks", unknown product
0x0210 rev 0x4a: DMA (unsupported), channel 0 configured to
compatibility, channel 1 configured to compatibility
atapiscsi0 at pciide0 channel 0 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <COMPAQ, CD-224E, 9.0B> SCSI0 5/cdrom
removable
pciide0: no compatibility interrupt for use by channel 1
vendor "Corrollary", unknown product 0x1117 (class memory subclass RAM,
rev 0x05) at pci0 dev 20 function 0 not configured
vendor "Corrollary", unknown product 0x1117 (class memory subclass RAM,
rev 0x05) at pci0 dev 20 function 1 not configured
pchb0 at pci0 dev 25 function 0 vendor "Compaq", unknown product 0x6010
rev 0x01
pchb1 at pci0 dev 26 function 0 vendor "Compaq", unknown product 0x6010
rev 0x01
pchb2 at pci0 dev 27 function 0 vendor "Compaq", unknown product 0x6010
rev 0x01
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask 77e5 netmask ffe5 ttymask ffe7
rd0: fixed, 3800 blocks
root on rd0a
rootdev=0x1100 rrootdev=0x2f00 rawdev=0x2f02

czeslaw
iD8DBQFFBmHF3VOnD+tUq3sRAusvAJ9BuMmj21/NIxMhrW9ox96FRlgeqwCdHCE1
aMA1XC1ACVq5/YQhZtbjPcU=
=ImmK
-----END PGP SIGNATURE-----