broken pkg, netatalk-3.1.7p0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

broken pkg, netatalk-3.1.7p0

stolendata.net
# pkg_add netatalk
quirks-2.114 signed on 2015-08-09T15:30:39Z
Ambiguous: choose package for netatalk
a       0: <None>
        1: netatalk-2.2.5p6
        2: netatalk-2.2.5p6-avahi
        3: netatalk-3.1.7p0
Your choice: 3
Can't install dbus-1.8.20v0 because of libraries
|library ICE.10.0 not found
| not found anywhere
|library SM.9.0 not found
| not found anywhere
|library X11.16.1 not found
| not found anywhere
|library xcb.3.1 not found
| not found anywhere
Can't install dbus-1.8.20v0 because of libraries
Can't install dbus-daemon-launch-helper-1.8.20: can't resolve dbus-1.8.20v0
Can't install avahi-0.6.31p19: can't resolve
dbus-daemon-launch-helper-1.8.20,dbus-1.8.20v0
Can't install dbus-glib-0.104p0v0: can't resolve dbus-1.8.20v0
Can't install dbus-glib-0.104p0v0: can't resolve dbus-1.8.20v0
Can't install py-dbus-1.2.0p3: can't resolve dbus-glib-0.104p0v0
Can't install netatalk-3.1.7p0: can't resolve
dbus-glib-0.104p0v0,py-dbus-1.2.0p3,avahi-0.6.31p19

This is on OpenBSD 5.8/i386.
Reply | Threaded
Open this post in threaded view
|

Re: broken pkg, netatalk-3.1.7p0

Antoine Jacoutot-7
On Sun, Oct 25, 2015 at 02:44:46AM +0200, stolendata.net wrote:

> # pkg_add netatalk
> quirks-2.114 signed on 2015-08-09T15:30:39Z
> Ambiguous: choose package for netatalk
> a       0: <None>
>         1: netatalk-2.2.5p6
>         2: netatalk-2.2.5p6-avahi
>         3: netatalk-3.1.7p0
> Your choice: 3
> Can't install dbus-1.8.20v0 because of libraries
> |library ICE.10.0 not found
> | not found anywhere
> |library SM.9.0 not found
> | not found anywhere
> |library X11.16.1 not found
> | not found anywhere
> |library xcb.3.1 not found
> | not found anywhere

You need to install the X sets.
http://www.openbsd.org/faq/faq4.html#AddFileSet

> Can't install dbus-1.8.20v0 because of libraries
> Can't install dbus-daemon-launch-helper-1.8.20: can't resolve dbus-1.8.20v0
> Can't install avahi-0.6.31p19: can't resolve
> dbus-daemon-launch-helper-1.8.20,dbus-1.8.20v0
> Can't install dbus-glib-0.104p0v0: can't resolve dbus-1.8.20v0
> Can't install dbus-glib-0.104p0v0: can't resolve dbus-1.8.20v0
> Can't install py-dbus-1.2.0p3: can't resolve dbus-glib-0.104p0v0
> Can't install netatalk-3.1.7p0: can't resolve
> dbus-glib-0.104p0v0,py-dbus-1.2.0p3,avahi-0.6.31p19
>
> This is on OpenBSD 5.8/i386.

--
Antoine