Quantcast

bioctl showing "0% done" on apparently healthy softraid

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

bioctl showing "0% done" on apparently healthy softraid

Joe Gidi
I have a file server running -current on amd64. It has a three-drive
RAID1
softraid array. Up until yesterday, I'd been running a snap from
February 18
and everything was behaving as expected.

After updating to a fresh snapshot
yesterday, I noticed that the
output of bioctl is different and a bit odd. It
now shows "0% done",
but the array and all three member drives are showing as
online:

$ sudo bioctl sd4       
Volume     
Status               Size Device 
softraid0 0 Online     
4000786726912 sd4     RAID1 0% done
          0 Online     
4000786726912 0:0.0   noencl
<sd1a>
          1 Online     
4000786726912 0:1.0   noencl
<sd2a>
          2 Online     
4000786726912 0:2.0   noencl
<sd3a>

SMART status on all member drives is
healthy, and I can see no sign of
an actual drive failure, so I don't
understand why bioctl appears to
be showing a rebuild in progress.

Can anyone
clue me in on why I'm seeing this?

Full dmesg:

        OpenBSD 6.1-beta
(GENERIC.MP) #32: Thu Mar 16 19:22:10 MDT 2017
[hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
 real
mem = 4162596864 (3969MB)
 avail mem = 4031762432 (3844MB)
 mpath0 at root
scsibus0 at mpath0: 256 targets
 mainbus0 at root
 bios0 at mainbus0: SMBIOS
rev. 2.8 @ 0xedc10 (87 entries)
 bios0: vendor LENOVO version "FBKTB3AUS"
date 06/16/2015
 bios0: LENOVO ThinkServer TS140
 acpi0 at bios0: rev 2
acpi0: sleep states S0 S5
 acpi0: tables DSDT FACP APIC FPDT FIDT TCPA DBGP
LUFT SSDT SSDT MCFG
HPET SSDT SSDT ASF! BGRT EINJ ERST HEST BERT
 acpi0:
wakeup devices UAR1(S0) PXSX(S0) RP01(S0) PXSX(S0) RP02(S0)
PXSX(S0) PXSX(S0)
RP04(S0) PXSX(S0) PXSX(S0) PXSX(S0) PXSX(S0)
GLAN(S0) EHC1(S0) EHC2(S0)
XHC_(S0) [...]
 acpitimer0 at acpi0: 3579545 Hz, 24 bits
 acpimadt0 at acpi0
addr 0xfee00000: PC-AT compat
 cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Xeon(R) CPU E3-1225 v3 @ 3.20GHz, 3193.07 MHz
 cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX
,SMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,P
OPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,
FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT

 cpu0: 256KB 64b/line
8-way L2 cache
 cpu0: TSC frequency 3193072850 Hz
 cpu0: smt 0, core 0,
package 0
 mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
 cpu0: mwait min=64, max=64,
C-substates=0.2.1.2.4, IBE
 cpu1 at mainbus0: apid 2 (application processor)
cpu1: Intel(R) Xeon(R) CPU E3-1225 v3 @ 3.20GHz, 3192.61 MHz
 cpu1:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX
,SMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,P
OPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,
FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT

 cpu1: 256KB 64b/line
8-way L2 cache
 cpu1: smt 0, core 1, package 0
 cpu2 at mainbus0: apid 4
(application processor)
 cpu2: Intel(R) Xeon(R) CPU E3-1225 v3 @ 3.20GHz,
3192.61 MHz
 cpu2:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX
,SMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,P
OPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,
FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT

 cpu2: 256KB 64b/line
8-way L2 cache
 cpu2: smt 0, core 2, package 0
 cpu3 at mainbus0: apid 6
(application processor)
 cpu3: Intel(R) Xeon(R) CPU E3-1225 v3 @ 3.20GHz,
3192.61 MHz
 cpu3:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX
,SMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,P
OPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,PERF,ITSC,
FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,SENSOR,ARAT

 cpu3: 256KB 64b/line
8-way L2 cache
 cpu3: smt 0, core 3, package 0
 ioapic0 at mainbus0: apid 8
pa 0xfec00000, version 20, 24 pins
 acpimcfg0 at acpi0 addr 0xf8000000, bus
0-63
 acpihpet0 at acpi0: 14318179 Hz
 acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (RP01)
 acpiprt2 at acpi0: bus 2 (RP02)
 acpiprt3
at acpi0: bus 3 (RP04)
 acpiprt4 at acpi0: bus -1 (PEG0)
 acpiprt5 at acpi0:
bus -1 (PEG1)
 acpiprt6 at acpi0: bus -1 (PEG2)
 acpiec0 at acpi0: not
present
 acpicpu0 at acpi0: C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu1 at acpi0: C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu2 at acpi0: C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu3 at acpi0: C2(200@148 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpipwrres0 at acpi0: FN00, resource for FAN0
 acpipwrres1 at acpi0: FN01,
resource for FAN1
 acpipwrres2 at acpi0: FN02, resource for FAN2
acpipwrres3 at acpi0: FN03, resource for FAN3
 acpipwrres4 at acpi0: FN04,
resource for FAN4
 acpitz0 at acpi0: critical temperature is 105 degC
acpitz1 at acpi0: critical temperature is 105 degC
 "INT3F0D" at acpi0 not
configured
 "PNP0501" at acpi0 not configured
 acpibtn0 at acpi0: PWRB
"PNP0C0B" at acpi0 not configured
 "PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
 "PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
 "PNP0C14" at acpi0 not configured
acpivideo0 at acpi0: GFX0
 acpivout0 at acpivideo0: DD1F
 cpu0: Enhanced
SpeedStep 3193 MHz: speeds: 3201, 3200, 3000, 2900,
2700, 2500, 2300, 2200,
2000, 1800, 1700, 1500, 1300, 1100, 1000, 800
MHz
 pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Xeon E3-1200 v3 Host" rev 0x06
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics P4600" rev 0x06

 drm0
at inteldrm0
 inteldrm0: msi
 inteldrm0: 1024x768, 32bpp
 wsdisplay0 at
inteldrm0 mux 1: console (std, vt100 emulation)
 wsdisplay0: screen 1-5 added
(std, vt100 emulation)
 azalia0 at pci0 dev 3 function 0 "Intel Core 4G HD
Audio" rev 0x06:
msi
 xhci0 at pci0 dev 20 function 0 "Intel 8 Series xHCI"
rev 0x05: msi
 usb0 at xhci0: USB revision 3.0
 uhub0 at usb0 configuration
1 interface 0 "Intel xHCI root hub" rev
3.00/1.00 addr 1
 "Intel 8 Series
MEI" rev 0x04 at pci0 dev 22 function 0 not
configured
 em0 at pci0 dev 25
function 0 "Intel I217-LM" rev 0x05: msi, address
6c:0b:84:09:f9:bd
 ehci0 at
pci0 dev 26 function 0 "Intel 8 Series USB" rev 0x05: apic 8
int 17
 usb1 at
ehci0: USB revision 2.0
 uhub1 at usb1 configuration 1 interface 0 "Intel
EHCI root hub" rev
2.00/1.00 addr 1
 azalia1 at pci0 dev 27 function 0 "Intel
8 Series HD Audio" rev 0x05:
msi
 azalia1: codecs: Realtek ALC662
 audio0 at
azalia1
 ppb0 at pci0 dev 28 function 0 "Intel 8 Series PCIE" rev 0xd5
 pci1
at ppb0 bus 1
 ppb1 at pci0 dev 28 function 1 "Intel 8 Series PCIE" rev 0xd5:
msi
 pci2 at ppb1 bus 2
 em1 at pci2 dev 0 function 0 "Intel 82574L" rev
0x00: msi, address
68:05:ca:3a:8e:b2
 ppb2 at pci0 dev 28 function 3 "Intel 8
Series PCIE" rev 0xd5: msi
 pci3 at ppb2 bus 3
 ppb3 at pci3 dev 0 function
0 "ITExpress IT8893E PCIE-PCI" rev 0x41
 pci4 at ppb3 bus 4
 ehci1 at pci0
dev 29 function 0 "Intel 8 Series USB" rev 0x05: apic 8
int 23
 usb2 at
ehci1: USB revision 2.0
 uhub2 at usb2 configuration 1 interface 0 "Intel
EHCI root hub" rev
2.00/1.00 addr 1
 pcib0 at pci0 dev 31 function 0 "Intel
C226 LPC" rev 0x05
 ahci0 at pci0 dev 31 function 2 "Intel 8 Series AHCI" rev
0x05: msi,
AHCI 1.3
 ahci0: port 0: 6.0Gb/s
 ahci0: port 1: 6.0Gb/s
 ahci0:
port 2: 6.0Gb/s
 ahci0: port 3: 6.0Gb/s
 ahci0: port 4: 1.5Gb/s
 scsibus1
at ahci0: 32 targets
 sd0 at scsibus1 targ 0 lun 0: <ATA, Samsung SSD 850,
EMT0> SCSI3
0/direct fixed naa.5002538d4019e022
 sd0: 238475MB, 512
bytes/sector, 488397168 sectors, thin
 sd1 at scsibus1 targ 1 lun 0: <ATA,
ST4000VN000-1H41, SC46> SCSI3
0/direct fixed naa.5000c50079458b1b
 sd1:
3815447MB, 512 bytes/sector, 7814037168 sectors
 sd2 at scsibus1 targ 2 lun
0: <ATA, ST4000VN000-1H41, SC46> SCSI3
0/direct fixed naa.5000c500799ccc22
sd2: 3815447MB, 512 bytes/sector, 7814037168 sectors
 sd3 at scsibus1 targ 3
lun 0: <ATA, ST4000VN000-1H41, SC46> SCSI3
0/direct fixed naa.5000c500794576ca
sd3: 3815447MB, 512 bytes/sector, 7814037168 sectors
 cd0 at scsibus1 targ 4
lun 0: <HL-DT-ST, DVD-ROM DTA0N, DC01> ATAPI
5/cdrom removable
 ichiic0 at
pci0 dev 31 function 3 "Intel 8 Series SMBus" rev 0x05:
apic 8 int 18
 iic0
at ichiic0
 sdtemp0 at iic0 addr 0x19: mcp98243
 spdmem0 at iic0 addr 0x51:
4GB DDR3 SDRAM ECC PC3-12800 with thermal
sensor
 isa0 at pcib0
 isadma0 at
isa0
 com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
 com0: console
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
 pckbd0 at pckbc0 (kbd slot)
 wskbd0
at pckbd0: console keyboard, using wsdisplay0
 pcppi0 at isa0 port 0x61
spkr0 at pcppi0
 vmm disabled by firmware
 vmm at mainbus0 not configured
error: [drm:pid0:intel_uncore_check_errors] *ERROR* Unclaimed
register before
interrupt
 uhub3 at uhub1 port 1 configuration 1 interface 0 "Intel Rate
Matching Hub" rev 2.00/0.05 addr 2
 uhub4 at uhub2 port 1 configuration 1
interface 0 "Intel Rate
Matching Hub" rev 2.00/0.05 addr 2
 vscsi0 at root
scsibus2 at vscsi0: 256 targets
 softraid0 at root
 scsibus3 at softraid0:
256 targets
 sd4 at scsibus3 targ 1 lun 0: <OPENBSD, SR RAID 1, 006> SCSI2
0/direct fixed
 sd4: 3815447MB, 512 bytes/sector, 7814036576 sectors
 root
on sd0a (918dcdbb8c221cb4.a) swap on sd0b dump on sd0b

--
 Joe Gidi
[hidden email]

 "You cannot buy skill." -- Ross Seyfried

Loading...