bad 5.1 package of poptop

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

bad 5.1 package of poptop

Federico Giannici
The 5.1 package of poptop "poptop-1.3.4p3.tgz" (taken from 2 different
official FTP sites) seems to be compiled for a platform after 5.1.

If I try to install it an error appears about a c library version not
present:

# pkg_add poptop-1.3.4p3.tgz
Can't install poptop-1.3.4p3 because of libraries
|library c.64.1 not found
| /usr/lib/libc.so.50.1 (system): bad major
| /usr/lib/libc.so.60.1 (system): bad major
| /usr/lib/libc.so.51.0 (system): bad major
| /usr/lib/libc.so.53.1 (system): bad major
| /usr/lib/libc.so.56.0 (system): bad major
| /usr/lib/libc.so.62.0 (system): bad major


If I force the install, the ldd command confirm the problem:

/usr/local/sbin# ldd ./pptpd
./pptpd:
./pptpd: can't load library 'libc.so.64.1'
./pptpd: exit status 4


Thanks.

Reply | Threaded
Open this post in threaded view
|

Re: bad 5.1 package of poptop

Tobias Ulmer
On Sat, May 26, 2012 at 02:31:52PM +0200, Federico Giannici wrote:

> The 5.1 package of poptop "poptop-1.3.4p3.tgz" (taken from 2
> different official FTP sites) seems to be compiled for a platform
> after 5.1.
>
> If I try to install it an error appears about a c library version
> not present:
>
> # pkg_add poptop-1.3.4p3.tgz
> Can't install poptop-1.3.4p3 because of libraries
> |library c.64.1 not found
> | /usr/lib/libc.so.50.1 (system): bad major
> | /usr/lib/libc.so.60.1 (system): bad major
> | /usr/lib/libc.so.51.0 (system): bad major
> | /usr/lib/libc.so.53.1 (system): bad major
> | /usr/lib/libc.so.56.0 (system): bad major
> | /usr/lib/libc.so.62.0 (system): bad major
>
>
> If I force the install, the ldd command confirm the problem:
>
> /usr/local/sbin# ldd ./pptpd
> ./pptpd:
> ./pptpd: can't load library 'libc.so.64.1'
> ./pptpd: exit status 4
>
>
> Thanks.
>

On which architecture?

I can observe no such problem:

argon:~$ echo $PKG_PATH
http://ftp.eu.openbsd.org/pub/OpenBSD/5.1/packages/i386/
argon:~$ sudo pkg_add -i poptop
poptop-1.3.4p3: ok
The following new rcscripts were installed: /etc/rc.d/pptpd
See rc.d(8) for details.
Look in /usr/local/share/doc/pkg-readmes for extra documentation.
argon:~$ ldd `which pptpd`
/usr/local/sbin/pptpd:
        Start    End      Type Open Ref GrpRef Name
        1c000000 3c004000 exe  1    0   0      /usr/local/sbin/pptpd
        0b939000 2b967000 rlib 0    1   0      /usr/lib/libc.so.62.0
        08d40000 08d40000 rtld 0    1   0      /usr/libexec/ld.so
argon:~$ dmesg|sed 2q
OpenBSD 5.1 (GENERIC) #160: Sun Feb 12 09:46:33 MST 2012
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
argon:~$

Reply | Threaded
Open this post in threaded view
|

Re: bad 5.1 package of poptop

Federico Giannici
Oops!
I forgot to say it's amd64.

Thanks.



On 05/26/12 16:06, Tobias Ulmer wrote:

> On Sat, May 26, 2012 at 02:31:52PM +0200, Federico Giannici wrote:
>> The 5.1 package of poptop "poptop-1.3.4p3.tgz" (taken from 2
>> different official FTP sites) seems to be compiled for a platform
>> after 5.1.
>>
>> If I try to install it an error appears about a c library version
>> not present:
>>
>> # pkg_add poptop-1.3.4p3.tgz
>> Can't install poptop-1.3.4p3 because of libraries
>> |library c.64.1 not found
>> | /usr/lib/libc.so.50.1 (system): bad major
>> | /usr/lib/libc.so.60.1 (system): bad major
>> | /usr/lib/libc.so.51.0 (system): bad major
>> | /usr/lib/libc.so.53.1 (system): bad major
>> | /usr/lib/libc.so.56.0 (system): bad major
>> | /usr/lib/libc.so.62.0 (system): bad major
>>
>>
>> If I force the install, the ldd command confirm the problem:
>>
>> /usr/local/sbin# ldd ./pptpd
>> ./pptpd:
>> ./pptpd: can't load library 'libc.so.64.1'
>> ./pptpd: exit status 4
>>
>>
>> Thanks.
>>
>
> On which architecture?
>
> I can observe no such problem:
>
> argon:~$ echo $PKG_PATH
> http://ftp.eu.openbsd.org/pub/OpenBSD/5.1/packages/i386/
> argon:~$ sudo pkg_add -i poptop
> poptop-1.3.4p3: ok
> The following new rcscripts were installed: /etc/rc.d/pptpd
> See rc.d(8) for details.
> Look in /usr/local/share/doc/pkg-readmes for extra documentation.
> argon:~$ ldd `which pptpd`
> /usr/local/sbin/pptpd:
>          Start    End      Type Open Ref GrpRef Name
>          1c000000 3c004000 exe  1    0   0      /usr/local/sbin/pptpd
>          0b939000 2b967000 rlib 0    1   0      /usr/lib/libc.so.62.0
>          08d40000 08d40000 rtld 0    1   0      /usr/libexec/ld.so
> argon:~$ dmesg|sed 2q
> OpenBSD 5.1 (GENERIC) #160: Sun Feb 12 09:46:33 MST 2012
>      [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
> argon:~$

Reply | Threaded
Open this post in threaded view
|

Re: bad 5.1 package of poptop

Tobias Ulmer
On Sat, May 26, 2012 at 04:22:41PM +0200, Federico Giannici wrote:
> Oops!
> I forgot to say it's amd64.

carbon:~$ ftp ftp://ftp.eu.openbsd.org/pub/OpenBSD/5.1/packages/amd64/poptop-1.3.4p3.tgz
Trying 77.238.36.56...
Connected to ftp-prod-srv04.it.su.se.
220 ftp-prod-srv04.it.su.se FTP server ready.
331 Please specify the password.
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
200 Switching to Binary mode.
250 Directory successfully changed.
Retrieving pub/OpenBSD/5.1/packages/amd64/poptop-1.3.4p3.tgz
local: poptop-1.3.4p3.tgz remote: poptop-1.3.4p3.tgz
150 Opening BINARY mode data connection for poptop-1.3.4p3.tgz (34753 bytes).
100% |******************************************************************************| 34753       00:00    
226 Transfer complete.
34753 bytes received in 0.32 seconds (104.60 KB/s)
221 Goodbye.
carbon:~$ tar xzf poptop-1.3.4p3.tgz +CONTENTS
carbon:~$ grep wantlib +CONTENTS
@wantlib c.62.0
@wantlib util.11.2


There's no problem with the packages. You seem to be mixing snapshots
with 5.1 somehow, check your PKG_PATH etc.


>
> Thanks.
>
>
>
> On 05/26/12 16:06, Tobias Ulmer wrote:
> >On Sat, May 26, 2012 at 02:31:52PM +0200, Federico Giannici wrote:
> >>The 5.1 package of poptop "poptop-1.3.4p3.tgz" (taken from 2
> >>different official FTP sites) seems to be compiled for a platform
> >>after 5.1.
> >>
> >>If I try to install it an error appears about a c library version
> >>not present:
> >>
> >># pkg_add poptop-1.3.4p3.tgz
> >>Can't install poptop-1.3.4p3 because of libraries
> >>|library c.64.1 not found
> >>| /usr/lib/libc.so.50.1 (system): bad major
> >>| /usr/lib/libc.so.60.1 (system): bad major
> >>| /usr/lib/libc.so.51.0 (system): bad major
> >>| /usr/lib/libc.so.53.1 (system): bad major
> >>| /usr/lib/libc.so.56.0 (system): bad major
> >>| /usr/lib/libc.so.62.0 (system): bad major
> >>
> >>
> >>If I force the install, the ldd command confirm the problem:
> >>
> >>/usr/local/sbin# ldd ./pptpd
> >>./pptpd:
> >>./pptpd: can't load library 'libc.so.64.1'
> >>./pptpd: exit status 4
> >>
> >>
> >>Thanks.
> >>
> >
> >On which architecture?
> >
> >I can observe no such problem:
> >
> >argon:~$ echo $PKG_PATH
> >http://ftp.eu.openbsd.org/pub/OpenBSD/5.1/packages/i386/
> >argon:~$ sudo pkg_add -i poptop
> >poptop-1.3.4p3: ok
> >The following new rcscripts were installed: /etc/rc.d/pptpd
> >See rc.d(8) for details.
> >Look in /usr/local/share/doc/pkg-readmes for extra documentation.
> >argon:~$ ldd `which pptpd`
> >/usr/local/sbin/pptpd:
> >         Start    End      Type Open Ref GrpRef Name
> >         1c000000 3c004000 exe  1    0   0      /usr/local/sbin/pptpd
> >         0b939000 2b967000 rlib 0    1   0      /usr/lib/libc.so.62.0
> >         08d40000 08d40000 rtld 0    1   0      /usr/libexec/ld.so
> >argon:~$ dmesg|sed 2q
> >OpenBSD 5.1 (GENERIC) #160: Sun Feb 12 09:46:33 MST 2012
> >     [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
> >argon:~$

Reply | Threaded
Open this post in threaded view
|

Re: bad 5.1 package of poptop

Marc Espie-2
In reply to this post by Federico Giannici
On Sat, May 26, 2012 at 02:31:52PM +0200, Federico Giannici wrote:

> The 5.1 package of poptop "poptop-1.3.4p3.tgz" (taken from 2
> different official FTP sites) seems to be compiled for a platform
> after 5.1.
>
> If I try to install it an error appears about a c library version
> not present:
>
> # pkg_add poptop-1.3.4p3.tgz
> Can't install poptop-1.3.4p3 because of libraries
> |library c.64.1 not found
> | /usr/lib/libc.so.50.1 (system): bad major
> | /usr/lib/libc.so.60.1 (system): bad major
> | /usr/lib/libc.so.51.0 (system): bad major
> | /usr/lib/libc.so.53.1 (system): bad major
> | /usr/lib/libc.so.56.0 (system): bad major
> | /usr/lib/libc.so.62.0 (system): bad major

Duh.
Stop wasting our collective time.

Hint: snapshots is *not* 5.1.

Reply | Threaded
Open this post in threaded view
|

Re: bad 5.1 package of poptop

Federico Giannici
On 05/26/12 16:41, Marc Espie wrote:

> On Sat, May 26, 2012 at 02:31:52PM +0200, Federico Giannici wrote:
>> The 5.1 package of poptop "poptop-1.3.4p3.tgz" (taken from 2
>> different official FTP sites) seems to be compiled for a platform
>> after 5.1.
>>
>> If I try to install it an error appears about a c library version
>> not present:
>>
>> # pkg_add poptop-1.3.4p3.tgz
>> Can't install poptop-1.3.4p3 because of libraries
>> |library c.64.1 not found
>> | /usr/lib/libc.so.50.1 (system): bad major
>> | /usr/lib/libc.so.60.1 (system): bad major
>> | /usr/lib/libc.so.51.0 (system): bad major
>> | /usr/lib/libc.so.53.1 (system): bad major
>> | /usr/lib/libc.so.56.0 (system): bad major
>> | /usr/lib/libc.so.62.0 (system): bad major
>
> Duh.
> Stop wasting our collective time.
>
> Hint: snapshots is *not* 5.1.

I'm sorry, I found the problem: I downloaded the correct package but
clearly when I issued the pkg_add command I erroneously was in another
directory so it automatically downloaded the package from the net (I
have just found that a lot of time ago I set the PKG_PATH environment
variable to snapshots, and I completely forgot it!).

Sorry...