audio/picard broken?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

audio/picard broken?

Edd Barrett-3
Hi,

Went to run picard today:

---8<---
$ picard
Traceback (most recent call last):
  File "/usr/local/bin/picard", line 2, in <module>
    from picard.tagger import main; main('/usr/share/locale', True)
  File "/usr/local/lib/python2.7/site-packages/picard/tagger.py", line 21, in <module>
    from PyQt4 import QtGui, QtCore
RuntimeError: the sip module implements API v12.0 to v12.2 but the PyQt4.QtGui module requires API v12.6
--->8---

--
Best Regards
Edd Barrett

http://www.theunixzoo.co.uk

Reply | Threaded
Open this post in threaded view
|

Re: audio/picard broken?

Landry Breuil-5
On Sat, Jul 06, 2019 at 04:44:14PM +0100, Edd Barrett wrote:

> Hi,
>
> Went to run picard today:
>
> ---8<---
> $ picard
> Traceback (most recent call last):
>   File "/usr/local/bin/picard", line 2, in <module>
>     from picard.tagger import main; main('/usr/share/locale', True)
>   File "/usr/local/lib/python2.7/site-packages/picard/tagger.py", line 21, in <module>
>     from PyQt4 import QtGui, QtCore
> RuntimeError: the sip module implements API v12.0 to v12.2 but the PyQt4.QtGui module requires API v12.6

Try rebuilding/upgrading it so that it's been rebuilt against last
py-sip ? Maybe all fscking consumers should be bumped.

Reply | Threaded
Open this post in threaded view
|

Re: audio/picard broken?

Edd Barrett-3
On Sat, Jul 06, 2019 at 08:07:46PM +0200, Landry Breuil wrote:
> Try rebuilding/upgrading it so that it's been rebuilt against last
> py-sip ? Maybe all fscking consumers should be bumped.

I've just updated my snapshot and pkgs and it launches fine.

Nonetheless, I'll help Kurt with the update.

--
Best Regards
Edd Barrett

http://www.theunixzoo.co.uk