arora core-dumps at startup (6.2/amd64)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

arora core-dumps at startup (6.2/amd64)

Jonathan Thornburg-4
Running 6.2-stable/amd64, arora (package arora-0.11.0p8) core-dumps
on startup:

% uname -a
OpenBSD copper.astro.indiana.edu 6.2 GENERIC.MP#0 amd64
% pkg_info|grep arora
arora-0.11.0p8      simple Qt4-based browser using WebKit
% arora
Failed to load translation: "C"
Trace/BPT trap (core dumped)
% env|grep LC
% env|grep LANG
%

Has anyone else run into this problem?  Is there a magic environment
variable that should be set before starting arora to persuade it to
try different language settings?  I don't see anything relevant in
'man arora'.

FWIW, using another machine that's still running 6.0/amd64
(package arora-0.11.0p7), arora gives the same startup message
and then sits at 100% CPU for about 15 seconds on a 2GHz Core i7
(Lenovo Thinkpad T530)... but then works fine.

Thanks, ciao,
--
-- "Jonathan Thornburg [remove -animal to reply]" <[hidden email]>
   "There was of course no way of knowing whether you were being watched
    at any given moment.  How often, or on what system, the Thought Police
    plugged in on any individual wire was guesswork.  It was even conceivable
    that they watched everybody all the time."  -- George Orwell, "1984"

Reply | Threaded
Open this post in threaded view
|

Re: arora core-dumps at startup (6.2/amd64)

Jeremie Courreges-Anglas-2
On Sun, Dec 24, 2017 at 10:11:42PM -0800, Jonathan Thornburg wrote:

> Running 6.2-stable/amd64, arora (package arora-0.11.0p8) core-dumps
> on startup:
>
> % uname -a
> OpenBSD copper.astro.indiana.edu 6.2 GENERIC.MP#0 amd64
> % pkg_info|grep arora
> arora-0.11.0p8      simple Qt4-based browser using WebKit
> % arora
> Failed to load translation: "C"
> Trace/BPT trap (core dumped)

Can you see a similar message in /var/log/messages?

...  /bsd: arora(58363): mmap W^X violation

That's probably the reason of your crash.  If I guess correctly, arora
should be linked with -Wl,-z,wxneeded for the qtwebkit engine to run.

But should you use a browser that hasn't seen an update since 2010?

Reply | Threaded
Open this post in threaded view
|

Re: arora core-dumps at startup (6.2/amd64)

Landry Breuil-5
On Mon, Dec 25, 2017 at 07:35:00AM +0100, Jeremie Courreges-Anglas wrote:

> On Sun, Dec 24, 2017 at 10:11:42PM -0800, Jonathan Thornburg wrote:
> > Running 6.2-stable/amd64, arora (package arora-0.11.0p8) core-dumps
> > on startup:
> >
> > % uname -a
> > OpenBSD copper.astro.indiana.edu 6.2 GENERIC.MP#0 amd64
> > % pkg_info|grep arora
> > arora-0.11.0p8      simple Qt4-based browser using WebKit
> > % arora
> > Failed to load translation: "C"
> > Trace/BPT trap (core dumped)
>
> Can you see a similar message in /var/log/messages?
>
> ...  /bsd: arora(58363): mmap W^X violation
>
> That's probably the reason of your crash.  If I guess correctly, arora
> should be linked with -Wl,-z,wxneeded for the qtwebkit engine to run.
>
> But should you use a browser that hasn't seen an update since 2010?

I was about to say this... i think qt4 itself is in low maintainance
mode, so arora might not get fixed if there are real serious issues in
qtwebkit.  Alternatives/forks might be 'Zeromus browser' or its own fork
'bluelightcat', but both didn't seem updated since 2015.
otherwise i'd suggest removing it.

Landry

Reply | Threaded
Open this post in threaded view
|

Re: arora core-dumps at startup (6.2/amd64)

Jeremie Courreges-Anglas-2

(A bit late, but adding ${MAINTAINER} to Cc)

On Mon, Dec 25 2017, Landry Breuil <[hidden email]> wrote:

> On Mon, Dec 25, 2017 at 07:35:00AM +0100, Jeremie Courreges-Anglas wrote:
>> On Sun, Dec 24, 2017 at 10:11:42PM -0800, Jonathan Thornburg wrote:
>> > Running 6.2-stable/amd64, arora (package arora-0.11.0p8) core-dumps
>> > on startup:
>> >
>> > % uname -a
>> > OpenBSD copper.astro.indiana.edu 6.2 GENERIC.MP#0 amd64
>> > % pkg_info|grep arora
>> > arora-0.11.0p8      simple Qt4-based browser using WebKit
>> > % arora
>> > Failed to load translation: "C"
>> > Trace/BPT trap (core dumped)
>>
>> Can you see a similar message in /var/log/messages?
>>
>> ...  /bsd: arora(58363): mmap W^X violation
>>
>> That's probably the reason of your crash.  If I guess correctly, arora
>> should be linked with -Wl,-z,wxneeded for the qtwebkit engine to run.
Back to this:

>> But should you use a browser that hasn't seen an update since 2010?
>
> I was about to say this... i think qt4 itself is in low maintainance
> mode, so arora might not get fixed if there are real serious issues in
> qtwebkit.  Alternatives/forks might be 'Zeromus browser' or its own fork
> 'bluelightcat', but both didn't seem updated since 2015.
> otherwise i'd suggest removing it.

Same here, we should delete the port IMO.  Brad, what do you think?

--
jca | PGP : 0x1524E7EE / 5135 92C1 AD36 5293 2BDF  DDCC 0DFA 74AE 1524 E7EE

signature.asc (847 bytes) Download Attachment