arandr

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

arandr

Fred
Hi Ports@,

I've just upgraded to:
port:fred ~> dmesg|head -2
OpenBSD 5.5-beta (GENERIC.MP) #287: Fri Feb  7 11:45:09 MST 2014
     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP

And arandr is now failing with the following error:

Exception: XRandR returned error code 1: X Error of failed request:
BadAtom (invalid Atom parameter)

The full error messages is shown below [1]

It was working fine with my previous snapshot which was I think 3rd of Feb.

Full dmesg at [2]

Thanks

Fred

[1]
port:fred ~> arandr
/usr/local/lib/python2.7/site-packages/gobject/__init__.py:115: Warning:
Attempt to add property screenlayout+metacity+KeyBindingButton::bound
after class was initialised
   type_register(cls, namespace.get('__gtype_name__'))
/usr/local/lib/python2.7/site-packages/gobject/__init__.py:115: Warning:
Attempt to add property screenlayout+metacity+ActionWidget::editable
after class was initialised
   type_register(cls, namespace.get('__gtype_name__'))
Traceback (most recent call last):
   File "/usr/local/bin/arandr", line 42, in <module>
     main()
   File "/usr/local/lib/python2.7/site-packages/screenlayout/gui.py",
line 318, in main
     force_version=options.force_version
   File "/usr/local/lib/python2.7/site-packages/screenlayout/gui.py",
line 159, in __init__
     self.filetemplate = self.widget.load_from_x()
   File "/usr/local/lib/python2.7/site-packages/screenlayout/widget.py",
line 93, in load_from_x
     self._xrandr.load_from_x()
   File "/usr/local/lib/python2.7/site-packages/screenlayout/xrandr.py",
line 123, in load_from_x
     screenline, items = self._load_raw_lines()
   File "/usr/local/lib/python2.7/site-packages/screenlayout/xrandr.py",
line 187, in _load_raw_lines
     output = self._output("--verbose")
   File "/usr/local/lib/python2.7/site-packages/screenlayout/xrandr.py",
line 56, in _output
     raise Exception("XRandR returned error code %d: %s"%(status,err))
Exception: XRandR returned error code 1: X Error of failed request:
BadAtom (invalid Atom parameter)
   Major opcode of failed request:  17 (X_GetAtomName)
   Atom id in failed request:  0x3131582f
   Serial number of failed request:  54
   Current serial number in output stream:  54

[2]
OpenBSD 5.5-beta (GENERIC.MP) #287: Fri Feb  7 11:45:09 MST 2014
     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 8447131648 (8055MB)
avail mem = 8214048768 (7833MB)
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.5 @ 0xaafd0000 (43 entries)
bios0: vendor TOSHIBA version "Version 3.60" date 01/24/2012
bios0: TOSHIBA TOSHIBA
acpi0 at bios0: rev 0
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP HPET APIC MCFG ASF! TCPA BOOT SLIC SSDT SSDT
SSDT SSDT
acpi0: wakeup devices LANC(S4) HDEF(S3) RP02(S4) PXSX(S4) RP04(S4)
PXSX(S4) USBB(S4) USBC(S4) EHC1(S4) EHC2(S4) PWRB(S4) LID_(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz, 2492.24 MHz
cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,NXE,LONG,LAHF,PERF,ITSC
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.1.2, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz, 2491.91 MHz
cpu1:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,NXE,LONG,LAHF,PERF,ITSC
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 1, core 0, package 0
cpu2 at mainbus0: apid 2 (application processor)
cpu2: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz, 2491.91 MHz
cpu2:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,NXE,LONG,LAHF,PERF,ITSC
cpu2: 256KB 64b/line 8-way L2 cache
cpu2: smt 0, core 1, package 0
cpu3 at mainbus0: apid 3 (application processor)
cpu3: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz, 2491.91 MHz
cpu3:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,NXE,LONG,LAHF,PERF,ITSC
cpu3: 256KB 64b/line 8-way L2 cache
cpu3: smt 1, core 1, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEGP)
acpiprt2 at acpi0: bus 1 (RP01)
acpiprt3 at acpi0: bus 2 (RP02)
acpiprt4 at acpi0: bus 4 (RP03)
acpiprt5 at acpi0: bus -1 (RP04)
acpiprt6 at acpi0: bus 5 (RP05)
acpiprt7 at acpi0: bus 6 (RP06)
acpiprt8 at acpi0: bus 7 (RP07)
acpiprt9 at acpi0: bus -1 (RP08)
acpiprt10 at acpi0: bus -1 (PCIB)
acpicpu0 at acpi0: C3, C2, C1, PSS
acpicpu1 at acpi0: C3, C2, C1, PSS
acpicpu2 at acpi0: C3, C2, C1, PSS
acpicpu3 at acpi0: C3, C2, C1, PSS
acpipwrres0 at acpi0: PDOC, resource for DOCK
acpitz0 at acpi0: critical temperature is 102 degC
acpitoshiba0 at acpi0
acpiac0 at acpi0: AC unit offline
acpibtn0 at acpi0: PWRB
acpibtn1 at acpi0: LID_
acpibat0 at acpi0: BAT1 model "G71C000E4410" serial 0000001888 type
Li-ION   oem "0"
acpidock0 at acpi0: DOCK not docked (0)
cpu0: Enhanced SpeedStep 2492 MHz: speeds: 2501, 2500, 2000, 1800, 1600,
1400, 1200, 1000, 800 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 2G Host" rev 0x09
vga1 at pci0 dev 2 function 0 "Intel HD Graphics 3000" rev 0x09
intagp0 at vga1
agp0 at intagp0: aperture at 0xb0000000, size 0x10000000
inteldrm0 at vga1
drm0 at inteldrm0
inteldrm0: 1366x768
wsdisplay0 at vga1 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
"Intel 6 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
puc0 at pci0 dev 22 function 3 "Intel 6 Series KT" rev 0x04: ports: 1 com
com4 at puc0 port 0 apic 2 int 19: ns16550a, 16 byte fifo
com4: probed fifo depth: 0 bytes
em0 at pci0 dev 25 function 0 "Intel 82579LM" rev 0x04: msi, address
e8:e0:b7:02:05:5d
ehci0 at pci0 dev 26 function 0 "Intel 6 Series USB" rev 0x04: apic 2 int 16
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 6 Series HD Audio" rev 0x04: msi
azalia0: codecs: Realtek ALC269, Intel/0x2805, using Realtek ALC269
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 6 Series PCIE" rev 0xb4: msi
pci1 at ppb0 bus 1
sdhc0 at pci1 dev 0 function 0 "Ricoh 5U823 SD/MMC" rev 0x04: apic 2 int 16
sdmmc0 at sdhc0
ppb1 at pci0 dev 28 function 1 "Intel 6 Series PCIE" rev 0xb4: msi
pci2 at ppb1 bus 2
ppb2 at pci0 dev 28 function 2 "Intel 6 Series PCIE" rev 0xb4: msi
pci3 at ppb2 bus 4
iwn0 at pci3 dev 0 function 0 "Intel Centrino Advanced-N 6030" rev 0x34:
msi, MIMO 2T2R, MoW, address 00:db:df:1f:24:6c
ppb3 at pci0 dev 28 function 4 "Intel 6 Series PCIE" rev 0xb4: msi
pci4 at ppb3 bus 5
"NEC xHCI" rev 0x04 at pci4 dev 0 function 0 not configured
ppb4 at pci0 dev 28 function 5 "Intel 6 Series PCIE" rev 0xb4: msi
pci5 at ppb4 bus 6
ppb5 at pci0 dev 28 function 6 "Intel 82801BAM Hub-to-PCI" rev 0xb4: msi
pci6 at ppb5 bus 7
ehci1 at pci0 dev 29 function 0 "Intel 6 Series USB" rev 0x04: apic 2 int 23
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
pcib0 at pci0 dev 31 function 0 "Intel QM67 LPC" rev 0x04
ahci0 at pci0 dev 31 function 2 "Intel 6 Series AHCI" rev 0x04: msi,
AHCI 1.3
scsibus0 at ahci0: 32 targets
sd0 at scsibus0 targ 0 lun 0: <ATA, INTEL SSDSC2BW24, DC02> SCSI3
0/direct fixed naa.50015178f366232e
sd0: 228936MB, 512 bytes/sector, 468862128 sectors, thin
cd0 at scsibus0 targ 2 lun 0: <MATSHITA, DVD-RAM UJ8B2E, 1.20> ATAPI
5/cdrom removable
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pms0: Synaptics touchpad, firmware 7.5
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
uhub2 at uhub0 port 1 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
ugen0 at uhub2 port 1 "AuthenTec Fingerprint Sensor" rev 2.00/25.01 addr 3
uvideo0 at uhub2 port 5 configuration 1 interface 0 "YZC864LB TOSHIBA
Web Camera" rev 2.00/25.17 addr 4
video0 at uvideo0
uhub3 at uhub1 port 1 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
uhub4 at uhub3 port 2 "NEC product 0x0059" rev 2.00/1.00 addr 3
uhidev0 at uhub4 port 1 configuration 1 interface 0 "Logitech Trackball"
rev 1.10/2.20 addr 4
uhidev0: iclass 3/1
ums0 at uhidev0: 3 buttons, Z dir
wsmouse1 at ums0 mux 0
uhub4: device problem, disabling port 2
uftdi0 at uhub4 port 3 "FTDI TTL232R-3V3" rev 2.00/6.00 addr 5
ucom0 at uftdi0 portno 1
uhub5 at uhub3 port 4 "O2 Micro OZ776 Hub" rev 1.10/1.10 addr 6
ugen1 at uhub5 port 2 "O2 O2Micro CCID SC Reader" rev 1.10/1.10 addr 7
vscsi0 at root
scsibus1 at vscsi0: 256 targets
softraid0 at root
scsibus2 at softraid0: 256 targets
root on sd0a (ba6ebc42de11aa8d.a) swap on sd0b dump on sd0b
uhidev1 at uhub4 port 2 configuration 1 interface 0 "Microsoft
Natural\M-. Ergonomic Keyboard 4000" rev 2.00/1.73 addr 8
uhidev1: no report descriptor
uhidev2 at uhub4 port 2 configuration 1 interface 1 "Microsoft product
0x00db" rev 2.00/1.73 addr 8
uhidev2: no report descriptor
uhidev1 detached
uhidev2 detached
uhidev1 at uhub4 port 2 configuration 1 interface 0 "Microsoft
Natural\M-. Ergonomic Keyboard 4000" rev 2.00/1.73 addr 8
uhidev1: iclass 3/1
ukbd0 at uhidev1: 8 variable keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
uhidev2 at uhub4 port 2 configuration 1 interface 1 "Microsoft
Natural\M-. Ergonomic Keyboard 4000" rev 2.00/1.73 addr 8
uhidev2: iclass 3/0, 1 report id
uhid0 at uhidev2 reportid 1: input=7, output=0, feature=0

Reply | Threaded
Open this post in threaded view
|

Re: arandr

Matthieu Herrb
On Mon, Feb 10, 2014 at 05:45:47PM +0000, Fred wrote:

> Hi Ports@,
>
> I've just upgraded to:
> port:fred ~> dmesg|head -2
> OpenBSD 5.5-beta (GENERIC.MP) #287: Fri Feb  7 11:45:09 MST 2014
>     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
>
> And arandr is now failing with the following error:
>
> Exception: XRandR returned error code 1: X Error of failed request: BadAtom
> (invalid Atom parameter)

Yes xrandr --verbose (as called by arandr, which I consider as an ugly
hack, but that's another stroy) now reports the above error. Looks
caused by the intel driver update. Investigating...

--
Matthieu Herrb