ami on AMD64 - hard lockups on write; 3.9 -current

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

ami on AMD64 - hard lockups on write; 3.9 -current

Marten King
Hi,

Writing to any logical drives beyond the primary causes hard lockup.
Newfs hangs towards the end of writing superblocks and the machine
needs to be powered off. The machine runs fine using only sd0.

Others are using these cards; are there known firmware problems that
could be related?

TIA

3.9 -current AMD64 bsd.mp

# bioctl -hi ami0
Volume  Status  Size   Device  
 ami0 0 Online  73.6G  sd0     RAID1
      0 Online  74.5G  0:0.0   noencl <ST3808110AS     2AAA>
      1 Online  74.5G  0:1.0   noencl <ST3808110AS     2AAA>
 ami0 1 Online   232G  sd1     RAID1
      0 Online   233G  0:2.0   noencl <ST3250824AS     3.AA>
      1 Online   233G  0:4.0   noencl <ST3250824AS     3.AA>
 ami0 2 Online   232G  sd2     RAID1
      0 Online   233G  0:5.0   noencl <ST3250824AS     3.AA>
      1 Online   233G  0:7.0   noencl <ST3250824AS     3.AA>


OpenBSD 3.9-current (GENERIC.MP) #769: Mon Apr  3 17:19:21 MDT 2006
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 2147020800 (2096700K)
avail mem = 1835683840 (1792660K)
using 22937 buffers containing 214908928 bytes (209872K) of memory
mainbus0 (root)
ipmi at mainbus0 not configured
mainbus0: Intel MP Specification (Version 1.4) (MSI      RHAPSODY    )
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: AMD Opteron(tm) Processor 246, 1994.58 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,NXE,MMXX,LONG,3DNOW2,3DNOW
cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 1MB 64b/line 16-way L2 cache
cpu0: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu0: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu0: apic clock running at 199MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: AMD Opteron(tm) Processor 246, 1994.32 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,NXE,MMXX,LONG,3DNOW2,3DNOW
cpu1: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 1MB 64b/line 16-way L2 cache
cpu1: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
cpu1: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
mpbios: bus 0 is type PCI  
mpbios: bus 1 is type PCI  
mpbios: bus 2 is type PCI  
mpbios: bus 3 is type PCI  
mpbios: bus 4 is type PCI  
mpbios: bus 5 is type ISA  
ioapic0 at mainbus0 apid 2 pa 0xfec00000, version 11, 24 pins
ioapic1 at mainbus0 apid 3 pa 0xfebfe000, version 11, 4 pins
ioapic2 at mainbus0 apid 4 pa 0xfebff000, version 11, 4 pins
pci0 at mainbus0 bus 0: configuration mode 1
ppb0 at pci0 dev 6 function 0 "AMD 8111 PCI-PCI" rev 0x07
pci1 at ppb0 bus 4
ohci0 at pci1 dev 0 function 0 "AMD 8111 USB" rev 0x0b: apic 2 int 19 (irq 9), version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: AMD OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1 at pci1 dev 0 function 1 "AMD 8111 USB" rev 0x0b: apic 2 int 19 (irq 9), version 1.0, legacy support
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: AMD OHCI root hub, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
vga1 at pci1 dev 4 function 0 "ATI Rage XL" rev 0x27
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 7 function 0 "AMD AMD8111 LPC" rev 0x05
pciide0 at pci0 dev 7 function 1 "AMD 8111 IDE" rev 0x03: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
pciide0: channel 0 disabled (no drives)
pciide0: channel 1 disabled (no drives)
amdiic0 at pci0 dev 7 function 2 "AMD 8111 SMBus" rev 0x02: SCI
iic0 at amdiic0
lm1 at iic0 addr 0x2d: W83627HF
lm2 at iic0 addr 0x2f: W83782D rev D
amdpm0 at pci0 dev 7 function 3 "AMD 8111 Power" rev 0x05: rng active
iic1 at amdpm0
ppb1 at pci0 dev 10 function 0 "AMD 8131 PCIX" rev 0x13
pci2 at ppb1 bus 3
bge0 at pci2 dev 5 function 0 "Broadcom BCM5704C" rev 0x10, BCM5704 B0 (0x2100): apic 3 int 2 (irq 5), address 00:30:48:77:04:6e
brgphy0 at bge0 phy 1: BCM5704 10/100/1000baseT PHY, rev. 0
bge1 at pci2 dev 5 function 1 "Broadcom BCM5704C" rev 0x10, BCM5704 B0 (0x2100): apic 3 int 3 (irq 9), address 00:30:48:77:04:6f
brgphy1 at bge1 phy 1: BCM5704 10/100/1000baseT PHY, rev. 0
aapic0 at pci0 dev 10 function 1 "AMD 8131 PCIX IOAPIC" rev 0x01
ppb2 at pci0 dev 11 function 0 "AMD 8131 PCIX" rev 0x13
pci3 at ppb2 bus 1
ppb3 at pci3 dev 1 function 0 vendor "Intel", unknown product 0x0335 rev 0x07
pci4 at ppb3 bus 2
ami0 at pci4 dev 14 function 0 "Symbios Logic MegaRAID SATA 4x/8x" rev 0x07: apic 4 int 0 (irq 10)
ami0: LSI 3008, 32b, FW 813G, BIOS vH425, 128MB RAM
ami0: 1 channels, 0 FC loops, 3 logical drives
scsibus0 at ami0: 40 targets
sd0 at scsibus0 targ 0 lun 0: <AMI, Host drive #00, > SCSI2 0/direct fixed
sd0: 75340MB, 75340 cyl, 64 head, 32 sec, 512 bytes/sec, 154296320 sec total
sd1 at scsibus0 targ 1 lun 0: <AMI, Host drive #01, > SCSI2 0/direct fixed
sd1: 237464MB, 237464 cyl, 64 head, 32 sec, 512 bytes/sec, 486326272 sec total
sd2 at scsibus0 targ 2 lun 0: <AMI, Host drive #02, > SCSI2 0/direct fixed
sd2: 237464MB, 237464 cyl, 64 head, 32 sec, 512 bytes/sec, 486326272 sec total
scsibus1 at ami0: 16 targets
aapic1 at pci0 dev 11 function 1 "AMD 8131 PCIX IOAPIC" rev 0x01
pchb0 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
pchb1 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
pchb2 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
pchb3 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
pchb4 at pci0 dev 25 function 0 "AMD AMD64 HyperTransport" rev 0x00
pchb5 at pci0 dev 25 function 1 "AMD AMD64 Address Map" rev 0x00
pchb6 at pci0 dev 25 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
pchb7 at pci0 dev 25 function 3 "AMD AMD64 Misc Cfg" rev 0x00
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
lm0 at isa0 port 0x290/8: W83627HF
lm1 detached
dkcsum: sd0 matches BIOS drive 0x80
dkcsum: sd1 matches BIOS drive 0x81
dkcsum: sd2 matches BIOS drive 0x82
root on sd0a
rootdev=0x400 rrootdev=0xd00 rawdev=0xd02
WARNING: / was not properly unmounted

Reply | Threaded
Open this post in threaded view
|

Re: ami on AMD64 - hard lockups on write; 3.9 -current

Jon Simola-2
On 4/7/06, [hidden email] <[hidden email]> wrote:

> Others are using these cards; are there known firmware problems that
> could be related?

> ami0: LSI 3008, 32b, FW 813G, BIOS vH425, 128MB RAM

I updated mine to 813J which solved some minor little issues and
didn't solve others (notably hard lock when promoting drives to hot
spare). Company doesn't want to spring for a spare power supply so I
haven't been able to try replicating that on my spare hardware yet.

--
Jon Simola
Systems Administrator
ABC Communications

Reply | Threaded
Open this post in threaded view
|

Re: ami on AMD64 - hard lockups on write; 3.9 -current

Marco Peereboom
In reply to this post by Marten King
I think you might have slipped though dlg's commit flurry.

Roll a new kernel from yesterday and try again.

[hidden email] wrote:

> Hi,
>
> Writing to any logical drives beyond the primary causes hard lockup.
> Newfs hangs towards the end of writing superblocks and the machine
> needs to be powered off. The machine runs fine using only sd0.
>
> Others are using these cards; are there known firmware problems that
> could be related?
>
> TIA
>
> 3.9 -current AMD64 bsd.mp
>
> # bioctl -hi ami0
> Volume  Status  Size   Device  
>  ami0 0 Online  73.6G  sd0     RAID1
>       0 Online  74.5G  0:0.0   noencl <ST3808110AS     2AAA>
>       1 Online  74.5G  0:1.0   noencl <ST3808110AS     2AAA>
>  ami0 1 Online   232G  sd1     RAID1
>       0 Online   233G  0:2.0   noencl <ST3250824AS     3.AA>
>       1 Online   233G  0:4.0   noencl <ST3250824AS     3.AA>
>  ami0 2 Online   232G  sd2     RAID1
>       0 Online   233G  0:5.0   noencl <ST3250824AS     3.AA>
>       1 Online   233G  0:7.0   noencl <ST3250824AS     3.AA>
>
>
> OpenBSD 3.9-current (GENERIC.MP) #769: Mon Apr  3 17:19:21 MDT 2006
>     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
> real mem = 2147020800 (2096700K)
> avail mem = 1835683840 (1792660K)
> using 22937 buffers containing 214908928 bytes (209872K) of memory
> mainbus0 (root)
> ipmi at mainbus0 not configured
> mainbus0: Intel MP Specification (Version 1.4) (MSI      RHAPSODY    )
> cpu0 at mainbus0: apid 0 (boot processor)
> cpu0: AMD Opteron(tm) Processor 246, 1994.58 MHz
> cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,NXE,MMXX,LONG,3DNOW2,3DNOW
> cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 1MB 64b/line 16-way L2 cache
> cpu0: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
> cpu0: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
> cpu0: apic clock running at 199MHz
> cpu1 at mainbus0: apid 1 (application processor)
> cpu1: AMD Opteron(tm) Processor 246, 1994.32 MHz
> cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,NXE,MMXX,LONG,3DNOW2,3DNOW
> cpu1: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 1MB 64b/line 16-way L2 cache
> cpu1: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
> cpu1: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
> mpbios: bus 0 is type PCI  
> mpbios: bus 1 is type PCI  
> mpbios: bus 2 is type PCI  
> mpbios: bus 3 is type PCI  
> mpbios: bus 4 is type PCI  
> mpbios: bus 5 is type ISA  
> ioapic0 at mainbus0 apid 2 pa 0xfec00000, version 11, 24 pins
> ioapic1 at mainbus0 apid 3 pa 0xfebfe000, version 11, 4 pins
> ioapic2 at mainbus0 apid 4 pa 0xfebff000, version 11, 4 pins
> pci0 at mainbus0 bus 0: configuration mode 1
> ppb0 at pci0 dev 6 function 0 "AMD 8111 PCI-PCI" rev 0x07
> pci1 at ppb0 bus 4
> ohci0 at pci1 dev 0 function 0 "AMD 8111 USB" rev 0x0b: apic 2 int 19 (irq 9), version 1.0, legacy support
> usb0 at ohci0: USB revision 1.0
> uhub0 at usb0
> uhub0: AMD OHCI root hub, rev 1.00/1.00, addr 1
> uhub0: 3 ports with 3 removable, self powered
> ohci1 at pci1 dev 0 function 1 "AMD 8111 USB" rev 0x0b: apic 2 int 19 (irq 9), version 1.0, legacy support
> usb1 at ohci1: USB revision 1.0
> uhub1 at usb1
> uhub1: AMD OHCI root hub, rev 1.00/1.00, addr 1
> uhub1: 3 ports with 3 removable, self powered
> vga1 at pci1 dev 4 function 0 "ATI Rage XL" rev 0x27
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> pcib0 at pci0 dev 7 function 0 "AMD AMD8111 LPC" rev 0x05
> pciide0 at pci0 dev 7 function 1 "AMD 8111 IDE" rev 0x03: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
> pciide0: channel 0 disabled (no drives)
> pciide0: channel 1 disabled (no drives)
> amdiic0 at pci0 dev 7 function 2 "AMD 8111 SMBus" rev 0x02: SCI
> iic0 at amdiic0
> lm1 at iic0 addr 0x2d: W83627HF
> lm2 at iic0 addr 0x2f: W83782D rev D
> amdpm0 at pci0 dev 7 function 3 "AMD 8111 Power" rev 0x05: rng active
> iic1 at amdpm0
> ppb1 at pci0 dev 10 function 0 "AMD 8131 PCIX" rev 0x13
> pci2 at ppb1 bus 3
> bge0 at pci2 dev 5 function 0 "Broadcom BCM5704C" rev 0x10, BCM5704 B0 (0x2100): apic 3 int 2 (irq 5), address 00:30:48:77:04:6e
> brgphy0 at bge0 phy 1: BCM5704 10/100/1000baseT PHY, rev. 0
> bge1 at pci2 dev 5 function 1 "Broadcom BCM5704C" rev 0x10, BCM5704 B0 (0x2100): apic 3 int 3 (irq 9), address 00:30:48:77:04:6f
> brgphy1 at bge1 phy 1: BCM5704 10/100/1000baseT PHY, rev. 0
> aapic0 at pci0 dev 10 function 1 "AMD 8131 PCIX IOAPIC" rev 0x01
> ppb2 at pci0 dev 11 function 0 "AMD 8131 PCIX" rev 0x13
> pci3 at ppb2 bus 1
> ppb3 at pci3 dev 1 function 0 vendor "Intel", unknown product 0x0335 rev 0x07
> pci4 at ppb3 bus 2
> ami0 at pci4 dev 14 function 0 "Symbios Logic MegaRAID SATA 4x/8x" rev 0x07: apic 4 int 0 (irq 10)
> ami0: LSI 3008, 32b, FW 813G, BIOS vH425, 128MB RAM
> ami0: 1 channels, 0 FC loops, 3 logical drives
> scsibus0 at ami0: 40 targets
> sd0 at scsibus0 targ 0 lun 0: <AMI, Host drive #00, > SCSI2 0/direct fixed
> sd0: 75340MB, 75340 cyl, 64 head, 32 sec, 512 bytes/sec, 154296320 sec total
> sd1 at scsibus0 targ 1 lun 0: <AMI, Host drive #01, > SCSI2 0/direct fixed
> sd1: 237464MB, 237464 cyl, 64 head, 32 sec, 512 bytes/sec, 486326272 sec total
> sd2 at scsibus0 targ 2 lun 0: <AMI, Host drive #02, > SCSI2 0/direct fixed
> sd2: 237464MB, 237464 cyl, 64 head, 32 sec, 512 bytes/sec, 486326272 sec total
> scsibus1 at ami0: 16 targets
> aapic1 at pci0 dev 11 function 1 "AMD 8131 PCIX IOAPIC" rev 0x01
> pchb0 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
> pchb1 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
> pchb2 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
> pchb3 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
> pchb4 at pci0 dev 25 function 0 "AMD AMD64 HyperTransport" rev 0x00
> pchb5 at pci0 dev 25 function 1 "AMD AMD64 Address Map" rev 0x00
> pchb6 at pci0 dev 25 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
> pchb7 at pci0 dev 25 function 3 "AMD AMD64 Misc Cfg" rev 0x00
> isa0 at pcib0
> isadma0 at isa0
> com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
> com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
> pckbc0 at isa0 port 0x60/5
> pckbd0 at pckbc0 (kbd slot)
> pckbc0: using irq 1 for kbd slot
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pcppi0 at isa0 port 0x61
> midi0 at pcppi0: <PC speaker>
> spkr0 at pcppi0
> lpt0 at isa0 port 0x378/4 irq 7
> lm0 at isa0 port 0x290/8: W83627HF
> lm1 detached
> dkcsum: sd0 matches BIOS drive 0x80
> dkcsum: sd1 matches BIOS drive 0x81
> dkcsum: sd2 matches BIOS drive 0x82
> root on sd0a
> rootdev=0x400 rrootdev=0xd00 rawdev=0xd02
> WARNING: / was not properly unmounted

Reply | Threaded
Open this post in threaded view
|

Re: ami on AMD64 - hard lockups on write; 3.9 -current

Kenneth R Westerback
In reply to this post by Marten King
On Fri, Apr 07, 2006 at 11:44:38AM -0500, [hidden email] wrote:

> Hi,
>
> Writing to any logical drives beyond the primary causes hard lockup.
> Newfs hangs towards the end of writing superblocks and the machine
> needs to be powered off. The machine runs fine using only sd0.
>
> Others are using these cards; are there known firmware problems that
> could be related?
>
> TIA
>
> 3.9 -current AMD64 bsd.mp

Try -current as of today. A fix was committed to ami (ami.c r1.143)
to address problems with timeout setup on the sync cache command. It
fixed similar hangups I was having.

.... Ken

>
> # bioctl -hi ami0
> Volume  Status  Size   Device  
>  ami0 0 Online  73.6G  sd0     RAID1
>       0 Online  74.5G  0:0.0   noencl <ST3808110AS     2AAA>
>       1 Online  74.5G  0:1.0   noencl <ST3808110AS     2AAA>
>  ami0 1 Online   232G  sd1     RAID1
>       0 Online   233G  0:2.0   noencl <ST3250824AS     3.AA>
>       1 Online   233G  0:4.0   noencl <ST3250824AS     3.AA>
>  ami0 2 Online   232G  sd2     RAID1
>       0 Online   233G  0:5.0   noencl <ST3250824AS     3.AA>
>       1 Online   233G  0:7.0   noencl <ST3250824AS     3.AA>
>
>
> OpenBSD 3.9-current (GENERIC.MP) #769: Mon Apr  3 17:19:21 MDT 2006
>     [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
> real mem = 2147020800 (2096700K)
> avail mem = 1835683840 (1792660K)
> using 22937 buffers containing 214908928 bytes (209872K) of memory
> mainbus0 (root)
> ipmi at mainbus0 not configured
> mainbus0: Intel MP Specification (Version 1.4) (MSI      RHAPSODY    )
> cpu0 at mainbus0: apid 0 (boot processor)
> cpu0: AMD Opteron(tm) Processor 246, 1994.58 MHz
> cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,NXE,MMXX,LONG,3DNOW2,3DNOW
> cpu0: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 1MB 64b/line 16-way L2 cache
> cpu0: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
> cpu0: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
> cpu0: apic clock running at 199MHz
> cpu1 at mainbus0: apid 1 (application processor)
> cpu1: AMD Opteron(tm) Processor 246, 1994.32 MHz
> cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,NXE,MMXX,LONG,3DNOW2,3DNOW
> cpu1: 64KB 64b/line 2-way I-cache, 64KB 64b/line 2-way D-cache, 1MB 64b/line 16-way L2 cache
> cpu1: ITLB 32 4KB entries fully associative, 8 4MB entries fully associative
> cpu1: DTLB 32 4KB entries fully associative, 8 4MB entries fully associative
> mpbios: bus 0 is type PCI  
> mpbios: bus 1 is type PCI  
> mpbios: bus 2 is type PCI  
> mpbios: bus 3 is type PCI  
> mpbios: bus 4 is type PCI  
> mpbios: bus 5 is type ISA  
> ioapic0 at mainbus0 apid 2 pa 0xfec00000, version 11, 24 pins
> ioapic1 at mainbus0 apid 3 pa 0xfebfe000, version 11, 4 pins
> ioapic2 at mainbus0 apid 4 pa 0xfebff000, version 11, 4 pins
> pci0 at mainbus0 bus 0: configuration mode 1
> ppb0 at pci0 dev 6 function 0 "AMD 8111 PCI-PCI" rev 0x07
> pci1 at ppb0 bus 4
> ohci0 at pci1 dev 0 function 0 "AMD 8111 USB" rev 0x0b: apic 2 int 19 (irq 9), version 1.0, legacy support
> usb0 at ohci0: USB revision 1.0
> uhub0 at usb0
> uhub0: AMD OHCI root hub, rev 1.00/1.00, addr 1
> uhub0: 3 ports with 3 removable, self powered
> ohci1 at pci1 dev 0 function 1 "AMD 8111 USB" rev 0x0b: apic 2 int 19 (irq 9), version 1.0, legacy support
> usb1 at ohci1: USB revision 1.0
> uhub1 at usb1
> uhub1: AMD OHCI root hub, rev 1.00/1.00, addr 1
> uhub1: 3 ports with 3 removable, self powered
> vga1 at pci1 dev 4 function 0 "ATI Rage XL" rev 0x27
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> pcib0 at pci0 dev 7 function 0 "AMD AMD8111 LPC" rev 0x05
> pciide0 at pci0 dev 7 function 1 "AMD 8111 IDE" rev 0x03: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
> pciide0: channel 0 disabled (no drives)
> pciide0: channel 1 disabled (no drives)
> amdiic0 at pci0 dev 7 function 2 "AMD 8111 SMBus" rev 0x02: SCI
> iic0 at amdiic0
> lm1 at iic0 addr 0x2d: W83627HF
> lm2 at iic0 addr 0x2f: W83782D rev D
> amdpm0 at pci0 dev 7 function 3 "AMD 8111 Power" rev 0x05: rng active
> iic1 at amdpm0
> ppb1 at pci0 dev 10 function 0 "AMD 8131 PCIX" rev 0x13
> pci2 at ppb1 bus 3
> bge0 at pci2 dev 5 function 0 "Broadcom BCM5704C" rev 0x10, BCM5704 B0 (0x2100): apic 3 int 2 (irq 5), address 00:30:48:77:04:6e
> brgphy0 at bge0 phy 1: BCM5704 10/100/1000baseT PHY, rev. 0
> bge1 at pci2 dev 5 function 1 "Broadcom BCM5704C" rev 0x10, BCM5704 B0 (0x2100): apic 3 int 3 (irq 9), address 00:30:48:77:04:6f
> brgphy1 at bge1 phy 1: BCM5704 10/100/1000baseT PHY, rev. 0
> aapic0 at pci0 dev 10 function 1 "AMD 8131 PCIX IOAPIC" rev 0x01
> ppb2 at pci0 dev 11 function 0 "AMD 8131 PCIX" rev 0x13
> pci3 at ppb2 bus 1
> ppb3 at pci3 dev 1 function 0 vendor "Intel", unknown product 0x0335 rev 0x07
> pci4 at ppb3 bus 2
> ami0 at pci4 dev 14 function 0 "Symbios Logic MegaRAID SATA 4x/8x" rev 0x07: apic 4 int 0 (irq 10)
> ami0: LSI 3008, 32b, FW 813G, BIOS vH425, 128MB RAM
> ami0: 1 channels, 0 FC loops, 3 logical drives
> scsibus0 at ami0: 40 targets
> sd0 at scsibus0 targ 0 lun 0: <AMI, Host drive #00, > SCSI2 0/direct fixed
> sd0: 75340MB, 75340 cyl, 64 head, 32 sec, 512 bytes/sec, 154296320 sec total
> sd1 at scsibus0 targ 1 lun 0: <AMI, Host drive #01, > SCSI2 0/direct fixed
> sd1: 237464MB, 237464 cyl, 64 head, 32 sec, 512 bytes/sec, 486326272 sec total
> sd2 at scsibus0 targ 2 lun 0: <AMI, Host drive #02, > SCSI2 0/direct fixed
> sd2: 237464MB, 237464 cyl, 64 head, 32 sec, 512 bytes/sec, 486326272 sec total
> scsibus1 at ami0: 16 targets
> aapic1 at pci0 dev 11 function 1 "AMD 8131 PCIX IOAPIC" rev 0x01
> pchb0 at pci0 dev 24 function 0 "AMD AMD64 HyperTransport" rev 0x00
> pchb1 at pci0 dev 24 function 1 "AMD AMD64 Address Map" rev 0x00
> pchb2 at pci0 dev 24 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
> pchb3 at pci0 dev 24 function 3 "AMD AMD64 Misc Cfg" rev 0x00
> pchb4 at pci0 dev 25 function 0 "AMD AMD64 HyperTransport" rev 0x00
> pchb5 at pci0 dev 25 function 1 "AMD AMD64 Address Map" rev 0x00
> pchb6 at pci0 dev 25 function 2 "AMD AMD64 DRAM Cfg" rev 0x00
> pchb7 at pci0 dev 25 function 3 "AMD AMD64 Misc Cfg" rev 0x00
> isa0 at pcib0
> isadma0 at isa0
> com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
> com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
> pckbc0 at isa0 port 0x60/5
> pckbd0 at pckbc0 (kbd slot)
> pckbc0: using irq 1 for kbd slot
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pcppi0 at isa0 port 0x61
> midi0 at pcppi0: <PC speaker>
> spkr0 at pcppi0
> lpt0 at isa0 port 0x378/4 irq 7
> lm0 at isa0 port 0x290/8: W83627HF
> lm1 detached
> dkcsum: sd0 matches BIOS drive 0x80
> dkcsum: sd1 matches BIOS drive 0x81
> dkcsum: sd2 matches BIOS drive 0x82
> root on sd0a
> rootdev=0x400 rrootdev=0xd00 rawdev=0xd02
> WARNING: / was not properly unmounted