ahci issue corebooted X220 does not recognise usb or stata

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

ahci issue corebooted X220 does not recognise usb or stata

Thomas Meulendijks
Hi OpenBSD Mailing list,

I am trying to install Openbsd via the install66.fs on a Thinkpad X220 [amd64] with coreboot.
I have the problem that it does not recognize any USB or SATA device may it be storage or peripherals like a keyboard, except for the boot USB.
I tried with external USB storage, multiple different internal SSD's, multiple USB keyboards, but sysctl does not show anything and dmesg does not give a message when plugged in or out.
I also tried with the grub and seabios payloads but it did not make a difference.
Coreboot and payloads are compiled at master and agenst the latest stable version but it did not make a difference.
coreboot Master version is 4.11-1189.

When I look at dmesg I see ahci failed, I know you guys will need to see my dmesg but since I can't save it to a drive [read problem above]
and the installation fs only has ftp to communicate to the web as far as I can see and I don't know how to set up a ftp server, I am at a loss of how to get it out.
Maybe I am missing something?

A part of dmesg I think may be helpful that I typed over:

....
em0 at pci0 dev 25 function 0 "Intel 82579LM" rev 0x05: msiem0: The EEPROM Checksum Is Not Valid
em0: Unable to initialize the hardware
ehci0 at pci0 dev 26 function 0 "Intel 6 Series USB" rev 0x05: apci 2 int 19
ehci0: reset timeout
ehci0 init failed, error=13
....
ehci1 at pci0 dev 29 function 0 "Intel 6 Series USB" rev 0x05: apci 2 int 18
ehci1: reset timeout
ehci1 init failed, error=13
"Intel QM67 LPC" rev 0x05 at pci0 dev 31 function 0 not configured
ahci0 at pci0 dev 31 function 2 "Intel 6 Series AHCI" rev 0x05: msi, unable to reset controller
"Intel 6 Series SMBus" rev 0x05 at pci0 dev 31 function 3 not configured
"Intel 6 Series Thermal" rev 0x05 at pci0 dev 31 function 6 not configured
....

I hope this is enough info and would greatly appreciate it if anyone could help me out!

Greetings,

Thomas

Reply | Threaded
Open this post in threaded view
|

Re: ahci issue corebooted X220 does not recognise usb or stata

Claudio Jeker
On Wed, Feb 19, 2020 at 02:34:40PM +0100, Thomas Meulendijks wrote:

> Hi OpenBSD Mailing list,
>
> I am trying to install Openbsd via the install66.fs on a Thinkpad X220 [amd64] with coreboot.
> I have the problem that it does not recognize any USB or SATA device may it be storage or peripherals like a keyboard, except for the boot USB.
> I tried with external USB storage, multiple different internal SSD's, multiple USB keyboards, but sysctl does not show anything and dmesg does not give a message when plugged in or out.
> I also tried with the grub and seabios payloads but it did not make a difference.
> Coreboot and payloads are compiled at master and agenst the latest stable version but it did not make a difference.
> coreboot Master version is 4.11-1189.
>
> When I look at dmesg I see ahci failed, I know you guys will need to see my dmesg but since I can't save it to a drive [read problem above]
> and the installation fs only has ftp to communicate to the web as far as I can see and I don't know how to set up a ftp server, I am at a loss of how to get it out.
> Maybe I am missing something?

The Thinkpad X220 works with its original BIOS so the problem is with your
coreboot and not with OpenBSD. coreboot fails to properly report something
(most probably some of the ACPI or SMBIOS information is wrong) and
because of that every PCI access seems to fail. Most probably pci0 is not
setup correctly.

We can't help you here, you changed your BIOS with something that is not
quite right. You should reach out to coreboot.
 

> A part of dmesg I think may be helpful that I typed over:
>
> ....
> em0 at pci0 dev 25 function 0 "Intel 82579LM" rev 0x05: msiem0: The EEPROM Checksum Is Not Valid
> em0: Unable to initialize the hardware
> ehci0 at pci0 dev 26 function 0 "Intel 6 Series USB" rev 0x05: apci 2 int 19
> ehci0: reset timeout
> ehci0 init failed, error=13
> ....
> ehci1 at pci0 dev 29 function 0 "Intel 6 Series USB" rev 0x05: apci 2 int 18
> ehci1: reset timeout
> ehci1 init failed, error=13
> "Intel QM67 LPC" rev 0x05 at pci0 dev 31 function 0 not configured
> ahci0 at pci0 dev 31 function 2 "Intel 6 Series AHCI" rev 0x05: msi, unable to reset controller
> "Intel 6 Series SMBus" rev 0x05 at pci0 dev 31 function 3 not configured
> "Intel 6 Series Thermal" rev 0x05 at pci0 dev 31 function 6 not configured
> ....
>
> I hope this is enough info and would greatly appreciate it if anyone could help me out!
>
> Greetings,
>
> Thomas
>

--
:wq Claudio

Reply | Threaded
Open this post in threaded view
|

Re: ahci issue corebooted X220 does not recognise usb or stata

Stefan Sperling-5
In reply to this post by Thomas Meulendijks
You should be reporting these to coreboot, not here.

On Wed, Feb 19, 2020 at 02:34:40PM +0100, Thomas Meulendijks wrote:

> Hi OpenBSD Mailing list,
>
> I am trying to install Openbsd via the install66.fs on a Thinkpad X220 [amd64] with coreboot.
> I have the problem that it does not recognize any USB or SATA device may it be storage or peripherals like a keyboard, except for the boot USB.
> I tried with external USB storage, multiple different internal SSD's, multiple USB keyboards, but sysctl does not show anything and dmesg does not give a message when plugged in or out.
> I also tried with the grub and seabios payloads but it did not make a difference.
> Coreboot and payloads are compiled at master and agenst the latest stable version but it did not make a difference.
> coreboot Master version is 4.11-1189.
>
> When I look at dmesg I see ahci failed, I know you guys will need to see my dmesg but since I can't save it to a drive [read problem above]
> and the installation fs only has ftp to communicate to the web as far as I can see and I don't know how to set up a ftp server, I am at a loss of how to get it out.
> Maybe I am missing something?
>
> A part of dmesg I think may be helpful that I typed over:
>
> ....
> em0 at pci0 dev 25 function 0 "Intel 82579LM" rev 0x05: msiem0: The EEPROM Checksum Is Not Valid
> em0: Unable to initialize the hardware
> ehci0 at pci0 dev 26 function 0 "Intel 6 Series USB" rev 0x05: apci 2 int 19
> ehci0: reset timeout
> ehci0 init failed, error=13
> ....
> ehci1 at pci0 dev 29 function 0 "Intel 6 Series USB" rev 0x05: apci 2 int 18
> ehci1: reset timeout
> ehci1 init failed, error=13
> "Intel QM67 LPC" rev 0x05 at pci0 dev 31 function 0 not configured
> ahci0 at pci0 dev 31 function 2 "Intel 6 Series AHCI" rev 0x05: msi, unable to reset controller
> "Intel 6 Series SMBus" rev 0x05 at pci0 dev 31 function 3 not configured
> "Intel 6 Series Thermal" rev 0x05 at pci0 dev 31 function 6 not configured
> ....
>
> I hope this is enough info and would greatly appreciate it if anyone could help me out!
>
> Greetings,
>
> Thomas
>
>