Xorg very slow startup (X1 Carbon, Intel 5500) -current

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Xorg very slow startup (X1 Carbon, Intel 5500) -current

Conor O'Reilly
I am using a 2015 Thinkpad X1 Carbon and am having issues starting X. I
first came across this issue with 5.7 and it persists. I was hoping with
the addition of the Broadwell drivers that it would be corrected however
that is not the case.

I installed -current snapshot this morning and it takes about 7 minutes to
boot into fvwm or cwm. I have tried openbox, WindowMaker, etc and it is the
same thing. When I finally to get into X, everything works as it should.
Exiting takes a bit longer but I am able to get out by putting
DisplayManager.*.resetSignal: 9 into /etc/X11/xdm/xdm-config. Subsequent
times after the initial boot are about 5 minutes from startx until I get to
a usable desktop. I have included my dmesg and my Xorg.0.log from this
morning's snapshot.

Any help with why it takes so long to get into X and how I can fix this
would be greatly appreciated.


OpenBSD 5.8-current (GENERIC.MP) #1385: Mon Sep 28 03:51:26 MDT 2015
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
RTC BIOS diagnostic error 80<clock_battery>
real mem = 8260685824 (7878MB)
avail mem = 8006217728 (7635MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xccbfd000 (66 entries)
bios0: vendor LENOVO version "N14ET26W (1.04 )" date 01/23/2015
bios0: LENOVO 20BSCTO1WW
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP ASF! HPET ECDT APIC MCFG SSDT SSDT SSDT SSDT SSDT
SSDT SSDT SSDT SSDT PCCT SSDT UEFI MSDM BATB FPDT UEFI
acpi0: wakeup devices LID_(S4) SLPB(S3) IGBE(S4) EXP2(S4) XHCI(S3) EHC1(S3)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpiec0 at acpi0
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i7-5600U CPU @ 2.60GHz, 2494.63 MHz
cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX
,SMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT
,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,3DNOWP,PERF,ITS
C,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,RDSEED,ADX,SMAP,SENSOR,AR
AT
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM) i7-5600U CPU @ 2.60GHz, 2494.22 MHz
cpu1:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX
,SMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT
,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,3DNOWP,PERF,ITS
C,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,RDSEED,ADX,SMAP,SENSOR,AR
AT
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 1, core 0, package 0
cpu2 at mainbus0: apid 2 (application processor)
cpu2: Intel(R) Core(TM) i7-5600U CPU @ 2.60GHz, 2494.22 MHz
cpu2:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX
,SMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT
,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,3DNOWP,PERF,ITS
C,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,RDSEED,ADX,SMAP,SENSOR,AR
AT
cpu2: 256KB 64b/line 8-way L2 cache
cpu2: smt 0, core 1, package 0
cpu3 at mainbus0: apid 3 (application processor)
cpu3: Intel(R) Core(TM) i7-5600U CPU @ 2.60GHz, 2494.23 MHz
cpu3:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX
,SMX,EST,TM2,SSSE3,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT
,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,LONG,LAHF,ABM,3DNOWP,PERF,ITS
C,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,RDSEED,ADX,SMAP,SENSOR,AR
AT
cpu3: 256KB 64b/line 8-way L2 cache
cpu3: smt 1, core 1, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 40 pins
acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PEG_)
acpiprt2 at acpi0: bus 3 (EXP1)
acpiprt3 at acpi0: bus 4 (EXP2)
acpiprt4 at acpi0: bus -1 (EXP3)
acpiprt5 at acpi0: bus 10 (EXP6)
acpicpu0 at acpi0: C3(200@233 mwait.1@0x40), C2(200@148 mwait.1@0x33),
C1(1000@1 mwait.1), PSS
acpicpu1 at acpi0: C3(200@233 mwait.1@0x40), C2(200@148 mwait.1@0x33),
C1(1000@1 mwait.1), PSS
acpicpu2 at acpi0: C3(200@233 mwait.1@0x40), C2(200@148 mwait.1@0x33),
C1(1000@1 mwait.1), PSS
acpicpu3 at acpi0: C3(200@233 mwait.1@0x40), C2(200@148 mwait.1@0x33),
C1(1000@1 mwait.1), PSS
acpipwrres0 at acpi0: PUBS, resource for XHCI, EHC1
acpipwrres1 at acpi0: NVP3, resource for PEG_
acpipwrres2 at acpi0: NVP2, resource for PEG_
acpitz0 at acpi0: critical temperature is 128 degC
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: SLPB
acpibat0 at acpi0: BAT0 model "00HW003" serial   785 type LiP oem "SMP"
acpibat1 at acpi0: BAT1 not present
acpiac0 at acpi0: AC unit online
acpithinkpad0 at acpi0
cpu0: Enhanced SpeedStep 2494 MHz: speeds: 2601, 2600, 2500, 2300, 2100,
2000, 1800, 1700, 1500, 1400, 1200, 1100, 900, 800, 600, 500 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 5G Host" rev 0x09
vga1 at pci0 dev 2 function 0 "Intel HD Graphics 5500" rev 0x09
intagp at vga1 not configured
inteldrm0 at vga1
drm0 at inteldrm0
inteldrm0: msi
inteldrm0: 2560x1440
wsdisplay0 at vga1 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
azalia0 at pci0 dev 3 function 0 "Intel Core 5G HD Audio" rev 0x09: msi
xhci0 at pci0 dev 20 function 0 "Intel 9 Series xHCI" rev 0x03: msi
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
"Intel 9 Series MEI" rev 0x03 at pci0 dev 22 function 0 not configured
em0 at pci0 dev 25 function 0 "Intel I218-LM" rev 0x03: msi, address
54:ee:75:48:ca:70
azalia1 at pci0 dev 27 function 0 "Intel 9 Series HD Audio" rev 0x03: msi
azalia1: codecs: Realtek ALC292
audio0 at azalia1
ppb0 at pci0 dev 28 function 0 "Intel 9 Series PCIE" rev 0xe3: msi
pci1 at ppb0 bus 3
ppb1 at pci0 dev 28 function 1 "Intel 9 Series PCIE" rev 0xe3: msi
pci2 at ppb1 bus 4
iwm0 at pci2 dev 0 function 0 "Intel Dual Band Wireless AC 7265" rev 0x59,
msi
ppb2 at pci0 dev 28 function 5 "Intel 9 Series PCIE" rev 0xe3: msi
pci3 at ppb2 bus 10
ahci0 at pci3 dev 0 function 0 "Samsung SM951" rev 0x01: apic 2 int 16,
AHCI 1.3
ahci0: port 0: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, SAMSUNG MZHPV512, BXW2> SCSI3 0/direct
fixed naa.5002538900000000
sd0: 488386MB, 512 bytes/sector, 1000215216 sectors, thin
ehci0 at pci0 dev 29 function 0 "Intel 9 Series USB" rev 0x03: apic 2 int 23
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
pcib0 at pci0 dev 31 function 0 "Intel 9 Series LPC" rev 0x03
ichiic0 at pci0 dev 31 function 3 "Intel 9 Series SMBus" rev 0x03: apic 2
int 18
iic0 at ichiic0
"Intel 9 Series Thermal" rev 0x03 at pci0 dev 31 function 6 not configured
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
wsmouse1 at pms0 mux 0
pms0: Synaptics clickpad, firmware 8.1
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
umodem0 at uhub0 port 4 configuration 1 interface 2 "Sierra Wireless Inc.
Sierra Wireless EM7345 4G LTE" rev 2.00/17.29 addr 2
umodem0: data interface 3, has no CM over data, has break
umodem0: status change notification available
ucom0 at umodem0
ugen0 at uhub0 port 4 configuration 1 "Sierra Wireless Inc. Sierra Wireless
EM7345 4G LTE" rev 2.00/17.29 addr 2
ugen1 at uhub0 port 6 "Validity Sensors VFS5011 Fingerprint Reader" rev
1.10/0.78 addr 3
ugen2 at uhub0 port 7 "Intel product 0x0a2a" rev 2.01/0.01 addr 4
uvideo0 at uhub0 port 8 configuration 1 interface 0 "Chicony Electronics
Co.,Ltd. Integrated Camera" rev 2.00/0.29 addr 5
video0 at uvideo0
uhub2 at uhub1 port 1 "Intel Rate Matching Hub" rev 2.00/0.03 addr 2
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a (f410ac8b38e9cf4b.a) swap on sd0b dump on sd0b
iwm0: hw rev 0x210, fw ver 25.228 (API ver 9), address 34:02:86:07:ff:a8


Xorg.0.log


[   713.011] (WW) checkDevMem: failed to open /dev/xf86 and /dev/mem
    (Operation not permitted)
    Check that you have set 'machdep.allowaperture=1'
    in /etc/sysctl.conf and reboot your machine
    refer to xf86(4) for details
[   713.011]     linear framebuffer access unavailable
[   713.018] (--) Using wscons driver on /dev/ttyC4 in pcvt compatibility
mode (version 3.32)
[   713.029]
X.Org X Server 1.17.2
Release Date: 2015-06-16
[   713.030] X Protocol Version 11, Revision 0
[   713.030] Build Operating System: OpenBSD 5.8 amd64
[   713.030] Current Operating System: OpenBSD orange.home 5.8
GENERIC.MP#1385 amd64
[   713.030] Build Date: 28 September 2015  04:33:01AM
[   713.030]
[   713.030] Current version of pixman: 0.32.6
[   713.030]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   713.030] Markers: (--) probed, (**) from config file, (==) default
setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   713.030] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep 28
10:52:38 2015
[   713.031] (==) Using system config directory
"/usr/X11R6/share/X11/xorg.conf.d"
[   713.032] (==) No Layout section.  Using the first Screen section.
[   713.032] (==) No screen section available. Using defaults.
[   713.032] (**) |-->Screen "Default Screen Section" (0)
[   713.032] (**) |   |-->Monitor "<default monitor>"
[   713.032] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[   713.032] (==) Disabling SIGIO handlers for input devices
[   713.032] (==) Automatically adding devices
[   713.032] (==) Automatically enabling devices
[   713.032] (==) Not automatically adding GPU devices
[   713.036] (==) FontPath set to:
    /usr/X11R6/lib/X11/fonts/misc/,
    /usr/X11R6/lib/X11/fonts/TTF/,
    /usr/X11R6/lib/X11/fonts/OTF/,
    /usr/X11R6/lib/X11/fonts/Type1/,
    /usr/X11R6/lib/X11/fonts/100dpi/,
    /usr/X11R6/lib/X11/fonts/75dpi/
[   713.037] (==) ModulePath set to "/usr/X11R6/lib/modules"
[   713.037] (II) The server relies on wscons to provide the list of input
devices.
    If no devices become available, reconfigure wscons or disable
AutoAddDevices.
[   713.037] (II) Loader magic: 0xdb08f831de0
[   713.037] (II) Module ABI versions:
[   713.037]     X.Org ANSI C Emulation: 0.4
[   713.037]     X.Org Video Driver: 19.0
[   713.037]     X.Org XInput driver : 21.0
[   713.037]     X.Org Server Extension : 9.0
[   713.037] (--) PCI:*(0:0:2:0) 8086:1616:17aa:2227 rev 9, Mem @
0xf0000000/16777216, 0xe0000000/268435456, I/O @ 0x00003000/64
[   713.037] (II) LoadModule: "glx"
[   713.038] (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
[   713.053] (II) Module glx: vendor="X.Org Foundation"
[   713.053]     compiled for 1.17.2, module version = 1.0.0
[   713.053]     ABI class: X.Org Server Extension, version 9.0
[   713.053] (==) AIGLX enabled
[   713.053] (==) Matched intel as autoconfigured driver 0
[   713.053] (==) Matched vesa as autoconfigured driver 1
[   713.053] (==) Assigned the driver to the xf86ConfigLayout
[   713.053] (II) LoadModule: "intel"
[   713.053] (II) Loading /usr/X11R6/lib/modules/drivers/intel_drv.so
[   713.055] (II) Module intel: vendor="X.Org Foundation"
[   713.055]     compiled for 1.17.2, module version = 2.99.916
[   713.055]     Module class: X.Org Video Driver
[   713.055]     ABI class: X.Org Video Driver, version 19.0
[   713.055] (II) LoadModule: "vesa"
[   713.055] (II) Loading /usr/X11R6/lib/modules/drivers/vesa_drv.so
[   713.056] (II) Module vesa: vendor="X.Org Foundation"
[   713.056]     compiled for 1.17.2, module version = 2.3.3
[   713.056]     Module class: X.Org Video Driver
[   713.056]     ABI class: X.Org Video Driver, version 19.0
[   713.056] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   713.056] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[   713.056] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[   713.056] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200,
6200, P6300
[   713.056] (II) VESA: driver for VESA chipsets: vesa
[   713.057] (II) intel(0): Using Kernel Mode Setting driver: i915, version
1.6.0 20080730
[   713.057] (WW) Falling back to old probe method for vesa
[   713.058] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD
graphics 5500
[   713.058] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2,
avx, avx2
[   713.058] (II) intel(0): Creating default Display subsection in Screen
section
    "Default Screen Section" for depth/fbbpp 24/32
[   713.058] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[   713.058] (==) intel(0): RGB weight 888
[   713.058] (==) intel(0): Default visual is TrueColor
[   713.059] (II) intel(0): Output eDP1 has no monitor section
[   713.059] (--) intel(0): Found backlight control interface wscons (type
'platform') for output eDP1
[   713.059] (II) intel(0): Enabled output eDP1
[   713.059] (II) intel(0): Output DP1 has no monitor section
[   713.059] (II) intel(0): Enabled output DP1
[   713.059] (II) intel(0): Output HDMI1 has no monitor section
[   713.059] (II) intel(0): Enabled output HDMI1
[   713.059] (II) intel(0): Output DP2 has no monitor section
[   713.059] (II) intel(0): Enabled output DP2
[   713.059] (II) intel(0): Output HDMI2 has no monitor section
[   713.059] (II) intel(0): Enabled output HDMI2
[   713.059] (--) intel(0): Using a maximum size of 64x64 for hardware
cursors
[   713.060] (II) intel(0): Output VIRTUAL1 has no monitor section
[   713.060] (II) intel(0): Enabled output VIRTUAL1
[   713.060] (--) intel(0): Output eDP1 using initial mode 2560x1440 on
pipe 0
[   713.060] (==) intel(0): TearFree disabled
[   713.060] (==) intel(0): DPI set to (96, 96)
[   713.060] (II) Loading sub module "dri2"
[   713.060] (II) LoadModule: "dri2"
[   713.060] (II) Module "dri2" already built-in
[   713.060] (II) Loading sub module "present"
[   713.060] (II) LoadModule: "present"
[   713.060] (II) Module "present" already built-in
[   713.060] (II) UnloadModule: "vesa"
[   713.060] (II) Unloading vesa
[   713.060] (==) Depth 24 pixmap format is 32 bpp
[   713.062] (II) intel(0): SNA initialized with Broadwell backend
[   713.062] (==) intel(0): Backing store enabled
[   713.062] (==) intel(0): Silken mouse disabled
[   713.062] (II) intel(0): HW Cursor enabled
[   713.062] (II) intel(0): RandR 1.2 enabled, ignore the following RandR
disabled message.
[   713.063] (==) intel(0): DPMS enabled
[   713.064] (II) intel(0): [DRI2] Setup complete
[   713.064] (II) intel(0): [DRI2]   DRI driver: i965
[   713.064] (II) intel(0): [DRI2]   VDPAU driver: i965
[   713.064] (II) intel(0): direct rendering: DRI2 enabled
[   713.064] (II) intel(0): hardware support for Present enabled
[   713.064] (--) RandR disabled
[   713.113] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[   713.113] (II) AIGLX: enabled GLX_ARB_create_context
[   713.113] (II) AIGLX: enabled GLX_ARB_create_context_profile
[   713.114] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[   713.114] (II) AIGLX: enabled GLX_INTEL_swap_event
[   713.114] (II) AIGLX: enabled GLX_SGI_swap_control and
GLX_MESA_swap_control
[   713.114] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[   713.114] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[   713.114] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer
objects
[   713.114] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[   713.114] (II) AIGLX: Loaded and initialized i965
[   713.114] (II) GLX: Initialized DRI2 GL provider for screen 0
[   713.118] (II) intel(0): switch to mode 2560x1440@60.0 on eDP1 using
pipe 0, position (0, 0), rotation normal, reflection none
[   713.134] (II) intel(0): Setting screen physical size to 677 x 381
[   713.225] (II) config/wscons: checking input device /dev/wskbd
[   713.225] (II) wskbd: using layout us
[   713.225] (II) LoadModule: "kbd"
[   713.226] (II) Loading /usr/X11R6/lib/modules/input/kbd_drv.so
[   713.226] (II) Module kbd: vendor="X.Org Foundation"
[   713.226]     compiled for 1.17.2, module version = 1.8.0
[   713.226]     Module class: X.Org XInput Driver
[   713.226]     ABI class: X.Org XInput driver, version 21.0
[   713.226] (II) Using input driver 'kbd' for '/dev/wskbd'
[   713.226] (**) /dev/wskbd: always reports core events
[   713.226] (**) /dev/wskbd: always reports core events
[   713.226] (**) Option "Protocol" "standard"
[   713.226] (**) Option "XkbRules" "base"
[   713.226] (**) Option "XkbModel" "pc105"
[   713.226] (**) Option "XkbLayout" "us"
[   713.226] (II) XINPUT: Adding extended input device "/dev/wskbd" (type:
KEYBOARD, id 6)
[   713.662] (II) config/wscons: checking input device /dev/wsmouse0
[   713.662] (**) /dev/wsmouse0: Applying InputClass "touchpad catchall"
[   713.662] (**) /dev/wsmouse0: Applying InputClass "Default clickpad
buttons"
[   713.662] (II) LoadModule: "synaptics"
[   713.663] (II) Loading /usr/X11R6/lib/modules/input/synaptics_drv.so
[   713.665] (II) Module synaptics: vendor="X.Org Foundation"
[   713.665]     compiled for 1.17.2, module version = 1.8.2
[   713.665]     Module class: X.Org XInput Driver
[   713.665]     ABI class: X.Org XInput driver, version 21.0
[   713.665] (II) Using input driver 'synaptics' for '/dev/wsmouse0'
[   713.665] (**) /dev/wsmouse0: always reports core events
[   713.665] (**) Option "Device" "/dev/wsmouse0"
[   714.526] (--) synaptics: /dev/wsmouse0: x-axis range 1472 - 5676
resolution 45
[   714.526] (--) synaptics: /dev/wsmouse0: y-axis range 1408 - 4758
resolution 68
[   714.527] (**) /dev/wsmouse0: always reports core events
[   714.531] (II) XINPUT: Adding extended input device "/dev/wsmouse0"
(type: TOUCHPAD, id 7)
[   714.531] (**) synaptics: /dev/wsmouse0: (accel) MinSpeed is now
constant deceleration 2.5
[   714.531] (**) synaptics: /dev/wsmouse0: (accel) MaxSpeed is now 1.75
[   714.531] (**) synaptics: /dev/wsmouse0: (accel) AccelFactor is now 0.037
[   714.531] (**) /dev/wsmouse0: (accel) keeping acceleration scheme 1
[   714.531] (**) /dev/wsmouse0: (accel) acceleration profile 1
[   714.531] (**) /dev/wsmouse0: (accel) acceleration factor: 2.000
[   714.531] (**) /dev/wsmouse0: (accel) acceleration threshold: 4
[   714.961] (II) config/wscons: checking input device /dev/wsmouse
[   714.961] (II) LoadModule: "ws"
[   714.962] (II) Loading /usr/X11R6/lib/modules/input/ws_drv.so
[   714.963] (II) Module ws: vendor="X.Org Foundation"
[   714.963]     compiled for 1.17.2, module version = 1.3.0
[   714.963]     Module class: X.Org XInput Driver
[   714.963]     ABI class: X.Org XInput driver, version 21.0
[   714.963] (II) Using input driver 'ws' for '/dev/wsmouse'
[   714.963] (**) /dev/wsmouse: always reports core events
[   714.963] (II) ws: /dev/wsmouse: debuglevel 0
[   714.963] (**) Option "Device" "/dev/wsmouse"
[   714.963] (**) ws: /dev/wsmouse: ZAxisMapping: buttons 4 and 5
[   714.963] (**) ws: /dev/wsmouse: WAxisMapping: buttons 6 and 7
[   714.963] (**) ws: /dev/wsmouse: associated screen: 0
[   714.963] (II) ws: /dev/wsmouse: minimum x position: 0
[   714.963] (II) ws: /dev/wsmouse: maximum x position: 2559
[   714.963] (II) ws: /dev/wsmouse: minimum y position: 0
[   714.963] (II) ws: /dev/wsmouse: maximum y position: 1439
[   714.963] (==) ws: /dev/wsmouse: Buttons: 7
[   714.963] (**) ws: /dev/wsmouse: YAxisMapping: buttons 4 and 5
[   714.963] (II) XINPUT: Adding extended input device "/dev/wsmouse"
(type: MOUSE, id 8)
[   714.963] (**) /dev/wsmouse: (accel) keeping acceleration scheme 1
[   714.963] (**) /dev/wsmouse: (accel) acceleration profile 0
[   714.963] (**) /dev/wsmouse: (accel) acceleration factor: 2.000
[   714.963] (**) /dev/wsmouse: (accel) acceleration threshold: 4

Reply | Threaded
Open this post in threaded view
|

Re: Xorg very slow startup (X1 Carbon, Intel 5500) -current

Ted Unangst-6
Conor O'Reilly wrote:

> I am using a 2015 Thinkpad X1 Carbon and am having issues starting X. I
> first came across this issue with 5.7 and it persists. I was hoping with
> the addition of the Broadwell drivers that it would be corrected however
> that is not the case.
>
> I installed -current snapshot this morning and it takes about 7 minutes to
> boot into fvwm or cwm. I have tried openbox, WindowMaker, etc and it is the
> same thing. When I finally to get into X, everything works as it should.
> Exiting takes a bit longer but I am able to get out by putting
> DisplayManager.*.resetSignal: 9 into /etc/X11/xdm/xdm-config. Subsequent
> times after the initial boot are about 5 minutes from startx until I get to
> a usable desktop. I have included my dmesg and my Xorg.0.log from this
> morning's snapshot.
>
> Any help with why it takes so long to get into X and how I can fix this
> would be greatly appreciated.

several people with the same laptop don't have this problem. don't think it's
hardware.

this is classic "no DNS" behavior though. X really, really, really wants to
know your hostname forwards and backwards and sideways and if it doesn't get
what it wants, you get to wait until it does...

I'd look into your network config.