Work-around for not-shown JPEG images in www/links+

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Work-around for not-shown JPEG images in www/links+

wenzehan
Hello, everybody!

My links+ in 6.4 would not display JPEG images and I figured it was due
to the configure script not detecting jpeglib. My current work-around:

1. define HAVE_LOCAL_H with 1 /usr/local/include/jconfig.h:
        -#define HAVE_LOCAL_H
        +#define HAVE_LOCAL_H 1
2. rebuild the package
        $ cd /usr/ports/www/links+
        $ make package
3. (as root) replace with self-compiled package
        # cd /usr/ports/packages/all
        # pkg_add -vrD unsigned links+*

I don't see whether upstream deliberately or accidentally does
#cmakedefine HAVE_LOCAL_H
instead of
#cmakedefine HAVE_LOCAL_H 1
and I, honestly, don't care. Just want to get this off my mind.

Guten Rutsch!
--
Hannes Wenzel <[hidden email]>


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Work-around for not-shown JPEG images in www/links+

Ted Unangst-6
Hannes Wenzel wrote:
> I don't see whether upstream deliberately or accidentally does
> #cmakedefine HAVE_LOCAL_H
> instead of
> #cmakedefine HAVE_LOCAL_H 1
> and I, honestly, don't care. Just want to get this off my mind.

fyi, the port was updated after 6.4 to fix this.

http://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/graphics/jpeg/Makefile

Reply | Threaded
Open this post in threaded view
|

Re: Work-around for not-shown JPEG images in www/links+

trondd-2
On Sat, December 29, 2018 5:14 pm, Ted Unangst wrote:

> Hannes Wenzel wrote:
>> I don't see whether upstream deliberately or accidentally does
>> #cmakedefine HAVE_LOCAL_H
>> instead of
>> #cmakedefine HAVE_LOCAL_H 1
>> and I, honestly, don't care. Just want to get this off my mind.
>
> fyi, the port was updated after 6.4 to fix this.
>
> http://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/graphics/jpeg/Makefile
>

Yup.  Thanks.  Also the relevant ports@ thread

https://marc.info/?l=openbsd-ports&m=154212464114072&w=2