Wireless LAN woes - ath driver

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Wireless LAN woes - ath driver

Aaron Mason
Hi all,

I have a laptop with an Atheros 2413-based wireless card running
OpenBSD 4.6 (09Sep09 snapshot) which worked fine connecting to my
WPA-enabled Netcomm NB6PLUS4W.  Well it died from overheating not long
ago and was hastily replaced by a Cisco 877 and a Netgear WG602
wireless router, which can only do WEP.  I set it up with a 128 bit
WEP key (still only a stop gap measure, an Alix board and DCMA81 are
on their way to replace it) and while it works fine on my Asus Eee
running Windows XP home and my partner's Dell Inspiron 1525 running
Windows 7, it fails almost completely on this laptop.

It can establish a connection, but TCP/IP performance is incredibly
unstable (WEP key censored for obvious reasons):

$ cat /etc/hostname.ath0
inet 192.168.1.253 255.255.255.0 NONE nwid AZZACASS-TEMP nwkey \
0xDECAFC0FFEECAECDEAD9000DAD
$ ping -c 400 192.168.1.254
PING 192.168.1.254 (192.168.1.254): 56 data bytes
64 bytes from 192.168.1.254: icmp_seq=77 ttl=255 time=67.710 ms
64 bytes from 192.168.1.254: icmp_seq=83 ttl=255 time=122.036 ms
64 bytes from 192.168.1.254: icmp_seq=84 ttl=255 time=23.836 ms
64 bytes from 192.168.1.254: icmp_seq=85 ttl=255 time=71.204 ms
64 bytes from 192.168.1.254: icmp_seq=90 ttl=255 time=5.063 ms
64 bytes from 192.168.1.254: icmp_seq=91 ttl=255 time=16.174 ms
64 bytes from 192.168.1.254: icmp_seq=92 ttl=255 time=18.868 ms
64 bytes from 192.168.1.254: icmp_seq=93 ttl=255 time=5.765 ms
64 bytes from 192.168.1.254: icmp_seq=94 ttl=255 time=7.194 ms
64 bytes from 192.168.1.254: icmp_seq=98 ttl=255 time=6.420 ms
64 bytes from 192.168.1.254: icmp_seq=107 ttl=255 time=9.166 ms
64 bytes from 192.168.1.254: icmp_seq=110 ttl=255 time=129.187 ms
64 bytes from 192.168.1.254: icmp_seq=112 ttl=255 time=6.756 ms
64 bytes from 192.168.1.254: icmp_seq=114 ttl=255 time=139.026 ms
64 bytes from 192.168.1.254: icmp_seq=115 ttl=255 time=152.119 ms
64 bytes from 192.168.1.254: icmp_seq=116 ttl=255 time=166.641 ms
64 bytes from 192.168.1.254: icmp_seq=118 ttl=255 time=94.697 ms
64 bytes from 192.168.1.254: icmp_seq=213 ttl=255 time=5.392 ms
64 bytes from 192.168.1.254: icmp_seq=375 ttl=255 time=8.643 ms
--- 192.168.1.254 ping statistics ---
400 packets transmitted, 19 packets received, 95.2% packet loss
round-trip min/avg/max/std-dev = 5.063/55.573/166.641/57.735 ms
$ ifconfig ath0
ath0: flags=8863<UP,BROADCAST,NOTRAILERS,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        lladdr 00:11:f5:a7:ab:e1
        priority: 4
        groups: wlan egress
        media: IEEE802.11 autoselect (DS1 mode 11b)
        status: active
        ieee80211: nwid AZZACASS-TEMP chan 1 bssid [redacted] 60%
nwkey <not displayed>
        inet 192.168.1.253 netmask 0xffffff00 broadcast 192.168.1.255
        inet6 [redacted] prefixlen 64 scopeid 0x1
$

It worked fine when I had a WPA-based router and while it is due for
replacement, I'd rather find out why this didn't work as I will be
using this router again should the replacement fail at any time.  It
seems to me that the BSDs don't like 128-bit keys much because my
brother-in-law's MacBook Pro couldn't talk TCP/IP either.

Any ideas?  Following is my dmesg, if it helps:

OpenBSD 4.6-current (GENERIC) #172: Wed Sep  9 07:44:33 MDT 2009
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Celeron(R) M processor 1.40GHz ("GenuineIntel"
686-class) 1.40 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,TM,SBF
real mem  = 736256000 (702MB)
avail mem = 704962560 (672MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 08/26/05, BIOS32 rev. 0 @
0xfd5b0, SMBIOS rev. 2.34 @ 0xdc010 (30 entries)
bios0: vendor TOSHIBA version "V1.10" date 08/26/2005
bios0: TOSHIBA Satellite M50
acpi0 at bios0: rev 0
acpi0: tables DSDT FACP APIC MCFG
acpi0: wakeup devices PB2_(S4) PB3_(S4) PB4_(S4) OHC1(S3) OHC2(S3)
EHCI(S3) P2P_(S4) ELAN(S0) MODM(S3)
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 99MHz
ioapic0 at mainbus0: apid 1 pa 0xfec00000, version 21, 24 pins
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (PB2_)
acpiprt2 at acpi0: bus -1 (PB3_)
acpiprt3 at acpi0: bus 2 (PB4_)
acpiprt4 at acpi0: bus 4 (P2P_)
acpiprt5 at acpi0: bus 1 (AGP_)
acpiec0 at acpi0
acpicpu0 at acpi0: C3, C2
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: PWRB
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT1 model "PA3451U " serial 3658Q type Li-Ion oem "TOSHIBA"
acpivideo0 at acpi0: VGA_
acpivout0 at acpivideo0: CRT_
acpivout1 at acpivideo0: LCD_
acpivout2 at acpivideo0: TV__
bios0: ROM list: 0xc0000/0xf000 0xcf000/0x1000 0xdc000/0x4000!
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 vendor "ATI", unknown product 0x5a31 rev 0x01
ppb0 at pci0 dev 1 function 0 "ATI RS480 PCIE" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 5 function 0 "ATI Radeon XPRESS 200M" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
ppb1 at pci0 dev 4 function 0 "ATI RS480 PCIE" rev 0x00
pci2 at ppb1 bus 2
ohci0 at pci0 dev 19 function 0 "ATI SB400 USB" rev 0x80: apic 1 int
19 (irq 11), version 1.0, legacy support
ohci1 at pci0 dev 19 function 1 "ATI SB400 USB" rev 0x80: apic 1 int
19 (irq 11), version 1.0, legacy support
ehci0 at pci0 dev 19 function 2 "ATI SB400 USB2" rev 0x80: apic 1 int
19 (irq 11)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "ATI EHCI root hub" rev 2.00/1.00 addr 1
piixpm0 at pci0 dev 20 function 0 "ATI SB400 SMBus" rev 0x81: SMI
iic0 at piixpm0
spdmem0 at iic0 addr 0x52: 256MB DDR2 SDRAM non-parity PC2-4200CL5 SO-DIMM
spdmem1 at iic0 addr 0x53: 512MB DDR2 SDRAM non-parity PC2-4200CL5 SO-DIMM
pciide0 at pci0 dev 20 function 1 "ATI SB400 IDE" rev 0x80: DMA,
channel 0 configured to compatibility, channel 1 configured to
compatibility
atapiscsi0 at pciide0 channel 1 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MATSHITA, DVD/CDRW UJDA770, 1.50> ATAPI
5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 2
pcib0 at pci0 dev 20 function 3 "ATI SB400 ISA" rev 0x80
ppb2 at pci0 dev 20 function 4 "ATI SB400 PCI" rev 0x80
pci3 at ppb2 bus 4
ath0 at pci3 dev 2 function 0 "Atheros AR2413" rev 0x01: apic 1 int 21 (irq 11)
ath0: AR2413 7.8 phy 4.5 rf 5.6, WOR4W, address 00:11:f5:a7:ab:e1
cbb0 at pci3 dev 4 function 0 "ENE CB-1410 CardBus" rev 0x01: apic 1
int 16 (irq 255), CardBus support disabled
rl0 at pci3 dev 6 function 0 "Realtek 8139" rev 0x10: apic 1 int 22
(irq 11), address 00:0f:b0:a0:f8:77
rlphy0 at rl0 phy 0: RTL internal PHY
cardslot0 at cbb0 slot 0 flags 0
pcmcia0 at cardslot0
auixp0 at pci0 dev 20 function 5 "ATI SB400 AC97" rev 0x80: apic 1 int
17 (irq 11)
auixp0: soft resetting aclink
auixp0: not up; resetting aclink hardware
auixp0: not up; resetting aclink hardware
auixp0: aclink hardware reset successful
"ATI SB400 Modem" rev 0x80 at pci0 dev 20 function 6 not configured
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 "ATI OHCI root hub" rev 1.00/1.00 addr 1
usb2 at ohci1: USB revision 1.0
uhub2 at usb2 "ATI OHCI root hub" rev 1.00/1.00 addr 1
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
mtrr: Pentium Pro MTRR support
umass0 at uhub0 port 1 configuration 1 interface 0 "USBest Technology
USB Mass Storage Device" rev 2.00/1.00 addr 2
umass0: using SCSI over Bulk-Only
scsibus1 at umass0: 2 targets, initiator 0
sd0 at scsibus1 targ 1 lun 0: <Ut163, , 1.00> SCSI2 0/direct removable
sd0: 490MB, 512 bytes/sec, 1003520 sec total
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
root on sd0a swap on sd0b dump on sd0b
ac97: codec id 0x414c4752 (Avance Logic ALC250A?)
ac97: codec features headphone, 20 bit DAC, 18 bit ADC, No 3D Stereo
audio0 at auixp0
### AML PARSE ERROR (0x3b3b): Undefined name: PBST
error evaluating: \\_SB_.PCI0.LPC0.BAT1._BST

--
Aaron Mason - Programmer, open source addict
I've taken my software vows - for beta or for worse