[Ver3.6/3.9] Old version need help

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[Ver3.6/3.9] Old version need help

cclai
Hello,

I'm Hachi,
Our company’s server uses the 3.6 and 3.9 version of the system,
Used for more than ten years,
and there is a need to reinstall at present.

I have tried the file installation on FTP and failed.
> Russia (Moscow) ftp://mirror.yandex.ru/pub/OpenBSD/
> cd39.iso

So I hope that your organization can provide
an installation package "3.6 and 3.9 version" to solve the problem.

It would be of great help to us.
Thank you very much.

Hachi
Reply | Threaded
Open this post in threaded view
|

Re: [Ver3.6/3.9] Old version need help

Delan Azabani
At 14:28, cclai wrote:
> So I hope that your organization can provide
> an installation package "3.6 and 3.9 version" to solve the problem.

Try this mirror:

https://ftp.nluug.nl/OpenBSD/3.6/
https://ftp.nluug.nl/OpenBSD/3.9/

Reply | Threaded
Open this post in threaded view
|

Re: [Ver3.6/3.9] Old version need help

Miko
In reply to this post by cclai
You shouldn't really be using 16/17-year-old operating systems that
are unmaintained and potentially insecure. You really should consider
migrating over to 6.8.

~miko

On Tue, Mar 30, 2021 at 10:08 AM cclai <[hidden email]> wrote:

>
> Hello,
>
> I'm Hachi,
> Our company’s server uses the 3.6 and 3.9 version of the system,
> Used for more than ten years,
> and there is a need to reinstall at present.
>
> I have tried the file installation on FTP and failed.
> > Russia (Moscow) ftp://mirror.yandex.ru/pub/OpenBSD/
> > cd39.iso
>
> So I hope that your organization can provide
> an installation package "3.6 and 3.9 version" to solve the problem.
>
> It would be of great help to us.
> Thank you very much.
>
> Hachi

Reply | Threaded
Open this post in threaded view
|

Re: [Ver3.6/3.9] Old version need help

Paul de Weerd
In reply to this post by cclai
You really should move to a more recent version of the OS; OpenBSD
3.6 was released in 2004, almost 17 years ago.

However, the public mirror at ftp.eu.openbsd.org has older versions
available for download:

http://ftp.eu.openbsd.org/pub/OpenBSD/

And, once you've downloaded a release that you plan to run for all
eternity, you should probably make (several) copies of the
installation media that you used.

Alternatively, I could sell you original versions of the 3.6 and 3.9
media (at least 3.9 is still in shrink-wrap) for a collectors edition
price (proceeds to be donated to the OpenBSD foundation).

Cheers,

Paul 'WEiRD' de Weerd

On Tue, Mar 30, 2021 at 02:28:59PM +0800, cclai wrote:
| Hello,
|
| I'm Hachi,
| Our company’s server uses the 3.6 and 3.9 version of the system,
| Used for more than ten years,
| and there is a need to reinstall at present.
|
| I have tried the file installation on FTP and failed.
| > Russia (Moscow) ftp://mirror.yandex.ru/pub/OpenBSD/
| > cd39.iso
|
| So I hope that your organization can provide
| an installation package "3.6 and 3.9 version" to solve the problem.
|
| It would be of great help to us.
| Thank you very much.
|
| Hachi

--
>++++++++[<++++++++++>-]<+++++++.>+++[<------>-]<.>+++[<+
+++++++++++>-]<.>++[<------------>-]<+.--------------.[-]
                 http://www.weirdnet.nl/                 

Reply | Threaded
Open this post in threaded view
|

Re: [Ver3.6/3.9] Old version need help

Kenneth Gober
In reply to this post by cclai
On Tue, Mar 30, 2021 at 4:06 AM cclai <[hidden email]> wrote:

> So I hope that your organization can provide
> an installation package "3.6 and 3.9 version" to solve the problem.
>

CD copies of 3.6 and 3.9 are still available for purchase from Computer
Shop of Calgary but there is an issue with their web site so you'll need
to email cshop (at) computershop.ca to place an order.

If you want to see a list of what's for sale, archive.org has that page:
https://web.archive.org/web/20190222064326/http://computershop.ca/cgi-bin/eStore

I ordered a couple of old versions myself in December to fill some gaps
in my collection, so I can confirm that purchases are still possible.  There
is some shipping delay due to the pandemic of course, so in the short term
get a copy from one of the archives that still has it.

In the long term, if your organization is depending on those versions then
you should have physical copies that you can keep yourself.  You cannot
rely on archives having old releases forever.  This is especially true for
packages -- even ftp.nluug.nl no longer has a complete package archive
for releases 3.0, 3.1, 3.2 and 3.3.  I haven't found a complete package
archive for 3.0 anywhere.

-ken
Reply | Threaded
Open this post in threaded view
|

Re: [Ver3.6/3.9] Old version need help

Erik van Westen
In reply to this post by cclai
Try ftp.nluug.nl, they seem to have everything starting with 2.0.

Regards,
Erik

On 30-03-2021 08:28, cclai wrote:

> Hello,
>
> I'm Hachi,
> Our company’s server uses the 3.6 and 3.9 version of the system,
> Used for more than ten years,
> and there is a need to reinstall at present.
>
> I have tried the file installation on FTP and failed.
>> Russia (Moscow) ftp://mirror.yandex.ru/pub/OpenBSD/
>> cd39.iso
> So I hope that your organization can provide
> an installation package "3.6 and 3.9 version" to solve the problem.
>
> It would be of great help to us.
> Thank you very much.
>
> Hachi

Reply | Threaded
Open this post in threaded view
|

Re: [Ver3.6/3.9] Old version need help

Stuart Henderson
In reply to this post by cclai
On 2021-03-30, cclai <[hidden email]> wrote:

> Hello,
>
> I'm Hachi,
> Our company’s server uses the 3.6 and 3.9 version of the system,
> Used for more than ten years,
> and there is a need to reinstall at present.
>
> I have tried the file installation on FTP and failed.
>> Russia (Moscow) ftp://mirror.yandex.ru/pub/OpenBSD/
>> cd39.iso
>
> So I hope that your organization can provide
> an installation package "3.6 and 3.9 version" to solve the problem.
>
> It would be of great help to us.
> Thank you very much.
>
> Hachi
>

These releases are about 15 years past end-of-life and include security
vulnerabilities. See these errata pages, also many of the problems fixed
in subsequent releases will also apply to the versions you mention

https://www.openbsd.org/errata36.html
https://www.openbsd.org/errata39.html

These systems really ought to be rebuilt using something newer
(additionally, such old releases are unlikely to run correctly on
current hardware/VMs).