VMM/VMD problem - sendbug not configured

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

VMM/VMD problem - sendbug not configured

Greg Taylor
From [hidden email] Sat Dec 16 12:44:54 2017
Return-Path: [hidden email]
Delivered-To: [hidden email]
Received: from localhost (triathlon.biodock.io [local])
by triathlon.biodock.io (OpenSMTPD) with ESMTPA id 39de18ff;
Sat, 16 Dec 2017 12:44:54 -0800 (PST)
Date: Sat, 16 Dec 2017 12:44:54 -0800 (PST)
To: [hidden email]
Subject:
From: [hidden email]
Cc: [hidden email]
Reply-To: [hidden email]
Message-Id: <[hidden email]>
Status: RO

>Synopsis: i386 errors with VMM/VMD and X on Intel i7
>Category: VMM/VMD
>Environment:
System      : OpenBSD 6.2
Details     : OpenBSD 6.2 (GENERIC.MP) #166: Tue Oct  3 19:58:05 MDT 2017
[hidden email]:/usr/src/sys/arch/i386/compile/GENERIC.MP

Architecture: OpenBSD.i386
Machine     : i386
>Description:
I attempted to configure VMM/VMD on my system.  I was able to start VMD
and create a disk image.  Whe I attempt to connect to the virtual system
the console output remains blank.  Further, after doing this, my browsers
(firefox and otter-browser) started to core dump regularly.
>How-To-Repeat:
1.  Install i386 version of OpenBSD 6.2 on an i7
2.  Start VMD using a minimal configuration
3.  Create a virtual disk using vmctl
4.  run 'vmctl start -c ...' on the disk image with wither alpine linux or
bsd
>Fix:
Next, I will reinstall amd64 version of OpenBSD on my system and try again.


dmesg:
OpenBSD 6.2 (GENERIC.MP) #166: Tue Oct  3 19:58:05 MDT 2017
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
GHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
real mem  = 3714842624 (3542MB)
avail mem = 3629563904 (3461MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: date 08/09/13, SMBIOS rev. 2.8 @ 0xecf30 (91 entries)
bios0: vendor American Megatrends Inc. version "3201" date 01/24/2017
bios0: ASUS All Series
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP APIC FPDT SSDT SSDT SSDT MCFG HPET SSDT SSDT UEFI
acpi0: wakeup devices PEGP(S4) PEG0(S4) PEGP(S4) PEG1(S4) PEGP(S4) PEG2(S4)
PXSX(S4) RP01(S4) PXSX(S4) RP02(S4) PXSX(S4) RP03(S4) PXSX(S4) RP04(S4)
PXSX(S4) RP05(S4) [...]
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4, IBE
cpu1 at mainbus0: apid 2 (application processor)
cpu1: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
GHz
cpu1:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
cpu2 at mainbus0: apid 4 (application processor)
cpu2: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
GHz
cpu2:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
cpu3 at mainbus0: apid 6 (application processor)
cpu3: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
GHz
cpu3:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
cpu4 at mainbus0: apid 1 (application processor)
cpu4: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
GHz
cpu4:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
cpu5 at mainbus0: apid 3 (application processor)
cpu5: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
GHz
cpu5:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
cpu6 at mainbus0: apid 5 (application processor)
cpu6: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
GHz
cpu6:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
cpu7 at mainbus0: apid 7 (application processor)
cpu7: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
GHz
cpu7:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
ioapic0 at mainbus0: apid 8 pa 0xfec00000, version 20, 24 pins
acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (PEG0)
acpiprt2 at acpi0: bus -1 (PEG1)
acpiprt3 at acpi0: bus -1 (PEG2)
acpiprt4 at acpi0: bus 2 (RP01)
acpiprt5 at acpi0: bus -1 (RP02)
acpiprt6 at acpi0: bus -1 (RP03)
acpiprt7 at acpi0: bus 3 (RP04)
acpiprt8 at acpi0: bus -1 (RP05)
acpiprt9 at acpi0: bus 4 (RP06)
acpiprt10 at acpi0: bus -1 (RP07)
acpiprt11 at acpi0: bus -1 (RP08)
acpiec0 at acpi0
acpiec at acpi0 not configured
acpicpu0 at acpi0: C1(@1 halt!), PSS
acpicpu1 at acpi0: C1(@1 halt!), PSS
acpicpu2 at acpi0: C1(@1 halt!), PSS
acpicpu3 at acpi0: C1(@1 halt!), PSS
acpicpu4 at acpi0: C1(@1 halt!), PSS
acpicpu5 at acpi0: C1(@1 halt!), PSS
acpicpu6 at acpi0: C1(@1 halt!), PSS
acpicpu7 at acpi0: C1(@1 halt!), PSS
acpipwrres0 at acpi0: PG00, resource for PEG0
acpipwrres1 at acpi0: PG01, resource for PEG1
acpipwrres2 at acpi0: PG02, resource for PEG2
acpipwrres3 at acpi0: FN00, resource for FAN0
acpipwrres4 at acpi0: FN01, resource for FAN1
acpipwrres5 at acpi0: FN02, resource for FAN2
acpipwrres6 at acpi0: FN03, resource for FAN3
acpipwrres7 at acpi0: FN04, resource for FAN4
acpitz0 at acpi0: critical temperature is 105 degC
acpitz1 at acpi0: critical temperature is 105 degC
"INT3F0D" at acpi0 not configured
"PNP0C14" at acpi0 not configured
acpibtn0 at acpi0: PWRB
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0C0B" at acpi0 not configured
"PNP0A0A" at acpi0 not configured
"PNP0C14" at acpi0 not configured
acpivideo0 at acpi0: GFX0
acpivout0 at acpivideo0: DD1F
bios0: ROM list: 0xc0000/0xea00
cpu0: Enhanced SpeedStep 3998 MHz: speeds: 4001, 4000, 3800, 3500, 3300,
3100, 2900, 2600, 2400, 2200, 1900, 1700, 1500, 1300, 1000, 800 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel Core 4G Host" rev 0x06
ppb0 at pci0 dev 1 function 0 "Intel Core 4G PCIE" rev 0x06: apic 8 int 16
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 vendor "NVIDIA", unknown product 0x1187 rev
0xa1
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
azalia0 at pci1 dev 0 function 1 vendor "NVIDIA", unknown product 0x0e0a
rev 0xa1: msi
azalia0: no supported codecs
xhci0 at pci0 dev 20 function 0 "Intel 9 Series xHCI" rev 0x00: msi
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev
3.00/1.00 addr 1
"Intel 9 Series MEI" rev 0x00 at pci0 dev 22 function 0 not configured
em0 at pci0 dev 25 function 0 "Intel I218-V" rev 0x00: msi, address
1c:87:2c:5a:3c:71
ehci0 at pci0 dev 26 function 0 "Intel 9 Series USB" rev 0x00: apic 8 int 20
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev
2.00/1.00 addr 1
azalia1 at pci0 dev 27 function 0 "Intel 9 Series HD Audio" rev 0x00: msi
azalia1: codecs: Realtek ALC1150
audio0 at azalia1
ppb1 at pci0 dev 28 function 0 "Intel 9 Series PCIE" rev 0xd0
pci2 at ppb1 bus 2
ppb2 at pci0 dev 28 function 3 "Intel 9 Series PCIE" rev 0xd0: apic 8 int 19
pci3 at ppb2 bus 3
ahci0 at pci3 dev 0 function 0 "ASMedia ASM1061 AHCI" rev 0x02: msi, AHCI
1.2
scsibus1 at ahci0: 32 targets
ppb3 at pci0 dev 28 function 5 "Intel 9 Series PCIE" rev 0xd0: apic 8 int 17
pci4 at ppb3 bus 4
rtwn0 at pci4 dev 0 function 0 "Realtek RTL8192CE" rev 0x01: msi
rtwn0: MAC/BB RTL8192CE, RF 6052 2T2R, address f0:79:59:e8:a6:24
ehci1 at pci0 dev 29 function 0 "Intel 9 Series USB" rev 0x00: apic 8 int 23
usb2 at ehci1: USB revision 2.0
uhub2 at usb2 configuration 1 interface 0 "Intel EHCI root hub" rev
2.00/1.00 addr 1
pcib0 at pci0 dev 31 function 0 "Intel Z97 LPC" rev 0x00
ahci1 at pci0 dev 31 function 2 "Intel 9 Series AHCI" rev 0x00: msi, AHCI
1.3
ahci1: port 0: 6.0Gb/s
ahci1: port 1: 3.0Gb/s
ahci1: port 2: 3.0Gb/s
ahci1: port 4: 1.5Gb/s
scsibus2 at ahci1: 32 targets
sd0 at scsibus2 targ 0 lun 0: <ATA, Samsung SSD 840, EXT0> SCSI3 0/direct
fixed naa.50025388a069abef
sd0: 476940MB, 512 bytes/sector, 976773168 sectors, thin
sd1 at scsibus2 targ 1 lun 0: <ATA, WDC WD7500AADS-0, 01.0> SCSI3 0/direct
fixed naa.50014ee202d24649
sd1: 715404MB, 512 bytes/sector, 1465149168 sectors
sd2 at scsibus2 targ 2 lun 0: <ATA, WDC WD7500AADS-0, 01.0> SCSI3 0/direct
fixed naa.50014ee202dfe678
sd2: 715404MB, 512 bytes/sector, 1465149168 sectors
cd0 at scsibus2 targ 4 lun 0: <ASUS, DRW-24B3ST i, 1.00> ATAPI 5/cdrom
removable
ichiic0 at pci0 dev 31 function 3 "Intel 9 Series SMBus" rev 0x00: apic 8
int 18
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 4GB DDR3 SDRAM PC3-12800
spdmem1 at iic0 addr 0x51: 4GB DDR3 SDRAM PC3-12800
spdmem2 at iic0 addr 0x52: 4GB DDR3 SDRAM PC3-12800
spdmem3 at iic0 addr 0x53: 4GB DDR3 SDRAM PC3-12800
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
vmm0 at mainbus0: VMX/EPT
uaudio0 at uhub0 port 9 configuration 1 interface 0 "Bose Corporation Bose
USB Audio" rev 1.00/1.00 addr 2
uaudio0: audio rev 1.00, 2 mixer controls
audio1 at uaudio0
uhidev0 at uhub0 port 9 configuration 1 interface 2 "Bose Corporation Bose
USB Audio" rev 1.00/1.00 addr 2
uhidev0: iclass 3/0, 2 report ids
uhid0 at uhidev0 reportid 2: input=63, output=63, feature=0
uvideo0 at uhub0 port 10 configuration 1 interface 0 "Logitech HD Pro
Webcam C920" rev 2.00/0.11 addr 3
video0 at uvideo0
uaudio1 at uhub0 port 10 configuration 1 interface 2 "Logitech HD Pro
Webcam C920" rev 2.00/0.11 addr 3
uaudio1: audio rev 1.00, 2 mixer controls
audio2 at uaudio1
uhidev1 at uhub0 port 14 configuration 1 interface 0 "Microsoft
Microsoft\M-. 2.4GHz Transceiver v9.0" rev 2.00/7.77 addr 4
uhidev1: iclass 3/1
ukbd0 at uhidev1: 8 variable keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
uhidev2 at uhub0 port 14 configuration 1 interface 1 "Microsoft
Microsoft\M-. 2.4GHz Transceiver v9.0" rev 2.00/7.77 addr 4
uhidev2: iclass 3/1, 26 report ids
uhid1 at uhidev2 reportid 18: input=0, output=0, feature=1
uhid2 at uhidev2 reportid 23: input=0, output=0, feature=1
ums0 at uhidev2 reportid 26: 5 buttons, Z and W dir
wsmouse0 at ums0 mux 0
uhidev3 at uhub0 port 14 configuration 1 interface 2 "Microsoft
Microsoft\M-. 2.4GHz Transceiver v9.0" rev 2.00/7.77 addr 4
uhidev3: iclass 3/0, 39 report ids
uhid3 at uhidev3 reportid 3: input=1, output=0, feature=0
uhid4 at uhidev3 reportid 7: input=7, output=0, feature=0
uhid5 at uhidev3 reportid 32: input=0, output=0, feature=18
uhid6 at uhidev3 reportid 33: input=2, output=0, feature=0
uhid7 at uhidev3 reportid 34: input=0, output=0, feature=26
uhid8 at uhidev3 reportid 35: input=0, output=0, feature=26
uhid9 at uhidev3 reportid 36: input=0, output=0, feature=31
uhid10 at uhidev3 reportid 37: input=0, output=0, feature=31
uhid11 at uhidev3 reportid 38: input=0, output=0, feature=31
uhid12 at uhidev3 reportid 39: input=31, output=0, feature=0
uhub3 at uhub1 port 1 configuration 1 interface 0 "Intel Rate Matching Hub"
rev 2.00/0.00 addr 2
uhub4 at uhub2 port 1 configuration 1 interface 0 "Intel Rate Matching Hub"
rev 2.00/0.00 addr 2
vscsi0 at root
scsibus3 at vscsi0: 256 targets
softraid0 at root
scsibus4 at softraid0: 256 targets
root on sd2a (f8d89407bb4180ca.a) swap on sd2b dump on sd2b

usbdevs:
Controller /dev/usb0:
addr 1: super speed, self powered, config 1, xHCI root hub(0x0000),
Intel(0x8086), rev 1.00
 port 1 disabled
 port 2 disabled
 port 3 disabled
 port 4 disabled
 port 5 disabled
 port 6 disabled
 port 7 disabled
 port 8 disabled
 port 9 addr 2: full speed, self powered, config 1, Bose USB Audio(0x1020),
Bose Corporation(0x05a7), rev 1.00
 port 10 addr 3: high speed, power 500 mA, config 1, HD Pro Webcam
C920(0x082d), Logitech(0x046d), rev 0.11, iSerialNumber A7F4B72F
 port 11 disabled
 port 12 disabled
 port 13 disabled
 port 14 addr 4: full speed, power 100 mA, config 1, Microsoft® 2.4GHz
Transceiver v9.0(0x07a5), Microsoft(0x045e), rev 7.77
 port 15 disabled
 port 16 disabled
Controller /dev/usb1:
addr 1: high speed, self powered, config 1, EHCI root hub(0x0000),
Intel(0x8086), rev 1.00
 port 1 addr 2: high speed, self powered, config 1, Rate Matching
Hub(0x8009), Intel(0x8087), rev 0.00
  port 1 powered
  port 2 powered
  port 3 powered
  port 4 powered
  port 5 powered
  port 6 powered
 port 2 powered
Controller /dev/usb2:
addr 1: high speed, self powered, config 1, EHCI root hub(0x0000),
Intel(0x8086), rev 1.00
 port 1 addr 2: high speed, self powered, config 1, Rate Matching
Hub(0x8001), Intel(0x8087), rev 0.00
  port 1 powered
  port 2 powered
  port 3 powered
  port 4 powered
  port 5 powered
  port 6 powered
  port 7 powered
  port 8 powered
 port 2 powered
Reply | Threaded
Open this post in threaded view
|

Re: VMM/VMD problem - sendbug not configured

Mike Larkin
On Mon, Dec 18, 2017 at 06:05:01PM -0800, Greg Taylor wrote:

> From [hidden email] Sat Dec 16 12:44:54 2017
> Return-Path: [hidden email]
> Delivered-To: [hidden email]
> Received: from localhost (triathlon.biodock.io [local])
> by triathlon.biodock.io (OpenSMTPD) with ESMTPA id 39de18ff;
> Sat, 16 Dec 2017 12:44:54 -0800 (PST)
> Date: Sat, 16 Dec 2017 12:44:54 -0800 (PST)
> To: [hidden email]
> Subject:
> From: [hidden email]
> Cc: [hidden email]
> Reply-To: [hidden email]
> Message-Id: <[hidden email]>
> Status: RO
>
> >Synopsis: i386 errors with VMM/VMD and X on Intel i7
> >Category: VMM/VMD
> >Environment:
> System      : OpenBSD 6.2
> Details     : OpenBSD 6.2 (GENERIC.MP) #166: Tue Oct  3 19:58:05 MDT 2017
> [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC.MP
>
> Architecture: OpenBSD.i386
> Machine     : i386
> >Description:
> I attempted to configure VMM/VMD on my system.  I was able to start VMD
> and create a disk image.  Whe I attempt to connect to the virtual system
> the console output remains blank.  Further, after doing this, my browsers
> (firefox and otter-browser) started to core dump regularly.
> >How-To-Repeat:
> 1.  Install i386 version of OpenBSD 6.2 on an i7

Yeah, i386 vmm is a bit shaky at the moment.

> 2.  Start VMD using a minimal configuration
> 3.  Create a virtual disk using vmctl
> 4.  run 'vmctl start -c ...' on the disk image with wither alpine linux or
> bsd
> >Fix:
> Next, I will reinstall amd64 version of OpenBSD on my system and try again.
>

you'll be much happier with that.

-ml

>
> dmesg:
> OpenBSD 6.2 (GENERIC.MP) #166: Tue Oct  3 19:58:05 MDT 2017
>     [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC.MP
> cpu0: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
> GHz
> cpu0:
> FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
> real mem  = 3714842624 (3542MB)
> avail mem = 3629563904 (3461MB)
> mpath0 at root
> scsibus0 at mpath0: 256 targets
> mainbus0 at root
> bios0 at mainbus0: date 08/09/13, SMBIOS rev. 2.8 @ 0xecf30 (91 entries)
> bios0: vendor American Megatrends Inc. version "3201" date 01/24/2017
> bios0: ASUS All Series
> acpi0 at bios0: rev 2
> acpi0: sleep states S0 S3 S4 S5
> acpi0: tables DSDT FACP APIC FPDT SSDT SSDT SSDT MCFG HPET SSDT SSDT UEFI
> acpi0: wakeup devices PEGP(S4) PEG0(S4) PEGP(S4) PEG1(S4) PEGP(S4) PEG2(S4)
> PXSX(S4) RP01(S4) PXSX(S4) RP02(S4) PXSX(S4) RP03(S4) PXSX(S4) RP04(S4)
> PXSX(S4) RP05(S4) [...]
> acpitimer0 at acpi0: 3579545 Hz, 24 bits
> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
> cpu0 at mainbus0: apid 0 (boot processor)
> mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
> cpu0: apic clock running at 99MHz
> cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4, IBE
> cpu1 at mainbus0: apid 2 (application processor)
> cpu1: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
> GHz
> cpu1:
> FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
> cpu2 at mainbus0: apid 4 (application processor)
> cpu2: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
> GHz
> cpu2:
> FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
> cpu3 at mainbus0: apid 6 (application processor)
> cpu3: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
> GHz
> cpu3:
> FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
> cpu4 at mainbus0: apid 1 (application processor)
> cpu4: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
> GHz
> cpu4:
> FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
> cpu5 at mainbus0: apid 3 (application processor)
> cpu5: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
> GHz
> cpu5:
> FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
> cpu6 at mainbus0: apid 5 (application processor)
> cpu6: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
> GHz
> cpu6:
> FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
> cpu7 at mainbus0: apid 7 (application processor)
> cpu7: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz ("GenuineIntel" 686-class) 4
> GHz
> cpu7:
> FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,NXE,PAGE1GB,LONG,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,LAHF,ABM,PERF,ITSC,FSGSBASE,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,SENSOR,ARAT
> ioapic0 at mainbus0: apid 8 pa 0xfec00000, version 20, 24 pins
> acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
> acpihpet0 at acpi0: 14318179 Hz
> acpiprt0 at acpi0: bus 0 (PCI0)
> acpiprt1 at acpi0: bus 1 (PEG0)
> acpiprt2 at acpi0: bus -1 (PEG1)
> acpiprt3 at acpi0: bus -1 (PEG2)
> acpiprt4 at acpi0: bus 2 (RP01)
> acpiprt5 at acpi0: bus -1 (RP02)
> acpiprt6 at acpi0: bus -1 (RP03)
> acpiprt7 at acpi0: bus 3 (RP04)
> acpiprt8 at acpi0: bus -1 (RP05)
> acpiprt9 at acpi0: bus 4 (RP06)
> acpiprt10 at acpi0: bus -1 (RP07)
> acpiprt11 at acpi0: bus -1 (RP08)
> acpiec0 at acpi0
> acpiec at acpi0 not configured
> acpicpu0 at acpi0: C1(@1 halt!), PSS
> acpicpu1 at acpi0: C1(@1 halt!), PSS
> acpicpu2 at acpi0: C1(@1 halt!), PSS
> acpicpu3 at acpi0: C1(@1 halt!), PSS
> acpicpu4 at acpi0: C1(@1 halt!), PSS
> acpicpu5 at acpi0: C1(@1 halt!), PSS
> acpicpu6 at acpi0: C1(@1 halt!), PSS
> acpicpu7 at acpi0: C1(@1 halt!), PSS
> acpipwrres0 at acpi0: PG00, resource for PEG0
> acpipwrres1 at acpi0: PG01, resource for PEG1
> acpipwrres2 at acpi0: PG02, resource for PEG2
> acpipwrres3 at acpi0: FN00, resource for FAN0
> acpipwrres4 at acpi0: FN01, resource for FAN1
> acpipwrres5 at acpi0: FN02, resource for FAN2
> acpipwrres6 at acpi0: FN03, resource for FAN3
> acpipwrres7 at acpi0: FN04, resource for FAN4
> acpitz0 at acpi0: critical temperature is 105 degC
> acpitz1 at acpi0: critical temperature is 105 degC
> "INT3F0D" at acpi0 not configured
> "PNP0C14" at acpi0 not configured
> acpibtn0 at acpi0: PWRB
> "PNP0C0B" at acpi0 not configured
> "PNP0C0B" at acpi0 not configured
> "PNP0C0B" at acpi0 not configured
> "PNP0C0B" at acpi0 not configured
> "PNP0C0B" at acpi0 not configured
> "PNP0A0A" at acpi0 not configured
> "PNP0C14" at acpi0 not configured
> acpivideo0 at acpi0: GFX0
> acpivout0 at acpivideo0: DD1F
> bios0: ROM list: 0xc0000/0xea00
> cpu0: Enhanced SpeedStep 3998 MHz: speeds: 4001, 4000, 3800, 3500, 3300,
> 3100, 2900, 2600, 2400, 2200, 1900, 1700, 1500, 1300, 1000, 800 MHz
> pci0 at mainbus0 bus 0: configuration mode 1 (bios)
> pchb0 at pci0 dev 0 function 0 "Intel Core 4G Host" rev 0x06
> ppb0 at pci0 dev 1 function 0 "Intel Core 4G PCIE" rev 0x06: apic 8 int 16
> pci1 at ppb0 bus 1
> vga1 at pci1 dev 0 function 0 vendor "NVIDIA", unknown product 0x1187 rev
> 0xa1
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> azalia0 at pci1 dev 0 function 1 vendor "NVIDIA", unknown product 0x0e0a
> rev 0xa1: msi
> azalia0: no supported codecs
> xhci0 at pci0 dev 20 function 0 "Intel 9 Series xHCI" rev 0x00: msi
> usb0 at xhci0: USB revision 3.0
> uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev
> 3.00/1.00 addr 1
> "Intel 9 Series MEI" rev 0x00 at pci0 dev 22 function 0 not configured
> em0 at pci0 dev 25 function 0 "Intel I218-V" rev 0x00: msi, address
> 1c:87:2c:5a:3c:71
> ehci0 at pci0 dev 26 function 0 "Intel 9 Series USB" rev 0x00: apic 8 int 20
> usb1 at ehci0: USB revision 2.0
> uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev
> 2.00/1.00 addr 1
> azalia1 at pci0 dev 27 function 0 "Intel 9 Series HD Audio" rev 0x00: msi
> azalia1: codecs: Realtek ALC1150
> audio0 at azalia1
> ppb1 at pci0 dev 28 function 0 "Intel 9 Series PCIE" rev 0xd0
> pci2 at ppb1 bus 2
> ppb2 at pci0 dev 28 function 3 "Intel 9 Series PCIE" rev 0xd0: apic 8 int 19
> pci3 at ppb2 bus 3
> ahci0 at pci3 dev 0 function 0 "ASMedia ASM1061 AHCI" rev 0x02: msi, AHCI
> 1.2
> scsibus1 at ahci0: 32 targets
> ppb3 at pci0 dev 28 function 5 "Intel 9 Series PCIE" rev 0xd0: apic 8 int 17
> pci4 at ppb3 bus 4
> rtwn0 at pci4 dev 0 function 0 "Realtek RTL8192CE" rev 0x01: msi
> rtwn0: MAC/BB RTL8192CE, RF 6052 2T2R, address f0:79:59:e8:a6:24
> ehci1 at pci0 dev 29 function 0 "Intel 9 Series USB" rev 0x00: apic 8 int 23
> usb2 at ehci1: USB revision 2.0
> uhub2 at usb2 configuration 1 interface 0 "Intel EHCI root hub" rev
> 2.00/1.00 addr 1
> pcib0 at pci0 dev 31 function 0 "Intel Z97 LPC" rev 0x00
> ahci1 at pci0 dev 31 function 2 "Intel 9 Series AHCI" rev 0x00: msi, AHCI
> 1.3
> ahci1: port 0: 6.0Gb/s
> ahci1: port 1: 3.0Gb/s
> ahci1: port 2: 3.0Gb/s
> ahci1: port 4: 1.5Gb/s
> scsibus2 at ahci1: 32 targets
> sd0 at scsibus2 targ 0 lun 0: <ATA, Samsung SSD 840, EXT0> SCSI3 0/direct
> fixed naa.50025388a069abef
> sd0: 476940MB, 512 bytes/sector, 976773168 sectors, thin
> sd1 at scsibus2 targ 1 lun 0: <ATA, WDC WD7500AADS-0, 01.0> SCSI3 0/direct
> fixed naa.50014ee202d24649
> sd1: 715404MB, 512 bytes/sector, 1465149168 sectors
> sd2 at scsibus2 targ 2 lun 0: <ATA, WDC WD7500AADS-0, 01.0> SCSI3 0/direct
> fixed naa.50014ee202dfe678
> sd2: 715404MB, 512 bytes/sector, 1465149168 sectors
> cd0 at scsibus2 targ 4 lun 0: <ASUS, DRW-24B3ST i, 1.00> ATAPI 5/cdrom
> removable
> ichiic0 at pci0 dev 31 function 3 "Intel 9 Series SMBus" rev 0x00: apic 8
> int 18
> iic0 at ichiic0
> spdmem0 at iic0 addr 0x50: 4GB DDR3 SDRAM PC3-12800
> spdmem1 at iic0 addr 0x51: 4GB DDR3 SDRAM PC3-12800
> spdmem2 at iic0 addr 0x52: 4GB DDR3 SDRAM PC3-12800
> spdmem3 at iic0 addr 0x53: 4GB DDR3 SDRAM PC3-12800
> isa0 at pcib0
> isadma0 at isa0
> pckbc0 at isa0 port 0x60/5 irq 1 irq 12
> pckbd0 at pckbc0 (kbd slot)
> wskbd0 at pckbd0: console keyboard, using wsdisplay0
> pcppi0 at isa0 port 0x61
> spkr0 at pcppi0
> npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
> vmm0 at mainbus0: VMX/EPT
> uaudio0 at uhub0 port 9 configuration 1 interface 0 "Bose Corporation Bose
> USB Audio" rev 1.00/1.00 addr 2
> uaudio0: audio rev 1.00, 2 mixer controls
> audio1 at uaudio0
> uhidev0 at uhub0 port 9 configuration 1 interface 2 "Bose Corporation Bose
> USB Audio" rev 1.00/1.00 addr 2
> uhidev0: iclass 3/0, 2 report ids
> uhid0 at uhidev0 reportid 2: input=63, output=63, feature=0
> uvideo0 at uhub0 port 10 configuration 1 interface 0 "Logitech HD Pro
> Webcam C920" rev 2.00/0.11 addr 3
> video0 at uvideo0
> uaudio1 at uhub0 port 10 configuration 1 interface 2 "Logitech HD Pro
> Webcam C920" rev 2.00/0.11 addr 3
> uaudio1: audio rev 1.00, 2 mixer controls
> audio2 at uaudio1
> uhidev1 at uhub0 port 14 configuration 1 interface 0 "Microsoft
> Microsoft\M-. 2.4GHz Transceiver v9.0" rev 2.00/7.77 addr 4
> uhidev1: iclass 3/1
> ukbd0 at uhidev1: 8 variable keys, 6 key codes
> wskbd1 at ukbd0 mux 1
> wskbd1: connecting to wsdisplay0
> uhidev2 at uhub0 port 14 configuration 1 interface 1 "Microsoft
> Microsoft\M-. 2.4GHz Transceiver v9.0" rev 2.00/7.77 addr 4
> uhidev2: iclass 3/1, 26 report ids
> uhid1 at uhidev2 reportid 18: input=0, output=0, feature=1
> uhid2 at uhidev2 reportid 23: input=0, output=0, feature=1
> ums0 at uhidev2 reportid 26: 5 buttons, Z and W dir
> wsmouse0 at ums0 mux 0
> uhidev3 at uhub0 port 14 configuration 1 interface 2 "Microsoft
> Microsoft\M-. 2.4GHz Transceiver v9.0" rev 2.00/7.77 addr 4
> uhidev3: iclass 3/0, 39 report ids
> uhid3 at uhidev3 reportid 3: input=1, output=0, feature=0
> uhid4 at uhidev3 reportid 7: input=7, output=0, feature=0
> uhid5 at uhidev3 reportid 32: input=0, output=0, feature=18
> uhid6 at uhidev3 reportid 33: input=2, output=0, feature=0
> uhid7 at uhidev3 reportid 34: input=0, output=0, feature=26
> uhid8 at uhidev3 reportid 35: input=0, output=0, feature=26
> uhid9 at uhidev3 reportid 36: input=0, output=0, feature=31
> uhid10 at uhidev3 reportid 37: input=0, output=0, feature=31
> uhid11 at uhidev3 reportid 38: input=0, output=0, feature=31
> uhid12 at uhidev3 reportid 39: input=31, output=0, feature=0
> uhub3 at uhub1 port 1 configuration 1 interface 0 "Intel Rate Matching Hub"
> rev 2.00/0.00 addr 2
> uhub4 at uhub2 port 1 configuration 1 interface 0 "Intel Rate Matching Hub"
> rev 2.00/0.00 addr 2
> vscsi0 at root
> scsibus3 at vscsi0: 256 targets
> softraid0 at root
> scsibus4 at softraid0: 256 targets
> root on sd2a (f8d89407bb4180ca.a) swap on sd2b dump on sd2b
>
> usbdevs:
> Controller /dev/usb0:
> addr 1: super speed, self powered, config 1, xHCI root hub(0x0000),
> Intel(0x8086), rev 1.00
>  port 1 disabled
>  port 2 disabled
>  port 3 disabled
>  port 4 disabled
>  port 5 disabled
>  port 6 disabled
>  port 7 disabled
>  port 8 disabled
>  port 9 addr 2: full speed, self powered, config 1, Bose USB Audio(0x1020),
> Bose Corporation(0x05a7), rev 1.00
>  port 10 addr 3: high speed, power 500 mA, config 1, HD Pro Webcam
> C920(0x082d), Logitech(0x046d), rev 0.11, iSerialNumber A7F4B72F
>  port 11 disabled
>  port 12 disabled
>  port 13 disabled
>  port 14 addr 4: full speed, power 100 mA, config 1, Microsoft® 2.4GHz
> Transceiver v9.0(0x07a5), Microsoft(0x045e), rev 7.77
>  port 15 disabled
>  port 16 disabled
> Controller /dev/usb1:
> addr 1: high speed, self powered, config 1, EHCI root hub(0x0000),
> Intel(0x8086), rev 1.00
>  port 1 addr 2: high speed, self powered, config 1, Rate Matching
> Hub(0x8009), Intel(0x8087), rev 0.00
>   port 1 powered
>   port 2 powered
>   port 3 powered
>   port 4 powered
>   port 5 powered
>   port 6 powered
>  port 2 powered
> Controller /dev/usb2:
> addr 1: high speed, self powered, config 1, EHCI root hub(0x0000),
> Intel(0x8086), rev 1.00
>  port 1 addr 2: high speed, self powered, config 1, Rate Matching
> Hub(0x8001), Intel(0x8087), rev 0.00
>   port 1 powered
>   port 2 powered
>   port 3 powered
>   port 4 powered
>   port 5 powered
>   port 6 powered
>   port 7 powered
>   port 8 powered
>  port 2 powered