Updating php

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Updating php

Stefano Tagliaferri
Hallo,

Today i've install mysql client and server, php and some modules that
runs whit apache on a U10. I've install them from package. Then i've run
the  /usr/ports/infrastructure/build/out-of-date and the result is that
the php is out of date. After this 've tried to update the packages via
ports running on the /usr/ports/www/php4 the make update command but
i've this error

===> Updating for php4-core-4.4.1p0
Upgrading from php4-core-4.4.0
Old package php4-core-4.4.0 contains potentially unsafe operations
        @unexec rm -f /usr/lib/apache/modules/libphp4.so
Can't update forward dependency of php4-mysql-4.4.0 on php4-core-4.4.0:
php4-core-4.4.1p0 doesn't match
Can't update forward dependency of php4-mcrypt-4.4.0 on php4-core-4.4.0:
php4-core-4.4.1p0 doesn't match
Can't update forward dependency of php4-pear-4.4.0 on php4-core-4.4.0:
php4-core-4.4.1p0 doesn't match
Can't update forward dependency of php4-imap-4.4.0 on php4-core-4.4.0:
php4-core-4.4.1p0 doesn't match
Can't update forward dependency of php4-mhash-4.4.0 on php4-core-4.4.0:
php4-core-4.4.1p0 doesn't match
Can't update forward dependency of php4-curl-4.4.0 on php4-core-4.4.0:
php4-core-4.4.1p0 doesn't match
Can't update forward dependency of php4-gd-4.4.0p2-no_x11 on
php4-core-4.4.0: php4-core-4.4.1p0 doesn't match
Can't update forward dependency of php4-domxml-4.4.0 on php4-core-4.4.0:
php4-core-4.4.1p0 doesn't match
Can't update php4-core-4.4.0 into php4-core-4.4.1p0
/usr/sbin/pkg_add:
/usr/ports/packages/sparc64/all/php4-core-4.4.1p0.tgz:Fatal error
*** Error code 1

Stop in /usr/ports/www/php4/core (line 1925 of
/usr/ports/infrastructure/mk/bsd.port.mk).


the ports tree is in sinch whit the OpenBSD 3.8 system, what can i do?

Thanks!

Stefano

[demime 1.01d removed an attachment of type application/pgp-signature which had a name of signature.asc]