[Update] databases/py-sqlobject : Update to 3.8.0

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Update] databases/py-sqlobject : Update to 3.8.0

wen heping
Hi, ports@

  Here is a patch for databases/py-sqlobject to update to 3.8.0.
It build well and pass all tests both with python2 and python3
on amd64-current system.

  Only one port depend on it: productivity/yokadi. But its newer
version would not depends on py-sqlobject, which I submitted
the patch just now.

Regards,
wen

py-sqlobject-3.8.0.diff.txt (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Remove databases py-sqlobject?

Kurt Mosiejczuk-9
On Thu, Dec 26, 2019 at 11:16:34AM +0000, wen heping wrote:
> Hi, ports@

>   Here is a patch for databases/py-sqlobject to update to 3.8.0.
> It build well and pass all tests both with python2 and python3
> on amd64-current system.

>   Only one port depend on it: productivity/yokadi. But its newer
> version would not depends on py-sqlobject, which I submitted
> the patch just now.

Do we just want to remove py-sqlobject then? Once we update yokadi,
of course.

--Kurt

Reply | Threaded
Open this post in threaded view
|

回复: Remove databases py-sqlobject?

wen heping
Hi,

    I hope we would keep this port because:
    i) It is in active developping upstream.
    ii) It is a good choice besides sqlalchemy if we want connect
to database with python.


Regards,
wen
________________________________
发件人: Kurt Mosiejczuk <[hidden email]>
发送时间: 2019年12月27日 1:14
收件人: wen heping <[hidden email]>
抄送: [hidden email] <[hidden email]>
主题: Remove databases py-sqlobject?

On Thu, Dec 26, 2019 at 11:16:34AM +0000, wen heping wrote:
> Hi, ports@

>   Here is a patch for databases/py-sqlobject to update to 3.8.0.
> It build well and pass all tests both with python2 and python3
> on amd64-current system.

>   Only one port depend on it: productivity/yokadi. But its newer
> version would not depends on py-sqlobject, which I submitted
> the patch just now.

Do we just want to remove py-sqlobject then? Once we update yokadi,
of course.

--Kurt