Unable to change LCD brightness - Packard Bell EasyNote TS13HR

classic Classic list List threaded Threaded
1 message Options
sam
Reply | Threaded
Open this post in threaded view
|

Unable to change LCD brightness - Packard Bell EasyNote TS13HR

sam
Hello,

I'm currently running OpenBSD 5.7-current. I installed via a snapshot.

OpenBSD 5.7-current (GENERIC.MP) #895: Wed Mar 18 18:55:03 MDT 2015
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP

I am unable to change the brightness of my laptop (Packard Bell
EasyNote TS13HR) when using OpenBSD. This issue persisted in OpenBSD
5.5-release and -stable (when I used OpenBSD last).

I have tried using the two brightness keys on my laptop which otherwise
work in various Linux distributions and Windows. I appreciate this may
seem to be a keybind issue, but it is not.

xbacklight has no effect.
$ xbacklight
70.000000 # this is the default value on my system?
$ xbacklight -set 10%
$ xbacklight -get    
10.000000

The change from 70% to 10% has no effect.

Any help would be greatly appreciated.
sysctl: http://cmpct.info/files/openbsd_brightness/sysctl.txt
acpidump: http://cmpct.info/files/openbsd_brightness/acpidump.tar.gz
dmesg below.

$ dmesg
OpenBSD 5.7-current (GENERIC.MP) #895: Wed Mar 18 18:55:03 MDT 2015
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 4123258880 (3932MB)
avail mem = 3994349568 (3809MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xe65a0 (52 entries)
bios0: vendor Packard Bell version "V1.20" date 03/16/2012
bios0: Packard Bell EasyNote TS13HR
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP ASF! HPET APIC MCFG SLIC SSDT BOOT ASPT SSDT
SSDT acpi0: wakeup devices P0P1(S4) GLAN(S0) EHC1(S3) HDEF(S0) PXSX(S4)
RP01(S4) PXSX(S4) PXSX(S4) PXSX(S4) RP04(S4) PXSX(S4) PXSX(S4) PXSX(S4)
PXSX(S4) PEG0(S4) PEGP(S4) [...] acpitimer0 at acpi0: 3579545 Hz, 24
bits acpihpet0 at acpi0: 14318179 Hz acpimadt0 at acpi0 addr
0xfee00000: PC-AT compat cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz, 2095.61 MHz
cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,XSAVE,AVX,NXE,LONG,LAHF,PERF,ITSC
cpu0: 256KB 64b/line 8-way L2 cache cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.1.2, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz, 2095.24 MHz
cpu1:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,XSAVE,AVX,NXE,LONG,LAHF,PERF,ITSC
cpu1: 256KB 64b/line 8-way L2 cache cpu1: smt 1, core 0, package 0
cpu2 at mainbus0: apid 2 (application processor)
cpu2: Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz, 2095.24 MHz
cpu2:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,XSAVE,AVX,NXE,LONG,LAHF,PERF,ITSC
cpu2: 256KB 64b/line 8-way L2 cache cpu2: smt 0, core 1, package 0
cpu3 at mainbus0: apid 3 (application processor)
cpu3: Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz, 2095.24 MHz
cpu3:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,XSAVE,AVX,NXE,LONG,LAHF,PERF,ITSC
cpu3: 256KB 64b/line 8-way L2 cache cpu3: smt 1, core 1, package 0
ioapic0 at mainbus0: apid 0 pa 0xfec00000, version 20, 24 pins
acpimcfg0 at acpi0 addr 0xe0000000, bus 0-255
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (P0P1)
acpiprt2 at acpi0: bus 2 (RP01)
acpiprt3 at acpi0: bus 3 (RP02)
acpiprt4 at acpi0: bus -1 (RP03)
acpiprt5 at acpi0: bus -1 (RP04)
acpiprt6 at acpi0: bus -1 (RP05)
acpiprt7 at acpi0: bus -1 (RP06)
acpiprt8 at acpi0: bus -1 (RP07)
acpiprt9 at acpi0: bus -1 (RP08)
acpiprt10 at acpi0: bus -1 (PEG0)
acpiprt11 at acpi0: bus -1 (PEG1)
acpiprt12 at acpi0: bus -1 (PEG2)
acpiprt13 at acpi0: bus -1 (PEG3)
acpiec0 at acpi0
acpicpu0 at acpi0: C3, C1, PSS
acpicpu1 at acpi0: C3, C1, PSS
acpicpu2 at acpi0: C3, C1, PSS
acpicpu3 at acpi0: C3, C1, PSS
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT0 model "Li_Ion_4000mA " serial ae66 type Lion
oem "SANYO " acpibtn0 at acpi0: PWRB
acpibtn1 at acpi0: LID0
acpibtn2 at acpi0: SLPB
acpivideo0 at acpi0: GFX0
acpivout0 at acpivideo0: DD03
cpu0: Enhanced SpeedStep 2095 MHz: speeds: 2100, 2000, 1900, 1800,
1700, 1600, 1500, 1400, 1300, 1200, 1100, 1000, 900, 800 MHz pci0 at
mainbus0 bus 0 pchb0 at pci0 dev 0 function 0 "Intel Core 2G Host" rev
0x09 vga1 at pci0 dev 2 function 0 "Intel HD Graphics 3000" rev 0x09
intagp at vga1 not configured
inteldrm0 at vga1
drm0 at inteldrm0
inteldrm0: 1366x768
wsdisplay0 at vga1 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
"Intel 6 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
ehci0 at pci0 dev 26 function 0 "Intel 6 Series USB" rev 0x04: apic 0
int 16 usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 6 Series HD Audio" rev 0x04:
msi azalia0: codecs: Realtek ALC269, Intel/0x2805, using Realtek ALC269
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 6 Series PCIE" rev 0xb4: msi
pci1 at ppb0 bus 2
2:0:0: mem address conflict 0xfffff800/0x800
bge0 at pci1 dev 0 function 0 "Broadcom BCM57785" rev 0x10, BCM57765 B0
(0x57785100): msi, address b8:70:f4:97:b8:9d brgphy0 at bge0 phy 1:
BCM57765 10/100/1000baseT PHY, rev. 4 sdhc0 at pci1 dev 0 function 1
"Broadcom SD Host Controller" rev 0x10: apic 0 int 17 sdhc0 at 0x10:
can't map registers vendor "Broadcom", unknown product 0x16be (class
system subclass miscellaneous, rev 0x10) at pci1 dev 0 function 2 not
configured vendor "Broadcom", unknown product 0x16bf (class system
subclass miscellaneous, rev 0x10) at pci1 dev 0 function 3 not
configured ppb1 at pci0 dev 28 function 1 "Intel 6 Series PCIE" rev
0xb4: msi pci2 at ppb1 bus 3 athn0 at pci2 dev 0 function 0 "Atheros
AR9287" rev 0x01: apic 0 int 17 athn0: AR9287 rev 2 (2T2R), ROM rev 4,
address cc:af:78:2e:c5:8b ehci1 at pci0 dev 29 function 0 "Intel 6
Series USB" rev 0x04: apic 0 int 23 usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1 pcib0 at pci0
dev 31 function 0 "Intel HM65 LPC" rev 0x04 ahci0 at pci0 dev 31
function 2 "Intel 6 Series AHCI" rev 0x04: msi, AHCI 1.3 ahci0: port 0,
at 3Gbps ahci0: port 1, at 1.5Gbps
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, TOSHIBA MK5059GS, GT00> SCSI3
0/direct fixed naa.50000395da3007e0 sd0: 476940MB, 512 bytes/sector,
976773168 sectors cd0 at scsibus1 targ 1 lun 0: <PIONEER, DVD-RW
DVRTD10RS, 1.00> ATAPI 5/cdrom removable ichiic0 at pci0 dev 31
function 3 "Intel 6 Series SMBus" rev 0x04: apic 0 int 19 iic0 at
ichiic0 spdmem0 at iic0 addr 0x50: 2GB DDR3 SDRAM PC3-10600 SO-DIMM
spdmem1 at iic0 addr 0x52: 2GB DDR3 SDRAM PC3-10600 SO-DIMM
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pms0: Synaptics touchpad, firmware 7.5
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
uhub2 at uhub0 port 1 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
uvideo0 at uhub2 port 3 configuration 1 interface 0 "Chicony
Electronics Co., Ltd. 1.3M HD WebCam" rev 2.00/48.53 addr 3 video0 at
uvideo0 uhub3 at uhub1 port 1 "Intel Rate Matching Hub" rev 2.00/0.00
addr 2 vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
softraid0: sd1 was not shutdown properly
sd1 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 005> SCSI2 0/direct
fixed sd1: 472834MB, 512 bytes/sector, 968365542 sectors
root on sd1a (b3439c9e7f73cf27.a) swap on sd1b dump on sd1b
WARNING: / was not properly unmounted