[UPDATE] security/arirang to 1.95

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[UPDATE] security/arirang to 1.95

jung-2
hiya

today, arirang v1.95 released ;-)

* new features
supported arirang Ruby script (-R option)
added script directory - some arirang ruby script examples
changed osfinger to malloc.
fixed few signal in old code.
fixed few bugs.

this is diff to update arirang 1.95

can someone commit it ? ;-)

thanks
- jung

arirang-1.95.diff (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [UPDATE] security/arirang to 1.95

Landry Breuil-5
On Wed, Sep 15, 2010 at 06:40:36PM +0900, jung wrote:

> hiya
>
> today, arirang v1.95 released ;-)
>
> * new features
> supported arirang Ruby script (-R option)
> added script directory - some arirang ruby script examples
> changed osfinger to malloc.
> fixed few signal in old code.
> fixed few bugs.
>
> this is diff to update arirang 1.95
>
> can someone commit it ? ;-)

I'm pretty sure there's a nicer way to deal with extconf.rb files in our
ruby ports infrastructure. And it should use lang/ruby MODULE.

Landry

Reply | Threaded
Open this post in threaded view
|

Re: [UPDATE] security/arirang to 1.95

jung-2
In reply to this post by jung-2
>I'm pretty sure there's a nicer way to deal with extconf.rb files in our
>ruby ports infrastructure. And it should use lang/ruby MODULE.

thank you for kind ask.

ok, changed the Makefile :-)

arirang-1.95-rev.diff (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [UPDATE] security/arirang to 1.95

Landry Breuil-5
On Thu, Sep 16, 2010 at 10:14:52AM +0900, jung wrote:
> >I'm pretty sure there's a nicer way to deal with extconf.rb files in our
> >ruby ports infrastructure. And it should use lang/ruby MODULE.
>
> thank you for kind ask.
>
> ok, changed the Makefile :-)

Asking ports for dependency ruby-1.8.6.369p3(lang/ruby)
arirang-1.95(security/arirang):
LIB_DEPENDS:   ruby.2 from ruby-1.8.6.369p3 (/usr/local/bin/arirang)

you need LIB_DEPENDS+=${MODRUBY_LIB_DEPENDS}...

Landry

Reply | Threaded
Open this post in threaded view
|

Re: [UPDATE] security/arirang to 1.95

jung-2
In reply to this post by jung-2
> Asking ports for dependency ruby-1.8.6.369p3(lang/ruby)
> arirang-1.95(security/arirang):
> LIB_DEPENDS:   ruby.2 from ruby-1.8.6.369p3 (/usr/local/bin/arirang)

> you need LIB_DEPENDS+=${MODRUBY_LIB_DEPENDS}..

yeap.

new diff attachment.
p.s related ruby ports is difficult ;-)

arirang-1.95-r2.diff (4K) Download Attachment