UPDATE: devel/py-jedi 0.10.2 -> 0.12.1 [2/2]

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

UPDATE: devel/py-jedi 0.10.2 -> 0.12.1 [2/2]

Elias M. Mariani
Alexandr was the original MAINTAINER,
As he told me, he is busy this days and I need to update py-jedi>0.11
to run devel/spyder 3.3.0 (another port that I'm sending to ports
later).

This update has a new dependency, devel/py-plaso:
https://marc.info/?l=openbsd-ports&m=153089461311328

The regression tests of the port returned OK.
The only consumer is x11/gnome/builder, may I ask the maintainers to
check if this updates have some impact on that port given that is a
run dependency ?
I will try it myself as well.

Cheers.
Elias.

py-jedi.diff (25K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: UPDATE: devel/py-jedi 0.10.2 -> 0.12.1 [2/2]

Elias M. Mariani
nvm, upstream of gnome-builder seems to be stuck with the >=0.12
version of py-jedi.
https://gitlab.gnome.org/GNOME/gnome-builder/blob/master/src/plugins/jedi/jedi_plugin.py#L193

I guess that we must wait for them to fix it ?
I do not know the protocol in this cases...

Cheers.
Elias.

2018-07-06 13:38 GMT-03:00 Elias M. Mariani <[hidden email]>:

> Alexandr was the original MAINTAINER,
> As he told me, he is busy this days and I need to update py-jedi>0.11
> to run devel/spyder 3.3.0 (another port that I'm sending to ports
> later).
>
> This update has a new dependency, devel/py-plaso:
> https://marc.info/?l=openbsd-ports&m=153089461311328
>
> The regression tests of the port returned OK.
> The only consumer is x11/gnome/builder, may I ask the maintainers to
> check if this updates have some impact on that port given that is a
> run dependency ?
> I will try it myself as well.
>
> Cheers.
> Elias.

Reply | Threaded
Open this post in threaded view
|

Re: UPDATE: devel/py-jedi 0.10.2 -> 0.12.1 [2/2]

Antoine Jacoutot-7
On Fri, Jul 06, 2018 at 01:56:52PM -0300, Elias M. Mariani wrote:
> nvm, upstream of gnome-builder seems to be stuck with the >=0.12
> version of py-jedi.
> https://gitlab.gnome.org/GNOME/gnome-builder/blob/master/src/plugins/jedi/jedi_plugin.py#L193
>
> I guess that we must wait for them to fix it ?
> I do not know the protocol in this cases...

Don't bother with gnome-builder. Jedi is not a hard requirement and they will
eventually cope with 0.12.

> 2018-07-06 13:38 GMT-03:00 Elias M. Mariani <[hidden email]>:
> > Alexandr was the original MAINTAINER,
> > As he told me, he is busy this days and I need to update py-jedi>0.11
> > to run devel/spyder 3.3.0 (another port that I'm sending to ports
> > later).
> >
> > This update has a new dependency, devel/py-plaso:
> > https://marc.info/?l=openbsd-ports&m=153089461311328
> >
> > The regression tests of the port returned OK.
> > The only consumer is x11/gnome/builder, may I ask the maintainers to
> > check if this updates have some impact on that port given that is a
> > run dependency ?
> > I will try it myself as well.
> >
> > Cheers.
> > Elias.
>

--
Antoine

Reply | Threaded
Open this post in threaded view
|

Re: UPDATE: devel/py-jedi 0.10.2 -> 0.12.1 [2/2]

Alexandr Shadchin-2
In reply to this post by Elias M. Mariani
On Fri, Jul 06, 2018 at 01:38:11PM -0300, Elias M. Mariani wrote:

> Alexandr was the original MAINTAINER,
> As he told me, he is busy this days and I need to update py-jedi>0.11
> to run devel/spyder 3.3.0 (another port that I'm sending to ports
> later).
>
> This update has a new dependency, devel/py-plaso:
> https://marc.info/?l=openbsd-ports&m=153089461311328
>
> The regression tests of the port returned OK.
> The only consumer is x11/gnome/builder, may I ask the maintainers to
> check if this updates have some impact on that port given that is a
> run dependency ?
> I will try it myself as well.
>
> Cheers.
> Elias.

I tested on amd64. ok shadchin@ (for devel/py-parso too)

Reply | Threaded
Open this post in threaded view
|

Re: UPDATE: devel/py-jedi 0.10.2 -> 0.12.1 [2/2]

Elias M. Mariani
Taking maintainer from alexandr.

2018-07-08 22:59 GMT-03:00 Alexandr Shadchin <[hidden email]>:

> On Fri, Jul 06, 2018 at 01:38:11PM -0300, Elias M. Mariani wrote:
>> Alexandr was the original MAINTAINER,
>> As he told me, he is busy this days and I need to update py-jedi>0.11
>> to run devel/spyder 3.3.0 (another port that I'm sending to ports
>> later).
>>
>> This update has a new dependency, devel/py-plaso:
>> https://marc.info/?l=openbsd-ports&m=153089461311328
>>
>> The regression tests of the port returned OK.
>> The only consumer is x11/gnome/builder, may I ask the maintainers to
>> check if this updates have some impact on that port given that is a
>> run dependency ?
>> I will try it myself as well.
>>
>> Cheers.
>> Elias.
>
> I tested on amd64. ok shadchin@ (for devel/py-parso too)

py-jedi.diff (25K) Download Attachment