Turning off Accel crashes X11

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Turning off Accel crashes X11

Jon Fineman
>Synopsis: Turning off Accel crashes X11
>Category: System
>Environment:
        System      : OpenBSD 6.6
        Details     : OpenBSD 6.6-current (GENERIC.MP) #439: Fri Nov  8 14:00:31 MST 2019
                         [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP

        Architecture: OpenBSD.amd64
        Machine     : amd64
>Description:
        In xorg.conf setting Option "Accel" "false" causes X11 to crash
>How-To-Repeat:
        In /etc/X11/xorg.conf in the Device section setting:
        Option "Accel" "false"
        Causes X11 to crash when restarted.
>Fix:
        Leave the setting default.


dmesg:
OpenBSD 6.6-current (GENERIC.MP) #439: Fri Nov  8 14:00:31 MST 2019
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 5978714112 (5701MB)
avail mem = 5785186304 (5517MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 3.0 @ 0xdf266000 (27 entries)
bios0: vendor Insyde Corp. version "V1.00" date 03/20/2017
bios0: Acer Aspire A315-21
acpi0 at bios0: ACPI 5.0
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP MSDM BOOT HPET MCFG WDAT UEFI SSDT IVRS SSDT SSDT SSDT UEFI SPCR SSDT CRAT TPM2 FPDT ASF! WDRT VFCT SSDT APIC SSDT BGRT
acpi0: wakeup devices GPP1(S4) GPP4(S4) GFX0(S4) GFX1(S4) GFX2(S4) GFX3(S4) GFX4(S4) EHC1(S3) XHC0(S3)
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpihpet0 at acpi0: 14318180 Hz
acpimcfg0 at acpi0
acpimcfg0: addr 0xf8000000, bus 0-63
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 16 (boot processor)
cpu0: AMD A9-9420 RADEON R5, 5 COMPUTE CORES 2C+3G, 2994.74 MHz, 15-70-00
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,MOVBE,POPCNT,AES,XSAVE,AVX,F16C,RDRAND,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,MWAITX,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,XSAVEOPT
cpu0: 96KB 64b/line 3-way I-cache, 32KB 64b/line 8-way D-cache, 1MB 64b/line 16-way L2 cache
cpu0: ITLB 48 4KB entries fully associative, 24 4MB entries fully associative
cpu0: DTLB 64 4KB entries fully associative, 64 4MB entries fully associative
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, IBE
cpu1 at mainbus0: apid 17 (application processor)
cpu1: AMD A9-9420 RADEON R5, 5 COMPUTE CORES 2C+3G, 2994.39 MHz, 15-70-00
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,MOVBE,POPCNT,AES,XSAVE,AVX,F16C,RDRAND,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,MWAITX,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,XSAVEOPT
cpu1: 96KB 64b/line 3-way I-cache, 32KB 64b/line 8-way D-cache, 1MB 64b/line 16-way L2 cache
cpu1: ITLB 48 4KB entries fully associative, 24 4MB entries fully associative
cpu1: DTLB 64 4KB entries fully associative, 64 4MB entries fully associative
cpu1: smt 1, core 0, package 0
ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 21, 24 pins, remapped
ioapic1 at mainbus0: apid 5 pa 0xfec01000, version 21, 32 pins, remapped
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (GPP0)
acpiprt2 at acpi0: bus 2 (GPP1)
acpiprt3 at acpi0: bus 3 (GPP2)
acpiprt4 at acpi0: bus -1 (GPP3)
acpiprt5 at acpi0: bus -1 (GPP4)
acpiprt6 at acpi0: bus -1 (GFX0)
acpiprt7 at acpi0: bus -1 (GFX1)
acpiprt8 at acpi0: bus -1 (GFX2)
acpiprt9 at acpi0: bus -1 (GFX3)
acpiprt10 at acpi0: bus -1 (GFX4)
acpiec0 at acpi0
acpicpu0 at acpi0: C2(0@400 io@0x414), C1(@1 halt!), PSS
acpicpu1 at acpi0: C2(0@400 io@0x414), C1(@1 halt!), PSS
acpipwrres0 at acpi0: WRST
acpipwrres1 at acpi0: P0U3, resource for XHC0
acpipwrres2 at acpi0: P3U3, resource for XHC0
acpipwrres3 at acpi0: P0U2, resource for EHC1
acpipwrres4 at acpi0: P3U2, resource for EHC1
acpipwrres5 at acpi0: P0SD, resource for SDIO
acpipwrres6 at acpi0: P3SD, resource for SDIO
acpipwrres7 at acpi0: P0ST, resource for SATA
acpipwrres8 at acpi0: P3ST, resource for SATA
acpitz0 at acpi0: critical temperature is 100 degC
acpibtn0 at acpi0: PWRB
acpipci0 at acpi0 PCI0: 0x00000010 0x00000011 0x00000000
acpicmos0 at acpi0
"PNP0C14" at acpi0 not configured
"PNP0C14" at acpi0 not configured
acpibtn1 at acpi0: SLPB
acpiac0 at acpi0: AC unit offline
acpibat0 at acpi0: BAT1 model "AP16M5J" serial 3742 type LION oem "PANASONIC"
acpibtn2 at acpi0: LID_
"AMD0030" at acpi0 not configured
"AMD0020" at acpi0 not configured
"AMD0020" at acpi0 not configured
"AMD0010" at acpi0 not configured
"SYNA7DB5" at acpi0 not configured
"AMD0010" at acpi0 not configured
"MSFT0101" at acpi0 not configured
acpivideo0 at acpi0: VGA_
acpivideo1 at acpi0: VGA_
acpivideo2 at acpi0: VGA_
cpu0: 2994 MHz: speeds: 3000 2700 2400 2100 1800 1400 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "AMD AMD64 15h Root Complex" rev 0x00
"AMD AMD64 15h IOMMU" rev 0x00 at pci0 dev 0 function 2 not configured
amdgpu0 at pci0 dev 1 function 0 "ATI Stoney Ridge" rev 0xda
drm0 at amdgpu0
amdgpu0: msi
azalia0 at pci0 dev 1 function 1 vendor "ATI", unknown product 0x15b3 rev 0x00: msi
azalia0: no supported codecs
pchb1 at pci0 dev 2 function 0 "AMD AMD64 15h Host" rev 0x00
ppb0 at pci0 dev 2 function 1 "AMD AMD64 15h PCIE" rev 0x00: msi
pci1 at ppb0 bus 1
ppb1 at pci0 dev 2 function 2 "AMD AMD64 15h PCIE" rev 0x00: msi
pci2 at ppb1 bus 2
rtsx0 at pci2 dev 0 function 0 "Realtek RTL8411B Card Reader" rev 0x01: msi
sdmmc0 at rtsx0: 4-bit, dma
re0 at pci2 dev 0 function 1 "Realtek 8168" rev 0x12: RTL8411B (0x5c80), msi, address a8:1e:84:82:c3:0b
rgephy0 at re0 phy 7: RTL8251 PHY, rev. 0
ppb2 at pci0 dev 2 function 3 "AMD AMD64 15h PCIE" rev 0x00: msi
pci3 at ppb2 bus 3
vendor "Atheros", unknown product 0x0042 (class network subclass miscellaneous, rev 0x31) at pci3 dev 0 function 0 not configured
pchb2 at pci0 dev 3 function 0 "AMD AMD64 15h Host" rev 0x00
"AMD AMD64 15h PSP 2.0" rev 0x00 at pci0 dev 8 function 0 not configured
pchb3 at pci0 dev 9 function 0 "AMD AMD64 15h Host" rev 0x00
azalia1 at pci0 dev 9 function 2 "AMD AMD64 15h HD Audio" rev 0x00: apic 5 int 22
azalia1: codecs: Realtek/0x0255
audio0 at azalia1
xhci0 at pci0 dev 16 function 0 "AMD FCH xHCI" rev 0x20: msi, xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "AMD xHCI root hub" rev 3.00/1.00 addr 1
ahci0 at pci0 dev 17 function 0 "AMD FCH AHCI" rev 0x4b: apic 4 int 19, AHCI 1.3
ahci0: port 0: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, ST1000LM035-1RK1, ACM1> naa.5000c500a7f53af8
sd0: 953869MB, 512 bytes/sector, 1953525168 sectors
ehci0 at pci0 dev 18 function 0 "AMD FCH USB2" rev 0x49: apic 4 int 18
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "AMD EHCI root hub" rev 2.00/1.00 addr 1
"AMD FCH SMBus" rev 0x4b at pci0 dev 20 function 0 not configured
pcib0 at pci0 dev 20 function 3 "AMD FCH LPC" rev 0x11
pchb4 at pci0 dev 24 function 0 vendor "AMD", unknown product 0x15b0 rev 0x00
pchb5 at pci0 dev 24 function 1 vendor "AMD", unknown product 0x15b1 rev 0x00
pchb6 at pci0 dev 24 function 2 vendor "AMD", unknown product 0x15b2 rev 0x00
pchb7 at pci0 dev 24 function 3 vendor "AMD", unknown product 0x15b3 rev 0x00
pchb8 at pci0 dev 24 function 4 vendor "AMD", unknown product 0x15b4 rev 0x00
pchb9 at pci0 dev 24 function 5 vendor "AMD", unknown product 0x15b5 rev 0x00
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pms0: Synaptics clickpad, firmware 8.2, 0x1e2a1 0x840300
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: SVM/RVI
efifb at mainbus0 not configured
uhub2 at uhub1 port 1 configuration 1 interface 0 "Advanced Micro Devices product 0x7900" rev 2.00/0.18 addr 2
urtwn0 at uhub2 port 1 configuration 1 interface 0 "Realtek 802.11n WLAN Adapter" rev 2.00/2.00 addr 3
urtwn0: MAC/BB RTL8188CUS, RF 6052 1T1R, address 74:da:38:f6:b4:79
ugen0 at uhub2 port 3 "Lite-On Technology product 0x3015" rev 2.01/0.01 addr 4
uvideo0 at uhub2 port 4 configuration 1 interface 0 "KSVGA0500171401441LM06 VGA WebCam" rev 2.00/0.06 addr 5
video0 at uvideo0
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a (be97021614325285.a) swap on sd0b dump on sd0b
initializing kernel modesetting (STONEY 0x1002:0x98E4 0x1025:0x1192 0xDA).
amdgpu_irq_add_domain: stub
amdgpu0: 1366x768, 32bpp
wsdisplay0 at amdgpu0 mux 1: console (std, vt100 emulation), using wskbd0
wsdisplay0: screen 1-5 added (std, vt100 emulation)

usbdevs:
Controller /dev/usb0:
addr 01: 1022:0000 AMD, xHCI root hub
         super speed, self powered, config 1, rev 1.00
         driver: uhub0
Controller /dev/usb1:
addr 01: 1022:0000 AMD, EHCI root hub
         high speed, self powered, config 1, rev 1.00
         driver: uhub1
addr 02: 0438:7900 Advanced Micro Devices, product 0x7900
         high speed, self powered, config 1, rev 0.18
         driver: uhub2
addr 03: 7392:7811 Realtek, 802.11n WLAN Adapter
         high speed, power 500 mA, config 1, rev 2.00, iSerial 00e04c000001
         driver: urtwn0
addr 04: 04ca:3015 Lite-On Technology, product 0x3015
         full speed, self powered, config 1, rev 0.01
         driver: ugen0
addr 05: 0bda:5648 KSVGA0500171401441LM06, VGA WebCam
         high speed, power 500 mA, config 1, rev 0.06, iSerial 200901010001
         driver: uvideo0

Reply | Threaded
Open this post in threaded view
|

Re: Turning off Accel crashes X11

Matthieu Herrb-3
On Wed, Nov 13, 2019 at 09:14:13PM -0500, Jon Fineman wrote:

> >Synopsis: Turning off Accel crashes X11
> >Category: System
> >Environment:
> System      : OpenBSD 6.6
> Details     : OpenBSD 6.6-current (GENERIC.MP) #439: Fri Nov  8 14:00:31 MST 2019
> [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
>
> Architecture: OpenBSD.amd64
> Machine     : amd64
> >Description:
> In xorg.conf setting Option "Accel" "false" causes X11 to crash
> >How-To-Repeat:
> In /etc/X11/xorg.conf in the Device section setting:
> Option "Accel" "false"
> Causes X11 to crash when restarted.
> >Fix:
> Leave the setting default.
>

Hi,

Thanks for the report.

Could you try to get an X backtrace (following the instructions in
/usr/xenocara/README on how to get a core file, and then running egdb
from ports on it) ? or at lease provide us the /var/log/Xorg.0.log
file from a crash ?

Thanks in advance.
--
Matthieu Herrb

Reply | Threaded
Open this post in threaded view
|

Re: Turning off Accel crashes X11

Jon Fineman

----- Original message -----
From: Matthieu Herrb <[hidden email]>
To: Jon Fineman <[hidden email]>
Cc: [hidden email]
Subject: Re: Turning off Accel crashes X11
Date: Thursday, November 14, 2019 1:02 AM

On Wed, Nov 13, 2019 at 09:14:13PM -0500, Jon Fineman wrote:

> >Synopsis: Turning off Accel crashes X11
> >Category: System
> >Environment:
> System      : OpenBSD 6.6
> Details     : OpenBSD 6.6-current (GENERIC.MP) #439: Fri Nov  8 14:00:31 MST 2019
> [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
>
> Architecture: OpenBSD.amd64
> Machine     : amd64
> >Description:
> In xorg.conf setting Option "Accel" "false" causes X11 to crash
> >How-To-Repeat:
> In /etc/X11/xorg.conf in the Device section setting:
> Option "Accel" "false"
> Causes X11 to crash when restarted.
> >Fix:
> Leave the setting default.
>

Hi,

Thanks for the report.

Could you try to get an X backtrace (following the instructions in
/usr/xenocara/README on how to get a core file, and then running egdb
from ports on it) ? or at lease provide us the /var/log/Xorg.0.log
file from a crash ?

Thanks in advance.
--
Matthieu Herrb



Some further info. When I restart xenodm with the flag set I remain at the console tty for root.
Normally I would be transferred to the xenodm login window. When I manually switch to that
window it is just blank. I can type but nothing happens. So saying it crashes might not be
quite accurate.

Below are the xorg.conf and Xorg.0.org log files. I am working on the dump. Some hints would be appreciated.


Section "Device"
        Identifier "graphicsdriver"
        Driver "AMDGPU"
        ### Option "SWCursor" "false"
        ### Option "Accel" "false"
        Option "Accel" "false"
        ### Option "EnablePageFlip" "false"
        Option "TearFree" "true"
        ### Option "AccelMethod" "none"
EndSection

Section "InputClass"
        Identifier "touchpad"
        Driver "synaptics"
        MatchIsTouchpad "on"
        #Device "wsmouse"

        # Enable clickpad/multitouch support
        Option "ClickPad" "true"

        # Middle-button emulation is not supported
        Option "EmulateMidButtonTime" "0"

        # Define right soft button at the bottom
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
        Option "VertEdgeScroll" "on"
        Option "VertTwoFingerScroll" "on"
        Option "HorizEdgeScroll" "on"
        Option "HorizTwoFingerScroll" "on"
        Option "CircularScrolling" "on"
        Option "CircScrollTrigger" "2"
        Option "EmulateTwoFingerMinZ" "40"
        Option "EmulateTwoFingerMinW" "8"
        Option "CoastingSpeed" "0"
        Option "FingerLow" "35"
EndSection



[341486.708] (--) checkDevMem: using aperture driver /dev/xf86
[341486.719] (--) Using wscons driver on /dev/ttyC4
[341486.738]
X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
[341486.739] Build Operating System: OpenBSD 6.6 amd64
[341486.739] Current Operating System: OpenBSD laptop.jonjfineman.me 6.6 GENERIC.MP#439 amd64
[341486.739] Build Date: 08 November 2019  02:26:05PM
[341486.739]  
[341486.739] Current version of pixman: 0.38.4
[341486.739] Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[341486.739] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[341486.739] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 14 16:50:01 2019
[341486.740] (==) Using config file: "/etc/X11/xorg.conf"
[341486.740] (==) Using system config directory "/usr/X11R6/share/X11/xorg.conf.d"
[341486.741] (==) No Layout section.  Using the first Screen section.
[341486.741] (==) No screen section available. Using defaults.
[341486.741] (**) |-->Screen "Default Screen Section" (0)
[341486.741] (**) |   |-->Monitor "<default monitor>"
[341486.743] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
[341486.743] (**) |   |-->Device "graphicsdriver"
[341486.743] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[341486.743] (==) Automatically adding devices
[341486.743] (==) Automatically enabling devices
[341486.743] (==) Not automatically adding GPU devices
[341486.743] (==) Max clients allowed: 256, resource mask: 0x1fffff
[341486.744] (==) FontPath set to:
        /usr/X11R6/lib/X11/fonts/misc/,
        /usr/X11R6/lib/X11/fonts/TTF/,
        /usr/X11R6/lib/X11/fonts/OTF/,
        /usr/X11R6/lib/X11/fonts/Type1/,
        /usr/X11R6/lib/X11/fonts/100dpi/,
        /usr/X11R6/lib/X11/fonts/75dpi/
[341486.744] (==) ModulePath set to "/usr/X11R6/lib/modules"
[341486.744] (II) The server relies on wscons to provide the list of input devices.
        If no devices become available, reconfigure wscons or disable AutoAddDevices.
[341486.744] (II) Loader magic: 0x9f681e28000
[341486.744] (II) Module ABI versions:
[341486.744] X.Org ANSI C Emulation: 0.4
[341486.744] X.Org Video Driver: 24.0
[341486.744] X.Org XInput driver : 24.1
[341486.744] X.Org Server Extension : 10.0
[341486.745] (--) PCI:*(0@0:1:0) 1002:98e4:1025:1192 rev 218, Mem @ 0xe0000000/268435456, 0xf0000000/8388608, 0xf0d00000/262144, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
[341486.745] (II) LoadModule: "glx"
[341486.749] (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
[341486.754] (II) Module glx: vendor="X.Org Foundation"
[341486.754] compiled for 1.20.5, module version = 1.0.0
[341486.754] ABI class: X.Org Server Extension, version 10.0
[341486.754] (II) LoadModule: "amdgpu"
[341486.757] (II) Loading /usr/X11R6/lib/modules/drivers/amdgpu_drv.so
[341486.758] (II) Module amdgpu: vendor="X.Org Foundation"
[341486.758] compiled for 1.20.5, module version = 19.1.0
[341486.758] Module class: X.Org Video Driver
[341486.758] ABI class: X.Org Video Driver, version 24.0
[341486.758] (II) AMDGPU: Driver for AMD Radeon:
        All GPUs supported by the amdgpu kernel driver
[341486.783] (II) AMDGPU(0): [KMS] Kernel modesetting enabled.
[341486.802] (II) AMDGPU(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[341486.802] (==) AMDGPU(0): Depth 24, (--) framebuffer bpp 32
[341486.802] (II) AMDGPU(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[341486.802] (==) AMDGPU(0): Default visual is TrueColor
[341486.802] (**) AMDGPU(0): Option "Accel" "false"
[341486.802] (**) AMDGPU(0): Option "TearFree" "true"
[341486.802] (==) AMDGPU(0): RGB weight 888
[341486.802] (II) AMDGPU(0): Using 8 bits per RGB (8 bit DAC)
[341486.802] (--) AMDGPU(0): Chipset: "Unknown AMD Radeon GPU" (ChipID = 0x98e4)
[341486.802] (II) Loading sub module "fb"
[341486.802] (II) LoadModule: "fb"
[341486.806] (II) Loading /usr/X11R6/lib/modules/libfb.so
[341486.807] (II) Module fb: vendor="X.Org Foundation"
[341486.807] compiled for 1.20.5, module version = 1.0.0
[341486.807] ABI class: X.Org ANSI C Emulation, version 0.4
[341486.807] (**) AMDGPU(0): GPU acceleration disabled, using ShadowFB
[341486.807] (II) Loading sub module "shadow"
[341486.807] (II) LoadModule: "shadow"
[341486.811] (II) Loading /usr/X11R6/lib/modules/libshadow.so
[341486.920] (II) Module shadow: vendor="X.Org Foundation"
[341486.920] compiled for 1.20.5, module version = 1.1.0
[341486.920] ABI class: X.Org ANSI C Emulation, version 0.4
[341486.920] (II) AMDGPU(0): KMS Pageflipping: enabled
[341486.921] (II) AMDGPU(0): Output eDP has no monitor section
[341486.921] (II) AMDGPU(0): Output HDMI-A-0 has no monitor section
[341486.921] (II) AMDGPU(0): Output DisplayPort-0 has no monitor section
[341486.934] (WW) AMDGPU(0): 3 ZaphodHeads crtcs unavailable. Some outputs will stay off.
[341486.935] (II) AMDGPU(0): EDID for output eDP
[341486.935] (II) AMDGPU(0): Manufacturer: CMN  Model: 15dc  Serial#: 0
[341486.935] (II) AMDGPU(0): Year: 2015  Week: 45
[341486.935] (II) AMDGPU(0): EDID Version: 1.4
[341486.935] (II) AMDGPU(0): Digital Display Input
[341486.935] (II) AMDGPU(0): 6 bits per channel
[341486.935] (II) AMDGPU(0): Digital interface is DisplayPort
[341486.935] (II) AMDGPU(0): Max Image Size [cm]: horiz.: 34  vert.: 19
[341486.935] (II) AMDGPU(0): Gamma: 2.20
[341486.935] (II) AMDGPU(0): No DPMS capabilities specified
[341486.935] (II) AMDGPU(0): Supported color encodings: RGB 4:4:4
[341486.935] (II) AMDGPU(0): First detailed timing is preferred mode
[341486.935] (II) AMDGPU(0): Preferred mode is native pixel format and refresh rate
[341486.935] (II) AMDGPU(0): redX: 0.569 redY: 0.332   greenX: 0.328 greenY: 0.581
[341486.935] (II) AMDGPU(0): blueX: 0.163 blueY: 0.147   whiteX: 0.313 whiteY: 0.329
[341486.935] (II) AMDGPU(0): Manufacturer's mask: 0
[341486.935] (II) AMDGPU(0): Supported detailed timing:
[341486.935] (II) AMDGPU(0): clock: 76.4 MHz   Image Size:  344 x 193 mm
[341486.935] (II) AMDGPU(0): h_active: 1366  h_sync: 1434  h_sync_end 1479 h_blank_end 1592 h_border: 0
[341486.935] (II) AMDGPU(0): v_active: 768  v_sync: 772  v_sync_end 779 v_blanking: 800 v_border: 0
[341486.935] (II) AMDGPU(0):  N156BGA-EB2
[341486.935] (II) AMDGPU(0):  CMN
[341486.935] (II) AMDGPU(0):  N156BGA-EB2
[341486.935] (II) AMDGPU(0): EDID (in hex):
[341486.935] (II) AMDGPU(0): 00ffffffffffff000daedc1500000000
[341486.935] (II) AMDGPU(0): 2d1901049522137802c3f59155549429
[341486.935] (II) AMDGPU(0): 25505400000001010101010101010101
[341486.935] (II) AMDGPU(0): 010101010101da1d56e250002030442d
[341486.935] (II) AMDGPU(0): 470058c110000018000000fe004e3135
[341486.935] (II) AMDGPU(0): 364247412d4542320a20000000fe0043
[341486.935] (II) AMDGPU(0): 4d4e0a202020202020202020000000fe
[341486.935] (II) AMDGPU(0): 004e3135364247412d4542320a2000f1
[341486.935] (II) AMDGPU(0): Printing probed modes for output eDP
[341486.935] (II) AMDGPU(0): Modeline "1366x768"x60.0   76.42  1366 1434 1479 1592  768 772 779 800 -hsync -vsync (48.0 kHz eP)
[341486.935] (II) AMDGPU(0): Modeline "1280x720"x60.0   76.42  1280 1434 1479 1592  720 772 779 800 -hsync -vsync (48.0 kHz e)
[341486.935] (II) AMDGPU(0): Modeline "1024x768"x60.0   76.42  1024 1434 1479 1592  768 772 779 800 -hsync -vsync (48.0 kHz e)
[341486.935] (II) AMDGPU(0): Modeline "800x600"x60.0   76.42  800 1434 1479 1592  600 772 779 800 -hsync -vsync (48.0 kHz e)
[341486.935] (II) AMDGPU(0): Modeline "640x480"x60.0   76.42  640 1434 1479 1592  480 772 779 800 -hsync -vsync (48.0 kHz e)
[341486.935] (II) AMDGPU(0): EDID for output HDMI-A-0
[341486.935] (II) AMDGPU(0): EDID for output DisplayPort-0
[341486.936] (II) AMDGPU(0): Output eDP connected
[341486.936] (II) AMDGPU(0): Output HDMI-A-0 disconnected
[341486.936] (II) AMDGPU(0): Output DisplayPort-0 disconnected
[341486.936] (II) AMDGPU(0): Using exact sizes for initial modes
[341486.936] (II) AMDGPU(0): Output eDP using initial mode 1366x768 +0+0
[341486.936] (II) AMDGPU(0): mem size init: gart size :bf89a000 vram size: s:1777a000 visible:1777a000
[341486.936] (==) AMDGPU(0): DPI set to (96, 96)
[341486.936] (==) AMDGPU(0): Using gamma correction (1.0, 1.0, 1.0)
[341486.936] (II) Loading sub module "ramdac"
[341486.936] (II) LoadModule: "ramdac"
[341486.936] (II) Module "ramdac" already built-in
[341486.936] (II) AMDGPU(0): Front buffer pitch: 6144 bytes
[341486.937] (==) AMDGPU(0): DRI3 disabled
[341486.937] (==) AMDGPU(0): Backing store enabled
[341486.937] (WW) AMDGPU(0): Direct rendering disabled
[341486.937] (II) AMDGPU(0): 2D and 3D acceleration disabled
[341486.937] (==) AMDGPU(0): DPMS enabled
[341486.937] (==) AMDGPU(0): Silken mouse enabled
[341486.968] (II) Initializing extension Generic Event Extension
[341486.969] (II) Initializing extension SHAPE
[341486.970] (II) Initializing extension MIT-SHM
[341486.971] (II) Initializing extension XInputExtension
[341486.972] (II) Initializing extension XTEST
[341486.973] (II) Initializing extension BIG-REQUESTS
[341486.975] (II) Initializing extension SYNC
[341486.976] (II) Initializing extension XKEYBOARD
[341486.977] (II) Initializing extension XC-MISC
[341486.978] (II) Initializing extension SECURITY
[341486.979] (II) Initializing extension XFIXES
[341486.980] (II) Initializing extension RENDER
[341486.981] (II) Initializing extension RANDR
[341486.984] (II) Initializing extension COMPOSITE
[341486.985] (II) Initializing extension DAMAGE
[341486.986] (II) Initializing extension MIT-SCREEN-SAVER
[341486.987] (II) Initializing extension DOUBLE-BUFFER
[341486.988] (II) Initializing extension RECORD
[341486.990] (II) Initializing extension DPMS
[341486.991] (II) Initializing extension Present
[341486.992] (II) Initializing extension DRI3
[341486.992] (II) Initializing extension X-Resource
[341486.993] (II) Initializing extension XVideo
[341486.994] (II) Initializing extension XVideo-MotionCompensation
[341486.994] (II) Initializing extension GLX
[341486.996] (II) AIGLX: Screen 0 is not DRI2 capable
[341487.087] (II) IGLX: Loaded and initialized swrast
[341487.087] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[341487.087] (II) Initializing extension XFree86-VidModeExtension
[341487.088] (II) Initializing extension XFree86-DGA
[341487.089] (II) Initializing extension XFree86-DRI
[341487.089] (II) Initializing extension DRI2
[341487.091] (II) AMDGPU(0): Setting screen physical size to 361 x 203
[341487.271] (EE) Received signal 6 sent by process 0, uid 0
[341487.272] (EE)
Fatal server error:
[341487.272] (EE) Caught signal 6 (Abort trap). Server aborting
[341487.272] (EE)
[341487.272] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[341487.272] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[341487.272] (EE)
[341487.275] (EE) Server terminated with error (1). Closing log file.


Reply | Threaded
Open this post in threaded view
|

Re: Turning off Accel crashes X11

Jon Fineman
Sorry if this is a duplicate, but I didn't see this get posted.


"Jon Fineman" <[hidden email]> wrote:

>
> ----- Original message -----
> From: Matthieu Herrb <[hidden email]>
> To: Jon Fineman <[hidden email]>
> Cc: [hidden email]
> Subject: Re: Turning off Accel crashes X11
> Date: Thursday, November 14, 2019 1:02 AM
>
> On Wed, Nov 13, 2019 at 09:14:13PM -0500, Jon Fineman wrote:
> > >Synopsis: Turning off Accel crashes X11
> > >Category: System
> > >Environment:
> > System      : OpenBSD 6.6
> > Details     : OpenBSD 6.6-current (GENERIC.MP) #439: Fri Nov  8 14:00:31 MST 2019
> > [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
> >
> > Architecture: OpenBSD.amd64
> > Machine     : amd64
> > >Description:
> > In xorg.conf setting Option "Accel" "false" causes X11 to crash
> > >How-To-Repeat:
> > In /etc/X11/xorg.conf in the Device section setting:
> > Option "Accel" "false"
> > Causes X11 to crash when restarted.
> > >Fix:
> > Leave the setting default.
> >
>
> Hi,
>
> Thanks for the report.
>
> Could you try to get an X backtrace (following the instructions in
> /usr/xenocara/README on how to get a core file, and then running egdb
> from ports on it) ? or at lease provide us the /var/log/Xorg.0.log
> file from a crash ?
>
> Thanks in advance.
> --
> Matthieu Herrb
>
>
>
> Some further info. When I restart xenodm with the flag set I remain at the console tty for root.
> Normally I would be transferred to the xenodm login window. When I manually switch to that
> window it is just blank. I can type but nothing happens. So saying it crashes might not be
> quite accurate.
>
> Below are the xorg.conf and Xorg.0.org log files. I am working on the dump. Some hints would be appreciated.
>
>
> Section "Device"
> Identifier "graphicsdriver"
> Driver "AMDGPU"
> ### Option "SWCursor" "false"
> ### Option "Accel" "false"
> Option "Accel" "false"
> ### Option "EnablePageFlip" "false"
> Option "TearFree" "true"
> ### Option "AccelMethod" "none"
> EndSection
>
> Section "InputClass"
> Identifier "touchpad"
> Driver "synaptics"
> MatchIsTouchpad "on"
> #Device "wsmouse"
>
> # Enable clickpad/multitouch support
> Option "ClickPad" "true"
>
> # Middle-button emulation is not supported
> Option "EmulateMidButtonTime" "0"
>
> # Define right soft button at the bottom
> Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
> Option "TapButton1" "1"
> Option "TapButton2" "2"
> Option "TapButton3" "3"
> Option "VertEdgeScroll" "on"
> Option "VertTwoFingerScroll" "on"
> Option "HorizEdgeScroll" "on"
> Option "HorizTwoFingerScroll" "on"
> Option "CircularScrolling" "on"
> Option "CircScrollTrigger" "2"
> Option "EmulateTwoFingerMinZ" "40"
> Option "EmulateTwoFingerMinW" "8"
> Option "CoastingSpeed" "0"
> Option "FingerLow" "35"
> EndSection
>
>
>
> [341486.708] (--) checkDevMem: using aperture driver /dev/xf86
> [341486.719] (--) Using wscons driver on /dev/ttyC4
> [341486.738]
> X.Org X Server 1.20.5
> X Protocol Version 11, Revision 0
> [341486.739] Build Operating System: OpenBSD 6.6 amd64
> [341486.739] Current Operating System: OpenBSD laptop.jonjfineman.me 6.6 GENERIC.MP#439 amd64
> [341486.739] Build Date: 08 November 2019  02:26:05PM
> [341486.739]  
> [341486.739] Current version of pixman: 0.38.4
> [341486.739] Before reporting problems, check http://wiki.x.org
> to make sure that you have the latest version.
> [341486.739] Markers: (--) probed, (**) from config file, (==) default setting,
> (++) from command line, (!!) notice, (II) informational,
> (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> [341486.739] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 14 16:50:01 2019
> [341486.740] (==) Using config file: "/etc/X11/xorg.conf"
> [341486.740] (==) Using system config directory "/usr/X11R6/share/X11/xorg.conf.d"
> [341486.741] (==) No Layout section.  Using the first Screen section.
> [341486.741] (==) No screen section available. Using defaults.
> [341486.741] (**) |-->Screen "Default Screen Section" (0)
> [341486.741] (**) |   |-->Monitor "<default monitor>"
> [341486.743] (==) No device specified for screen "Default Screen Section".
> Using the first device section listed.
> [341486.743] (**) |   |-->Device "graphicsdriver"
> [341486.743] (==) No monitor specified for screen "Default Screen Section".
> Using a default monitor configuration.
> [341486.743] (==) Automatically adding devices
> [341486.743] (==) Automatically enabling devices
> [341486.743] (==) Not automatically adding GPU devices
> [341486.743] (==) Max clients allowed: 256, resource mask: 0x1fffff
> [341486.744] (==) FontPath set to:
> /usr/X11R6/lib/X11/fonts/misc/,
> /usr/X11R6/lib/X11/fonts/TTF/,
> /usr/X11R6/lib/X11/fonts/OTF/,
> /usr/X11R6/lib/X11/fonts/Type1/,
> /usr/X11R6/lib/X11/fonts/100dpi/,
> /usr/X11R6/lib/X11/fonts/75dpi/
> [341486.744] (==) ModulePath set to "/usr/X11R6/lib/modules"
> [341486.744] (II) The server relies on wscons to provide the list of input devices.
> If no devices become available, reconfigure wscons or disable AutoAddDevices.
> [341486.744] (II) Loader magic: 0x9f681e28000
> [341486.744] (II) Module ABI versions:
> [341486.744] X.Org ANSI C Emulation: 0.4
> [341486.744] X.Org Video Driver: 24.0
> [341486.744] X.Org XInput driver : 24.1
> [341486.744] X.Org Server Extension : 10.0
> [341486.745] (--) PCI:*(0@0:1:0) 1002:98e4:1025:1192 rev 218, Mem @ 0xe0000000/268435456, 0xf0000000/8388608, 0xf0d00000/262144, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
> [341486.745] (II) LoadModule: "glx"
> [341486.749] (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
> [341486.754] (II) Module glx: vendor="X.Org Foundation"
> [341486.754] compiled for 1.20.5, module version = 1.0.0
> [341486.754] ABI class: X.Org Server Extension, version 10.0
> [341486.754] (II) LoadModule: "amdgpu"
> [341486.757] (II) Loading /usr/X11R6/lib/modules/drivers/amdgpu_drv.so
> [341486.758] (II) Module amdgpu: vendor="X.Org Foundation"
> [341486.758] compiled for 1.20.5, module version = 19.1.0
> [341486.758] Module class: X.Org Video Driver
> [341486.758] ABI class: X.Org Video Driver, version 24.0
> [341486.758] (II) AMDGPU: Driver for AMD Radeon:
> All GPUs supported by the amdgpu kernel driver
> [341486.783] (II) AMDGPU(0): [KMS] Kernel modesetting enabled.
> [341486.802] (II) AMDGPU(0): Creating default Display subsection in Screen section
> "Default Screen Section" for depth/fbbpp 24/32
> [341486.802] (==) AMDGPU(0): Depth 24, (--) framebuffer bpp 32
> [341486.802] (II) AMDGPU(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
> [341486.802] (==) AMDGPU(0): Default visual is TrueColor
> [341486.802] (**) AMDGPU(0): Option "Accel" "false"
> [341486.802] (**) AMDGPU(0): Option "TearFree" "true"
> [341486.802] (==) AMDGPU(0): RGB weight 888
> [341486.802] (II) AMDGPU(0): Using 8 bits per RGB (8 bit DAC)
> [341486.802] (--) AMDGPU(0): Chipset: "Unknown AMD Radeon GPU" (ChipID = 0x98e4)
> [341486.802] (II) Loading sub module "fb"
> [341486.802] (II) LoadModule: "fb"
> [341486.806] (II) Loading /usr/X11R6/lib/modules/libfb.so
> [341486.807] (II) Module fb: vendor="X.Org Foundation"
> [341486.807] compiled for 1.20.5, module version = 1.0.0
> [341486.807] ABI class: X.Org ANSI C Emulation, version 0.4
> [341486.807] (**) AMDGPU(0): GPU acceleration disabled, using ShadowFB
> [341486.807] (II) Loading sub module "shadow"
> [341486.807] (II) LoadModule: "shadow"
> [341486.811] (II) Loading /usr/X11R6/lib/modules/libshadow.so
> [341486.920] (II) Module shadow: vendor="X.Org Foundation"
> [341486.920] compiled for 1.20.5, module version = 1.1.0
> [341486.920] ABI class: X.Org ANSI C Emulation, version 0.4
> [341486.920] (II) AMDGPU(0): KMS Pageflipping: enabled
> [341486.921] (II) AMDGPU(0): Output eDP has no monitor section
> [341486.921] (II) AMDGPU(0): Output HDMI-A-0 has no monitor section
> [341486.921] (II) AMDGPU(0): Output DisplayPort-0 has no monitor section
> [341486.934] (WW) AMDGPU(0): 3 ZaphodHeads crtcs unavailable. Some outputs will stay off.
> [341486.935] (II) AMDGPU(0): EDID for output eDP
> [341486.935] (II) AMDGPU(0): Manufacturer: CMN  Model: 15dc  Serial#: 0
> [341486.935] (II) AMDGPU(0): Year: 2015  Week: 45
> [341486.935] (II) AMDGPU(0): EDID Version: 1.4
> [341486.935] (II) AMDGPU(0): Digital Display Input
> [341486.935] (II) AMDGPU(0): 6 bits per channel
> [341486.935] (II) AMDGPU(0): Digital interface is DisplayPort
> [341486.935] (II) AMDGPU(0): Max Image Size [cm]: horiz.: 34  vert.: 19
> [341486.935] (II) AMDGPU(0): Gamma: 2.20
> [341486.935] (II) AMDGPU(0): No DPMS capabilities specified
> [341486.935] (II) AMDGPU(0): Supported color encodings: RGB 4:4:4
> [341486.935] (II) AMDGPU(0): First detailed timing is preferred mode
> [341486.935] (II) AMDGPU(0): Preferred mode is native pixel format and refresh rate
> [341486.935] (II) AMDGPU(0): redX: 0.569 redY: 0.332   greenX: 0.328 greenY: 0.581
> [341486.935] (II) AMDGPU(0): blueX: 0.163 blueY: 0.147   whiteX: 0.313 whiteY: 0.329
> [341486.935] (II) AMDGPU(0): Manufacturer's mask: 0
> [341486.935] (II) AMDGPU(0): Supported detailed timing:
> [341486.935] (II) AMDGPU(0): clock: 76.4 MHz   Image Size:  344 x 193 mm
> [341486.935] (II) AMDGPU(0): h_active: 1366  h_sync: 1434  h_sync_end 1479 h_blank_end 1592 h_border: 0
> [341486.935] (II) AMDGPU(0): v_active: 768  v_sync: 772  v_sync_end 779 v_blanking: 800 v_border: 0
> [341486.935] (II) AMDGPU(0):  N156BGA-EB2
> [341486.935] (II) AMDGPU(0):  CMN
> [341486.935] (II) AMDGPU(0):  N156BGA-EB2
> [341486.935] (II) AMDGPU(0): EDID (in hex):
> [341486.935] (II) AMDGPU(0): 00ffffffffffff000daedc1500000000
> [341486.935] (II) AMDGPU(0): 2d1901049522137802c3f59155549429
> [341486.935] (II) AMDGPU(0): 25505400000001010101010101010101
> [341486.935] (II) AMDGPU(0): 010101010101da1d56e250002030442d
> [341486.935] (II) AMDGPU(0): 470058c110000018000000fe004e3135
> [341486.935] (II) AMDGPU(0): 364247412d4542320a20000000fe0043
> [341486.935] (II) AMDGPU(0): 4d4e0a202020202020202020000000fe
> [341486.935] (II) AMDGPU(0): 004e3135364247412d4542320a2000f1
> [341486.935] (II) AMDGPU(0): Printing probed modes for output eDP
> [341486.935] (II) AMDGPU(0): Modeline "1366x768"x60.0   76.42  1366 1434 1479 1592  768 772 779 800 -hsync -vsync (48.0 kHz eP)
> [341486.935] (II) AMDGPU(0): Modeline "1280x720"x60.0   76.42  1280 1434 1479 1592  720 772 779 800 -hsync -vsync (48.0 kHz e)
> [341486.935] (II) AMDGPU(0): Modeline "1024x768"x60.0   76.42  1024 1434 1479 1592  768 772 779 800 -hsync -vsync (48.0 kHz e)
> [341486.935] (II) AMDGPU(0): Modeline "800x600"x60.0   76.42  800 1434 1479 1592  600 772 779 800 -hsync -vsync (48.0 kHz e)
> [341486.935] (II) AMDGPU(0): Modeline "640x480"x60.0   76.42  640 1434 1479 1592  480 772 779 800 -hsync -vsync (48.0 kHz e)
> [341486.935] (II) AMDGPU(0): EDID for output HDMI-A-0
> [341486.935] (II) AMDGPU(0): EDID for output DisplayPort-0
> [341486.936] (II) AMDGPU(0): Output eDP connected
> [341486.936] (II) AMDGPU(0): Output HDMI-A-0 disconnected
> [341486.936] (II) AMDGPU(0): Output DisplayPort-0 disconnected
> [341486.936] (II) AMDGPU(0): Using exact sizes for initial modes
> [341486.936] (II) AMDGPU(0): Output eDP using initial mode 1366x768 +0+0
> [341486.936] (II) AMDGPU(0): mem size init: gart size :bf89a000 vram size: s:1777a000 visible:1777a000
> [341486.936] (==) AMDGPU(0): DPI set to (96, 96)
> [341486.936] (==) AMDGPU(0): Using gamma correction (1.0, 1.0, 1.0)
> [341486.936] (II) Loading sub module "ramdac"
> [341486.936] (II) LoadModule: "ramdac"
> [341486.936] (II) Module "ramdac" already built-in
> [341486.936] (II) AMDGPU(0): Front buffer pitch: 6144 bytes
> [341486.937] (==) AMDGPU(0): DRI3 disabled
> [341486.937] (==) AMDGPU(0): Backing store enabled
> [341486.937] (WW) AMDGPU(0): Direct rendering disabled
> [341486.937] (II) AMDGPU(0): 2D and 3D acceleration disabled
> [341486.937] (==) AMDGPU(0): DPMS enabled
> [341486.937] (==) AMDGPU(0): Silken mouse enabled
> [341486.968] (II) Initializing extension Generic Event Extension
> [341486.969] (II) Initializing extension SHAPE
> [341486.970] (II) Initializing extension MIT-SHM
> [341486.971] (II) Initializing extension XInputExtension
> [341486.972] (II) Initializing extension XTEST
> [341486.973] (II) Initializing extension BIG-REQUESTS
> [341486.975] (II) Initializing extension SYNC
> [341486.976] (II) Initializing extension XKEYBOARD
> [341486.977] (II) Initializing extension XC-MISC
> [341486.978] (II) Initializing extension SECURITY
> [341486.979] (II) Initializing extension XFIXES
> [341486.980] (II) Initializing extension RENDER
> [341486.981] (II) Initializing extension RANDR
> [341486.984] (II) Initializing extension COMPOSITE
> [341486.985] (II) Initializing extension DAMAGE
> [341486.986] (II) Initializing extension MIT-SCREEN-SAVER
> [341486.987] (II) Initializing extension DOUBLE-BUFFER
> [341486.988] (II) Initializing extension RECORD
> [341486.990] (II) Initializing extension DPMS
> [341486.991] (II) Initializing extension Present
> [341486.992] (II) Initializing extension DRI3
> [341486.992] (II) Initializing extension X-Resource
> [341486.993] (II) Initializing extension XVideo
> [341486.994] (II) Initializing extension XVideo-MotionCompensation
> [341486.994] (II) Initializing extension GLX
> [341486.996] (II) AIGLX: Screen 0 is not DRI2 capable
> [341487.087] (II) IGLX: Loaded and initialized swrast
> [341487.087] (II) GLX: Initialized DRISWRAST GL provider for screen 0
> [341487.087] (II) Initializing extension XFree86-VidModeExtension
> [341487.088] (II) Initializing extension XFree86-DGA
> [341487.089] (II) Initializing extension XFree86-DRI
> [341487.089] (II) Initializing extension DRI2
> [341487.091] (II) AMDGPU(0): Setting screen physical size to 361 x 203
> [341487.271] (EE) Received signal 6 sent by process 0, uid 0
> [341487.272] (EE)
> Fatal server error:
> [341487.272] (EE) Caught signal 6 (Abort trap). Server aborting
> [341487.272] (EE)
> [341487.272] (EE)
> Please consult the The X.Org Foundation support
> at http://wiki.x.org
>  for help.
> [341487.272] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
> [341487.272] (EE)
> [341487.275] (EE) Server terminated with error (1). Closing log file.
>