Trimming KDE 3

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Trimming KDE 3

Vadim Zhukov
So there is a strong agreement that KDE 3 should be trimmed.
Before aja@ goes tedu and remove whole x11/kde with all dependants,
here is a proposal that keeps some unique parts of KDE 3, while
removing most heavy parts. This should help bulk builders by
minimizing time spent in tagged builds. Further plans include
trimming of x11/kde/base3 and, maybe, others, allowing to get
rid of dpb tags entirely.

There are three lists below. I'm asking all interested parties
take attention at the third one, and tell your opinions (either in
public or privately, at your option).

Thank you all in advance for reading. :)

1. Things going to go:

editors/kile have KDE4+ counterpart
games/kslide have KDE4+ counterpart (palapeli)
graphics/digikam have KDE4+ counterpart
graphics/gwenview have KDE4+ counterpart
graphics/gwenview-i18n have KDE4+ counterpart
graphics/kimdaba use Digikam, dude!
graphics/kipi-plugins have KDE4+ counterpart
graphics/libkdcraw have KDE4+ counterpart
graphics/libkexif have KDE4+ counterpart
graphics/libkexiv2 have KDE4+ counterpart
graphics/libkipi have KDE4+ counterpart
misc/ktimeclock one more reminder with ugly interface?
multimedia/k3b have KDE4+ counterpart
multimedia/kaffeine have KDE4+ counterpart
net/ktorrent have KDE4+ counterpart
productivity/taskjuggler we want to get rid of x11/kde/pim3
sysutils/filelight have KDE4+ counterpart
sysutils/krename have KDE4+ counterpart
x11/kde/addons3 unuseful without KDE desktop
x11/kde/admin3 outdated
x11/kde/edu3 have KDE4+ counterparts
x11/kde/games3 have KDE4+ counterparts
x11/kde/graphics3 have KDE4+ counterparts
x11/kde/multimedia3 have KDE4+ counterparts
x11/kde/network3 have KDE4+ counterparts, a lot of holes
x11/kde/pim3 have KDE4+ counterparts, a lot of holes
x11/kde/sdk3 outdated
x11/kde/utils3 have KDE4+ counterparts
x11/kde/webdev outdated
x11/kmplayer ETOOMANYMPLAYERS
x11/quadkonsole superseded by Yakuake and tmux
x11/tellico have KDE4+ counterpart
x11/yakuake have KDE4+ counterpart
x11/qinx unuseful without KDE desktop

2. Things going to stay for now:

cad/klogic should be updated to KDE4+ version
games/kbilliards unique, not ported to KDE4+
games/taxipilot unique, not ported to KDE4+
inputmethods/uim,-kde last thing to go
math/kst unique, not ported to KDE4+
multimedia/kguitar unique, not ported to KDE4+
sysutils/knutclient should be updated to KDE4+ version
x11/kde/accessibility3 last thing to go
x11/kde/arts3 required by x11/kde/libs3
x11/kde/base3 common dependency
x11/kde/libs3 common dependency

3. Things that I'm not sure about:

audio/amarok very friendly player, but what about Clementine?
devel/kdbg any users?
mail/kbiff any users?
x11/kdirstat does filelight supersede it?
x11/krusader the only x11/kde/bindings3 user
x11/kde/bindings3 only for krusader
x11/kde/okle any users?
x11/kde/toys3 any users?
x11/kountdown any users?

Reply | Threaded
Open this post in threaded view
|

Re: Trimming KDE 3

Chris Bennett
On Wed, Apr 27, 2016 at 12:30:55AM +0300, Vadim Zhukov wrote:
> 2. Things going to stay for now:
>
> x11/kde/base3 common dependency
>

Can the need for sudo be replaced with doas?
I don't like kde but my dad loves it. Sigh.

Chris Bennett

Reply | Threaded
Open this post in threaded view
|

Re: Trimming KDE 3

Vadim Zhukov
2016-04-27 22:11 GMT+03:00 Chris Bennett <[hidden email]>:
> On Wed, Apr 27, 2016 at 12:30:55AM +0300, Vadim Zhukov wrote:
>> 2. Things going to stay for now:
>>
>> x11/kde/base3                 common dependency
>>
>
> Can the need for sudo be replaced with doas?

Yes, but I want to trim things first, to make life (e.g., testing) a
bit easier. :)

--
  WBR,
  Vadim Zhukov

Reply | Threaded
Open this post in threaded view
|

Re: Trimming KDE 3

alan01346
In reply to this post by Vadim Zhukov
It'd be nice if you could update ktorrent if you're dealing with KDE
4.  There's a problem with the version in ports downloading from
public or your own server, has to do with keys I think.  It's been
fixed for a long time but not in the version we use.  The only ports
torrent client I could make work on a public Rasberry Pi image is
transmission-qt, but I only gave transmission-gtk about 10 minutes
test.  Spent hours studying rtorrent first, with transmission-qt I
just loaded my .torrent file and it started working.

Reply | Threaded
Open this post in threaded view
|

Re: Trimming KDE 3

alan01346
Oops, I use 5.7, I didn't check what's in later versions.  This is
ktorrent-2.2.8p11.

On 4/29/16, Alan Corey <[hidden email]> wrote:
> It'd be nice if you could update ktorrent if you're dealing with KDE
> 4.  There's a problem with the version in ports downloading from
> public or your own server, has to do with keys I think.  It's been
> fixed for a long time but not in the version we use.  The only ports
> torrent client I could make work on a public Rasberry Pi image is
> transmission-qt, but I only gave transmission-gtk about 10 minutes
> test.  Spent hours studying rtorrent first, with transmission-qt I
> just loaded my .torrent file and it started working.
>


--
Credit is the root of all evil.  - AB1JX

Reply | Threaded
Open this post in threaded view
|

Re: Trimming KDE 3

Vadim Zhukov
In reply to this post by alan01346
2016-04-29 16:00 GMT+03:00 Alan Corey <[hidden email]>:
> It'd be nice if you could update ktorrent if you're dealing with KDE
> 4.  There's a problem with the version in ports downloading from
> public or your own server, has to do with keys I think.  It's been
> fixed for a long time but not in the version we use.  The only ports
> torrent client I could make work on a public Rasberry Pi image is
> transmission-qt, but I only gave transmission-gtk about 10 minutes
> test.  Spent hours studying rtorrent first, with transmission-qt I
> just loaded my .torrent file and it started working.

We have ktorrent-4.3.1 for KDE4, and it works well for me. In 5.9 it
should work more solid because we have fixed a bug in Qt that caused
crashes in apps opening many file descriptors.

--
  WBR,
  Vadim Zhukov

Reply | Threaded
Open this post in threaded view
|

Re: Trimming KDE 3

Marc Espie-2
In reply to this post by Vadim Zhukov
On Wed, Apr 27, 2016 at 12:30:55AM +0300, Vadim Zhukov wrote:

> 1. Things going to go:
>
> editors/kile have KDE4+ counterpart
> games/kslide have KDE4+ counterpart (palapeli)
> graphics/digikam have KDE4+ counterpart
> graphics/gwenview have KDE4+ counterpart
> graphics/gwenview-i18n have KDE4+ counterpart
> graphics/kimdaba use Digikam, dude!
> graphics/kipi-plugins have KDE4+ counterpart
> graphics/libkdcraw have KDE4+ counterpart
> graphics/libkexif have KDE4+ counterpart
> graphics/libkexiv2 have KDE4+ counterpart
> graphics/libkipi have KDE4+ counterpart
> misc/ktimeclock one more reminder with ugly interface?
> multimedia/k3b have KDE4+ counterpart
> multimedia/kaffeine have KDE4+ counterpart
> net/ktorrent have KDE4+ counterpart
> productivity/taskjuggler we want to get rid of x11/kde/pim3
> sysutils/filelight have KDE4+ counterpart
> sysutils/krename have KDE4+ counterpart
> x11/kde/addons3 unuseful without KDE desktop
> x11/kde/admin3 outdated
> x11/kde/edu3 have KDE4+ counterparts
> x11/kde/games3 have KDE4+ counterparts
> x11/kde/graphics3 have KDE4+ counterparts
> x11/kde/multimedia3 have KDE4+ counterparts
> x11/kde/network3 have KDE4+ counterparts, a lot of holes
> x11/kde/pim3 have KDE4+ counterparts, a lot of holes
> x11/kde/sdk3 outdated
> x11/kde/utils3 have KDE4+ counterparts
> x11/kde/webdev outdated
> x11/kmplayer ETOOMANYMPLAYERS
> x11/quadkonsole superseded by Yakuake and tmux
> x11/tellico have KDE4+ counterpart
> x11/yakuake have KDE4+ counterpart
> x11/qinx unuseful without KDE desktop

No objections I just checked the few things I used in kde3 do indeed work
satisfactorily in kde4 (digikam and gwenview for the most part)