Touchpad (iatp) error on resume on Chromebook Pixel 2015

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Touchpad (iatp) error on resume on Chromebook Pixel 2015

Bobby Johnson
Hardware is the Chromebook pixel 2015.  No response from touchpad or touchscreen on resume.  These errors pop up in the dmesg.  Full dmesg below.

iatp0: failed reading main memory map
iatp1: failed reading main memory map
iatp0: failed reading 540
iatp1: failed reading 680
iatp0: failed reading t44 and t5

I'm using the wsmouse touchpad xorg configuration.

- xorg.conf excerpt
Section "InputClass"
        Identifier "wsmouse touchpad"
        Driver "ws"
        MatchIsTouchpad "on"
        Option "ZAxisMapping" "5 4"
        Option "acceleration factor" "3.2"
EndSection



OpenBSD 6.2-current (GENERIC.MP) #15: Tue Feb 27 22:15:26 MST 2018
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 17094049792 (16302MB)
avail mem = 16568954880 (15801MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.7 @ 0x7ce42020 (9 entries)
bios0: vendor coreboot version "(null)" date 04/02/2015
bios0: GOOGLE Samus
acpi0 at bios0: rev 2
acpi0: sleep states S0 S1 S2 S3 S4 S5
acpi0: tables DSDT FACP HPET APIC MCFG SSDT
acpi0: wakeup devices HDEF(S3) WLAN(S3) EHCI(S3) XHCI(S3) ATPA(S3) CODC(S3) LID0(S5)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz, 2394.64 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,RDSEED,ADX,SMAP,PT,SENSOR,ARAT,MELTDOWN
cpu0: 256KB 64b/line 8-way L2 cache
acpihpet0: recalibrated TSC frequency 2394461141 Hz
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz, 2893.31 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,RDSEED,ADX,SMAP,PT,SENSOR,ARAT,MELTDOWN
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 1, core 0, package 0
cpu2 at mainbus0: apid 3 (application processor)
cpu2: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz, 2893.31 MHz
cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,RDSEED,ADX,SMAP,PT,SENSOR,ARAT,MELTDOWN
cpu2: 256KB 64b/line 8-way L2 cache
cpu2: smt 1, core 1, package 0
cpu3 at mainbus0: apid 2 (application processor)
cpu3: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz, 2893.31 MHz
cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,ERMS,INVPCID,RDSEED,ADX,SMAP,PT,SENSOR,ARAT,MELTDOWN
cpu3: 256KB 64b/line 8-way L2 cache
cpu3: smt 0, core 1, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 40 pins
acpimcfg0 at acpi0 addr 0xf0000000, bus 0-255
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (RP01)
acpiprt2 at acpi0: bus -1 (RP02)
acpiprt3 at acpi0: bus -1 (RP03)
acpiprt4 at acpi0: bus -1 (RP04)
acpiprt5 at acpi0: bus -1 (RP05)
acpiprt6 at acpi0: bus -1 (RP06)
acpiprt7 at acpi0: bus -1 (RP07)
acpiprt8 at acpi0: bus -1 (RP08)
acpiec0 at acpi0
acpicpu0 at acpi0: C3(700@148 mwait.1@0x33), C2(900@67 mwait.1@0x10), C1(1000@0 mwait.1@0x1), PSS
acpicpu1 at acpi0: C3(700@148 mwait.1@0x33), C2(900@67 mwait.1@0x10), C1(1000@0 mwait.1@0x1), PSS
acpicpu2 at acpi0: C3(700@148 mwait.1@0x33), C2(900@67 mwait.1@0x10), C1(1000@0 mwait.1@0x1), PSS
acpicpu3 at acpi0: C3(700@148 mwait.1@0x33), C2(900@67 mwait.1@0x10), C1(1000@0 mwait.1@0x1), PSS
acpitz0 at acpi0: critical temperature is 104 degC
"INT3438" at acpi0 not configured
"INT3437" at acpi0 not configured
acpiac0 at acpi0: AC unit offline
acpibat0 at acpi0: BAT0 model "3487041" serial 875640880 type LION oem "21484737139854675"
acpials0 at acpi0: ALS_
"GOOG0003" at acpi0 not configured
tpm0 at acpi0: TPM_ addr 0xfed40000/0x5000: Infineon SLB9635 1.2 rev 0x10
"INTL9C60" at acpi0 not configured
dwiic0 at acpi0: I2C0 addr 0xe121f000/0x1000 irq 7
iic0 at dwiic0
iatp0 at iic0 addr 0x4a irq 27: Atmel maXTouch Touchpad (960x540)
wsmouse0 at iatp0 mux 0
"RT5677CE" at iic0 addr 0x2c not configured
"ATML0000" at acpi0 not configured
dwiic1 at acpi0: I2C1 addr 0xe1221000/0x1000 irq 7
iic1 at dwiic1
iatp1 at iic1 addr 0x4b irq 28: Atmel maXTouch Touchscreen (2559x1699)
wsmouse1 at iatp1 mux 0
"ATML0001" at acpi0 not configured
"INT3430" at acpi0 not configured
"RT5677AA" at acpi0 not configured
"GOOG9999" at acpi0 not configured
acpibtn0 at acpi0: LID0
acpibtn1 at acpi0: PWRB
acpicbkbd0 at acpi0: KBLT
"GGL0001" at acpi0 not configured
cpu0: Enhanced SpeedStep 2394 MHz: speeds: 2401, 2400, 1700, 1300, 900, 500 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 5G Host" rev 0x09
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics 5500" rev 0x09
drm0 at inteldrm0
inteldrm0: msi
inteldrm0: 2560x1700, 32bpp
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
azalia0 at pci0 dev 3 function 0 "Intel Core 5G HD Audio" rev 0x09: msi
xhci0 at pci0 dev 20 function 0 "Intel 9 Series xHCI" rev 0x03: msi
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
ppb0 at pci0 dev 28 function 0 "Intel 9 Series PCIE" rev 0xe3
pci1 at ppb0 bus 1
iwm0 at pci1 dev 0 function 0 "Intel Dual Band Wireless AC 7260" rev 0xcb, msi
pcib0 at pci0 dev 31 function 0 "Intel 9 Series LPC" rev 0x03
ahci0 at pci0 dev 31 function 2 "Intel 9 Series AHCI" rev 0x03: msi, AHCI 1.3
ahci0: port 0: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, KINGSTON RBU-SUS, S9FM> SCSI3 0/direct fixed t10.ATA_KINGSTON_RBU-SUS151S364GD_50026B7E52006244_
sd0: 61057MB, 512 bytes/sector, 125045424 sectors, thin
pchtemp0 at pci0 dev 31 function 6 "Intel 9 Series Thermal" rev 0x03: disabled
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16450, no fifo
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: VMX/EPT
efifb at mainbus0 not configured
uvideo0 at uhub0 port 7 configuration 1 interface 0 "NMGAAI00010200257T00074 NCM-G102" rev 2.00/0.02 addr 2
video0 at uvideo0
ugen0 at uhub0 port 8 "Intel product 0x07dc" rev 2.00/0.01 addr 3
cdce0 at uhub0 port 12 configuration 2 interface 0 "Lenovo Thinkpad USB LAN" rev 3.00/30.00 addr 4
cdce0: address 3c:18:a0:08:65:c5
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
sd1 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 006> SCSI2 0/direct fixed
sd1: 55799MB, 512 bytes/sector, 114276478 sectors
root on sd1a (903e5e5185545c53.a) swap on sd1b dump on sd1b
iwm0: hw rev 0x140, fw ver 16.242414.0, address 6c:29:95:a5:75:80
video0 detached
uvideo0 detached
ugen0 detached
cdce0 detached
uhub0 detached
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
iatp0: failed reading main memory map
iatp1: failed reading main memory map
iatp0: failed reading 540
iatp1: failed reading 680
uvideo0 at uhub0 port 7 configuration 1 interface 0 "NMGAAI00010200257T00074 NCM-G102" rev 2.00/0.02 addr 2
video0 at uvideo0
ugen0 at uhub0 port 8 "Intel product 0x07dc" rev 2.00/0.01 addr 3
cdce0 at uhub0 port 12 configuration 2 interface 0 "Lenovo Thinkpad USB LAN" rev 3.00/30.00 addr 4
cdce0: address 3c:18:a0:08:65:c5
iatp0: failed reading t44 and t5

Reply | Threaded
Open this post in threaded view
|

Re: Touchpad (iatp) error on resume on Chromebook Pixel 2015

Anthony J. Bentley-4
bob writes:
> Hardware is the Chromebook pixel 2015.  No response from touchpad or touchscr
> een on resume.  These errors pop up in the dmesg.  Full dmesg below.
>
> iatp0: failed reading main memory map
> iatp1: failed reading main memory map
> iatp0: failed reading 540
> iatp1: failed reading 680

I get these as well with my 2015 Pixel, with or without your xorg.conf.
(I don't get the "iatp0: failed reading t44 and t5" message either way.)

I almost never suspend my laptops. Have you successfully suspended
this laptop before? Is this a regression?

Reply | Threaded
Open this post in threaded view
|

Re: Touchpad (iatp) error on resume on Chromebook Pixel 2015

Bobby Johnson
It is a regression, it used to resume without issue. I’m not sure when it started because I don’t use this laptop very often.

> On Mar 1, 2018, at 1:37 AM, Anthony J. Bentley <[hidden email]> wrote:
>
> bob writes:
>> Hardware is the Chromebook pixel 2015.  No response from touchpad or touchscr
>> een on resume.  These errors pop up in the dmesg.  Full dmesg below.
>>
>> iatp0: failed reading main memory map
>> iatp1: failed reading main memory map
>> iatp0: failed reading 540
>> iatp1: failed reading 680
>
> I get these as well with my 2015 Pixel, with or without your xorg.conf.
> (I don't get the "iatp0: failed reading t44 and t5" message either way.)
>
> I almost never suspend my laptops. Have you successfully suspended
> this laptop before? Is this a regression?

Reply | Threaded
Open this post in threaded view
|

Re: Touchpad (iatp) error on resume on Chromebook Pixel 2015

Bobby Johnson
I tried reverting iatp.c to the previous revision. Didn’t make a difference. Any thoughts on where else to look?

> On Mar 1, 2018, at 10:14 AM, Bobby Johnson <[hidden email]> wrote:
>
> It is a regression, it used to resume without issue. I’m not sure when it started because I don’t use this laptop very often.
>
>> On Mar 1, 2018, at 1:37 AM, Anthony J. Bentley <[hidden email]> wrote:
>>
>> bob writes:
>>> Hardware is the Chromebook pixel 2015.  No response from touchpad or touchscr
>>> een on resume.  These errors pop up in the dmesg.  Full dmesg below.
>>>
>>> iatp0: failed reading main memory map
>>> iatp1: failed reading main memory map
>>> iatp0: failed reading 540
>>> iatp1: failed reading 680
>>
>> I get these as well with my 2015 Pixel, with or without your xorg.conf.
>> (I don't get the "iatp0: failed reading t44 and t5" message either way.)
>>
>> I almost never suspend my laptops. Have you successfully suspended
>> this laptop before? Is this a regression?