Sparcstation console problem

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Sparcstation console problem

Mike-569
Hello,

I am having a problem with the serial console of an old SS20.

It used to have OBSD 3.8 installed on this box, that was connected via a Wyse 50 that worked without problems for years, however upon installing 4.9 I can only get one logon via the console.  After logout I get the login prompt again however no text is echoed when attempting to log in.

The system is still accessable via ssh, getty is still running.  No combination of resetting the serial link has any effect, eg sending a break, or powering the terminal off.

What is interesting however is that a echo "blah blah blah" > /dev/console produces the obvious output on the terminal however after the terminal has been sat at login promp for longer than a minute or so, even this does not work.

I have tried to disable the console in /dev/ttys and use ttya instead but the same situation occurs.

After initiating a reboot/halt via ssh I get the normal shutdown messages outputted on the console.

To rule out hardware issues I have tried using serial terminal software on my laptop and sticking in the hard drive to a spare sparcstation 5, none of this helps.

Trying to kill the getty results in a new prompt being presented after some seconds.

It does not make sense how inital login works fine, but subsequent ones fail.  Any ideas ?

Regards, Mike