Serious problems with current since end of april, related to scsi controllers (Adaptec/LSILogic)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Serious problems with current since end of april, related to scsi controllers (Adaptec/LSILogic)

Ulrich Kahl
Hi!

Since end of april, sorry I don't have a more precise date, one of my
systems has serious problems.
It can't boot sucessfully with a Adaptec controller anymore, the first
sign is that it can't find one library, e.g. libc or libz, and later
the hard disks transfer rate can't established and the system freezes. See
the first dmesg.

After switching the controller to a LSILogic one, the system boots
correctly, but (presumly) under higher disk io load the system panics,
syncing my local cvs repository with cvsync in this case. See second
dmesg and trace output.

Does someone else encounter similar problems?

If you need further information, please drop me a note.


        Ulrich


First dmesg ----

>> OpenBSD/i386 BOOT 3.02
boot>
booting hd0a:/bsd: 7181376+1055428 [52+365600+349966]=0x889bdc
entry point at 0x200120

[ using 715992 bytes of bsd ELF symbol table ]
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2010 OpenBSD. All rights reserved.  http://www.OpenBSD.org

OpenBSD 4.7-current (GENERIC.MP) #560: Wed Apr 28 11:55:01 MDT 2010
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC.MP
RTC BIOS diagnostic error 13<memory_size>
cpu0: Intel Pentium III ("GenuineIntel" 686-class) 1 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 2146988032 (2047MB)
avail mem = 2069180416 (1973MB)
RTC BIOS diagnostic error 13<memory_size>
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 08/16/00, BIOS32 rev. 0 @ 0xfd8b0, SMBIOS rev. 2.3 @ 0xe0010 (76 entries)
bios0: vendor Phoenix Technologies Ltd. version "ID.W2.02US" date 08/16/2000
bios0: Hewlett-Packard HP VISUALIZE NT Workstation
acpi0 at bios0: rev 0
acpi0: tables DSDT FACP APIC BOOT
acpi0: wakeup devices PCI0(S4) USB0(S1) LAN0(S4) KBC_(S1) COMA(S1) PCI1(S4)
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 1 (boot processor)
cpu0: apic clock running at 132MHz
cpu1 at mainbus0: apid 0 (application processor)
cpu1: Intel Pentium III ("GenuineIntel" 686-class) 1 GHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 11, 16 pins
ioapic1 at mainbus0: apid 3 pa 0xfec01000, version 11, 16 pins
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 2 (PCI1)
acpicpu0 at acpi0
acpicpu1 at acpi0
acpibtn0 at acpi0: PWRB
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x1000 0xc9000/0x5400 0xe0000/0x4000!
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "ServerWorks CNB20HE Host" rev 0x22
ppb0 at pci0 dev 0 function 1 "ServerWorks CNB20LE Host" rev 0x01
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "Matrox MGA G200 AGP" rev 0x03
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"Hewlett-Packard Visualize FX2" rev 0x80 at pci1 dev 1 function 0 not configured
pchb1 at pci0 dev 0 function 2 "ServerWorks CNB20HE Host" rev 0x00
pchb2 at pci0 dev 0 function 3 "ServerWorks CNB20HE Host" rev 0x00
pci2 at pchb2 bus 2
ahc0 at pci2 dev 2 function 0 "Adaptec AHA-29160 U160" rev 0x02: apic 3 int 8 (irq 11)
scsibus0 at ahc0: 16 targets, initiator 7
sd0 at scsibus0 targ 0 lun 0: <SEAGATE, ST373405LC, 0002> SCSI3 0/direct fixed
sd0: 70007MB, 512 bytes/sec, 143374741 sec total
sd1 at scsibus0 targ 1 lun 0: <SEAGATE, ST373405LW, HPA4> SCSI2 0/direct fixed
sd1: 70007MB, 512 bytes/sec, 143374738 sec total
fxp0 at pci0 dev 7 function 0 "Intel 8255x" rev 0x08, i82559: apic 3 int 10 (irq 10), address 00:30:6e:0a:c3:1d
inphy0 at fxp0 phy 1: i82555 10/100 PHY, rev. 4
clcs0 at pci0 dev 8 function 0 "Cirrus Logic CS4280/46xx CrystalClear" rev 0x01: apic 3 int 11 (irq 5)
ac97: codec id 0x43525903 (Cirrus Logic CS4297 rev 3)
ac97: codec features headphone, 18 bit DAC, 18 bit ADC, No 3D Stereo
piixpm0 at pci0 dev 15 function 0 "ServerWorks OSB4" rev 0x50: polling
iic0 at piixpm0
piixpm0: exec: op 1, addr 0x20, cmdlen 1, len 1, flags 0x08: timeout, status 0x5<BUSY,DEVERR>
iic0: addr 0x20 00=00 01=00 02=00 03=02 04=04 05=04 06=04 07=06 08=08 09=08 0a=08 0b=0a 0c=0c 0d=0c 0e=0c 0f=0e 10=10 11=10 12=10 13=12 14=14 15=14 16=14 17=16
18=18 19=18 1a=18 1b=1a 1c=1c 1d=1c 1e=1c 1f=1e 20=20 21=20 3e=3e 48=48 4a=48 4e=4e fc=fc fe=fe words 00=ffff 01=ffff 02=ffff 03=ffff 04=ffff 05=ffff 06=ffff 07=ffff
pciide0 at pci0 dev 15 function 1 "ServerWorks OSB4 IDE" rev 0x00: DMA
atapiscsi0 at pciide0 channel 1 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <MITSUMI, CD-ROM FX4830T!B, R02J> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 2
ohci0 at pci0 dev 15 function 2 "ServerWorks OSB4/CSB5 USB" rev 0x04: apic 2 int 9 (irq 9), version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0 "ServerWorks OHCI root hub" rev 1.00/1.00 addr 1
isa0 at mainbus0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
com0: console
com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
mtrr: Pentium Pro MTRR support
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
ahc0: target 0 using 16bit transfers
ahc0: target 0 synchronous at 20.0MHz, offset = 0x3f
ahc0: target 1 using 16bit transfers
ahc0: target 1 synchronous at 20.0MHz, offset = 0x3f
root on sd0a swap on sd0b dump on sd0b
WARNING: / was not properly unmounted
clcs0: firmware loaded
audio0 at clcs0
Automatic boot in progress: starting file system checks.
/dev/rsd0a: 2570 files, 27488 used, 486951 free (503 frags, 60806 blocks, 0.1% fragmentation)
/dev/rsd0a: MARKING FILE SYSTEM CLEAN
fsck: /dev/rsd1j in fstab more than once!
/dev/rsd1a: file system is clean; not checking
/dev/rsd1d: file system is clean; not checking
/dev/rsd1e: file system is clean; not checking
/dev/rsd1f: file system is clean; not checking
/dev/rsd1g: file system is clean; not checking
/dev/rsd1h: file system is clean; not checking
/dev/rsd0k: 487 files, 397959 used, 18881474 free (66 frags, 2360176 blocks, 0.0% fragmentation)
/dev/rsd0k: MARKING FILE SYSTEM CLEAN
/dev/rsd0d: 3 files, 3 used, 2062700 free (28 frags, 257834 blocks, 0.0% fragmentation)
/dev/rsd0d: MARKING FILE SYSTEM CLEAN
/dev/rsd0f: 13392 files, 242729 used, 787798 free (6646 frags, 97644 blocks, 0.6% fragmentation)
/dev/rsd0f: MARKING FILE SYSTEM CLEAN
/dev/rsd0g: 9424 files, 101126 used, 413313 free (7393 frags, 50740 blocks, 1.4% fragmentation)
/dev/rsd0g: MARKING FILE SYSTEM CLEAN
/dev/rsd0h: 88347 files, 1069488 used, 1439365 free (1413 frags, 179744 blocks, 0.1% fragmentation)
/dev/rsd0h: MARKING FILE SYSTEM CLEAN
/dev/rsd0j: file system is clean; not checking
/dev/rsd0i: file system is clean; not checking
/dev/rsd0e: INCORRECT BLOCK COUNT I=962297 (2144 should be 416) (CORRECTED)
/dev/rsd0e: FREE BLK COUNT(S) WRONG IN SUPERBLK (SALVAGED)
/dev/rsd0e: SUMMARY INFORMATION BAD (SALVAGED)
/dev/rsd0e: BLK(S) MISSING IN BIT MAPS (SALVAGED)
/dev/rsd0e: 2421 files, 13357 used, 3866978 free (778 frags, 483275 blocks, 0.0% fragmentation)
/dev/rsd0e: MARKING FILE SYSTEM CLEAN
/dev/rsd1j: 527180 files, 4435945 used, 15359273 free (98161 frags, 1907639 blocks, 0.5% fragmentation)
/dev/rsd1j: MARKING FILE SYSTEM CLEAN
setting tty flags
kbd: keyboard mapping set to de
pf enabled
grep: can't load library 'libc.so.53.1'
grep: can't load library 'libc.so.53.1'
machdep.allowaperture: 0 -> 2
starting network
starting system logger
starting initial daemons: portmap mountd nfsd rpc.lockd rpc.statd ntpd.
savecore: no core dump
checking quotas: done.
building ps databases: kvm dev.
clearing /tmp
starting pre-securelevel daemons:.
setting kernel security level: kern.securelevel: 0 -> 1
creating runtime link editor directory cache.
preserving editor files.
starting network daemons: sshd sendmail ftpd inetd.
starting local daemons: smartdahc0: target 0 using 8bit transfers
ahc0: target 0 using asynchronous transfers
ahc0: target 1 using 8bit transfers
ahc0: target 1 using asynchronous transfers
ahc0: target 0 using 16bit transfers
ahc0: target 0 using 8bit transfers
ahc0: target 0 using asynchronous transfers
ahc0: target 0 using 16bit transfers
ahc0: target 0 using 8bit transfers
ahc0: target 0 using asynchronous transfers
ahc0: target 0 using 16bit transfers
ahc0: target 0 synchronous at 20.0MHz, offset = 0x3f
ahc0: target 0 using 16bit transfers
ahc0: target 0 synchronous at 20.0MHz, offset = 0x3f
ahc0: target 1 using 16bit transfers
ahc0: target 1 synchronous at 20.0MHz, offset = 0x3f
ahc0: target 0 using 8bit transfers
ahc0: target 0 using asynchronous transfers
ahc0: target 1 using 8bit transfers
ahc0: target 1 using asynchronous transfers
ahc0: target 1 using 16bit transfers
ahc0: target 1 synchronous at 20.0MHz, offset = 0x3f
ahc0: target 1 using 8bit transfers
ahc0: target 1 using asynchronous transfers
ahc0: target 1 using 16bit transfers
ahc0: target 1 synchronous at 20.0MHz, offset = 0x3f
ahc0: target 1 using 8bit transfers
ahc0: target 1 using asynchronous transfers
ahc0: target 0 using 16bit transfers
ahc0: target 0 using 8bit transfers
ahc0: target 0 using asynchronous transfers
ahc0: target 0 using 16bit transfers
ahc0: target 0 synchronous at 20.0MHz, offset = 0x3f
ahc0: target 0 using 16bit transfers
ahc0: target 0 synchronous at 20.0MHz, offset = 0x3f

Second dmesg ----

>> OpenBSD/i386 BOOT 3.02

com0: 9600 baud
boot>
booting hd0a:/bsd: 7181376+1055428 [52+365600+349966]=0x889bdc
entry point at 0x200120

[ using 715992 bytes of bsd ELF symbol table ]
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2010 OpenBSD. All rights reserved.  http://www.OpenBSD.org

OpenBSD 4.7-current (GENERIC.MP) #560: Wed Apr 28 11:55:01 MDT 2010
    [hidden email]:/usr/src/sys/arch/i386/compile/GENERIC.MP
RTC BIOS diagnostic error 13<memory_size>
cpu0: Intel Pentium III ("GenuineIntel" 686-class) 1 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 2146988032 (2047MB)
avail mem = 2069180416 (1973MB)
RTC BIOS diagnostic error 13<memory_size>
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 08/16/00, BIOS32 rev. 0 @ 0xfd8b0, SMBIOS rev. 2.3 @ 0xe0010 (76 entries)
bios0: vendor Phoenix Technologies Ltd. version "ID.W2.02US" date 08/16/2000
bios0: Hewlett-Packard HP VISUALIZE NT Workstation
acpi0 at bios0: rev 0
acpi0: tables DSDT FACP APIC BOOT
acpi0: wakeup devices PCI0(S4) USB0(S1) LAN0(S4) KBC_(S1) COMA(S1) PCI1(S4)
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 1 (boot processor)
cpu0: apic clock running at 132MHz
cpu1 at mainbus0: apid 0 (application processor)
cpu1: Intel Pentium III ("GenuineIntel" 686-class) 1 GHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 11, 16 pins
ioapic1 at mainbus0: apid 3 pa 0xfec01000, version 11, 16 pins
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 2 (PCI1)
acpicpu0 at acpi0
acpicpu1 at acpi0
acpibtn0 at acpi0: PWRB
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x1000 0xc9000/0x4000 0xe0000/0x4000!
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "ServerWorks CNB20HE Host" rev 0x22
ppb0 at pci0 dev 0 function 1 "ServerWorks CNB20LE Host" rev 0x01
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "Matrox MGA G200 AGP" rev 0x03
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
"Hewlett-Packard Visualize FX2" rev 0x80 at pci1 dev 1 function 0 not configured
pchb1 at pci0 dev 0 function 2 "ServerWorks CNB20HE Host" rev 0x00
pchb2 at pci0 dev 0 function 3 "ServerWorks CNB20HE Host" rev 0x00
pci2 at pchb2 bus 2
mpi0 at pci2 dev 2 function 0 "Symbios Logic 53c1030" rev 0x08: apic 3 int 8 (irq 11)
scsibus0 at mpi0: 16 targets, initiator 7
sd0 at scsibus0 targ 0 lun 0: <SEAGATE, ST373405LC, 0002> SCSI3 0/direct fixed
sd0: 70007MB, 512 bytes/sec, 143374741 sec total
sd1 at scsibus0 targ 1 lun 0: <SEAGATE, ST373405LW, HPA4> SCSI2 0/direct fixed
sd1: 70007MB, 512 bytes/sec, 143374738 sec total
mpi0: target 0 Sync at 10MHz width 16bit offset 63 QAS 0 DT 0 IU 0
mpi0: target 1 Sync at 10MHz width 16bit offset 63 QAS 0 DT 0 IU 0
mpi1 at pci2 dev 2 function 1 "Symbios Logic 53c1030" rev 0x08: apic 3 int 9 (irq 11)
scsibus1 at mpi1: 16 targets, initiator 7
fxp0 at pci0 dev 7 function 0 "Intel 8255x" rev 0x08, i82559: apic 3 int 10 (irq 10), address 00:30:6e:0a:c3:1d
inphy0 at fxp0 phy 1: i82555 10/100 PHY, rev. 4
clcs0 at pci0 dev 8 function 0 "Cirrus Logic CS4280/46xx CrystalClear" rev 0x01: apic 3 int 11 (irq 5)
ac97: codec id 0x43525903 (Cirrus Logic CS4297 rev 3)
ac97: codec features headphone, 18 bit DAC, 18 bit ADC, No 3D Stereo
piixpm0 at pci0 dev 15 function 0 "ServerWorks OSB4" rev 0x50: polling
iic0 at piixpm0
piixpm0: exec: op 1, addr 0x1b, cmdlen 1, len 0, flags 0x08: timeout, status 0x5<BUSY,DEVERR>
pciide0 at pci0 dev 15 function 1 "ServerWorks OSB4 IDE" rev 0x00: DMA
atapiscsi0 at pciide0 channel 1 drive 0
scsibus2 at atapiscsi0: 2 targets
cd0 at scsibus2 targ 0 lun 0: <MITSUMI, CD-ROM FX4830T!B, R02J> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 2
ohci0 at pci0 dev 15 function 2 "ServerWorks OSB4/CSB5 USB" rev 0x04: apic 2 int 9 (irq 9), version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0 "ServerWorks OHCI root hub" rev 1.00/1.00 addr 1
isa0 at mainbus0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
com0: console
com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
mtrr: Pentium Pro MTRR support
vscsi0 at root
scsibus3 at vscsi0: 256 targets
softraid0 at root
root on sd0a swap on sd0b dump on sd0b
clcs0: firmware loaded
audio0 at clcs0
Automatic boot in progress: starting file system checks.
/dev/rsd0a: file system is clean; not checking
/dev/rsd1a: file system is clean; not checking
/dev/rsd0k: file system is clean; not checking
/dev/rsd1d: file system is clean; not checking
/dev/rsd0d: file system is clean; not checking
/dev/rsd0f: file system is clean; not checking
/dev/rsd1e: file system is clean; not checking
/dev/rsd0g: file system is clean; not checking
/dev/rsd0h: file system is clean; not checking
/dev/rsd0j: file system is clean; not checking
/dev/rsd1f: file system is clean; not checking
/dev/rsd0i: file system is clean; not checking
/dev/rsd0e: file system is clean; not checking
/dev/rsd1g: file system is clean; not checking
/dev/rsd1h: file system is clean; not checking
/dev/rsd1j: file system is clean; not checking
setting tty flags
kbd: keyboard mapping set to de
pf enabled
machdep.allowaperture: 0 -> 2
starting network
starting system logger
starting initial daemons: portmap mountd nfsd rpc.lockd rpc.statd ntpd.
savecore: no core dump
checking quotas: done.
building ps databases: kvm dev.
clearing /tmp
starting pre-securelevel daemons:.
setting kernel security level: kern.securelevel: 0 -> 1
creating runtime link editor directory cache.
preserving editor files.
starting network daemons: sshd sendmail ftpd inetd.
starting local daemons: dbus.
standard daemons: apmd cron.
Mon May 10 12:52:04 CEST 2010

OpenBSD/i386 (versuchsanstalt.lokal) (tty00)

login: mode = 0100444, inum = 2995346, fs = /system
panic: ffs_valloc: dup alloc
Stopped at      Debugger+0x4:   leave
RUN AT LEAST 'trace' AND 'ps' AND INCLUDE OUTPUT WHEN REPORTING THIS PANIC!
IF RUNNING SMP, USE 'mach ddbcpu <#>' AND 'trace' ON OTHER PROCESSORS, TOO.
DO NOT EVEN BOTHER REPORTING THIS WITHOUT INCLUDING THAT INFORMATION!
ddb{1}> ps
   PID   PPID   PGRP    UID  S       FLAGS  WAIT          COMMAND
 12976   6790  12976   1000  3   0x2044182  poll          systat
 10095  32125  10095   1001  3   0x2004082  kqread        tail
* 3196      1   5690   1001  7   0x2004002                cvsync
  6790   5139   6790   1000  3   0x2004082  pause         ksh
  5139   1458   1458   1000  3   0x2000180  select        sshd
  1458  18271   1458      0  3   0x2004080  netio         sshd
 21770  14215  21770   1000  3   0x2044182  poll          systat
 14215  22041  14215   1000  3   0x2004082  pause         ksh
 22041  13178  13178   1000  3   0x2000180  select        sshd
 13178  18271  13178      0  3   0x2004080  netio         sshd
 32125    279  32125   1001  3   0x2004082  pause         ksh
   279  22298  22298   1000  3   0x2000180  select        sshd
 22298  18271  22298      0  3   0x2004080  netio         sshd
  1006      1   1006      0  3   0x2004082  ttyin         getty
 32633      1  32633      0  3   0x2004082  ttyin         getty
  5167      1   5167      0  3   0x2004082  ttyin         getty
  2007      1   2007      0  3   0x2004082  ttyin         getty
 27632      1  27632      0  3   0x2004082  ttyin         getty
  8129      1   8129      0  3   0x2004082  ttyin         getty
  1362      1   1362      0  3   0x2000080  select        cron
 32163      1  32163      0  3   0x2000080  kqread        apmd
 25766      1  25766    572  3   0x2000180  poll          dbus-daemon
 15417      1  15417      0  3   0x2040180  select        sendmail
 13250      1  13250      0  3   0x2000180  select        inetd
 15341      1  15341      0  3   0x2000080  poll          ftpd
 18271      1  18271      0  3   0x2000080  select        sshd
 29253  27349  26381     83  3   0x2000180  poll          ntpd
 27349  26381  26381     83  3   0x2000180  poll          ntpd
 26381      1  26381      0  3   0x2000080  poll          ntpd
 19476      1  19476      0  3   0x2080088  poll          rpc.statd
 17836      1  17836      0  3   0x2000080  poll          rpc.lockd
 27221  23279  23279      0  3   0x2000080  nfsd          nfsd
 23901  23279  23279      0  3   0x2000080  nfsd          nfsd
 11136  23279  23279      0  3   0x2000080  nfsd          nfsd
 21512  23279  23279      0  3   0x2000080  nfsd          nfsd
 23279      1  23279      0  3   0x2000080  netcon        nfsd
 30430      1  30430      0  3   0x2000080  select        mountd
 22354   4503   4503     74  3   0x2000180  bpf           pflogd
  9955      1   9955     28  3   0x2000180  poll          portmap
  4503      1   4503      0  3   0x2000080  netio         pflogd
  5418   1707   1707     73  2   0x2000180                syslogd
  1707      1   1707      0  3   0x2000088  netio         syslogd
    15      0      0      0  3   0x2100200  bored         crypto
    14      0      0      0  3   0x2100200  aiodoned      aiodoned
    13      0      0      0  3   0x2100200  syncer        update
    12      0      0      0  3   0x2100200  cleaner       cleaner
    11      0      0      0  3    0x100200  reaper        reaper
    10      0      0      0  3   0x2100200  pgdaemon      pagedaemon
     9      0      0      0  3   0x2100200  pftm          pfpurge
     8      0      0      0  3   0x2100200  usbtsk        usbtask
     7      0      0      0  3   0x2100200  usbevt        usb0
     6      0      0      0  3   0x2100200  acpi_idle     acpi0
     5      0      0      0  3  0x40100200                idle1
     4      0      0      0  3   0x2100200  bored         syswq
     3      0      0      0  7  0x40100200                idle0
     2      0      0      0  3   0x2100200  kmalloc       kmthread
     1      0      1      0  3   0x2004080  wait          init
     0     -1      0      0  3   0x2080200  scheduler     swapper
ddb{1}> trace
Debugger(d08b63d8,d2fa1800,de415b40,d8843170,d8844400) at Debugger+0x4
panic(d07bd070,8124,2db492,d2fa18d4,7ff) at panic+0x55
ffs_inode_alloc(d8bde958,8180,d8e44550,de415ba4) at ffs_inode_alloc+0x11b
ufs_makeinode(8180,d8ba5ef4,de415e38,de415e4c) at ufs_makeinode+0x78
ufs_create(de415d18,687880a8,8aa93f45,0,d08b6c64) at ufs_create+0x26
VOP_CREATE(d8ba5ef4,de415e38,de415e4c,de415d68) at VOP_CREATE+0x34
vn_open(de415e28,a03,180,d8c142cc) at vn_open+0xd8
sys_open(d8c142cc,de415f68,de415f58,d8c142cc) at sys_open+0xdb
syscall() at syscall+0x12b
--- syscall (number 5) ---
0xaca2e9:
ddb{1}> mach ddbcpu 0
Stopped at      Debugger+0x4:   leave
RUN AT LEAST 'trace' AND 'ps' AND INCLUDE OUTPUT WHEN REPORTING THIS PANIC!
IF RUNNING SMP, USE 'mach ddbcpu <#>' AND 'trace' ON OTHER PROCESSORS, TOO.
DO NOT EVEN BOTHER REPORTING THIS WITHOUT INCLUDING THAT INFORMATION!
ddb{0}> trace
Debugger(d09d82e0,de361e40,de361e42,0,20) at Debugger+0x4
i386_ipi_handler(b0,58,d8da0010,10,10) at i386_ipi_handler+0x4f
Xintripi() at Xintripi+0x47
--- interrupt ---
__mp_lock(d0925084,d0925084,d2e6ec80,de361f24,d0203539) at __mp_lock+0x43
i386_softintlock(0,d0380058,d0920010,10,de360010) at i386_softintlock+0x10
Xintrltimer() at Xintrltimer+0x4e
--- interrupt ---
cpu_idle_cycle(d09d82e0) at cpu_idle_cycle+0xf
Bad frame pointer: 0xd0a8be78
ddb{0}>

Reply | Threaded
Open this post in threaded view
|

Re: Serious problems with current since end of april, related to scsi controllers (Adaptec/LSILogic)

Landry Breuil-4
On Tue, May 11, 2010 at 5:30 PM, Ulrich Kahl <[hidden email]> wrote:

> Hi!
>
> Since end of april, sorry I don't have a more precise date, one of my
> systems has serious problems.
> It can't boot sucessfully with a Adaptec controller anymore, the first
> sign is that it can't find one library, e.g. libc or libz, and later
> the hard disks transfer rate can't established and the system freezes. See
> the first dmesg.
>
> After switching the controller to a LSILogic one, the system boots
> correctly, but (presumly) under higher disk io load the system panics,
> syncing my local cvs repository with cvsync in this case. See second
> dmesg and trace output.
>
> Does someone else encounter similar problems?

With the LSILogic using mpi(4), be sure to really run current, r 1.143
of dev/ic/mpi.c was causing this problem and has been backed out some
days ago.
No idea for the adapted problem though.

Landry