SSL: BAD_SIGNATURE with offlineimap-7.2.1 on OpenBSD 6.4-current (GENERIC.MP) #437: Mon Nov 12 20:06:01 MST 2018

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

SSL: BAD_SIGNATURE with offlineimap-7.2.1 on OpenBSD 6.4-current (GENERIC.MP) #437: Mon Nov 12 20:06:01 MST 2018

Mikolaj Kucharski-3
Hi,

I just upgraded base system to:

OpenBSD 6.4-current (GENERIC.MP) #437: Mon Nov 12 20:06:01 MST 2018
    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP

and all packages to the latest snapshot at the time:

$ pkg_info -f quirks | awk -F: '/digital-signature/ {print $2}'
2018-11-11T21

$ pkg_info -qI offlineimap
offlineimap-7.2.1

I'm seeing this while OfflineIMAP 7.2.1 talks to outlook.office365.com:


Establishing connection to outlook.office365.com:993 (Remote)
ERROR: Unknown SSL protocol connecting to host 'outlook.office365.com' for repository 'Remote'. OpenSSL responded:
[SSL: BAD_SIGNATURE] bad signature (_ssl.c:730)

..and connection closes. Is this known problem? I don't see this problem
when OfflineIMAP talks to Google.

Regards,
 Mikolaj

Reply | Threaded
Open this post in threaded view
|

Re: SSL: BAD_SIGNATURE with offlineimap-7.2.1 on OpenBSD 6.4-current (GENERIC.MP) #437: Mon Nov 12 20:06:01 MST 2018

Gonzalo L. Rodriguez-2
On [13/11/18] [07:58P], Mikolaj Kucharski wrote:

>Hi,
>
>I just upgraded base system to:
>
>OpenBSD 6.4-current (GENERIC.MP) #437: Mon Nov 12 20:06:01 MST 2018
>    [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
>
>and all packages to the latest snapshot at the time:
>
>$ pkg_info -f quirks | awk -F: '/digital-signature/ {print $2}'
>2018-11-11T21
>
>$ pkg_info -qI offlineimap
>offlineimap-7.2.1
>
>I'm seeing this while OfflineIMAP 7.2.1 talks to outlook.office365.com:
>
>
>Establishing connection to outlook.office365.com:993 (Remote)
>ERROR: Unknown SSL protocol connecting to host 'outlook.office365.com' for repository 'Remote'. OpenSSL responded:
>[SSL: BAD_SIGNATURE] bad signature (_ssl.c:730)
>
>..and connection closes. Is this known problem? I don't see this problem
>when OfflineIMAP talks to Google.
>
>Regards,
> Mikolaj
>

Fixed on the last snapshot.

--
Sending from my toaster.

Reply | Threaded
Open this post in threaded view
|

Re: SSL: BAD_SIGNATURE with offlineimap-7.2.1 on OpenBSD 6.4-current (GENERIC.MP) #437: Mon Nov 12 20:06:01 MST 2018

Gonzalo L. Rodriguez-2
On [13/11/18] [10:37P], Gonzalo L. Rodriguez wrote:

>On [13/11/18] [07:58P], Mikolaj Kucharski wrote:
>>Hi,
>>
>>I just upgraded base system to:
>>
>>OpenBSD 6.4-current (GENERIC.MP) #437: Mon Nov 12 20:06:01 MST 2018
>>   [hidden email]:/usr/src/sys/arch/amd64/compile/GENERIC.MP
>>
>>and all packages to the latest snapshot at the time:
>>
>>$ pkg_info -f quirks | awk -F: '/digital-signature/ {print $2}'
>>2018-11-11T21
>>
>>$ pkg_info -qI offlineimap
>>offlineimap-7.2.1
>>
>>I'm seeing this while OfflineIMAP 7.2.1 talks to outlook.office365.com:
>>
>>
>>Establishing connection to outlook.office365.com:993 (Remote)
>>ERROR: Unknown SSL protocol connecting to host 'outlook.office365.com' for repository 'Remote'. OpenSSL responded:
>>[SSL: BAD_SIGNATURE] bad signature (_ssl.c:730)
>>
>>..and connection closes. Is this known problem? I don't see this problem
>>when OfflineIMAP talks to Google.
>>
>>Regards,
>>Mikolaj
>>
>
>Fixed on the last snapshot.
>
>--
>Sending from my toaster.
>

Sorry, I misread your email, discard my previous answer

--
Sending from my toaster.